Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2018-12-04 00:37:05

młodyLinuxiarz
Użytkownik
Zarejestrowany: 2016-01-25

Dostrajanie zarządzania pamięcią

Witam,
Dosyć długo byłem nieobecny ale wróciłem :-D Z problemem niestety. Otóż pytałem wujka google o możliwości dostrojenia zarządzania pamięcią w taki sposób aby zwiększyć użycie swap by było więcej wolnej fizycznej pamięci RAM. Niestety to co wujek podpowiedział nie wygrało starcia z Firefoxem i Blenderem na moim HP Elitebook 6930p z 2GB RAM i Devuanem Ascii na pokładzie. Po uruchomieniu Firefoxa z 4 kartami (1 plik tekstowy z kernel.org i 3 karty na wyszukiwarce google) i do tego jeszcze Blendera 2.79b z moją niezbyt rozbudowaną sceną skutkuje wolnymi tylko 100MB RAM i 900 MB cache/buffer i 0 MB użytego swap (tak pokazuje free -h). Próba wyrenderowania jednej klatki zawiesza środowisko graficzne (XFCE). Tego problemu nie mam na Devuanie Jessie. Byłbym wdzięczny za każdą wskazówkę

Pozdrawiam,
młodyLinuxiarz

Dopisek:
Na Devuanie Ascii Jądro jest w wersji 4.9.0-6-amd64 a na Jessie 3.16 (i386)

Ostatnio edytowany przez młodyLinuxiarz (2018-12-04 00:42:39)


Nic na siłę, wszystko młotkiem :-P

Offline

 

#2 2018-12-04 11:55:05

andreq
Członek DUG
Skąd: Nisko
Zarejestrowany: 2005-01-11

Re: Dostrajanie zarządzania pamięcią

Wklej wyniki:

Kod:

fdisk -l /dev/sda
mount
cat /etc/fstab
free -h
cat /proc/sys/vm/swappiness

Offline

 

#3 2018-12-04 14:43:48

młodyLinuxiarz
Użytkownik
Zarejestrowany: 2016-01-25

Re: Dostrajanie zarządzania pamięcią

fdisk:

Kod:

Disk /dev/sda: 37,3 GiB, 40007761920 bytes, 78140160 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x1a235b66

Device     Boot   Start      End  Sectors  Size Id Type
/dev/sda1          2048  2099199  2097152    1G 82 Linux swap / Solaris
/dev/sda2       2099200 78140159 76040960 36,3G  5 Extended
/dev/sda5  *    2101248 78140159 76038912 36,3G 83 Linux

mount:

Kod:

sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=945580k,nr_inodes=236395,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=191364k,mode=755)
/dev/sda5 on / type ext4 (rw,relatime,errors=remount-ro,commit=600,data=ordered)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
pstore on /sys/fs/pstore type pstore (rw,relatime)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=592440k)
tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/elogind type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/usr/lib/elogind/elogind-cgroups-agent,name=elogind)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=191360k,mode=700,uid=1000,gid=1000)

fstab:

Kod:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=74ce4d79-42c2-4b64-9a67-99270e8d8433 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda1 during installation
UUID=2d0e65b8-02a4-48c9-bd95-c7a45783cdf6 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/sr1        /media/cdrom1   udf,iso9660 user,noauto     0       0

free -h:

Kod:

              total        used        free      shared  buff/cache   available
Mem:           1,8G        1,0G         77M        546M        763M        157M
Swap:          1,0G        2,8M        1,0G

Kod:

cat /proc/sys/vm/swappiness
100

Nic na siłę, wszystko młotkiem :-P

Offline

 

#4 2018-12-04 15:44:24

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Dostrajanie zarządzania pamięcią

Zmień swappiness na 30

Offline

 

#5 2018-12-04 19:14:45

młodyLinuxiarz
Użytkownik
Zarejestrowany: 2016-01-25

Re: Dostrajanie zarządzania pamięcią

Niestety bez zmian


Nic na siłę, wszystko młotkiem :-P

Offline

 

#6 2018-12-04 19:58:44

andreq
Członek DUG
Skąd: Nisko
Zarejestrowany: 2005-01-11

Re: Dostrajanie zarządzania pamięcią

Spróbuj dodać plik swap:

Kod:

dd if=/dev/zero of=/plik_swap bs=1M count=512
mkswap /plik_swap
swapon /plik_swap

PS. Tylko przy dd się nie pomyl ma czytać z /dev/zero a pisać do pliku /plik_swap ;-)
PS2. Zajętość ram i swap łatwo obserwować za pomocą htop, free trzeba puszczać w pętli

Ostatnio edytowany przez andreq (2018-12-04 19:59:01)

Offline

 

#7 2018-12-04 20:10:26

młodyLinuxiarz
Użytkownik
Zarejestrowany: 2016-01-25

Re: Dostrajanie zarządzania pamięcią

Mam już partycję swap, z której system nijak chyba nie chce korzystać. Ale spróbuję jeszcze z plikiem w takim razie

Dopisek: Nie pomogło, htop pokazał użycie swap na poziomie 324K a przy próbie renderowania zmroziło całe środowisko graficzne. Musiałem się ratować Alt+SysRq+F

Ostatnio edytowany przez młodyLinuxiarz (2018-12-04 20:18:26)


Nic na siłę, wszystko młotkiem :-P

Offline

 

#8 2018-12-04 20:24:34

wikingagressor
Użytkownik
Skąd: Józefów k.Błonia, mazowieckie
Zarejestrowany: 2015-02-03

Re: Dostrajanie zarządzania pamięcią

Problem polega na tym, ze linuks jak nie uzywa pamieci RAM, to zamienia ja na disk cache. Ustawiajac swappiness=100 praktycznie kazales kernelowi zeby to robil nieustannie i dlatego brakuje ci pamieci na programy. Ustaw swappiness na defaultowa wartosc, czyli 60. Zobacz jak bedzie reagowal system i podbijaj do maks 90. Kiedy system bedzie ci najplynniej chodzil to taka wartosc jest dla ciebie optymalna i ja musisz ustawic na stale w pliku /etc/sysctl.conf.


Peace, Love and Debian for the World!!!

Offline

 

#9 2018-12-04 21:58:52

młodyLinuxiarz
Użytkownik
Zarejestrowany: 2016-01-25

Re: Dostrajanie zarządzania pamięcią

Niestety swappiness żadnej różnicy nie robił. Chyba skompiluję sobie jądro od zera wolnym czasem, może tam znajdę jakieś dodatkowe opcje


Nic na siłę, wszystko młotkiem :-P

Offline

 

#10 2018-12-04 22:45:08

wikingagressor
Użytkownik
Skąd: Józefów k.Błonia, mazowieckie
Zarejestrowany: 2015-02-03

Re: Dostrajanie zarządzania pamięcią

A jak ustawiales ten parametr?


Peace, Love and Debian for the World!!!

Offline

 

#11 2018-12-04 22:54:12

młodyLinuxiarz
Użytkownik
Zarejestrowany: 2016-01-25

Re: Dostrajanie zarządzania pamięcią

Najpierw

Kod:

tomekdev@devstation:~$ sudo sysctl -w vm.swappiness=60 # Potem kolejne wartości +10

Potem na wypadek konieczności restartu dodałem do /etc/sysctl.conf


Nic na siłę, wszystko młotkiem :-P

Offline

 

#12 2018-12-05 03:40:10

wikingagressor
Użytkownik
Skąd: Józefów k.Błonia, mazowieckie
Zarejestrowany: 2015-02-03

Re: Dostrajanie zarządzania pamięcią

Sprobuj po zmianie parametru  w /etc/sysctl.conf dodatkowo uruchomic:

Kod:

sudo sysctl -p /etc/sysctl.conf

Moze to ci jakos da rade, ewentualnie doloz ramu do lapka jak sie da.


Peace, Love and Debian for the World!!!

Offline

 

#13 2018-12-05 17:00:06

młodyLinuxiarz
Użytkownik
Zarejestrowany: 2016-01-25

Re: Dostrajanie zarządzania pamięcią

Narazie obszedłem problem poprzez zmianę ustawień blendera (w Ascii jest nowszy niż w Jessie, może dlatego większe zapotrzebowanie na RAM). Temat narazie pozostawię otwarty, sprawdzę jeszcze czy coś da rekompilacja jądra z innymi ustawieniami. RAMu w lapku mogę jeszcze sobie sporo dorzucić w razie czego bo chyba ma 2 sloty wymienne, ale optymalizacja przede wszystkim :-D


Nic na siłę, wszystko młotkiem :-P

Offline

 

#14 2018-12-05 17:29:29

hi
Użytkownik
Zarejestrowany: 2016-03-24

Re: Dostrajanie zarządzania pamięcią

młodyLinuxiarz napisał(-a):

Na Devuanie Ascii Jądro jest w wersji 4.9.0-6-amd64 a na Jessie 3.16 (i386)

bo ten cały Devuan ma wymieszane debianowe backporty ze standardowym debianowym repo. W jessie też masz jajko 4.9x tyle, że jest ono w backportach tam gdzie być powinno:
https://packages.debian.org/jessie-backports/linux-image-686

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
To nie jest tylko forum, to nasza mała ojczyzna ;-)