Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2018-03-13 19:15:12

paw4el
Użytkownik
Skąd: wielkopolska
Zarejestrowany: 2010-07-05
Serwis

console-setup - problem z aktualizacją systemu

Witam.
Mam problem z aktualizacją systemu. Chodzi o pakiet console-setup

Kod:

Konfigurowanie pakietu console-setup (1.179) ...
dpkg: błąd przetwarzania pakietu console-setup (--configure):
 installed console-setup package post-installation script subprocess returned error exit status 20
Wystąpiły błędy podczas przetwarzania:
 console-setup
E: Sub-process /usr/bin/dpkg returned an error code (1)
Konfigurowanie pakietu console-setup (1.179) ...
dpkg: błąd przetwarzania pakietu console-setup (--configure):
 installed console-setup package post-installation script subprocess returned error exit status 20
Wystąpiły błędy podczas przetwarzania:
 console-setup

Miał ktoś podoby problem ?

Offline

 

#2 2018-03-13 19:31:07

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: console-setup - problem z aktualizacją systemu

Ja mam: xD

Kod:

 # aptitude safe-upgrade
Resolving dependencies...
The following packages will be upgraded:
  console-setup console-setup-linux keyboard-configuration
3 packages upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Need to get 0 B/1,976 kB of archives. After unpacking 486 kB will be used.
Do you want to continue? [Y/n/?]
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
Reading changelogs... Done
Preconfiguring packages ...
console-setup failed to preconfigure, with exit status 20
(Reading database ... 204462 files and directories currently installed.)
Preparing to unpack .../console-setup-linux_1.179_all.deb ...
Unpacking console-setup-linux (1.179) over (1.178) ...
Preparing to unpack .../console-setup_1.179_all.deb ...
Unpacking console-setup (1.179) over (1.178) ...
Preparing to unpack .../keyboard-configuration_1.179_all.deb ...
Unpacking keyboard-configuration (1.179) over (1.178) ...
Setting up keyboard-configuration (1.179) ...
Processing triggers for systemd (238-2) ...
Processing triggers for man-db (2.8.2-1) ...
Setting up console-setup-linux (1.179) ...
Setting up console-setup (1.179) ...
dpkg: error processing package console-setup (--configure):
 installed console-setup package post-installation script subprocess returned error exit status 128
Errors were encountered while processing:
 console-setup
E: Sub-process /usr/bin/dpkg returned an error code (1)
Setting up console-setup (1.179) ...
dpkg: error processing package console-setup (--configure):
 installed console-setup package post-installation script subprocess returned error exit status 20
Errors were encountered while processing:
 console-setup

Current status: 3 (-3) upgradable.

# apt-cache policy console-setup
console-setup:
  Installed: 1.179
  Candidate: 1.179
  Version table:
 *** 1.179 990
        990 https://deb.debian.org/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status
     1.178 500
        500 https://deb.debian.org/debian testing/main amd64 Packages


# aptitude install console-setup=1.178
The following packages will be DOWNGRADED:
  console-setup{b}
0 packages upgraded, 0 newly installed, 1 downgraded, 0 to remove and 3 not upgraded.
Need to get 0 B/103 kB of archives. After unpacking 63.5 kB will be used.
The following packages have unmet dependencies:
 console-setup : Depends: keyboard-configuration (= 1.178) but 1.179 is installed
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     console-setup [1.179 (now, unstable)]



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

     Remove the following packages:
1)     console-setup [1.179 (now, unstable)]



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

     Downgrade the following packages:
1)     console-setup-linux [1.179 (now, unstable) -> 1.178 (testing)]
2)     keyboard-configuration [1.179 (now, unstable) -> 1.178 (testing)]



Accept this solution? [Y/n/q/?]
The following packages will be DOWNGRADED:
  console-setup console-setup-linux keyboard-configuration
0 packages upgraded, 0 newly installed, 3 downgraded, 0 to remove and 3 not upgraded.
Need to get 0 B/1,480 kB of archives. After unpacking 486 kB will be freed.
Do you want to continue? [Y/n/?]
Preconfiguring packages ...
dpkg: warning: downgrading console-setup-linux from 1.179 to 1.178
(Reading database ... 204538 files and directories currently installed.)
Preparing to unpack .../console-setup-linux_1.178_all.deb ...
Unpacking console-setup-linux (1.178) over (1.179) ...
dpkg: warning: downgrading console-setup from 1.179 to 1.178
Preparing to unpack .../console-setup_1.178_all.deb ...
Unpacking console-setup (1.178) over (1.179) ...
dpkg: warning: downgrading keyboard-configuration from 1.179 to 1.178
Preparing to unpack .../keyboard-configuration_1.178_all.deb ...
Unpacking keyboard-configuration (1.178) over (1.179) ...
Setting up keyboard-configuration (1.178) ...
Processing triggers for systemd (238-2) ...
Processing triggers for man-db (2.8.2-1) ...
Setting up console-setup-linux (1.178) ...
Setting up console-setup (1.178) ...

Current status: 6 (+3) upgradable.

Offline

 

#3 2018-03-13 20:17:02

Pakos
Członek DUG
Zarejestrowany: 2007-06-12
Serwis

Re: console-setup - problem z aktualizacją systemu

kazdy na sidzie ma, downgrade albo poczekac :P

Offline

 

#4 2018-03-14 09:03:34

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: console-setup - problem z aktualizacją systemu

Po co czekać?

Kod:

apt purge console-setup
apt install console-setup

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Nas ludzie lubią po prostu, a nie klikając w przyciski ;-)