Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2016-05-22 15:48:59

yaros
Użytkownik
Zarejestrowany: 2011-11-17

Instalacja AdobeAir [SOLVED]

Próbuję zainstalować na komputerze siostry (Debian testing 64 bit, KDE) e-Deklaracje wg tej instrukcji: http://www.finanse.mf.gov.pl/documents/766655/11964 … kcjeLinux.pdf i wykładam się na instalacji AdobeAir - instalator mnie atakuje komunikatem: "Nie można zainstalować środowiska Adobe AIR. W systemie nie można odnaleźć narzędzi systemu Debian do tworzenia pakietów deb (na przykład dpkg-deb lub ar)."
Na moim PC aplikacja działa, na tym laptopie (przed reinstalacją systemu) też działała, przy czym była instalowana jakieś trzy lata temu, także pakiety się trochę pozmieniały ;) Nie bardzo mam pomysł czego mu brakuje - dpkg-dev jest, build-essentials też... jakieś pomysły? Szukałem po necie ale jakoś ten problem mi się nie rzucił na oko.

Ostatnio edytowany przez yaros (2016-05-25 14:11:55)

Offline

 

#2 2016-05-22 19:00:39

Pavlo950
człowiek pasjonat :D
Zarejestrowany: 2012-02-20
Serwis

Offline

 

#3 2016-05-22 22:49:05

yaros
Użytkownik
Zarejestrowany: 2011-11-17

Re: Instalacja AdobeAir [SOLVED]

Podziękował za sznurki - okazało się, że nie wszystko z tego: "aptitude install build-essential ccache devscripts dpkg-dev dh-make pbuilder" było zainstalowane. Niestety, doinstalowanie brakujących pakietów nic nie zmieniło - nadal ten sam komunikat od instalatora adobeair, czyli: "Nie można zainstalować środowiska Adobe AIR. W systemie nie można odnaleźć narzędzi systemu Debian do tworzenia pakietów deb (na przykład dpkg-deb lub ar)."

Offline

 

#4 2016-05-22 23:17:20

thomsson
Dyskutant
Zarejestrowany: 2011-10-26

Re: Instalacja AdobeAir [SOLVED]

A doinstalowałeś te paczki 32 bit? Bo air na lx jest tylko 32 bit więc może tego mu brakuje do szczęścia


ilin napisał
"DUG to tez moja mała ojczyzna"

Offline

 

#5 2016-05-23 00:30:57

neo86
Lubię marudzić
Skąd: Depresja społeczności polskiej
Zarejestrowany: 2014-06-29

Re: Instalacja AdobeAir [SOLVED]

Ja użyłem paczki 64 bitowej i działała prawidłowo (w razie czego jest też 32 bitowa): http://update.devolo.com/linux/apt/pool/main/a/adobeair/ <= Tam są gotowe paczki *.deb ale nie biorę odpowiedzialności jeśli komuś coś się dziwnego porobi. U mnie wszystko prawidłowo się zainstalowało (Debian Jessie) i nie było i nie ma żadnych problemów z działaniem tej paczki. Były także spełnione wszystkie zależności.

Ostatnio edytowany przez neo86 (2016-05-23 00:36:47)


Death R.I.P.

Offline

 

#6 2016-05-23 07:35:32

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Instalacja AdobeAir [SOLVED]

neo86 napisał(-a):

Ja użyłem paczki 64 bitowej i działała prawidłowo (w razie czego jest też 32 bitowa): http://update.devolo.com/linux/apt/pool/main/a/adobeair/ <= Tam są gotowe paczki *.deb ale nie biorę odpowiedzialności jeśli komuś coś się dziwnego porobi. U mnie wszystko prawidłowo się zainstalowało (Debian Jessie) i nie było i nie ma żadnych problemów z działaniem tej paczki. Były także spełnione wszystkie zależności.

Nie ma wersji 64-bitowej

To tylko zapakowana wersja 32-bit, której instalacja na współczesnych systemach nie ma żadnego sensu

Offline

 

#7 2016-05-23 08:58:43

yaros
Użytkownik
Zarejestrowany: 2011-11-17

Re: Instalacja AdobeAir [SOLVED]

Próba instalacji paczek w wersji i386 mnie przerasta:

Kod:

root@debAga:~# aptitude install build-essential:i386 ccache:i386 devscripts:i386 dpkg-dev:i386 dh-make:i386 pbuilder:i386 
Nie znaleziono pakietu, którego nazwa lub opis zawierałyby "dh-make:i386"
Nie znaleziono pakietu, którego nazwa lub opis zawierałyby "dh-make:i386"
Następujące NOWE pakiety zostaną zainstalowane:
  apt:i386{ab} binutils:i386{ab} build-essential:i386{b} ccache:i386{b} cpp:i386{ab} cpp-5:i386{ab} devscripts:i386{b} g++:i386{ab} g++-5:i386{ab} gcc:i386{ab} 
  gcc-5:i386{ab} gcc-5-base:i386{a} libapt-pkg5.0:i386{a} libasan2:i386{a} libatomic1:i386{a} libbz2-1.0:i386{a} libc6-dev:i386{a} libcc1-0:i386{a} 
  libcilkrts5:i386{a} libgcc-5-dev:i386{a} libgdbm3:i386{a} libisl15:i386{a} libitm1:i386{a} liblz4-1:i386{a} libmpc3:i386{a} libmpfr4:i386{a} libmpx0:i386{a} 
  libperl5.22:i386{a} libquadmath0:i386{a} libstdc++-5-dev:i386{a} libubsan0:i386{a} linux-libc-dev:i386{a} make:i386{ab} perl:i386{ab} perl-base:i386{ab} 
  strace:i386{ab} wdiff:i386{ab} 
0 pakietów aktualizowanych, 37 instalowanych, 0 do usunięcia i 0 nieaktualizowanych.
Do pobrania 88,8 MB archiwów. Zajęte po rozpakowaniu: 368 MB.
Następujące pakiety mają niespełnione zależności:
 perl-base : W konflikcie z: perl-base:i386 ale zaplanowana jest instalacja wersji 5.22.2-1.
 perl-base:i386 : W konflikcie z: perl-base ale zainstalowana jest wersja 5.22.2-1.
 ccache : W konflikcie z: ccache:i386 ale zaplanowana jest instalacja wersji 3.2.5-1.
 ccache:i386 : W konflikcie z: ccache ale zainstalowana jest wersja 3.2.5-1.
 strace : W konflikcie z: strace:i386 ale zaplanowana jest instalacja wersji 4.10-3.
 strace:i386 : W konflikcie z: strace ale zainstalowana jest wersja 4.10-3.
 apt : W konflikcie z: apt:i386 ale zaplanowana jest instalacja wersji 1.2.12.
 apt:i386 : W konflikcie z: apt ale zainstalowana jest wersja 1.2.12.
 wdiff : W konflikcie z: wdiff:i386 ale zaplanowana jest instalacja wersji 1.2.2-1+b1.
 wdiff:i386 : W konflikcie z: wdiff ale zainstalowana jest wersja 1.2.2-1+b1.
 cpp-5 : W konflikcie z: cpp-5:i386 ale zaplanowana jest instalacja wersji 5.3.1-19.
 cpp-5:i386 : W konflikcie z: cpp-5 ale zainstalowana jest wersja 5.3.1-19.
 binutils : W konflikcie z: binutils:i386 ale zaplanowana jest instalacja wersji 2.26-9.
 binutils:i386 : W konflikcie z: binutils ale zainstalowana jest wersja 2.26-9.
 cpp : W konflikcie z: cpp:i386 ale zaplanowana jest instalacja wersji 4:5.3.1-1.
 cpp:i386 : W konflikcie z: cpp ale zainstalowana jest wersja 4:5.3.1-1.
 g++ : W konflikcie z: g++:i386 ale zaplanowana jest instalacja wersji 4:5.3.1-1.
 g++:i386 : W konflikcie z: g++ ale zainstalowana jest wersja 4:5.3.1-1.
 gcc : W konflikcie z: gcc:i386 ale zaplanowana jest instalacja wersji 4:5.3.1-1.
 gcc:i386 : W konflikcie z: gcc ale zainstalowana jest wersja 4:5.3.1-1.
 build-essential : W konflikcie z: build-essential:i386 ale zaplanowana jest instalacja wersji 11.7.
 build-essential:i386 : W konflikcie z: build-essential ale zainstalowana jest wersja 11.7.
 g++-5 : W konflikcie z: g++-5:i386 ale zaplanowana jest instalacja wersji 5.3.1-19.
 g++-5:i386 : W konflikcie z: g++-5 ale zainstalowana jest wersja 5.3.1-19.
 make : W konflikcie z: make:i386 ale zaplanowana jest instalacja wersji 4.1-9.
 make:i386 : W konflikcie z: make ale zainstalowana jest wersja 4.1-9.
 gcc-5 : W konflikcie z: gcc-5:i386 ale zaplanowana jest instalacja wersji 5.3.1-19.                                                                                
 gcc-5:i386 : W konflikcie z: gcc-5 ale zainstalowana jest wersja 5.3.1-19.                                                                                         
 perl : W konflikcie z: perl:i386 ale zaplanowana jest instalacja wersji 5.22.2-1.                                                                                  
 perl:i386 : W konflikcie z: perl ale zainstalowana jest wersja 5.22.2-1.                                                                                           
 devscripts : W konflikcie z: devscripts:i386 ale zaplanowana jest instalacja wersji 2.16.4.                                                                        
 devscripts:i386 : W konflikcie z: devscripts ale zainstalowana jest wersja 2.16.4.                                                                                 
Nie można rozwiązać problemów z zależnościami!  Rezygnacja...

Paczek z nieznanych źródeł to wolałbym nie instalować...

Offline

 

#8 2016-05-23 12:07:10

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Instalacja AdobeAir [SOLVED]

Spróbuj użyć apt-get. Aptitude czasem się gubi przy pierwszej próbie instalacji po dodawaniu architektury.
Poza tym tamta lista pakietów może być niepotrzebna. Może wystarczy same build-essential.

Paczek z nieznanych źródeł to wolałbym nie instalować...

I słusznie.
Tym bardziej, że tamte pakiety są zupełnie nieprzydatne.

Offline

 

#9 2016-05-23 12:59:19

yaros
Użytkownik
Zarejestrowany: 2011-11-17

Re: Instalacja AdobeAir [SOLVED]

apt-get niewiele zmienia - nadal chce wywalić za dużo. Przy próbie instalacji:

Kod:

root@debAga:~# apt-get install build-essential:i386
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 build-essential:i386 : Wymaga: gcc:i386 (>= 4:4.9.1) ale nie zostanie zainstalowany
                        Wymaga: g++:i386 (>= 4:4.9.1) ale nie zostanie zainstalowany
                        Wymaga: make:i386
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

root@debAga:~# apt-get install gcc:i386 cpp:i386 gcc-5:i386 binutils:i386 

Następujące pakiety zostaną USUNIĘTE:
  bbswitch-dkms binutils binutils-i586-linux-gnu broadcom-sta-dkms build-essential bumblebee bumblebee-nvidia cpp cpp-5 debhelper devscripts dh-autoreconf dh-make
  dh-strip-nondeterminism dkms dpkg-dev equivs flashplugin-nonfree g++ g++-5 gcc gcc-5 hardening-includes kde-plasma-desktop kde-standard kdeplasma-addons
  kinfocenter libtool lintian linux-compiler-gcc-5-x86 linux-headers-4.5.0-2-amd64 linux-headers-amd64 network-manager-pptp nvidia-driver nvidia-kernel-dkms
  pbuilder plasma-desktop plasma-widgets-addons plasma-workspace pptp-linux primus sddm-theme-breeze task-desktop task-kde-desktop x11-session-utils
  x11-xserver-utils xorg

Chyba spróbuję tego AdobeAir jakoś przenieść z jednej maszyny na drugą (skopiować katalogi/pliki)...

Znalazłem jeszcze logi tego instalatora:

Kod:

[setup:3108][INFO] Runtime Installer begin with version 2.6.0.19170 on Linux x86
[setup:3108][INFO] Commandline is: 
[setup:3108][INFO] No installed runtime detected
[setup:3108][INFO] Relaunching with elevation
[setup:3108][INFO] Launching subprocess with commandline /tmp/air.XDXdwf/setup -ei
[setup:3130][INFO] Runtime Installer begin with version 2.6.0.19170 on Linux x86
[setup:3130][INFO] Commandline is: -stdio /tmp/air.ghpmJN/channel -ei
[setup:3130][INFO] No installed runtime detected
[setup:3130][INFO] Starting silent runtime install. Installing runtime version 2.6.0.19170
[setup:3130][INFO] Session detected: GNOME
[setup:3130][ERR] Error occurred during rpm create operation; beginning rollback: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="dpkg-query: pakiet "adobe-certs" nie jest zainstalowany i informacje o nim nie są dostępne;Użyj dpkg --info (= dpkg-deb --info), aby zobaczyć informacje o pakiecie,;oraz dpkg --contents (= dpkg-deb --contents), aby sprawdzić jego zawartość.Could not run the command : ar" errorID=5031]
[setup:3130][INFO] Rollback complete
[setup:3130][ERR] Exiting due to error: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="dpkg-query: pakiet "adobe-certs" nie jest zainstalowany i informacje o nim nie są dostępne;Użyj dpkg --info (= dpkg-deb --info), aby zobaczyć informacje o pakiecie,;oraz dpkg --contents (= dpkg-deb --contents), aby sprawdzić jego zawartość.Could not run the command : ar" errorID=5031]
[setup:3130][ERR] Runtime Installer end with exit code 7
[setup:3108][ERR] Exiting due to error: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="dpkg-query: pakiet "adobe-certs" nie jest zainstalowany i informacje o nim nie są dostępne;Użyj dpkg --info (= dpkg-deb --info), aby zobaczyć informacje o pakiecie,;oraz dpkg --contents (= dpkg-deb --contents), aby sprawdzić jego zawartość.Could not run the command : ar" errorID=5031]
[setup:3108][ERR] Runtime Installer end with exit code 7

adobe-certs faktycznie nie ma (i nie wiem skąd wziąć) ale ar jest w systemie...


[EDYTA]
Trochę mnie dziwi w tym logu: [setup:3130][INFO] Session detected: GNOME Może to jest problem z KDE5

Jak się uruchamia instalator to w plikach tymczasowych generuje się jakiś plik .deb ale jest od razu usuwany (zanim pojawia się okienkowy komunikat o błędzie).

Ostatnio edytowany przez yaros (2016-05-23 13:41:53)

Offline

 

#10 2016-05-23 16:05:21

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Instalacja AdobeAir [SOLVED]

Ogólnie to nie tędy droga:

aptitude show build-essential
Package: build-essential                 
Version: 12.2
State: installed
Automatically installed: no
Priority: optional
Section: devel
Maintainer: Matthias Klose <doko@debian.org>
Architecture: amd64
Uncompressed Size: 20.5 k
Depends: libc6-dev | libc-dev, gcc (>= 4:5.3), g++ (>= 4:5.3), make, dpkg-dev (>= 1.17.11)
Conflicts: build-essential:i386
Description: Informational list of build-essential packages

W instrukcji (generalnie dla starszych systemów) tego nie ma, są podane inne pakiety w wersji 32-bit.
http://www.finanse.mf.gov.pl/documents/766655/11964 … kcjeLinux.pdf

Musisz w komunikatach/logach znaleźć informacje o konkretnych brakujących bibliotekach 32-bitowych.

Offline

 

#11 2016-05-23 17:21:33

yaros
Użytkownik
Zarejestrowany: 2011-11-17

Re: Instalacja AdobeAir [SOLVED]

Pakiety z instrukcji są zainstalowane. Jedyny zapis o brakujących pakietach w logach to ten: pakiet "adobe-certs" nie jest zainstalowany.
Na stronie adobe pisalli, że te pakiety, które się nie dają zainstalować w architekturze i386 to poszukać -dev i zainstalować je - ale to nic nie pomogło.

Offline

 

#12 2016-05-23 18:10:41

uzytkownikubunt
Zbanowany
Zarejestrowany: 2012-04-25

Re: Instalacja AdobeAir [SOLVED]

3030

Ostatnio edytowany przez uzytkownikubunt (2016-12-01 01:41:13)

Offline

 

#13 2016-05-23 19:59:51

Renia
Użytkownik
Zarejestrowany: 2014-08-29

Re: Instalacja AdobeAir [SOLVED]

Jestem świeżo po instalacji Debiana Jessie 64-bit, jak zwykle pojawił się problem z zainstalowaniem E-Deklaracje, Adobe Air i Adobe Acrobat Reader. Udało się rozwiązać jak widać niżej. Wszystko z zaufanych repozytoriów i źródeł, ale czy w ogóle można ufać programom od Adobe.


Kod:

#!/bin/bash
sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libgtk2.0-0:i386 libstdc++6:i386 libnss3-1d:i386 \
lib32nss-mdns libxml2:i386 libxslt1.1:i386 libcanberra-gtk-module:i386 \
gtk2-engines-murrine:i386 gtk2-engines:i386 libaudio2:i386 \
libgnome-keyring0:i386 libice6:i386 liblcms2-2:i386 libmng1:i386 \
libmysqlclient18:i386 libqt4-designer:i386 libqt4-network:i386 \
libqt4-qt3support:i386 libqt4-script:i386 libqt4-sql:i386 \
libqt4-sql-mysql:i386 libqt4-xml:i386 libqtcore4:i386 libqtdbus4:i386 \
libqtgui4:i386 libsm6:i386 libuuid1:i386 libxt6:i386 uuid-runtime
cd /tmp
sudo apt-get download libgnome-keyring0:i386
sudo dpkg-deb -R libgnome-keyring0_3.12.0-1+b1_i386.deb gnome-keyring
sudo cp gnome-keyring/usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/i386-linux-gnu/
sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/i386-linux-gnu/libgnome-keyring.so.0
sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
sudo ln -s /usr/lib/x86_64-linux-gnu/libsvn_auth_kwallet-1.so.1.0.0 /usr/lib/libsvn_auth_kwallet-1.so.0.0
sudo ln -s /usr/lib/x86_64-linux-gnu/libsvn_auth_kwallet-1.so.1 /usr/lib/libsvn_auth_kwallet-1.so.1
sudo ln -s /opt/kde3/lib/libkwalletclient.so.1 /usr/lib/libkwalletclient.so.1
sudo ln -s /usr/lib/libnss3.so /usr/lib/libnss3.so.1d
sudo ln -s /usr/lib/libssl3.so /usr/lib/libssl3.so.1d
sudo ln -s /usr/lib/libsmime3.so /usr/lib/libsmime3.so.1d
sudo ln -s /usr/lib/libnspr4.so /usr/lib/libnspr4.so.0d
wget http://airdownload.adobe.com/air/lin/download/2.6/AdobeAIRInstaller.bin
chmod a+x AdobeAIRInstaller.bin
./AdobeAIRInstaller.bin
wget ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.1/enu/AdbeRdr9.5.1-1_i486linux_enu.bin
chmod +x AdbeRdr9.5.1-1_i486linux_enu.bin
sudo ./AdbeRdr9.5.1-1_i486linux_enu.bin
sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libBIB.so /usr/lib/libBIB.so
sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libBIBUtils.so /usr/lib/libBIBUtils.so
sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libACE.so /usr/lib/libACE.so
sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libAGM.so /usr/lib/libAGM.so
sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libCoolType.so /usr/lib/libCoolType.so
sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libAXE8SharedExpat.so /usr/lib/libAXE8SharedExpat.so
sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libJP2K.so /usr/lib/libJP2K.so
sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libAdobeXMP.so /usr/lib/libAdobeXMP.so
sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libicuuc.so.36 /usr/lib/libicuuc.so.36
sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libResAccess.so /usr/lib/libResAccess.so
sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libicudata.so.36 /usr/lib/libicudata.so.36
sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.0.9.8
sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libssl.so.0.9.8 /usr/lib/libssl.so.0.9.8
wget http://www.finanse.mf.gov.pl/documents/766655/1196444/e-DeklaracjeDesktop.air
cd /opt/Adobe\ AIR/Versions/1.0
Adobe\ AIR\ Application\ Installer /tmp/e-DeklaracjeDesktop.air

Screen dla niedowiarków :)

http://iv.pl/images/13277696714486267327.jpg

Ostatnio edytowany przez Renia (2016-05-25 01:11:31)


Instalacja E-Deklaracje na Debianie 64-bit:
https://forum.dug.net.pl/viewtopic.php?pid=301794#p301794

Offline

 

#14 2016-05-24 09:28:20

yaros
Użytkownik
Zarejestrowany: 2011-11-17

Re: Instalacja AdobeAir [SOLVED]

Niestety, na testingu to nie działa. Cały czas ten sam problem:

Kod:

[setup:3715][INFO] Runtime Installer begin with version 2.6.0.19170 on Linux x86
[setup:3715][INFO] Commandline is: 
[setup:3715][INFO] No installed runtime detected
[setup:3715][INFO] Relaunching with elevation
[setup:3715][INFO] Launching subprocess with commandline /tmp/air.pXeu9F/setup -ei
[setup:3737][INFO] Runtime Installer begin with version 2.6.0.19170 on Linux x86
[setup:3737][INFO] Commandline is: -stdio /tmp/air.S1tBMh/channel -ei
[setup:3737][INFO] No installed runtime detected
[setup:3737][INFO] Starting silent runtime install. Installing runtime version 2.6.0.19170
[setup:3737][INFO] Session detected: GNOME
[setup:3737][ERR] Error occurred during rpm create operation; beginning rollback: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="dpkg-query: pakiet "adobe-certs" nie jest zainstalowany i informacje o nim nie są dostępne;Użyj dpkg --info (= dpkg-deb --info), aby zobaczyć informacje o pakiecie,;oraz dpkg --contents (= dpkg-deb --contents), aby sprawdzić jego zawartość.Could not run the command : ar" errorID=5031]
[setup:3737][INFO] Rollback complete
[setup:3737][ERR] Exiting due to error: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="dpkg-query: pakiet "adobe-certs" nie jest zainstalowany i informacje o nim nie są dostępne;Użyj dpkg --info (= dpkg-deb --info), aby zobaczyć informacje o pakiecie,;oraz dpkg --contents (= dpkg-deb --contents), aby sprawdzić jego zawartość.Could not run the command : ar" errorID=5031]
[setup:3737][ERR] Runtime Installer end with exit code 7
[setup:3715][ERR] Exiting due to error: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="dpkg-query: pakiet "adobe-certs" nie jest zainstalowany i informacje o nim nie są dostępne;Użyj dpkg --info (= dpkg-deb --info), aby zobaczyć informacje o pakiecie,;oraz dpkg --contents (= dpkg-deb --contents), aby sprawdzić jego zawartość.Could not run the command : ar" errorID=5031]
[setup:3715][ERR] Runtime Installer end with exit code 7

EDYTA:

AdobeAir się udało zainstalować - zbudowałem sobie paczkę deb wg instrukcji z tej strony: http://ubuntuforums.org/showthread.php?t=741729
I teraz mam w systemie ten cały AdobeAir, który wywala się z podobnym błędem przy próbie instalacji e-Deklaracji:

Kod:

Nie można zainstalować aplikacji Adobe AIR. W systemie nie można odnaleźć narzędzi systemu Debian do tworzenia pakietów deb (na przykład dpkg-deb lub ar).

I w logach jest:

Kod:

[Adobe AIR Application Installer:13641][INFO] Application Installer begin with version 2.6.0.19170 on Linux x86
[Adobe AIR Application Installer:13641][INFO] Commandline is: /root/e-DeklaracjeDesktop.air
[Adobe AIR Application Installer:13641][INFO] Installed runtime (2.6.0.19170) located at /opt/Adobe AIR
[Adobe AIR Application Installer:13641][INFO] Unpackaging file:///root/e-DeklaracjeDesktop.air to /tmp/FlashTmp.GJhBpI
[Adobe AIR Application Installer:13641][INFO] Application signature verified
[Adobe AIR Application Installer:13641][INFO] Unpackaging/validation complete
[Adobe AIR Application Installer:13641][INFO] No app located for appID 'e-Deklaracje' and pubID 'A1909296681C7ACEFE45687D3A64758C8659BF46.1'
[Adobe AIR Application Installer:13641][INFO] Converting unpackaged application to a native installation package in /tmp/FlashTmp.vJRZ6S
[Adobe AIR Application Installer:13641][ERR] Native installation package creation failed: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="Unhandled exception Error: Error creating the package Could not run the command : ar" errorID=5031]
[Adobe AIR Application Installer:13641][ERR] Application Installer end with exit code 7

Przy czym ar w systemie jest...

Ostatnio edytowany przez yaros (2016-05-24 11:28:54)

Offline

 

#15 2016-05-24 16:35:53

neo86
Lubię marudzić
Skąd: Depresja społeczności polskiej
Zarejestrowany: 2014-06-29

Re: Instalacja AdobeAir [SOLVED]

yossarian napisał(-a):

Paczek z nieznanych źródeł to wolałbym nie instalować...

I słusznie.
Tym bardziej, że tamte pakiety są zupełnie nieprzydatne.

Ja zamiast kombinować jak Wy tutaj zainstalowałem: http://update.devolo.com/linux/apt/pool/main/a/adob … lo1_amd64.deb potem e-Deklaracje i to wystarczyło by się rozliczyć z podatku.


Death R.I.P.

Offline

 

#16 2016-05-24 19:22:10

yaros
Użytkownik
Zarejestrowany: 2011-11-17

Re: Instalacja AdobeAir [SOLVED]

Problem rozwiązany - może niezbyt "ładnie" ale skutecznie ;)
AdobeAir zainstalowałem z paczki utworzonej z instalatora wg tej instrukcji: http://ubuntuforums.org/showthread.php?t=741729
e-Deklaracje skopiowałem z działającej instalacji -> wystarczyło skopiować katalog e-Deklaracje z /opt i utworzyć odpowiedni skrót :)

Offline

 

#17 2016-05-24 22:22:45

Renia
Użytkownik
Zarejestrowany: 2014-08-29

Re: Instalacja AdobeAir [SOLVED]

neo86 napisał(-a):

Ja zamiast kombinować jak Wy tutaj zainstalowałem: http://update.devolo.com/linux/apt/pool/main/a/adob … lo1_amd64.deb potem e-Deklaracje i to wystarczyło by się rozliczyć z podatku.

Faktycznie działa pod Debianem Testing 64-bit z KDE.

Kod:

su
dpkg --add-architecture i386
apt-get update
apt-get install libbz2-1.0:i386 libc6:i386 libgtk2.0-0:i386 libnss3:i386 libstdc++6:i386 libxml2:i386 libxaw7:i386 libxslt1.1:i386
cd /tmp
wget http://update.devolo.com/linux/apt/pool/main/a/adobeair/adobeair_2.6.0.19170-devolo1_amd64.deb
wget http://update.devolo.com/linux/apt/pool/main/d/devolo-ia32-libs/devolo-ia32-libs_1_i386.deb
dpkg -i *.deb

Sprawdziłam potem pliki z oryginalnego AdobeAIRInstaller.bin, przed zaakceptowaniem licencji są dostępne w /tmp/air*** i w tej paczce z devolo różnią się tylko dwa, jeden *png, drugi *desktop, a reszta identyczna. Z kolei devolo-ia32-libs to zwykła wydmuszka więc nie ma sensu przejmować się i kombinować pod górkę.


Edit:
Jednak nie działa tak samo jak na Jessie, bo niestety E-Deklaracje na Testingu nie instalują, Jest błąd jak u Kolegi wyżej:

Nie można zainstalować aplikacji Adobe AIR. W systemie nie można odnaleźć narzędzi systemu Debian do tworzenia pakietów deb (na przykład dpkg-deb lub ar).

Edit2:
Zazdroszczę im tego projektu: https://aur.archlinux.org/packages/e-deklaracje/

Edit3:
Udało się tym sposobem: http://jazz.tvtom.pl/adobe-air-ipla-w-lmde-ubuntu-64-bit/

Kod:

apt-get install libbz2-1.0:i386 libxaw7:i386 libxmu6:i386 libxpm4:i386 \
libnspr4-0d:i386 gcc-4.9-base:i386 libncurses5:i386 libcrypto++6:i386 libssl1.0.2:i386
apt-get install lzma xz-utils

Kod:

root@debian:/tmp# wget --timestamping http://airdownload.adobe.com/air/lin/download/2.6/adobeair.deb
--2016-05-24 23:58:22--  http://airdownload.adobe.com/air/lin/download/2.6/adobeair.deb
Translacja airdownload.adobe.com (airdownload.adobe.com)... 104.87.188.245
Łączenie się z airdownload.adobe.com (airdownload.adobe.com)|104.87.188.245|:80... połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 301 Moved Permanently
Lokalizacja: https://airdownload.adobe.com/air/lin/download/2.6/adobeair.deb [podążanie]
--2016-05-24 23:58:22--  https://airdownload.adobe.com/air/lin/download/2.6/adobeair.deb
Łączenie się z airdownload.adobe.com (airdownload.adobe.com)|104.87.188.245|:443... połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 200 OK
Długość: 14855686 (14M) [application/x-deb]
Zapis do: `adobeair.deb'

adobeair.deb                100%[==========================================>]  14,17M  5,63MB/s    in 2,5s    

2016-05-24 23:58:24 (5,63 MB/s) - zapisano `adobeair.deb' [14855686/14855686]

root@debian:/tmp# dpkg-deb --extract adobeair.deb adobeair_64
root@debian:/tmp# dpkg-deb --control adobeair.deb adobeair_64/DEBIAN
root@debian:/tmp# sudo sed --in-place 's/Architecture: i386/Architecture: all/g' adobeair_64/DEBIAN/control
root@debian:/tmp# dpkg --build adobeair_64
dpkg-deb: building package 'adobeair' in 'adobeair_64.deb'.
root@debian:/tmp# rm --recursive adobeair_64
root@debian:/tmp# sudo dpkg --install adobeair_64.deb
Wybieranie wcześniej niewybranego pakietu adobeair.
(Odczytywanie bazy danych ... 104481 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu adobeair_64.deb ...

 Running 32-bit AIR on 64-bit systems has not been fully tested. However, 32-bit AIR is expected to run on 64-bit systems if they have the required 32-bit libraries and packages installed. 
 The following links describe how to install or update AIR 2.6 on 64-bit versions of Ubuntu 9.10, Fedora Core 12 and OpenSuse 11.2. 
 Installing Adobe AIR 2.6 on 64-bit Linux visit http://kb2.adobe.com/cps/521/cpsid_52132.html 
 Updating to Adobe AIR 2.6 on 64-bit Linux visit http://kb2.adobe.com/cps/521/cpsid_52132.html
Rozpakowywanie pakietu adobeair (1:2.6.0.19170) ...
Konfigurowanie pakietu adobeair (1:2.6.0.19170) ...
root@debian:/tmp# sudo ln --symbolic /usr/lib/libadobecertstore.so /usr/lib32

Edit4:
Sytuacja jak wcześniej, paczka AdobeAir instaluje się poprawnie, ale E-Deklaracje już nie chcą.

Ostatnio edytowany przez Renia (2016-05-25 00:55:42)


Instalacja E-Deklaracje na Debianie 64-bit:
https://forum.dug.net.pl/viewtopic.php?pid=301794#p301794

Offline

 

#18 2016-05-26 01:28:30

neo86
Lubię marudzić
Skąd: Depresja społeczności polskiej
Zarejestrowany: 2014-06-29

Re: Instalacja AdobeAir [SOLVED]

Ja nie wiem co Wy wyprawiacie...

Wystarczy zainstalować DEBy z tego miejsca: http://update.devolo.com/linux/apt/pool/main/a/adobeair/

Potem zainstalować plik "e-DeklaracjeDesktop.air"

i normalnie działa!

(Screen na dowód)
http://s25.postimg.org/lxo9seya3/edeklaracje_2016.jpg

Bez żadnych kombinacji z kompilowaniem czy bawieniem się z jakimś plikiem BIN.

Debian 8.x Jessie wersja 64 Bitowa...


Death R.I.P.

Offline

 

#19 2016-05-26 01:47:55

Renia
Użytkownik
Zarejestrowany: 2014-08-29

Re: Instalacja AdobeAir [SOLVED]

neo86 napisał(-a):

Ja nie wiem co Wy wyprawiacie...

Wystarczy zainstalować DEBy z tego miejsca: http://update.devolo.com/linux/apt/pool/main/a/adobeair/

Potem zainstalować plik "e-DeklaracjeDesktop.air"

i normalnie działa!

Bez żadnych kombinacji z kompilowaniem czy bawieniem się z jakimś plikiem BIN.

Debian 8.x Jessie wersja 64 Bitowa...

Na Jessie instalacja przebiega bez zarzutu bez względu na metodę, ale na Testing/Stretch już nie i nic tu nie pomogą te paczki co zalinkowałeś, bo E-Deklaracje nie chcą się zainstalować. Właśnie o tym jest ten wątek.

yaros napisał(-a):

e-Deklaracje skopiowałem z działającej instalacji -> wystarczyło skopiować katalog e-Deklaracje z /opt i utworzyć odpowiedni skrót

To jest rozwiązanie, oczywiście dla tych co mają kopię programu do przywrócenia.


Instalacja E-Deklaracje na Debianie 64-bit:
https://forum.dug.net.pl/viewtopic.php?pid=301794#p301794

Offline

 

#20 2016-05-26 03:04:27

rychu
elektryk dyżurny
Skąd: gdańsk
Zarejestrowany: 2004-12-28

Re: Instalacja AdobeAir [SOLVED]

Renia napisał(-a):

Właśnie o tym jest ten wątek.

trzeba będzie zorganizować jakiś medal za cierpliwość i spokój ducha


linux regd. user #248790

Offline

 

#21 2017-02-02 01:09:59

Renia
Użytkownik
Zarejestrowany: 2014-08-29

Re: Instalacja AdobeAir [SOLVED]

Co rok to horror.

Pojawiały się kolejne aktualizacje E-Deklaracji, ale pod systemem 64-bit nijak nie da się aktualizować więc zainstalowałam pod Debianem 32-bit i na żywca skopiowałam do /opt/e-Deklaracje w Debianie 64-bit. Działa, najnowsza wersja gotowa do wysłania PIT.


Instalacja E-Deklaracje na Debianie 64-bit:
https://forum.dug.net.pl/viewtopic.php?pid=301794#p301794

Offline

 

#22 2017-02-03 19:55:38

neo86
Lubię marudzić
Skąd: Depresja społeczności polskiej
Zarejestrowany: 2014-06-29

Re: Instalacja AdobeAir [SOLVED]

Renia napisał(-a):

Co rok to horror.

Pojawiały się kolejne aktualizacje E-Deklaracji, ale pod systemem 64-bit nijak nie da się aktualizować więc zainstalowałam pod Debianem 32-bit i na żywca skopiowałam do /opt/e-Deklaracje w Debianie 64-bit. Działa, najnowsza wersja gotowa do wysłania PIT.

Przepraszam ale po jakiego grzyba się męczysz? Strasznie sobie życie komplikujesz...

https://pit-format-online.pl/

I po problemie bo to jest aplikacja przeglądarkowa.


Death R.I.P.

Offline

 

#23 2017-02-04 00:38:13

Renia
Użytkownik
Zarejestrowany: 2014-08-29

Re: Instalacja AdobeAir [SOLVED]

Nie mam zamiaru posiłkować się wytworami jakiejś spółki z ograniczoną odpowiedzialnością, która wymaga zawarcia umowy na użycie tego czegoś i ogranicza mi możliwość  swobodnego wyboru podmiotu, któremu chcę przekazać 1% podatku.

Chcę korzystać E-Deklaracji, gdzie dostaję zawsze URZĘDOWE POŚWIADCZENIE ODBIORU.


Instalacja E-Deklaracje na Debianie 64-bit:
https://forum.dug.net.pl/viewtopic.php?pid=301794#p301794

Offline

 

#24 2017-02-04 20:20:42

Huk
Smoleńsk BULWA!
Zarejestrowany: 2006-11-08

Re: Instalacja AdobeAir [SOLVED]

@Renia:

UPO powinnaś dostać z KAŻDEJ aplikacji do składania pitu bo to jest generowane przez ministerstwo a nie przez te aplikację.

Generalnie działa to tak że programy do pitów generują tylko XML z danymi który potem i tak idzie do ministerstwa i z ministerstwa dostajesz zwrotny pliczek z UPO - owszem większość darmowych programów wymaga przekazania 1% podatku, ale zwykle jest możliwość zmiany domyślnego podmiotu (czytaj. standardowo jest wybrany przez twórców programu, ale możesz podać własny) - jedyne z czym się spotkałem to ograniczenie że nie można NIE wskazać żadnego podmiotu.

Hmm swoją drogą czy na stronie ZUS / US w tamtym roku czasem też nie było już wersji on-line w HTML5 do składania pitów... ?

Offline

 

#25 2017-02-04 20:45:15

Renia
Użytkownik
Zarejestrowany: 2014-08-29

Re: Instalacja AdobeAir [SOLVED]

Rozumiem Wasze dobre intencje, ale lepsze zło znane od nieznanego. Poza tym nadal nie widzę plusów korzystania z pośredników w postaci firm typu sp. z o.o. zawierania z nimi umów (zajrzyjcie sobie do ich regulaminów) i godzenia się na jakiekolwiek niedogodności z tym związane.

Od lat wysyłam z E-Deklaracji, które nie są idealne ze względu na antylinuksowy Adobe Reader i Air, ale mam wszystko ładnie poukładane w historii, zdarzyło mi się też robić korekty, a 1% podatku przekazuję komu chcę bez żadnych zbędnych kombinacji. PIT już poszedł z E-Deklaracji 9.01, czyli najnowszej wersji, a odezwałam się w temacie, żeby innym dać wskazówkę co do aktualizacji.

Edit:
Nie wiem, czy jakaś burza przeszła przez forum, widzę, że uzytkownikubunt usunął bardzo przydatny post z tego tematu przez co wątek sporo stracił...

Ostatnio edytowany przez Renia (2017-02-04 21:03:08)


Instalacja E-Deklaracje na Debianie 64-bit:
https://forum.dug.net.pl/viewtopic.php?pid=301794#p301794

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Możesz wyłączyć AdBlock — tu nie ma reklam ;-)