Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundacji Dzieciom zdazyć z Pomocą.
Więcej informacji na dug.net.pl/pomagamy/.

#1  2024-02-10 19:44:22

  skullman - Użytkownik

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Aktualizacja kernela i (chyba) nvidia

Na wstępie nadmienię, że przez pomyłkę stałem się posiadaczem maszyny z GPU od nVidia po grubo ponad dziesięciu latach unikania tego badziewia i za nic tego nie ogarniam.
Sam model karty i maszyny jest chyba bez znaczenia. System to bookworm, stery z repo w wersji 525.147.05-4~deb12u1 a cała konfiguracja bumblebee poszłą bez problemów i będów na kernelu

Kod:

6.1.0-17-amd64

Problem pojawił się dziś przy próbie aktualizacji systemu i pakietu jądra do wersji

Kod:

linux-image-6.1.0-18-amd64

Konfiguracja pakietu kończy się takimi kwiatkami:

Kod:

Po tej operacji zostanie dodatkowo użyte 0 B miejsca na dysku.
Konfigurowanie pakietu linux-image-6.1.0-18-amd64 (6.1.76-1) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-18-amd64.
Sign command: /usr/lib/linux-kbuild-6.1/scripts/sign-file
Signing key: /var/lib/dkms/mok.key
Public certificate (MOK): /var/lib/dkms/mok.pub

Building module:
Cleaning build area...
env NV_VERBOSE=1 make -j12 modules KERNEL_UNAME=6.1.0-18-amd64................(bad exit status: 2)
Error! Bad return status for module build on kernel: 6.1.0-18-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-current/525.147.05/build/make.log for more information.
Error! One or more modules failed to install during autoinstall.
Refer to previous errors for more information.
dkms: autoinstall for kernel: 6.1.0-18-amd64 failed!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 11
dpkg: błąd przetwarzania pakietu linux-image-6.1.0-18-amd64 (--configure):
 podproces zainstalowany pakiet linux-image-6.1.0-18-amd64 skrypt post-installation zwrócił kod błędu 1
Konfigurowanie pakietu linux-headers-6.1.0-18-amd64 (6.1.76-1) ...
/etc/kernel/header_postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-18-amd64.
Sign command: /usr/lib/linux-kbuild-6.1/scripts/sign-file
Signing key: /var/lib/dkms/mok.key
Public certificate (MOK): /var/lib/dkms/mok.pub

Building module:
Cleaning build area...
env NV_VERBOSE=1 make -j12 modules KERNEL_UNAME=6.1.0-18-amd64................(bad exit status: 2)
Error! Bad return status for module build on kernel: 6.1.0-18-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-current/525.147.05/build/make.log for more information.
Error! One or more modules failed to install during autoinstall.
Refer to previous errors for more information.
dkms: autoinstall for kernel: 6.1.0-18-amd64 failed!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 11
Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-headers-6.1.0-18-amd64.postinst line 11.
dpkg: błąd przetwarzania pakietu linux-headers-6.1.0-18-amd64 (--configure):
 podproces zainstalowany pakiet linux-headers-6.1.0-18-amd64 skrypt post-installation zwrócił kod błędu 1
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu linux-image-amd64:
 linux-image-amd64 zależy od linux-image-6.1.0-18-amd64 (= 6.1.76-1); jednakże:
  Pakiet linux-image-6.1.0-18-amd64 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu linux-image-amd64 (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu linux-headers-amd64:
 linux-headers-amd64 zależy od linux-headers-6.1.0-18-amd64 (= 6.1.76-1); jednakże:
  Pakiet linux-headers-6.1.0-18-amd64 nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu linux-headers-amd64 (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Wystąpiły błędy podczas przetwarzania:
 linux-image-6.1.0-18-amd64
 linux-headers-6.1.0-18-amd64
 linux-image-amd64
 linux-headers-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

a wspomniany log kończy się tak:

Kod:

ERROR: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol '__rcu_read_lock'
ERROR: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol '__rcu_read_unlock'
make[3]: *** [/usr/src/linux-headers-6.1.0-18-common/scripts/Makefile.modpost:126: /var/lib/dkms/nvidia-current/525.147.05/build/Module.symvers] Błąd 1
make[2]: *** [/usr/src/linux-headers-6.1.0-18-common/Makefile:1991: modpost] Błąd 2
make[2]: Opuszczenie katalogu '/usr/src/linux-headers-6.1.0-18-amd64'
make[1]: *** [Makefile:250: __sub-make] Błąd 2
make[1]: Opuszczenie katalogu '/usr/src/linux-headers-6.1.0-18-common'
make: *** [Makefile:82: modules] Błąd 2

Może ktoś używa śmieci od nVidii i zna sę trochę na tym? Znalazłem wątek na forum nVidii traktujący o podobnym problemie ale tam generalnie pisali, że problemy kompilacji pojawiają się w wersji 6.7 i chyba 6.8. Ja tego nie ogarniam bo przecież wersja jądra ani sterowników się nie zmieniła. Może spróbować z liquorixem?

Ostatnio edytowany przez skullman (2024-02-12 07:04:20)

Offline

 

#2  2024-02-10 21:35:53

  zl23 - Użytkownik

zl23
Użytkownik
Zarejestrowany: 2016-09-02

Re: Aktualizacja kernela i (chyba) nvidia

Witam.

Nie tylko ty masz z tym problem.
To wina dzisiejszej (10 luty) aktualizacji 12.4 -> 12.5.

Zerknij:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1062932
https://lists.debian.org/debian-kernel/2024/02/msg00144.html
https://lists.debian.org/debian-release/2024/02/msg00435.html

U mnie (sterownik firmowy NVidii – plik *.run) to samo.
Fragment pliku '/var/lib/dkms/nvidia/550.40.07/build/make.log'

Kod:

  LD [M]  /var/lib/dkms/nvidia/550.40.07/build/nvidia-modeset.o
  LD [M]  /var/lib/dkms/nvidia/550.40.07/build/nvidia-drm.o
  LD [M]  /var/lib/dkms/nvidia/550.40.07/build/nvidia-peermem.o
  LD [M]  /var/lib/dkms/nvidia/550.40.07/build/nvidia-uvm.o
  MODPOST /var/lib/dkms/nvidia/550.40.07/build/Module.symvers
ERROR: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol '__rcu_read_lock'
ERROR: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol '__rcu_read_unlock'
make[3]: *** [/usr/src/linux-headers-6.1.0-18-common/scripts/Makefile.modpost:126: /var/lib/dkms/nvidia/550.40.07/build/Module.symvers] Błąd 1
make[2]: *** [/usr/src/linux-headers-6.1.0-18-common/Makefile:1991: modpost] Błąd 2
make[2]: Opuszczenie katalogu '/usr/src/linux-headers-6.1.0-18-amd64'
make[1]: *** [Makefile:250: __sub-make] Błąd 2
make[1]: Opuszczenie katalogu '/usr/src/linux-headers-6.1.0-18-common'
make: *** [Makefile:85: modules] Błąd 2

Trzeba poczekać aż naprawią.
Debian działa normalnie na dotychczasowym jądrze.

PS.
Nie nazywałbym kart NVidii śmieciami.
Skąd taka niechęć?

Ostatnio edytowany przez zl23 (2024-02-10 21:52:24)

Offline

 

#3  2024-02-10 22:01:55

  skullman - Użytkownik

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Re: Aktualizacja kernela i (chyba) nvidia

OK, dzięki, szukałem w złym miejscu to i złe odpowiedzi znalazłem, jak widać w tym przypadku to problem z debianem (podobno stable) a nie sterownikiem od nVidii
Sam hardware bez odpowiednio działającego oprogramowania to śmieć a nvidia dostarcza takie właśnie śmiecie. To nie jest niechęć tylko praktyka. Dla porównania weź AMDGPU, działa od kopa, bez zbędnego drążenia manuala jak zmusić kartę graficzną do pracy.

Offline

 

#4  2024-02-10 23:11:18

  lama - Użytkownik

lama
Użytkownik
Zarejestrowany: 2012-08-28

Offline

 

#5  2024-02-11 07:49:36

  zl23 - Użytkownik

zl23
Użytkownik
Zarejestrowany: 2016-09-02

Re: Aktualizacja kernela i (chyba) nvidia

@lama
Dodanie gałęzi backports to nie jest rozwiązanie problemu.
Dodam, że aktualnie w backports mają jakiegoś starocia: 6.5.10-1~bpo12+1 z listopada ub. r.
https://backports.debian.org/changes/bookworm-backports.html

Dlatego uważam, że dopisanie '[solved]' do tematu wątku jest przedwczesne.

PS.
Z tą błędną aktualizacją nie ma tragedii, bo nowe jądro się nie skompilowało i Debian uruchamia się poprawnie na jądrze poprzednim.

Ostatnio edytowany przez zl23 (2024-02-11 07:51:45)

Offline

 

#6  2024-02-12 07:06:45

  skullman - Użytkownik

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Re: Aktualizacja kernela i (chyba) nvidia

Zmieniłem, jeśli uważasz, że przedwcześnie. My tu jednak tego nie rozwiążemy, trzeba poczekać na dewów Debiana.

Offline

 

#7  2024-02-12 08:02:13

  zl23 - Użytkownik

zl23
Użytkownik
Zarejestrowany: 2016-09-02

Re: Aktualizacja kernela i (chyba) nvidia

Dziwi mnie milczenie na ten temat na oficjalnej stronie Debiana:
https://www.debian.org/News/2024/20240210

Na różnych listach debianowych jest dość głośno z tego powodu.
Niektórzy ponoć nawet nie umieją uruchomić systemu po tej aktualizacji np.:
https://forums.debian.net/viewtopic.php?t=158200&am … &start=20

Błąd się może każdemu zdarzyć – ale żeby się nie przyznać?

A propos dewów Debiana.
Coś mi się wydaje, że zwalą winę na NVidię:
"My podnieśli ABI do 18, a NVidia to wiecie, rozumiecie..."

Ale to tylko takie moje niewinne spekulacje.
Pozdrawiam.

Offline

 

#8  2024-02-12 10:14:57

  skullman - Użytkownik

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Re: Aktualizacja kernela i (chyba) nvidia

Wiesz, dziwne jest to, że ani jądro ani sterownik nie dostały nowego numerka.

Offline

 

#9  2024-02-12 11:20:09

  Pavlo950 - człowiek pasjonat :D

Pavlo950
człowiek pasjonat :D
Zarejestrowany: 2012-02-20
Serwis

Re: Aktualizacja kernela i (chyba) nvidia

zl23 napisał(-a):

Błąd się może każdemu zdarzyć – ale żeby się nie przyznać?

A propos dewów Debiana.
Coś mi się wydaje, że zwalą winę na NVidię:
"My podnieśli ABI do 18, a NVidia to wiecie, rozumiecie..."

I słusznie. Starsze karty NVidii sprawiają również problem pod Windowsem - podobno coś nie halo jest ze sterownikiem i za bardzo "drenuje" procka.

A może ruszy pod kernelem liquorixa?

Online

 

#10  2024-02-12 21:58:34

  zl23 - Użytkownik

zl23
Użytkownik
Zarejestrowany: 2016-09-02

Re: Aktualizacja kernela i (chyba) nvidia

Coś się ruszyło.
W 'incoming' pojawiła się wersja 525.147.05-6~deb12u1 sterowników NVidia dla Bookworm (12 luty):
https://incoming.debian.org/debian-buildd/pool/non- … hics-drivers/

W changelog można przeczytać:

mvidia-graphics-drivers (525.147.05-6~deb12u1) bookworm; urgency=medium
  * Rebuild for bookworm.

— Andreas Beckmann <anbe@debian.org>  Sun, 11 Feb 2024 02:35:05 +0100

nvidia-graphics-drivers (525.147.05-6) unstable; urgency=medium

  * Apply pfn_valid patch from gentoo to fix kernel module build for
    Linux 6.1.76, 6.6.15, 6.7.3, 6.8.  (Closes: #1063363, #1062932)
  * nvidia-detect: Tesla and regular driver packages have been merged.
  * nvidia-detect: Add superficial autopkgtest for checking codename support.
  * Update lintian overrides.

— Andreas Beckmann <anbe@debian.org>  Fri, 09 Feb 2024 20:43:30 +0100

Za niedługo pakiety będą więc dostępne.
Załatane zostały  sterowniki z repozytorium Debiana.

Z tego wynika, że osoby używający sterowników ze strony www.nvidia.com (plik *.run) będę musiały poczekać na ruch NVidii.

PS.
Nie będzie już pakietów 'Tesla".
Ciekawe czy pakiet 'nvidia-tesla-470-driver' obsługujący starsze karty, dostępny w Bookworm zniknie czy zmieni nazwę na legacy?

PS. nr 2 (13 luty).
Tesla jednak po staremu:
https://incoming.debian.org/debian-buildd/pool/non- … rs-tesla-470/

nvidia-graphics-drivers-tesla-470 (470.223.02-4~deb12u1) bookworm; urgency=medium

  * Rebuild for bookworm.

— Andreas Beckmann <anbe@debian.org>  Tue, 13 Feb 2024 00:00:08 +0100

nvidia-graphics-drivers-tesla-470 (470.223.02-4) unstable; urgency=medium

  * Apply pfn_valid patch from gentoo to fix kernel module build for
    Linux 6.1.76, 6.6.15, 6.7.3, 6.8.  (Closes: #1063361)
  * Update lintian overrides.

— Andreas Beckmann <anbe@debian.org>  Thu, 08 Feb 2024 14:23:21 +0100

Ostatnio edytowany przez zl23 (2024-02-13 16:27:17)

Offline

 

#11  2024-02-13 19:28:41

  skullman - Użytkownik

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Re: Aktualizacja kernela i (chyba) nvidia

Liquorix zbudował się normalnie.

Kod:

$ uname -r
6.7.4-1-liquorix-amd64

Offline

 

#12  2024-02-13 21:06:09

  zl23 - Użytkownik

zl23
Użytkownik
Zarejestrowany: 2016-09-02

Re: Aktualizacja kernela i (chyba) nvidia

https://wiki.debian.org/DontBreakDebian

Pozwolę sobie na kilka cytatów z ww. strony:

W Debianie instalowanie oprogramowania z przypadkowych stron internetowych jest złym nawykiem.
Zawsze lepiej jest używać oprogramowania z oficjalnych repozytoriów Debiana, jeśli to w ogóle możliwe.

Nie twórz FrankenDebian (to od stwora dr Frankensteina, który był pozszywany z wielu innych części)
Debian Stable nie powinien być bezmyślnie łączony z innymi wydaniami.

Nie podążaj ślepo za złymi radami
Niestety w Internecie można znaleźć wiele złych porad. Samouczki znalezione na blogach, forach i innych stronach często zawierają instrukcje, które w subtelny sposób zepsują Twój system. Nie kieruj się po prostu pierwszą poradą, którą znajdziesz lub tutorialem, który wydaje się najłatwiejszy. Poświęć trochę czasu na przeczytanie dokumentacji i porównaj różnice między tutorialami.

A to, że Debian ma taka wtopę z Nvidią i od 3 dni od wydania 12.5 (jak można przeczytać na listach sygnały o tym błędzie były juz 4 lutego) nie ma w repozytorium poprawionych paczek to osobna historia.
Dziwne, że zdecydowali się wersję 12.5 uwolnić z takim błędem.
Użytkowników z kartami Nvidia chyba nie ma znów tak mało.
Chyba, że Nvidia ma tak mocno u nich nagrabione.
Może ...

Pozdrawiam.

Ostatnio edytowany przez zl23 (2024-02-13 21:07:16)

Offline

 

#13  2024-02-14 23:24:23

  wachcio - Użytkownik

wachcio
Użytkownik
Zarejestrowany: 2019-08-10

Re: Aktualizacja kernela i (chyba) nvidia

Też "nadziałem" się na tę aktualizację. Jak usunąć to niepoprawnie zainstalowane nowe jądro, żeby przy każdym włączaniu kompa nie trzeba było ręcznie wybierać. Może tylko zmiany w grub-ie?

Offline

 

#14  2024-02-15 07:20:45

  zl23 - Użytkownik

zl23
Użytkownik
Zarejestrowany: 2016-09-02

Re: Aktualizacja kernela i (chyba) nvidia

@wachcio
Proponuję poczekać – w końcu wiecznie tego nie będą naprawiać.

Ale jak tak bardzo chcesz...
Ja bym zrobił to tak.
1. Sprawdzenie na jakim jadrze "jadę"

Kod:

uname -a
Linux user 6.1.0-17-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.69-1 (2023-12-30) x86_64 GNU/Linux

U mnie jest to 6.1.69.
Felerne jadro to 6.1.76.
Paczek 6.1.69 nie ruszam!

2.
Wyświetlenie zainstalowanych paczek dot. jadra

Kod:

dpkg -l | grep 6.1.69
ii  linux-headers-6.1.0-17-amd64            6.1.69-1                            amd64        Header files for Linux 6.1.0-17-amd64
ii  linux-headers-6.1.0-17-common           6.1.69-1                            all          Common header files for Linux 6.1.0-17
ii  linux-image-6.1.0-17-amd64              6.1.69-1                            amd64        Linux 6.1 for 64-bit PCs (signed)

Kod:

dpkg -l | grep 6.1.76
ii  linux-compiler-gcc-12-x86               6.1.76-1                            amd64        Compiler for Linux on x86 (meta-package)
iF  linux-headers-6.1.0-18-amd64            6.1.76-1                            amd64        Header files for Linux 6.1.0-18-amd64
ii  linux-headers-6.1.0-18-common           6.1.76-1                            all          Common header files for Linux 6.1.0-18
iU  linux-headers-amd64                     6.1.76-1                            amd64        Header files for Linux amd64 configuration (meta-package)
iF  linux-image-6.1.0-18-amd64              6.1.76-1                            amd64        Linux 6.1 for 64-bit PCs (signed)
iU  linux-image-amd64                       6.1.76-1                            amd64        Linux for 64-bit PCs (meta-package)
ii  linux-kbuild-6.1                        6.1.76-1                            amd64        Kbuild infrastructure for Linux 6.1
ii  linux-libc-dev:amd64                    6.1.76-1                            amd64        Linux support headers for userspace development

3. Usunąłbym tylko

Kod:

linux-headers-6.1.0-18-amd64            6.1.76-1                            
linux-headers-6.1.0-18-common           6.1.76-1
linux-image-6.1.0-18-amd64              6.1.76-1

Pozostałe pakiety są potrzebne – należy tylko obniżyć ich wersję (z 6.1.76 –> 6.1.69).
Najłatwiej zrobić to w Synapticu: "Pakiet – wymuś wersję"

Pozdrawiam.

PS.
Przyczyną tego zamieszania jest sterownik Nvidii – dobre jądro nie może się skompilować na dotychczasowym sterowniku.
Dopóki w repozytorium nie pojawi się poprawiony nvidia-driver to jądro 6.1.76 będzie sprawiało problemy.

Ostatnio edytowany przez zl23 (2024-02-15 07:39:22)

Offline

 

#15  2024-02-16 23:31:33

  wachcio - Użytkownik

wachcio
Użytkownik
Zarejestrowany: 2019-08-10

Re: Aktualizacja kernela i (chyba) nvidia

U mnie już aktualizacja poszła bez problemu

Offline

 

#16  2024-02-17 07:21:26

  zl23 - Użytkownik

zl23
Użytkownik
Zarejestrowany: 2016-09-02

Re: Aktualizacja kernela i (chyba) nvidia

Radujmy się!

W repozytorium Debiana Bookworm pojawiły się poprawione pakiety:
nvidia-driver                    525.147.05-7~deb12u1
nvidia-tesla-470-driver    470.223.02-4~deb12u1

Właściciele kart NVidia używający zastrzeżonych sterowników mogą więc aktualizować.

Kod:

date
sob, 17 lut 2024, 07:01:02 CET

Kod:

# apt update

# apt policy nvidia-driver
nvidia-driver:
  Zainstalowana: 525.147.05-4~deb12u1
  Kandydująca:   525.147.05-7~deb12u1

# apt policy nvidia-tesla-470-driver
nvidia-tesla-470-driver:
  Zainstalowana: (brak)
  Kandydująca:   470.223.02-4~deb12u1

W moim przypadku aktualizacja przebiegła poprawnie.

Osoby korzystające ze sterownika ze strony www.nvidia.com (plik *.run) muszą jeszcze poczekać, bo NVidia na narazie jeszcze sterowników nie zaktualizowała:
https://www.nvidia.com/en-us/drivers/unix/

PS.
@wachcio
To cieszy, że nie miałeś problemu z aktualizacją.
Ale problemów z aktualizacją również nie mieli posiadacze kart graficznych Intela, Amd a także NVidii którzy korzystali z wolnego sterownika nouveau.

Pozdrawiam.

Offline

 

#17  2024-02-17 13:53:27

  wachcio - Użytkownik

wachcio
Użytkownik
Zarejestrowany: 2019-08-10

Re: Aktualizacja kernela i (chyba) nvidia

Tak wiem, że sprawa dotyczyła części użytkowników. Po prostu chciałem poinformować innych, że mogą już aktualizować choć wyraziłem się dużo mniej precyzyjnie

Offline

 

#18  2024-02-23 19:59:13

  zl23 - Użytkownik

zl23
Użytkownik
Zarejestrowany: 2016-09-02

Re: Aktualizacja kernela i (chyba) nvidia

Aby informacja była kompletna.

Dzisiaj NVidia była taka grzeczna i wypuściła poprawione sterowniki 550.54.14, 535.161.07, 470.239.06 (pliki *.run):
https://www.nvidia.com/download/driverResults.aspx/218826/en-us/
https://www.nvidia.com/download/driverResults.aspx/218856/en-us/
https://www.nvidia.com/Download/driverResults.aspx/218852/en-us/

Sprawdziłem.
NVIDIA-Linux-x86_64-550.54.14-no-compat32.run + jądro 6.1.0-18-amd64  Debian 6.1.76-1.
Wszystko w porządku – zainstalowane i działa..

Po prawie dwóch tygodniach problem został rozwiązany definitywnie (tak myślę, chociaż jąder  535.161.07, 470.239.06 nie sprawdzałem).
(24 luty: sprawdziłem  470.239.06 – działa).

Tu: https://download.nvidia.com/XFree86/Linux-x86_64/ nie ma jeszcze katalogu 550.54.14/ , ale jak w w poleceniu wget wpisze się go ręcznie + nazwa pliku to się go ściągnie.
(26 luty: katalogi 550.54.14/, 535.161.07/, 470.239.06 są już widoczne).

Pozdrawiam.

Ostatnio edytowany przez zl23 (2024-02-26 18:46:49)

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
To nie jest tylko forum, to nasza mała ojczyzna ;-)