Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundacji Dzieciom zdazyć z Pomocą.
Więcej informacji na dug.net.pl/pomagamy/.

#1  2022-01-05 15:33:16

  norse - Użytkownik

norse
Użytkownik
Zarejestrowany: 2022-01-05

[Solved]Nie mogę usunąć mono-complete

Pakiet był uszkodzony, nie dało się go poprawnie zainstalować w sidzie.

Kod:

Następujące pakiety mają niespełnione zależności:
 libnunit-cil-dev : Wymaga: libnunit-console-runner2.6.3-cil (= 2.6.4+dfsg-1.1) ale nie zostanie zainstalowany
E: Niespełnione zależności. Proszę spróbować wykonać "apt --fix-broken install" bez pakietów (lub podać rozwiązanie).

Kod:

dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libnunit-cil-dev:
 libnunit-cil-dev zależy od libnunit-console-runner2.6.3-cil (= 2.6.4+dfsg-1.1);
 jednakże:
  Pakiet libnunit-console-runner2.6.3-cil nie jest zainstalowany.

dpkg: błąd przetwarzania pakietu libnunit-cil-dev (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Konfigurowanie pakietu libnunit-core-interfaces2.6.3-cil (2.6.4+dfsg-1.1) ...
* Installing 1 assembly from libnunit-core-interfaces2.6.3-cil into Mono
E: installing Assembly /usr/lib/cli/nunit.core.interfaces-2.6.3/nunit.core.inter
faces.dll failed
E: Installation of libnunit-core-interfaces2.6.3-cil with /usr/share/cli-common/
runtimes.d/mono failed
dpkg: błąd przetwarzania pakietu libnunit-core-interfaces2.6.3-cil (--configure)
:
 podproces zainstalowany pakiet libnunit-core-interfaces2.6.3-cil skrypt post-in
stallation zwrócił kod błędu 29
Konfigurowanie pakietu libnunit-framework2.6.3-cil (2.6.4+dfsg-1.1) ...
* Installing 1 assembly from libnunit-framework2.6.3-cil into Mono
E: installing Assembly /usr/lib/cli/nunit.framework-2.6.3/nunit.framework.dll fa
iled
E: Installation of libnunit-framework2.6.3-cil with /usr/share/cli-common/runtim
es.d/mono failed
dpkg: błąd przetwarzania pakietu libnunit-framework2.6.3-cil (--configure):
 podproces zainstalowany pakiet libnunit-framework2.6.3-cil skrypt post-installa
tion zwrócił kod błędu 29
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libnunit-m
ocks2.6.3-cil:
 libnunit-mocks2.6.3-cil zależy od libnunit-framework2.6.3-cil; jednakże:
  Pakiet libnunit-framework2.6.3-cil nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libnunit-mocks2.6.3-cil (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libnunit-c
ore2.6.3-cil:
 libnunit-core2.6.3-cil zależy od libnunit-core-interfaces2.6.3-cil; jednakże:
  Pakiet libnunit-core-interfaces2.6.3-cil nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libnunit-core2.6.3-cil (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libmono-ci
l-dev:
 libmono-cil-dev zależy od libnunit-cil-dev (>= 2.4); jednakże:
  Pakiet libnunit-cil-dev nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libmono-cil-dev (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libnunit-u
til2.6.3-cil:
 libnunit-util2.6.3-cil zależy od libnunit-core-interfaces2.6.3-cil; jednakże:
  Pakiet libnunit-core-interfaces2.6.3-cil nie jest jeszcze skonfigurowany.
 libnunit-util2.6.3-cil zależy od libnunit-core2.6.3-cil; jednakże:
  Pakiet libnunit-core2.6.3-cil nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libnunit-util2.6.3-cil (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu mono-devel
:
 mono-devel zależy od libmono-cil-dev (= 6.8.0.105+dfsg-3.2); jednakże:
  Pakiet libmono-cil-dev nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu mono-devel (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu mono-xsp4-
base:
 mono-xsp4-base zależy od mono-devel; jednakże:
  Pakiet mono-devel nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu mono-xsp4-base (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu mono-xsp4:
 mono-xsp4 zależy od mono-xsp4-base (= 4.2-2.3); jednakże:
  Pakiet mono-xsp4-base nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu mono-xsp4 (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu monodoc-ht
tp:
 monodoc-http zależy od mono-xsp4 | mono-apache-server4 | mono-fastcgi-server4; 
jednakże:
  Pakiet mono-xsp4 nie jest jeszcze skonfigurowany.
  Pakiet mono-apache-server4 nie jest zainstalowany.
  Pakiet mono-fastcgi-server4 nie jest zainstalowany.

dpkg: błąd przetwarzania pakietu monodoc-http (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu monodoc-ma
nual:
 monodoc-manual zależy od monodoc-http | monodoc-viewer; jednakże:
  Pakiet monodoc-http nie jest jeszcze skonfigurowany.
  Pakiet monodoc-viewer nie jest zainstalowany.
  Pakiet monodoc-http dostarcza monodoc-viewer, ale nie został jeszcze skonfigur
owany.

dpkg: błąd przetwarzania pakietu monodoc-manual (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Wystąpiły błędy podczas przetwarzania:
 libnunit-cil-dev
 libnunit-core-interfaces2.6.3-cil
 libnunit-framework2.6.3-cil
 libnunit-mocks2.6.3-cil
 libnunit-core2.6.3-cil
 libmono-cil-dev
 libnunit-util2.6.3-cil
 mono-devel
 mono-xsp4-base
 mono-xsp4
 monodoc-http
 monodoc-manual
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ostatnio edytowany przez norse (2022-01-05 19:02:48)

Offline

 

#2  2022-01-05 16:01:06

  fnmirk - Redaktor

fnmirk
Redaktor
Zarejestrowany: 2008-02-19

Re: [Solved]Nie mogę usunąć mono-complete

A co zwraca polecenie:

Kod:

apt --fix-broken install

Spróbuj odinstalować te pakiety

norse napisał(-a):

Kod:

libnunit-cil-dev
 libnunit-core-interfaces2.6.3-cil
 libnunit-framework2.6.3-cil
 libnunit-mocks2.6.3-cil
 libnunit-core2.6.3-cil
 libmono-cil-dev
 libnunit-util2.6.3-cil
 mono-devel
 mono-xsp4-base
 mono-xsp4
 monodoc-http
 monodoc-manual

Offline

 

#3  2022-01-05 16:09:02

  norse - Użytkownik

norse
Użytkownik
Zarejestrowany: 2022-01-05

Re: [Solved]Nie mogę usunąć mono-complete

Niestety nie pomaga. I przy usuwaniu pojawia się.

Kod:

Następujące pakiety mają niespełnione zależności:
 mono-xsp4 : Wymaga: mono-xsp4-base (= 4.2-2.3) ale nie zostanie zainstalowany
E: Niespełnione zależności. Proszę spróbować wykonać "apt --fix-broken install" bez pakietów (lub podać rozwiązanie).

apt install mono-xsp4-base
Następujące pakiety mają niespełnione zależności:
 libnunit-cil-dev : Wymaga: libnunit-console-runner2.6.3-cil (= 2.6.4+dfsg-1.1) ale nie zostanie zainstalowany
E: Niespełnione zależności. Proszę spróbować wykonać "apt --fix-broken install" bez pakietów (lub podać rozwiązanie).

Ponownie apt --fix-broken install pokazuje to samo. Polecenie to zwraca to co wkleiłem w tym drugim kodzie w poście wyżej.

Ostatnio edytowany przez norse (2022-01-05 16:10:14)

Offline

 

#4  2022-01-05 16:25:51

  fnmirk - Redaktor

fnmirk
Redaktor
Zarejestrowany: 2008-02-19

Re: [Solved]Nie mogę usunąć mono-complete

To niestety jest Sid i wymaga czasem dziwnych rozwiązań. Spróbuj zbudować pusty pakiet libnunit-console-runner2.6.3-cil według tego opisu:
https://dug.net.pl/drukuj/154/equivs___tworzenie_pustych_pakietow/

Offline

 

#5  2022-01-05 16:52:17

  norse - Użytkownik

norse
Użytkownik
Zarejestrowany: 2022-01-05

Re: [Solved]Nie mogę usunąć mono-complete

Przez ten wadliwy pakiet nie mogę zainstalować equivs, ani żadnego innego pakietu.

Offline

 

#6  2022-01-05 17:36:57

  fnmirk - Redaktor

fnmirk
Redaktor
Zarejestrowany: 2008-02-19

Re: [Solved]Nie mogę usunąć mono-complete

Spróbuj:

Kod:

apt update

i następnie:

Kod:

apt -o Debug::pkgProblemResolver=yes upgrade

Polecenia z forum wklejaj do edytora tekstu i dopiero do terminala, albo przepisuj. Inaczej mogą pojawić się błędy.

Przeczytaj:
https://www.debian.org/doc/manuals/debian-reference … y_downgrading

Dodatkowo:
https://www.debian.org/doc/manuals/debian-reference … e_of_archives
https://www.debian.org/doc/manuals/debian-reference … idate_version

Offline

 

#7  2022-01-05 17:57:26

  norse - Użytkownik

norse
Użytkownik
Zarejestrowany: 2022-01-05

Re: [Solved]Nie mogę usunąć mono-complete

Próbowałem też usunąć w ten sposób, jednak nie pomogło ten pakiet libnunit-core-interfaces2.6.3-cil i jego pliki są uszkodzone.

Kod:

cd /var/lib/dpkg/info
ls libnunit-console-runner2.6.3-cil*
rm libnunit-console-runner2.6.3-cil.clilibs libnunit-console-runner2.6.3-cil.list libnunit-console-runner2.6.3-cil.md5sums libnunit-console-runner2.6.3-cil.postinst libnunit-console-runner2.6.3-cil.postrm libnunit-console-runner2.6.3-cil.prerm
dpkg --remove --force-remove-reinstreq libnunit-console-runner2.6.3-cil

Kod:

apt -o Debug::pkgProblemResolver=yes upgrade

Konfigurowanie pakietu libnunit-core-interfaces2.6.3-cil (2.6.4+dfsg-1.1) ...
W: removing assembly: The assembly mscorlib.dll was not found or could not be lo
aded. failed!
E: installing Assembly /usr/share/cli-common/policies.d/libnunit-core-interfaces
2.6.3-cil/policy.2.6.nunit.core.interfaces.dll failed
E: Installation of policy.2.6.nunit.core.interfaces with /usr/share/cli-common/r
untimes.d/mono failed
dpkg: błąd przetwarzania pakietu libnunit-core-interfaces2.6.3-cil (--configure)
:
 podproces zainstalowany pakiet libnunit-core-interfaces2.6.3-cil skrypt post-in
stallation zwrócił kod błędu 1
Konfigurowanie pakietu libnunit-framework2.6.3-cil (2.6.4+dfsg-1.1) ...
! /usr/share/cli-common/packages.d/libnunit-framework2.6.3-cil.installcligac doe
sn't exist!
dpkg: błąd przetwarzania pakietu libnunit-framework2.6.3-cil (--configure):
 podproces zainstalowany pakiet libnunit-framework2.6.3-cil skrypt post-installa
tion zwrócił kod błędu 1
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libnunit-m
ocks2.6.3-cil:
 libnunit-mocks2.6.3-cil zależy od libnunit-framework2.6.3-cil; jednakże:
  Pakiet libnunit-framework2.6.3-cil nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libnunit-mocks2.6.3-cil (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libnunit-c
ore2.6.3-cil:
 libnunit-core2.6.3-cil zależy od libnunit-core-interfaces2.6.3-cil; jednakże:
  Pakiet libnunit-core-interfaces2.6.3-cil nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libnunit-core2.6.3-cil (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu libnunit-u
til2.6.3-cil:
 libnunit-util2.6.3-cil zależy od libnunit-core-interfaces2.6.3-cil; jednakże:
  Pakiet libnunit-core-interfaces2.6.3-cil nie jest jeszcze skonfigurowany.
 libnunit-util2.6.3-cil zależy od libnunit-core2.6.3-cil; jednakże:
  Pakiet libnunit-core2.6.3-cil nie jest jeszcze skonfigurowany.

dpkg: błąd przetwarzania pakietu libnunit-util2.6.3-cil (--configure):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Wystąpiły błędy podczas przetwarzania:
 libnunit-core-interfaces2.6.3-cil
 libnunit-framework2.6.3-cil
 libnunit-mocks2.6.3-cil
 libnunit-core2.6.3-cil
 libnunit-util2.6.3-cil
E: Sub-process /usr/bin/dpkg returned an error code (1)

Offline

 

#8  2022-01-05 18:08:20

  fnmirk - Redaktor

fnmirk
Redaktor
Zarejestrowany: 2008-02-19

Re: [Solved]Nie mogę usunąć mono-complete

Spróbuj jeszcze:

Kod:

apt-get -f install

Ewentualnie:

Kod:

dpkg --configure -a

Jeszcze można spróbować, jeżeli masz zainstalowany program aptitude, jego użyć do diagnozy. Jednak z nim ci nie pomogę bo go praktycznie nie używam i mogę ci pomóc do reszty zepsuć system. Jednak czasem aptitude pomaga rozwiązać problem.

Offline

 

#9  2022-01-05 18:12:09

  norse - Użytkownik

norse
Użytkownik
Zarejestrowany: 2022-01-05

Re: [Solved]Nie mogę usunąć mono-complete

Ogólnie wszystkie polecenia wraz z aptitude już próbowałem, wyskakują w nim te same błędy. Prawdopodobnie są jakieś brakujące i uszkodzone pliki w katalogu /usr/share/cli-common/policies.d/

Ostatnio edytowany przez norse (2022-01-05 19:02:05)

Offline

 

#10  2022-01-05 18:20:50

  mati75 - Psuj

mati75
Psuj
Skąd: default city
Zarejestrowany: 2010-03-14
Serwis

Re: [Solved]Nie mogę usunąć mono-complete

Kod:

dpkg -r -f libnunit-console-runner2.6.3-cil

Kod:

apt-get install -f

https://l0calh0st.pl/obrazki/userbar.png

Offline

 

#11  2022-01-05 18:27:44

  fnmirk - Redaktor

fnmirk
Redaktor
Zarejestrowany: 2008-02-19

Re: [Solved]Nie mogę usunąć mono-complete

Tak, ale aptitude często sugeruje rozwiązanie problemu.

Skup się na przejrzeniu: https://www.debian.org/doc/manuals/debian-reference/index.en.html, autor często dostarcza właściwych podpowiedzi ułatwiających rozwiązanie problemu.

Spróbuj użyć dpkg do usuwania tych pakietów.

Kod:

dpkg --purge nazwa_pakietu

Polecenie dpkg posiada opcję --force-..., wymuszenie działań bez względu na konsekwencje. Jej użycie wymaga dużej rozwagi.

Przeczytaj wcześniej:

Kod:

dpkg --force-help

Offline

 

#12  2022-01-05 18:34:17

  norse - Użytkownik

norse
Użytkownik
Zarejestrowany: 2022-01-05

Re: [Solved]Nie mogę usunąć mono-complete

Ciągle ten pakiet blokuje wszystko.

Kod:

dpkg --purge --force-all libnunit-console-runner2.6.3-cil
(Odczytywanie bazy danych ... 140827 plików i katalogów obecnie zainstalowanych.)
Usuwanie pakietu libnunit-console-runner2.6.3-cil (2.6.4+dfsg-1.1) ...
E: File does not exist: /usr/share/cli-common/packages.d/policy.2.6.nunit-console-runner.installcligac
dpkg: błąd przetwarzania pakietu libnunit-console-runner2.6.3-cil (--purge):
 podproces zainstalowany pakiet libnunit-console-runner2.6.3-cil skrypt post-removal zwrócił kod błędu 1
Wystąpiły błędy podczas przetwarzania:
 libnunit-console-runner2.6.3-cil

Offline

 

#13  2022-01-05 18:48:13

  fnmirk - Redaktor

fnmirk
Redaktor
Zarejestrowany: 2008-02-19

Re: [Solved]Nie mogę usunąć mono-complete

Pewne rzeczy musisz wykonać kompleksowo. Używasz najpierw dpkg, a następnie naprawiasz system używając menadżera apt.

Użyj kolejno poleceń tak jak przedstawił to mati75. Możesz użyć dpkg tak jak użyłeś lub tak jak przedstawił to mati75.

Offline

 

#14  2022-01-05 19:01:20

  norse - Użytkownik

norse
Użytkownik
Zarejestrowany: 2022-01-05

Re: [Solved]Nie mogę usunąć mono-complete

Wygląda na to że rozwiązałem problem w następujący sposób. Dziękuje wam za pomoc.

Kod:

ls -l /var/lib/dpkg/info | grep -i libnunit-framework2.6.3-cil
mv /var/lib/dpkg/info/libnunit-framework2.6.3-cil.* /tmp
mv /var/lib/dpkg/info/libnunit-core-interfaces2.6.3-cil.* /tmp

Następnie programem do osieroconych pakietów usunąłem resztę zależności.

Kod:

deborphan --guess-all
apt purge libmono-*

Ostatnio edytowany przez norse (2022-01-06 10:34:02)

Offline

 

#15  2022-01-06 13:39:19

  fnmirk - Redaktor

fnmirk
Redaktor
Zarejestrowany: 2008-02-19

Re: [Solved]Nie mogę usunąć mono-complete

To jeszcze wykonaj:

Kod:

apt autoremove

i

Kod:

apt purge `dpkg -l | grep '^rc' | awk '{print $2}'`

Zapisz sobie co chce usuwać apt, bo czasem może usunąć istotne pakiety dla systemu (to jest Sid).

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Możesz wyłączyć AdBlock — tu nie ma reklam ;-)