Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundacji Dzieciom zdazyć z Pomocą.
Więcej informacji na dug.net.pl/pomagamy/.

#1  2020-09-27 23:24:40

  P@blo - Nadworny matematyk

P@blo
Nadworny matematyk
Skąd: Wrocław v Jasło
Zarejestrowany: 2010-11-11

[solved][nginx]<meta> in <head> not working

Cześć,

Dawno nic nie pisałem, ale wiem że na towarzystwo tutaj zawsze można liczyć :)

Od razu mówię - nie znam się - z webówki to cienias ze mnie, tyle że wiem jakieś podstawy. Pierwotna potrzeba to odświeżanie obrazka na stronie za każdym F5. Chodzi o to żeby obrazek był załadowany za każdym razem a nie leciał z cache-u. Z tego co już wiem to najlepiej dodać meta w nagłówku i z tego co rozumiem to coś w tym stylu:

Kod:

$ head index.html
<html>
        <head>
                <meta http-equiv="content-type" content="text/html;charset=utf-8">
                <title>testowy</title>
                <meta http-equiv="Cache-control" content="no-cache">
                <META HTTP-EQUIV="EXPIRES" CONTENT="Mon, 22 Jul 2002 11:12:01 GMT">
        </head>
        </body>
...

Problem w tym że poza <title> nic nie działa:

Kod:

$ curl -I localhost
HTTP/1.1 200 OK
Server: nginx/1.10.3
Date: Sun, 27 Sep 2020 21:19:41 GMT
Content-Type: text/html
Content-Length: 1114
Last-Modified: Sun, 27 Sep 2020 20:38:53 GMT
Connection: keep-alive
ETag: "5f70f85d-45a"
Accept-Ranges: bytes

Coś prawdopodobnie trzeba doinstalować, ustawić w configu... nie wiem, szukam już któryś dzień ale google dziwadła mi podsyła...


Dzięki za jakąkolwiek podpowiedź :)
Pozdr

Ostatnio edytowany przez P@blo (2020-10-02 15:13:48)


ThinkPadX220i
| Procesor: Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz |
|  Debian: sid   |   Arch: amd64   |   Sound: alsa   |
| No DE | WM: DWM  |  DM: .bash_profile  |  BIOS+MBR |

Offline

 

#2  2020-09-29 17:32:19

  rulezdc - Członek DUG

rulezdc
Członek DUG
Skąd: Tarnowskie Góry
Zarejestrowany: 2007-05-22

Re: [solved][nginx]<meta> in <head> not working

Cześć
A nie czasami powinieneś użyć nagówka:
https://developer.mozilla.org/pl/docs/Web/HTTP/Headers/Cache-Control

Offline

 

#3  2020-09-29 18:48:15

  mati75 - Psuj

mati75
Psuj
Skąd: default city
Zarejestrowany: 2010-03-14
Serwis

Re: [solved][nginx]<meta> in <head> not working

do nginxa:

Kod:

        add_header Last-Modified $date_gmt;
        add_header Cache-Control 'no-store, no-cache, must-revalidate, proxy-revalidate, max-age=0';
        if_modified_since off;
        expires off;
        etag off;

https://l0calh0st.pl/obrazki/userbar.png

Offline

 

#4  2020-10-01 13:30:22

  P@blo - Nadworny matematyk

P@blo
Nadworny matematyk
Skąd: Wrocław v Jasło
Zarejestrowany: 2010-11-11

Re: [solved][nginx]<meta> in <head> not working

Hej,

No tak jak pisałem, nie znam się, nie wszystko jest tu dla mnie oczywiste. Raczej szukałem rozwiązania, które wpłynie na jedną konkretną stronę, a nie całą usługę. Ale ok dodałem do /etc/nginx/nginx.conf w sekcji http:

Kod:

(...)
http {

        ##
        # Basic Settings
        ##
        (...)

        include /etc/nginx/conf.d/*.conf;
        include /etc/nginx/sites-enabled/*;

        add_header Last-Modified $date_gmt;
        add_header Cache-Control 'no-store, no-cache, must-revalidate, proxy-revalidate, max-age=0';
        if_modified_since off;
        expires off;
        etag off;
}
(..)

następnie:

Kod:

$ sudo service nginx reload
[ ok ] Reloading nginx configuration: nginx.
$ curl -I localhost
HTTP/1.1 200 OK
Server: nginx/1.10.3
Date: Thu, 01 Oct 2020 11:17:39 GMT
Content-Type: text/html
Content-Length: 1114
Connection: keep-alive
Last-Modified: Thursday, 01-Oct-2020 11:17:39 GMT
Cache-Control: no-store, no-cache, must-revalidate, proxy-revalidate, max-age=0
Accept-Ranges: bytes

czyli niby ok, ale niestety strona (w chrome - bo może to ważne) odświeża się tak jak wcześniej czyli F5, łąduje z cache, a CTRL+SHIFT+R faktycznie odświeża stronę i ładuje wszystko od nowa.

Prawdopodobnie strona jest ustawiona i skonfigurowana prawidłowo, ale optymalizacja chromium nakazuje mimo wszystko ignorować i trzymać w cache-u co się da... Jeśli jednak ktoś ma jeszcze jakiś pomysł to chętnie skorzystam.

Dzięki

[edit]
Zmieniłem zwykłego html na php, dodałem dump parametr rand(1,10000) do obrazka i hula. Trudno :)

Pozdrawiam

Ostatnio edytowany przez P@blo (2020-10-02 15:15:10)


ThinkPadX220i
| Procesor: Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz |
|  Debian: sid   |   Arch: amd64   |   Sound: alsa   |
| No DE | WM: DWM  |  DM: .bash_profile  |  BIOS+MBR |

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
To nie jest tylko forum, to nasza mała ojczyzna ;-)