Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundacji Dzieciom zdazyć z Pomocą.
Więcej informacji na dug.net.pl/pomagamy/.

#1  2019-08-18 01:33:41

  mjaqb - Nowy użytkownik

mjaqb
Nowy użytkownik
Zarejestrowany: 2019-08-18

Problem z apache i http2 w Debian 10

Zrobiłem upgrade z Debian 9.5 do 10 i przestał działać http2. Nie bardzo wiem, co powinienem sprawdzać, czego szukać - w konfigu apache jest aktywowany h2, apache wstaje bez błędów... ale http2 nie działa? OpenSSL 1.1.1c  28 May 2019 więc powinien wspierać (?).

Z góry dzięki za jakieś pomysły.

Offline

 

#2  2019-08-18 02:19:04

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Problem z apache i http2 w Debian 10

Logi Apacha, szczególnie error.log powinny coś wyjaśnić.


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#3  2019-08-18 06:01:25

  Bodzio - Ojciec Założyciel

Bodzio
Ojciec Założyciel
Skąd: Gorlice
Zarejestrowany: 2004-04-17
Serwis

Re: Problem z apache i http2 w Debian 10

Miałem podobnie z owncloud. Błędem był brak współpracy Apache z najnowszym php7. Powrót do poprzedniej wersji rozwiązał sprawę.


Debian jest lepszy niż wszystkie klony
Linux register users: #359018
http://www.freebsd.org/gifs/powerlogo.gif
Beskid Niski

Offline

 

#4  2019-08-18 09:31:05

  urbinek - Użytkownik

urbinek
Użytkownik
Skąd: Sosnowiec
Zarejestrowany: 2009-10-01
Serwis

Re: Problem z apache i http2 w Debian 10

systemctl --failed
systemctl status [nazwa usługi która nie działa]

i zarzucić logami z samego apacha


A w wolnym czasie, robię noże :)
http://nginx.urbinek.eu/_photos/signature.png

Online

 

#5  2019-08-18 11:04:30

  yossarian - Szczawiożerca

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Problem z apache i http2 w Debian 10

Bodzio napisał(-a):

Miałem podobnie z owncloud. Błędem był brak współpracy Apache z najnowszym php7. Powrót do poprzedniej wersji rozwiązał sprawę.

Aktualny Apache bez problemów współpracuje z PHP7.3:

Kod:

PHP 7.3.4-2 (cli) (built: Apr 13 2019 19:05:48) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.4, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.4-2, Copyright (c) 1999-2018, by Zend Technologies
Server version: Apache/2.4.38 (Debian)
Server built:   2019-04-07T18:15:40

U Ciebie problemem był sam owncloud (projekt od dawna pozbawiony odpowiedniego wsparcia).

W tym przypadku bez logów niczego nie można powiedzieć.

Offline

 

#6  2019-08-18 14:24:58

  mjaqb - Nowy użytkownik

mjaqb
Nowy użytkownik
Zarejestrowany: 2019-08-18

Re: Problem z apache i http2 w Debian 10

Wiem już więcej - w logu mam:

[Sun Aug 18 14:21:42.227173 2019] [http2:warn] [pid 22134] AH10034: The mpm module (prefork.c) is not supported by mod_http2. The mpm determines how things are processed in your server. HTTP/2 has more demands in this regard and the currently selected mpm will just not do. This is an advisory warning. Your server will continue to work, but the HTTP/2 protocol will be inactive.

natomiast w momencie gdy próbuję wyłączyć mpm_prefork dostaję informację, że zależy od niego php 7.3. Czy da się uruchomić php 7.3 i http2?

Offline

 

#7  2019-08-18 14:52:44

  yossarian - Szczawiożerca

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Problem z apache i http2 w Debian 10

Tu masz instrukcje (na dole w sekcji Troubleshooting):
https://http2.pro/doc/Apache

Offline

 

#8  2019-08-18 15:02:53

  mjaqb - Nowy użytkownik

mjaqb
Nowy użytkownik
Zarejestrowany: 2019-08-18

Re: Problem z apache i http2 w Debian 10

Ale ta instrukcja mówi mniej-więcej - wyłącz php 7.3, włącz php 7.1. Ja pytałem czy mogę zostać przy php 7.3 i używać http2 czy nie jest to możliwe?

Offline

 

#9  2019-08-18 16:51:06

  yossarian - Szczawiożerca

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Problem z apache i http2 w Debian 10

Bez urazy, ale czytanie nie jest twoją najmocniejszą stroną…

Offline

 

#10  2019-08-18 20:19:40

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Problem z apache i http2 w Debian 10

Musisz przełączyć Apacha na MPM Event albo MPM Worker.
To wynika z Twojego kawałka logu, i nie trzeba do tego specjalnych kombinacji alpejskich.

Albo w ogóle fruwać na Nginxa, ten gada po http2 bez problemu ostatnio,
a nie ma setek modułów i trybów pracy, jak Apache.


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#11  2019-08-18 20:34:43

  mjaqb - Nowy użytkownik

mjaqb
Nowy użytkownik
Zarejestrowany: 2019-08-18

Re: Problem z apache i http2 w Debian 10

Faktycznie nie doczytałem. Wielkie dzięki za pomoc! Działa.

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
To nie jest tylko forum, to nasza mała ojczyzna ;-)