Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2018-09-20 17:55:20

Blackhole
Użytkownik
Skąd: Chorzów
Zarejestrowany: 2005-09-07
Serwis

[gpp] libmvec.so.1 nie znaleziony przez ld

Hej.
Kompiluję na VPS-ie programik, w którym używam następujących plików nagłówkowycg:

#include <stdio.h>
#include <stdlib.h>
#include <string>
//#include <vector>
#include <list>
#include <iostream>
#include "math.h"

//#include <occi.h>

#include <unistd.h>
#include <sys/stat.h>
#include <sys/time.h>

#include <dirent.h>
#include <time.h>

i wywala mi błąd:

Kod:

~/bin$ make

g++ -I../include -I/usr/include  mz_s.cpp
/usr/bin/ld: cannot find /lib/x86_64-linux-gnu/libmvec.so.1
collect2: error: ld returned 1 exit status
Makefile:13: polecenia dla obiektu 'mz_s.o' nie powiodły się
make: *** [mz_s.o] Błąd 1

Makefile wygląda tak:

INCLUDES= -I../include -I/usr/include

XLIBS= -L/usr/X11R6/lib
LIBS= $(XLIBS)

OBJECTS=mz_s.o

OPTIM=

.SUFFIXES: .cpp .h

.cpp.o:
    clear
    g++ $(INCLUDES) $(OPTIM) $<
    @mv a.out mz_s

all: mz_s

mz_s: $(OBJECTS)
    @echo "-------------------------------------------------------------"

clean:
    rm -f $(OBJECTS)
    rm -f *~

W necie prawie nic nie ma o takim błędzie.
Ktoś jest w stanie pomóc?
Czy można jakoś znaleźć, jaki pakiet potrzebuję doinstalować, aby ta biblioteka była dostępna?


Ściskam prawicę, Jacek

http://doscniewoli.plPoznaj prawdę o pieniądzach
http://www.youtube.com/watch?v=BlhFK2Gc1Nw — cz. I

Offline

 

#2 2018-09-20 18:00:32

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: [gpp] libmvec.so.1 nie znaleziony przez ld

Biblioteka ta jest w libc6, więc powinieneś ją mieć w systemie.

Offline

 

#3 2018-09-20 18:10:01

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: [gpp] libmvec.so.1 nie znaleziony przez ld

Kod:

ls -l /lib/x86_64-linux-gnu/libmvec.so.1
lrwxrwxrwx 1 root root 15 lip 16 22:23 /lib/x86_64-linux-gnu/libmvec.so.1 -> libmvec-2.27.so

Może  masz stare pliki nagłówkowe libc6-dev, albo zwalone dowiązanie?


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#4 2018-09-20 18:10:02

Blackhole
Użytkownik
Skąd: Chorzów
Zarejestrowany: 2005-09-07
Serwis

Re: [gpp] libmvec.so.1 nie znaleziony przez ld

Okazuje się, że mam straszny bałagan w pakietach... niespełnione zależności, itd. Można powiedzieć, iż w tym temacie jestem zielony.
Mogę prosić o jakieś wskazówki, jakich poleceń użyć, by jakoś "odkopać" się z tym błędów pokazywanych w aptitude? Co chwilę mam coś na czerwono.


Ściskam prawicę, Jacek

http://doscniewoli.plPoznaj prawdę o pieniądzach
http://www.youtube.com/watch?v=BlhFK2Gc1Nw — cz. I

Offline

 

#5 2018-09-20 18:11:08

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: [gpp] libmvec.so.1 nie znaleziony przez ld

Kod:

aptitude dist-upgrade

na początek.


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#6 2018-09-20 18:42:16

Blackhole
Użytkownik
Skąd: Chorzów
Zarejestrowany: 2005-09-07
Serwis

Re: [gpp] libmvec.so.1 nie znaleziony przez ld

~# aptitude dist-upgrade
Następujące NOWE pakiety zostaną zainstalowane:   
  autopoint{a} dh-autoreconf{a} dh-strip-nondeterminism{a} libapparmor1{a} libdrm-amdgpu1{a} libdrm-amdgpu1:i386{a} libfastjson4{a} libfile-stripnondeterminism-perl{ab} libgphoto2-port12{a}
  libldap-common{a} libllvm3.8{a} libllvm3.8:i386{a} liblognorm5{a} librpmsign3{a} libseccomp2{a}
Następujące pakiety zostaną zaktualizowane:
  autoconf dbconfig-common debhelper debugedit e2fslibs e2fsprogs gettext gettext-base i965-va-driver i965-va-driver:i386 ifupdown ldap-utils libasprintf-dev libasprintf0c2 libcomerr2 libcups2
  libcupsimage2 libdrm-dev libdrm-intel1 libdrm-intel1:i386 libdrm-nouveau2 libdrm-nouveau2:i386 libdrm-radeon1 libdrm-radeon1:i386 libdrm2 libdrm2:i386 libgcrypt20 libgcrypt20:i386 libgeoip1
  libgettextpo-dev libgettextpo0 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-dri:i386{b} libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386 libglib2.0-0 libglib2.0-data libgpg-error0
  libgpg-error0:i386 libgphoto2-6 libgphoto2-dev libgphoto2-l10n libjs-jquery libjs-sphinxdoc libjs-underscore libldap-2.4-2 libldap-2.4-2:i386 libldap2-dev libllvm3.5 libllvm3.5:i386 libodbc1
  libpam-systemd libpcap0.8 libpcap0.8:i386 libpulse0 libpulse0:i386 librpm3 librpmbuild3 librpmio3 libsqlite3-0 libss2 libssl-dev libssl-doc libssl1.0.0 libssl1.0.0:i386 libsystemd0 libsystemd0:i386
  libudev1 libudev1:i386 libva1 libva1:i386 libvdpau1 libvdpau1:i386 manpages manpages-dev mesa-common-dev odbcinst odbcinst1debian2 openssl python-dnspython rpm rpm-common rpm2cpio{b} rsyslog
  shared-mime-info systemd systemd-sysv tar tcpdump udev unixodbc va-driver-all va-driver-all:i386 vdpau-va-driver vdpau-va-driver:i386
Następujące częściowo zainstalowane pakiety zostaną skonfigurowane:
  binutils lib32z1 lib32z1-dev libc-dev-bin{b} libc6 libc6-dev{b} libc6-dev-i386 libc6-dev-x32{b} libc6-i386{b} locales{b} zlib1g-dev{b}
Następujące pakiety POLECANE przez inne NIE zostaną zainstalowane:
  geoip-database
98 pakietów aktualizowanych, 15 instalowanych, 0 do usunięcia i 2 nieaktualizowanych.
Do pobrania 0 B archiwów. Zajęte po rozpakowaniu: 99,3 MB.
Następujące pakiety mają niespełnione zależności:
rpm2cpio : Wymaga: libarchive13 który jest pakietem wirtualnym.
libc6-dev-x32 : Wymaga: libc6-x32 (= 2.24-11+deb9u1) ale zainstalowana jest wersja 2.19-18+deb8u6.
libgphoto2-2-dev : Wymaga: libgphoto2-dev (= 2.5.4-1.1+b2) ale zaplanowana jest instalacja wersji 2.5.12-1~bpo8+1.
zlib1g-dev : Wymaga: zlib1g (= 1:1.2.8.dfsg-5) ale zainstalowana jest wersja 1:1.2.8.dfsg-2+b1.
libfile-stripnondeterminism-perl : Wymaga: libarchive-zip-perl który jest pakietem wirtualnym.
libgl1-mesa-dri:i386 : Wymaga: libsensors4:i386 (>= 1:3.0.0) który jest pakietem wirtualnym.
libc-dev-bin : Wymaga: libc6 (> 2.24) ale zainstalowana jest wersja 2.19-18+deb8u6.
libc6-i386 : Wymaga: libc6 (= 2.24-11+deb9u1) ale zainstalowana jest wersja 2.19-18+deb8u6.
librpmsign1 : Wymaga: librpm3 (= 4.11.3-1.1) ale zaplanowana jest instalacja wersji 4.12.0.2+dfsg1-2~bpo8+1.
               Wymaga: librpmio3 (= 4.11.3-1.1) ale zaplanowana jest instalacja wersji 4.12.0.2+dfsg1-2~bpo8+1.
locales : Wymaga: libc-bin (> 2.24) ale zainstalowana jest wersja 2.19-18+deb8u6.
libc6-dev : Wymaga: libc6 (= 2.24-11+deb9u1) ale zainstalowana jest wersja 2.19-18+deb8u6.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
E: Nie można znaleźć źródła do pobrania wersji "2.19-18+deb8u6" pakietu "libc6:i386"
Następujące działania rozwiążą problemy z zależnościami:

      Usunięcie następujących pakietów:                     
1)      alien                                               
2)      build-essential                                     
3)      debhelper                                           
4)      dh-php5                                             
5)      g++                                                 
6)      g++-4.9                                             
7)      gcc-4.9-multilib                                   
8)      gcc-multilib                                       
9)      lib32asan1                                         
10)     lib32atomic1                                       
11)     lib32cilkrts5                                       
12)     lib32gcc-4.9-dev                                   
13)     lib32gcc1                                           
14)     lib32gomp1                                         
15)     lib32itm1                                           
16)     lib32ncurses5                                       
17)     lib32ncurses5-dev                                   
18)     lib32quadmath0                                     
19)     lib32stdc++6                                       
20)     lib32tinfo-dev                                     
21)     lib32tinfo5                                         
22)     lib32ubsan0                                         
23)     lib32z1                                             
24)     lib32z1-dev                                         
25)     libc-dev-bin                                       
26)     libc6-dev                                           
27)     libc6-dev-i386                                     
28)     libc6-dev-x32                                       
29)     libc6-i386                                         
30)     libexif-dev                                         
31)     libexpat1-dev                                       
32)     libfontconfig1-dev                                 
33)     libfreetype6-dev                                   
34)     libftgl-dev                                         
35)     libgl1-mesa-dri:i386                               
36)     libgphoto2-2-dev                                   
37)     libgphoto2-dev                                     
38)     libncurses5-dev                                     
39)     libpcre3-dev                                       
40)     libpng12-dev                                       
41)     librpmsign1                                         
42)     libssl-dev                                         
43)     libstdc++-4.9-dev                                   
44)     libtool                                             
45)     libusb-dev                                         
46)     libx32asan1                                         
47)     libx32cilkrts5                                     
48)     libx32gcc-4.9-dev                                   
49)     libx32ubsan0                                       
50)     locales                                             
51)     php5-dev                                           
52)     pkg-php-tools                                       
53)     postgresql                                         
54)     postgresql-9.6                                     
55)     postgresql-contrib-9.6                             
56)     rpm                                                 
57)     rpm2cpio                                           
58)     sun-java6-bin                                       
59)     sun-java6-jre                                       
60)     zlib1g-dev                                         

      Zatrzymanie bieżących wersji następujących pakietów: 
61)     dh-autoreconf [niezainstalowany]                   
62)     dh-strip-nondeterminism [niezainstalowany]         
63)     libfile-stripnondeterminism-perl [niezainstalowany]

      Pozostawienie następujących problemów z zależnościami:
64)     libgl1-mesa-glx:i386 poleca libgl1-mesa-dri:i386   
65)     libltdl-dev poleca libtool                         
66)     gcc-4.9 poleca libc6-dev (>= 2.13-5)               
67)     gcc poleca libc6-dev | libc-dev                     
68)     dpkg-dev poleca build-essential                     
69)     wine32-development:i386 poleca libgl1-mesa-dri:i386
70)     libgcc-4.9-dev poleca libc6-dev (>= 2.13-5)         
71)     libc6-dev-i386 poleca gcc-multilib                 


Zaakceptować rozwiązanie? [Y/n/q/?]

Jest to bezpieczne?


Ściskam prawicę, Jacek

http://doscniewoli.plPoznaj prawdę o pieniądzach
http://www.youtube.com/watch?v=BlhFK2Gc1Nw — cz. I

Offline

 

#7 2018-09-20 18:49:08

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: [gpp] libmvec.so.1 nie znaleziony przez ld

Nie wiem, co tam masz za repozytoria, ale je przejrzyj najpierw.


Potem zrób sobie backup całego folderu /etc, a potem możesz wywalić dowolną liczbę pakietów aż osiągniesz poziom instalatora.

W Debianie nie ma problemu wywalonych bibliotek, bo ich zainstalowanie trwa kilka minut.

Jak masz backup swoich zmian w plikach konfiguracyjnych i skryptów, oraz innych unikalnych rzeczy, które sam tam popełniłeś bądź są z innych powodów niepowtarzalne, to nawet totalne zaoranie VPSa to też nie jest problem,
którym trzeba się nadmiernie przejmować.

Poza tym masz tam np:

Kod:

   libgl1-mesa-glx:

Czyżbyś do VPSa zapiął telepatycznie monitor? xD
Bo Xorg nie obrabia GLX przez połączenie TCP, OpenGL i EGL gadają ze sterami przez urządzenia blokowe /dev/dri/card* albo inne specyficzne dla danego sterownika,
ale nie przez sieć.

Dowód rzeczowy organoleptyczny:

Kod:

COMMAND     PID USER   FD   TYPE  DEVICE SIZE/OFF  NODE NAME
X          9032 root  mem    CHR 195,255           2622 /dev/nvidiactl
X          9032 root  mem    CHR   195,0           2623 /dev/nvidia0
X          9032 root   12u   CHR 195,255      0t0  2622 /dev/nvidiactl
X          9032 root   13u   CHR   10,63      0t0  1034 /dev/vga_arbiter
X          9032 root   14u   CHR   195,0      0t0  2623 /dev/nvidia0
X          9032 root   15u   CHR   195,0      0t0  2623 /dev/nvidia0
X          9032 root   16u   CHR   195,0      0t0  2623 /dev/nvidia0
X          9032 root   19u   CHR 195,254      0t0 39043 /dev/nvidia-modeset
X          9032 root   21u   CHR 226,128      0t0  3123 /dev/dri/renderD128
X          9032 root   22u   CHR   195,0      0t0  2623 /dev/nvidia0
X          9032 root   23u   CHR   195,0      0t0  2623 /dev/nvidia0
X          9032 root   24u   CHR   195,0      0t0  2623 /dev/nvidia0
X          9032 root   25u   CHR   195,0      0t0  2623 /dev/nvidia0
X          9032 root   26u   CHR   195,0      0t0  2623 /dev/nvidia0
X          9032 root   27u   CHR 195,255      0t0  2622 /dev/nvidiactl
X          9032 root   28u   CHR 195,254      0t0 39043 /dev/nvidia-modeset
X          9032 root   29u   CHR   195,0      0t0  2623 /dev/nvidia0
X          9032 root   30u   CHR   195,0      0t0  2623 /dev/nvidia0
X          9032 root   32u   CHR 226,128      0t0  3123 /dev/dri/renderD128
quiterss  10110 pacjent  mem    CHR 195,255           2622 /dev/nvidiactl
quiterss  10110 pacjent    6u   CHR 195,255      0t0  2622 /dev/nvidiactl
quiterss  10110 pacjent    7u   CHR   195,0      0t0  2623 /dev/nvidia0
quiterss  10110 pacjent    8u   CHR   195,0      0t0  2623 /dev/nvidia0
choqok    10148 pacjent  mem    CHR 195,255           2622 /dev/nvidiactl
choqok    10148 pacjent    6u   CHR 195,255      0t0  2622 /dev/nvidiactl
choqok    10148 pacjent    7u   CHR   195,0      0t0  2623 /dev/nvidia0
choqok    10148 pacjent    8u   CHR   195,0      0t0  2623 /dev/nvidia0
kglobalac 10160 pacjent  mem    CHR 195,255           2622 /dev/nvidiactl
kglobalac 10160 pacjent    6u   CHR 195,255      0t0  2622 /dev/nvidiactl
kglobalac 10160 pacjent    7u   CHR   195,0      0t0  2623 /dev/nvidia0
kglobalac 10160 pacjent    8u   CHR   195,0      0t0  2623 /dev/nvidia0
kwalletd5 10173 pacjent  mem    CHR 195,255           2622 /dev/nvidiactl
kwalletd5 10173 pacjent    6u   CHR 195,255      0t0  2622 /dev/nvidiactl
kwalletd5 10173 pacjent    7u   CHR   195,0      0t0  2623 /dev/nvidia0
kwalletd5 10173 pacjent    8u   CHR   195,0      0t0  2623 /dev/nvidia0
klauncher 10265 pacjent  mem    CHR 195,255           2622 /dev/nvidiactl
klauncher 10265 pacjent    5u   CHR 195,255      0t0  2622 /dev/nvidiactl
klauncher 10265 pacjent    6u   CHR   195,0      0t0  2623 /dev/nvidia0
klauncher 10265 pacjent    7u   CHR   195,0      0t0  2623 /dev/nvidia0
kded5     10321 pacjent  mem    CHR 195,255           2622 /dev/nvidiactl
kded5     10321 pacjent    6u   CHR 195,255      0t0  2622 /dev/nvidiactl
kded5     10321 pacjent    7u   CHR   195,0      0t0  2623 /dev/nvidia0
kded5     10321 pacjent    8u   CHR   195,0      0t0  2623 /dev/nvidia0
firefox   10402 pacjent  mem    CHR 195,255           2622 /dev/nvidiactl
firefox   10402 pacjent  mem    CHR   195,0           2623 /dev/nvidia0
firefox   10402 pacjent   47u   CHR 195,255      0t0  2622 /dev/nvidiactl
firefox   10402 pacjent   49u   CHR 195,254      0t0 39043 /dev/nvidia-modeset
firefox   10402 pacjent   50u   CHR   195,0      0t0  2623 /dev/nvidia0
firefox   10402 pacjent   51u   CHR   195,0      0t0  2623 /dev/nvidia0
firefox   10402 pacjent   53u   CHR 226,128      0t0  3123 /dev/dri/renderD128
firefox   10402 pacjent   54u   CHR 195,254      0t0 39043 /dev/nvidia-modeset
firefox   10402 pacjent   55u   CHR   195,0      0t0  2623 /dev/nvidia0
firefox   10402 pacjent   56u   CHR   195,0      0t0  2623 /dev/nvidia0
firefox   10402 pacjent   57u   CHR   195,0      0t0  2623 /dev/nvidia0
firefox   10402 pacjent   58u   CHR   195,0      0t0  2623 /dev/nvidia0
firefox   10402 pacjent   59u   CHR   195,0      0t0  2623 /dev/nvidia0
firefox   10402 pacjent   64u   CHR 195,254      0t0 39043 /dev/nvidia-modeset
firefox   10402 pacjent   67u   CHR   195,0      0t0  2623 /dev/nvidia0
firefox   10402 pacjent   69u   CHR   195,0      0t0  2623 /dev/nvidia0
firefox   10402 pacjent   71u   CHR   195,0      0t0  2623 /dev/nvidia0
firefox   10402 pacjent   74u   CHR   195,0      0t0  2623 /dev/nvidia0
firefox   10402 pacjent   77u   CHR   195,0      0t0  2623 /dev/nvidia0

Pozdro

Ostatnio edytowany przez Jacekalex (2018-09-20 19:01:18)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#8 2018-09-20 20:18:27

Blackhole
Użytkownik
Skąd: Chorzów
Zarejestrowany: 2005-09-07
Serwis

Re: [gpp] libmvec.so.1 nie znaleziony przez ld

Po wybraniu "Y", efekt jest taki:

Zaakceptować rozwiązanie? [Y/n/q/?] Y
Następujące NOWE pakiety zostaną zainstalowane:
  autopoint{a} libapparmor1{a} libdrm-amdgpu1{a} libfastjson4{a} libgphoto2-port12{a} libldap-common{a} libllvm3.8{a} liblognorm5{a} libseccomp2{a}
Następujące pakiety zostaną USUNIĘTE:
  alien{a} build-essential{a} debhelper{a} dh-php5{a} g++{a} g++-4.9{a} gcc-4.9-multilib{a} gcc-multilib{a} lib32asan1{a} lib32atomic1{a} lib32cilkrts5{a} lib32gcc-4.9-dev{a} lib32gcc1{a} lib32gomp1{a}
  lib32itm1{a} lib32ncurses5{a} lib32ncurses5-dev{a} lib32quadmath0{a} lib32stdc++6{a} lib32tinfo-dev{a} lib32tinfo5{a} lib32ubsan0{a} lib32z1{a} lib32z1-dev{a} libc-dev-bin{a} libc6-dev{a}
  libc6-dev-i386{a} libc6-dev-x32{a} libc6-i386{a} libexif-dev{a} libexpat1-dev{a} libfontconfig1-dev{a} libfreetype6-dev{a} libftgl-dev{a} libgl1-mesa-dri:i386{a} libgphoto2-2-dev{a} libgphoto2-dev{a}
  libncurses5-dev{a} libpcre3-dev{a} libpng12-dev{a} librpmsign1{a} libssl-dev{a} libstdc++-4.9-dev{a} libtool{a} libusb-dev{a} libx32asan1{a} libx32cilkrts5{a} libx32gcc-4.9-dev{a} libx32ubsan0{a}
  locales{a} php5-dev{a} pkg-php-tools{a} postgresql{a} postgresql-9.6{a} postgresql-contrib-9.6{a} rpm{a} rpm2cpio{a} sun-java6-bin{a} sun-java6-jre{a} zlib1g-dev{a}
Następujące pakiety zostaną zaktualizowane:
  autoconf dbconfig-common debugedit e2fslibs e2fsprogs gettext gettext-base i965-va-driver i965-va-driver:i386 ifupdown ldap-utils libasprintf-dev libasprintf0c2 libcomerr2 libcups2 libcupsimage2
  libdrm-dev libdrm-intel1 libdrm-intel1:i386 libdrm-nouveau2 libdrm-nouveau2:i386 libdrm-radeon1 libdrm-radeon1:i386 libdrm2 libdrm2:i386 libgcrypt20 libgcrypt20:i386 libgeoip1 libgettextpo-dev
  libgettextpo0 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386 libglib2.0-0 libglib2.0-data libgpg-error0 libgpg-error0:i386 libgphoto2-6
  libgphoto2-l10n libjs-jquery libjs-sphinxdoc libjs-underscore libldap-2.4-2 libldap-2.4-2:i386 libldap2-dev libllvm3.5 libllvm3.5:i386 libodbc1 libpam-systemd libpcap0.8 libpcap0.8:i386 libpulse0
  libpulse0:i386 librpm3 librpmbuild3 librpmio3 libsqlite3-0 libss2 libssl-doc libssl1.0.0 libssl1.0.0:i386 libsystemd0 libsystemd0:i386 libudev1 libudev1:i386 libva1 libva1:i386 libvdpau1 libvdpau1:i386
  manpages manpages-dev mesa-common-dev odbcinst odbcinst1debian2 openssl python-dnspython rpm-common rsyslog shared-mime-info systemd systemd-sysv tar tcpdump udev unixodbc va-driver-all
  va-driver-all:i386 vdpau-va-driver vdpau-va-driver:i386
Następujące częściowo zainstalowane pakiety zostaną skonfigurowane:
  binutils libc6
Następujące pakiety POLECANE przez inne NIE zostaną zainstalowane:
  geoip-database
92 pakietów aktualizowanych, 9 instalowanych, 60 do usunięcia i 2 nieaktualizowanych.
Do pobrania 0 B archiwów. Zwolnione po rozpakowaniu: 248 MB.
Kontynuować? [Y/n/?] Y
E: Nie można znaleźć źródła do pobrania wersji "2.19-18+deb8u6" pakietu "libc6:i386"
E: Nie można znaleźć źródła do pobrania wersji "2.19-18+deb8u6" pakietu "libc6:i386"
E: Błąd wewnętrzny: nie można utworzyć listy pakietów do pobrania
~#


Ściskam prawicę, Jacek

http://doscniewoli.plPoznaj prawdę o pieniądzach
http://www.youtube.com/watch?v=BlhFK2Gc1Nw — cz. I

Offline

 

#9 2018-09-20 20:34:38

Blackhole
Użytkownik
Skąd: Chorzów
Zarejestrowany: 2005-09-07
Serwis

Re: [gpp] libmvec.so.1 nie znaleziony przez ld

Mój /etc/apt/sources.list:

Kod:

# deb http://ftp.pl.debian.org/debian/ squeeze main

deb http://ftp.pl.debian.org/debian/ squeeze main non-free contrib
deb-src http://ftp.pl.debian.org/debian/ squeeze main non-free contrib

#deb http://http.debian.net/debian squeeze-backports main

deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

deb http://ftp.pl.debian.org/debian/ squeeze-updates main contrib non-free
deb-src http://ftp.pl.debian.org/debian/ squeeze-updates main contrib non-free

deb http://ftp.pl.debian.org/debian/ jessie-backports main contrib non-free
deb-src http://ftp.pl.debian.org/debian/ jessie-backports main contrib non-free

# squeeze-updates, previously known as 'volatile'
#deb http://ftp.pl.debian.org/debian/ squeeze-updates main contrib non-free
#deb-src http://ftp.pl.debian.org/debian/ squeeze-updates main contrib non-free

#deb http://www.deb-multimedia.org/ oldstable main non-free

Ściskam prawicę, Jacek

http://doscniewoli.plPoznaj prawdę o pieniądzach
http://www.youtube.com/watch?v=BlhFK2Gc1Nw — cz. I

Offline

 

#10 2018-09-20 20:48:10

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: [gpp] libmvec.so.1 nie znaleziony przez ld

Kod:

###   root ~> cat /etc/apt/apt.conf

APT::Default-Release "stable";
APT::Get::Install-Recommends "false";
APT::Get::Install-Suggests "false";
Apt::Get::Purge;
Acquire::PDiffs "true";

Dpkg::Options {
   "--force-confdef";
   "--force-confold";
}

Dpkg::Progress-Fancy "1";
APT::Color "1";

Kod:

###  root ~> cat /etc/apt/sources.list
deb https://deb.debian.org/debian stable main  
deb-src https://deb.debian.org/debian stable main  
deb https://deb.debian.org/debian stable-updates main  
deb-src https://deb.debian.org/debian stable-updates main  
deb https://deb.debian.org/debian/ stretch-backports main  
deb-src https://deb.debian.org/debian stretch-backports main  
deb https://deb.debian.org/debian-security stable/updates main
deb-src https://deb.debian.org/debian-security stable/updates main

deb https://deb.debian.org/debian testing main  
deb-src https://deb.debian.org/debian testing main  
deb https://deb.debian.org/debian testing-updates main  
deb-src https://deb.debian.org/debian testing-updates main  
deb https://deb.debian.org/debian-security testing/updates main
deb-src https://deb.debian.org/debian-security testing/updates main

#Prosody IM
deb https://packages.prosody.im/debian stretch main

Kod:

root ~> aptitude -y dist-upgrade
Nie zostaną zainstalowane, zaktualizowane ani usunięte żadne pakiety.
0 pakietów aktualizowanych, 0 instalowanych, 0 do usunięcia i 0 nieaktualizowanych.
Do pobrania 0 B archiwów. Zajęte po rozpakowaniu: 0 B.

SOA#1

Jak trzymasz porządek w systemie, to potem masz porządek w systemie. xD

PS:
Do apt po https może być potrzebna paczuszka:

Kod:

apt-transport-https

Za uwagę dziękuje:

Kod:

root ~> lsb_release -a
No LSB modules are available.
Distributor ID:    Debian
Description:    Debian GNU/Linux 9.5 (stretch)
Release:    9.5
Codename:    stretch

EDIT:
Masz pomieszane repozytoria Squeeze (Debian 6) i oldstable (wersja Debian 8 Jessie ).
Pomieszanie Squeeze i Jessie w repo to gotowy przepis na piękną katastrofę,
zwłaszcza jak repo Jessie dodasz do Squeeze, wtedy pomimo wpisu oldstable to repo jest o 2 wydania młodsze od Squeeze
Jeśli jeszcze do tego nie ustawiłeś zmiennej Default-Release, to w ogóle dziwne, że przy próbie aktualizacji z tego systemu zostało cokolwiek, co jeszcze działa. xD


Pozdro
;-)

Ostatnio edytowany przez Jacekalex (2018-09-20 20:58:35)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#11 2018-09-20 21:35:28

Blackhole
Użytkownik
Skąd: Chorzów
Zarejestrowany: 2005-09-07
Serwis

Re: [gpp] libmvec.so.1 nie znaleziony przez ld

U mnie nie ma pliku /etc/apt/apt.conf
Pewnie to pojawia się w nowszej wersji Debiana.

Myślisz, że mogę sobie podmienić bez obaw mój sources.list na ten Twój?

-----edit-----

Kod:

# lsb_release -a
No LSB modules are available.
Distributor ID:    Debian
Description:    Debian GNU/Linux 8.6 (jessie)
Release:    8.6
Codename:    jessie

Ostatnio edytowany przez Blackhole (2018-09-20 21:37:28)


Ściskam prawicę, Jacek

http://doscniewoli.plPoznaj prawdę o pieniądzach
http://www.youtube.com/watch?v=BlhFK2Gc1Nw — cz. I

Offline

 

#12 2018-09-20 22:00:53

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: [gpp] libmvec.so.1 nie znaleziony przez ld

U mnie nie ma pliku /etc/apt/apt.conf
Pewnie to pojawia się w nowszej wersji Debiana.

Nigdy nie pojawia się w żadnej wersji Debiana.

Pojawia się wtedy, jak użyjesz edytora tesktu i taki plik tam zapiszesz.

Co do podmiany repo, to po zainstalowaniu apt-transport-https i aktualizacji list pakietów pewnie trzeba najpierw zaktualizować apta i aptitude.

Ale przed podmianką repozytoriów trzeba wyprostować apta czyli wypierdolić wszystkie paczki, które powodują konflikty (na starych repozytoriach), choćby trzeba cofnąć system do poziomu Adama i Ewy pod zakazanym drzewem. xD

Ostatnio edytowany przez Jacekalex (2018-09-20 22:01:19)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#13 2018-09-21 12:55:39

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Re: [gpp] libmvec.so.1 nie znaleziony przez ld

Może to głupie pytanie ale czy przed wydaniem polecenia

Kod:

aptitude dist-upgrade

wydaleś polecenie 

Kod:

aptitude updade

?

Offline

 

#14 2018-09-22 06:09:54

wikingagressor
Użytkownik
Skąd: Józefów k.Błonia, mazowieckie
Zarejestrowany: 2015-02-03

Re: [gpp] libmvec.so.1 nie znaleziony przez ld

Jak sie bawisz w programowanie lub jakas developerke, to polecalbym zaoranie tego i postawienie standardowego stretcha i dopiero wtedy kombinowac z takimi podstawami jak libc6.


Peace, Love and Debian for the World!!!

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
To nie jest tylko forum, to nasza mała ojczyzna ;-)