Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2018-06-17 10:44:46

brii
Użytkownik
Skąd: Częstochowa
Zarejestrowany: 2013-09-03

[Rozwiązany] apt-get i niespełnione zależności - pakiet te źródeł

Witam!

Od kilku dni szarpię się z problemem którego nie potrafię ominąć. Otóż instaluję Asteriska z repozytoriów wraz z zależnościami, wszystko jest OK - problem nie dotyczy samego Asteriska. Mam w komputerze specyficzną kartę ISDN, która nie jest obsługiwana przez DAHDI z repozytoriów, więc kompiluję DAHDI ze źródeł od producenta karty i instaluję je w w systemie przez make install, więc apt nic o nim nie wie. By Asterisk mógł z niego skorzystać potrzebny jest pakiet asterisk-dahdi, jest w repozytoriach, ale wymaga on doinstalowania pakietu dahdi z repozytoriów, który to nadpisuje własnoręcznie skompilowane DAHDI. Póki co pobrałem asterisk-dahdi i zainstalowałem je na siłę używając:

Kod:

dpkg --ignore-depends=dahid -i asterisk-dahdiXXXX.deb

Wszystko działa, ale problem polega na tym, że nie mogę już korzystać z apt-get - jak próbuję robić cokolwiek to dostaję komunikat:

Kod:

Następujące pakiety mają niespełnione zależności:
asterisk-dahdi : Wymaga : dahdi ale nie zostanie zainstalowany
Niespełnione zależności. Proszę spróbować wykonać "apt --fix-broken install" bez pakietów (lub podać rozwiązanie).

Rozwiązaniem dla mnie jest zasugerowanie apt by uznał, że pakiet dahdi jest zainstalowany i to w najnowszej wersji i by się od niego odstosunkował ;) Nie chciałbym by któregoś dnia apt nadpisał mi działające DAHDI takim z repozytoriów które niestety dla mnie jest bezużyteczne.
Da się to jakoś zrobić? Debian bez działającego apt jest nieco "upośledzony"...
Z góry dziękuję za pomoc.

Ostatnio edytowany przez brii (2018-06-17 12:47:34)


Na świecie jest 10 rodzajów ludzi: ci, którzy rozumieją liczby binarne i ci, którzy nie.

Offline

 

#2 2018-06-17 11:57:23

Pavlo950
człowiek pasjonat :D
Zarejestrowany: 2012-02-20
Serwis

Re: [Rozwiązany] apt-get i niespełnione zależności - pakiet te źródeł

Ktoś kiedyś gdzieś tworzył puste paczki i wrzucał żeby się "apt odstosunkował". Może zadziała.

Offline

 

#3 2018-06-17 12:47:02

brii
Użytkownik
Skąd: Częstochowa
Zarejestrowany: 2013-09-03

Re: [Rozwiązany] apt-get i niespełnione zależności - pakiet te źródeł

Dzięki za podpowiedź, potrzebny jest do tego equivs
Żeby stworzyć pusty pakiet który zastąpi dahdi z repozytorium wystarczy utworzyć plik "dahdi" którego zawartość będzie miała dwa wiersze:

Kod:

Package: dahdi
Version: 5.0

Następnie trzeba wydać polecenie: equivs-build dahdi
W ten sposób powstanie paczka .deb którą wystarczy zainstalować :)


Na świecie jest 10 rodzajów ludzi: ci, którzy rozumieją liczby binarne i ci, którzy nie.

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Możesz wyłączyć AdBlock — tu nie ma reklam ;-)