Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2013-08-30 13:35:53

curlybracket
Nowy użytkownik
Zarejestrowany: 2013-08-30

Samba: publiczny katalog i kwestia praw dostępu

Mam serwer udostępniający zasoby przez Sambę.
Generalnie wszystko działa poprawnie, użytkownicy mogą się dostać do swoich zasobów poprzez sieć.
Moim zadaniem jest utworzenie katalogu pub/ który będzie dostępny dla wszystkich i wszyscy będą mieli do niego pełne prawa dostępu.

Utworzyłem użytkownika pub z katalogiem pub, nadałem temu katalogowi chmod 777 i utworzyłem każdemu użytkownikowi systemu w jego katalogu domowym symlink do pub/ i rzeczywiście, każdy może sobie tam wejść i coś zapisać.

Problem polega na tym, że jeżeli użytkownik A utworzy tam plik to użytkownik B nie będzie mógł tego pliku usunąć czy skopiować bo tworzone pliki otrzymują prawa -rwx------

Jak więc mogę sprawić, żeby wszystko co tworzone w obrębie pub/ otrzymywało prawa 777?
Druga sprawa - nie jestem pewien czy ustawienie 777 na pub/ to jest dobry pomysł, może powinienem zrobić to jakoś inaczej?

Mój smb.conf:

Kod:

[global]
   workgroup = mygroup
   netbios name = myserver
   server string = My Server
   hosts allow = (...)
   hosts deny = 0.0.0.0/0
   dns proxy = no
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
   preferred master = auto
   local master = yes
   printcap name = /etc/printcap
   load printers = no
   printing = bsd

####### Authentication #######

   security = user
   encrypt passwords = true
   invalid users = root
   unix password sync = yes
   pam password change = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
   socket options = TCP_NODELAY
   domain master = auto
   unix extensions = no

#======================= Share Definitions =======================

[homes]
   comment = Home Directories
   browseable = no
   writable = yes
   hide dot files = yes
   veto files = /.*/
   follow symlinks = yes
   wide links = yes
   create mask = 0700
   directory mask = 0700
   read only = no

[pub]
   comment = Public Directory
   browseable = no
   read only = no
   writeable = yes
   hide dot files = yes
   follow symlinks = yes
   path = /home/pub
   create mask = 0777
   directory mask = 0777

Offline

 

#2 2013-08-30 13:50:19

Cramin
Nowy użytkownik
Skąd: Myszków
Zarejestrowany: 2013-08-30
Spam…

Re: Samba: publiczny katalog i kwestia praw dostępu

Ustawienie

Kod:

create mode = 0777
directory mode = 0777

w sekcji zasobu powinno rozwiązać sprawę.

Ostatnio edytowany przez Cramin (2013-08-30 13:50:39)

Offline

 

#3 2013-08-30 14:18:47

curlybracket
Nowy użytkownik
Zarejestrowany: 2013-08-30

Re: Samba: publiczny katalog i kwestia praw dostępu

Zauważ, że w smb.conf, który wkleiłem jest sekcja:

Kod:

[pub]
   comment = Public Directory
   browseable = no
   read only = no
   writeable = yes
   hide dot files = yes
   follow symlinks = yes
   path = /home/pub
   create mask = 0777
   directory mask = 0777

No i efekt jest taki jak opisałem czyli nowo tworzone pliki i katalogi nie mają praw 777.

Offline

 

#4 2013-08-30 15:16:28

Cramin
Nowy użytkownik
Skąd: Myszków
Zarejestrowany: 2013-08-30
Spam…

Re: Samba: publiczny katalog i kwestia praw dostępu

Skrótem myślowym miałem na myśli:

Kod:

force create mode = 0777
force directory mode = 0777

Choć 0755 byłby lepszym wyborem.

Offline

 

#5 2013-08-30 15:56:13

curlybracket
Nowy użytkownik
Zarejestrowany: 2013-08-30

Re: Samba: publiczny katalog i kwestia praw dostępu

A, rozumiem.
Ale próbowałem tych parametrów i nie wpłynęły na działanie.

Jest jeszcze kwestia umask i z tym też eksperymentowałem, ale nie jest dla mnie jasne jak to powinienem zrobić prawidłowo.
Moje eksperymenty z umask wyglądały tak, że wywoływałem polecenie umask w pub/ i otrzymywałem wynik 0022, następnie wywoływałem umask 0000 oraz umask 000 i to niczego nie zmieniało. Podobnie umask 0777 niczego nie zmieniało - nadal mogłem jako użytkownik ze zdalnego komputera stworzyć pliki w pub/ a chyba jednak nie powinienem móc.

Nie bardzo rozumiem dlaczego nic nie przynosi efektów.

Offline

 

#6 2013-09-01 21:14:36

qlemik
Użytkownik
Zarejestrowany: 2007-11-27

Re: Samba: publiczny katalog i kwestia praw dostępu

nie ma bata musi działać  :)

dodaj:

Kod:

    create mode = 0660
        directory mode = 0770
        force create mode = 0660
        force directory mode = 0770

ewentualnie:

1. dodaj wszystkich urzytkowników do grupy pub (gpassw user1 pub) itd.
2. chown pub:pub /home/pub (tak na wszelki wypadek bo nie wiem co tam mozesz miec :) )
3. chmod g+s /home/pub (poczytaj sgid)
4. dodaj do samby to co podalem wyżej i dodatkowo: force group = pub


ja mam coś podobnego i tutaj masz kawałek mojeg smb.conf

Kod:

[z1]

        comment = Z1 na E52
        path = /home/samba/z1
        browsable=yes
        public=yes
        writable=yes
        create mode = 0660
        directory mode = 0770
        force create mode = 0660
        force directory mode = 0770
        force group = uzytkownicy_domeny
        follow symlinks = yes
        valid users = @uzytkownicy_domeny
        write list = @uzytkownicy_domeny
        #vfs objects = recycle
        recycle:repository = .KOSZ
        recycle:keeptree = True
        recycle:versions = True
        recycle:touch = True
        recycle:exclude = *.tmp|*.tmp|*.TMP|*.o|*.obj|~$*|*.ba0                                                                                             $
        recycle:exclude_dir = /tmp|/temp|/cache
        # Audit settings
        vfs objects = full_audit recycle
        full_audit:prefix = %u|%I|%S|%m|
        full_audit:failure = connect
        full_audit:success = connect disconnect mkdir rmdir read write sendfile rename unlink chmod fchmod chown fchown ftruncate lock symlink readlink link$
        full_audit:facility = local5
        full_audit:priority = notice

samba 4.0.5 przy starszych wersjach 3.8 nazwy grup muszą być podane w cudzusłowiu " "

Żona ogląda jakiś badziewiasty serial i tv zajęty wiec trochę się rozpisałem

Pozdrawiam
:)

Offline

 

#7 2013-09-05 17:35:01

curlybracket
Nowy użytkownik
Zarejestrowany: 2013-08-30

Re: Samba: publiczny katalog i kwestia praw dostępu

Udało mi się. Wielkie dzięki!

Offline

 

#8 2017-11-30 16:15:43

robzio
Nowy użytkownik
Zarejestrowany: 2017-11-30

Re: Samba: publiczny katalog i kwestia praw dostępu

Witam miałem podobny problem jednak rozwiązałem go w ten sam sposób.

Teraz mam pytanie.
Mam udział "test" i użytkowników w grupie1 i każdy może tworzyć i usuwać pliki i to jest ok.
A czy jest możliwość dla użytkownika który jest w grupie1 ustawić aby jeden folder był tylko do odczytu??
Ewentualnie czy dla użytkownika można w danym udziale "test" ustawić brak dostępu do katalogu np. dokumenty

jak to zrobić??

Offline

 

#9 2017-12-01 08:26:46

wikingagressor
Użytkownik
Skąd: Józefów k.Błonia, mazowieckie
Zarejestrowany: 2015-02-03

Re: Samba: publiczny katalog i kwestia praw dostępu

robzio napisał(-a):

Witam miałem podobny problem jednak rozwiązałem go w ten sam sposób.

Teraz mam pytanie.
Mam udział "test" i użytkowników w grupie1 i każdy może tworzyć i usuwać pliki i to jest ok.
A czy jest możliwość dla użytkownika który jest w grupie1 ustawić aby jeden folder był tylko do odczytu??
Ewentualnie czy dla użytkownika można w danym udziale "test" ustawić brak dostępu do katalogu np. dokumenty

jak to zrobić??

Najlatwiej to zrobic dwiema grupami. Grupa1 ma pelny dostep do folderu "test", czyli 077x. Dostep Grupy2 zalezy od wartosci x: dla 5 moga otworzyc katalog i odczytac zawartosc, dla 0 nie moga wejsc do katalogu.


Peace, Love and Debian for the World!!!

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Nas ludzie lubią po prostu, a nie klikając w przyciski ;-)