Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2017-10-15 01:44:04

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Drukarka Brother HL-2035 sterownik nie działa

Cześć,
mam drukarkę Brother HL-2035, której nawet nie musiałem instalować na Jessie bo od razu mi ją wykryło. Natomiast podczas drukowania na 1200 dpi na stronie drukuje się w pomniejszeniu obok siebie kilka kopi tego, co powinno zajmować całą stronę jako jeden wydruk. Pomyślałem, że najprościej będzie, żeby rozwiązać problem - zainstalować sterownik producenta, więc odnalazłem to:

http://support.brother.com/g/b/downloadhowto.aspx?c … amp;type3=625

i zainstalowałem. Trochę naknociłem (w ogóle pierwszy raz widzę taką metodę instalacji czegoś - co to jest? ;p) bo na początku zainstalowałem tę drukarkę z opisu "MFC-J880DW", ponieważ kopiowałem całe komendy, potem bodajże nie kliknąłem "no" już instalując swój model (albo jeszcze raz instalując tamten model... Chyba raczej na tamtej, hehe) na etapie "When you see the message "Will you specify the DeviceURI ?",", ale na końcu zrobiłem wszystko według mnie poprawnie przeprowadzając jeszcze raz procedurę od początku dla mojego modelu. Skutek jest taki, że drukarka jest widoczna w systemie, a podczas próby wydruku czy na 300 dpi, czy 1200 dpi pojawia się jedynie na dole ekranu drukarka, na którą jak się kliknie, widać, że coś poszło do druku, lecz nie drukuje (drukarka nie reaguje w żaden sposób). Ponieważ te zainstalowane pakiety to chyba:

Kod:

dpkg -l brh*
Wybór:U=nieznany/I=instalacja/R=usunięcie/P=wyczyszczenie/H=zatrzymanie
| Stan:N=brak/I=zainstalowany/C=skonfigurowany/U=rozpakowany/
|/  F=częśc. skonfigurowany/H=częśc. zainstalowany/W=wyzw. czek./T=wyzw. zapl.
|| Błędy?=(brak)/R-do pon. inst. (duże litery w "Stan" i "Błędy"=problemy)
||/ Nazwa          Wersja       Architektura Opis
+++-==============-============-============-=================================
ii  brhl2030lpr    2.0.1-1      i386         Brother HL-2030 LPR driver

i

Kod:

dpkg -l cupsw*
Wybór:U=nieznany/I=instalacja/R=usunięcie/P=wyczyszczenie/H=zatrzymanie
| Stan:N=brak/I=zainstalowany/C=skonfigurowany/U=rozpakowany/
|/  F=częśc. skonfigurowany/H=częśc. zainstalowany/W=wyzw. czek./T=wyzw. zapl.
|| Błędy?=(brak)/R-do pon. inst. (duże litery w "Stan" i "Błędy"=problemy)
||/ Nazwa          Wersja       Architektura Opis
+++-==============-============-============-=================================
ii  cupswrapperhl2 2.0.1-2      i386         Brother HL2030 CUPS wrapper drive

(bo na początku instalacji jest się informowanym, że takie pliki .deb zostaną zainstalowane) Pomyślałem, że skoro wyskakuje, że te pakiety są i386 (mam oczywiście dodaną tę architekturę:

Kod:

dpkg --print-architecture
amd64

i

Kod:

dpkg --print-foreign-architectures
i386

), to idąc za doświadczeniem z postu:

https://forum.dug.net.pl/viewtopic.php?id=29911

pomyślałem, że pewnie brakuje im bibliotek. No i dalej grzebiąc po Internecie, doszedłem do tego jak szukać brakujących bibliotek:

https://en.wikipedia.org/wiki/Ldd_(Unix)
http://www.ulos.pl/sprawdzanie-brakujacych-bibliotek

i z użyciem tej komendy:

Kod:

ldd scieżka_programu | grep "not found"

mam problem, bo szukając najpierw potrzebnych ścieżek do tych pakietów mam takie zwroty:

Kod:

whereis brhl2030lpr
brhl2030lpr:

Kod:

root@debian:/home/abc# which brhl2030lpr
root@debian:/home/abc#

Kod:

whereis cupswrapperhl2
cupswrapperhl2:

Kod:

which cupswrapperhl2
root@debian:/home/abc#

Podpowiedzcie proszę, dobra to droga z tym szukaniem bibliotek? Jeśli tak, to jak mogę namierzyć te ścieżki pakietów, żeby wiedzieć jaką bibliotekę dograć?

Z góry dzięki za pomoc.

Ostatnio edytowany przez pltvgz20 (2017-10-15 02:03:01)

Offline

 

#2 2017-10-15 18:40:04

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

Dalej na razie nie działa, ale powiem co dziś próbowałem robić: W Synapticu wszedłem we właściwości tych zainstalowanych pakietów i w zależnościach tych pakietów nie było nic wskazane, gdzie np. dla Firefoxa była cała lista... Usunąłem wszystkie te pakiety, które do tej pory mi się zainstalowały z tych wskazanych na początku instalacji:

Kod:

apt-get remove --purge mfcj880dwlpr mfcj880dwcupswrapper:i386 brscan4 brscan-skey brhl2030lpr cupswrapperhl2030:i386

Wszedłem na LibreOffice i już była od tego momentu widoczna tylko ta drukarka, którą sam wykrył Debian już dawno temu. Przeprowadziłem ponownie instalację zgodnie z instrukcją - nadal nie działa.

To przebieg instalacji (Martwi mnie pogrubiony fragment. Pogrubienia nie widać, bo całość jest w "code", ale widać w treści ten fragment między "b" a "/b" w nawiasach kwadratowych:

Kod:

bash linux-brprinter-installer-2.1.1-1 HL-2035
You are going to install following packages.
   brhl2030lpr-2.0.1-1.i386.deb
   cupswrapperHL2030-2.0.1-2.i386.deb
OK? [y/N] ->y

Ign.  http://ftp.pl.debian.org oldstable InRelease                                                    
Pobieranie:1 http://ftp.pl.debian.org oldstable-updates InRelease [145 kB]                            
Stary http://www.deb-multimedia.org jessie InRelease                                                  
Stary http://ftp.pl.debian.org oldstable Release.gpg                                                  
Stary http://ftp.pl.debian.org oldstable Release                                                      
Stary https://repo.skype.com stable InRelease                                                         
Stary http://www.deb-multimedia.org jessie/main amd64 Packages                                        
Stary http://www.deb-multimedia.org jessie/non-free amd64 Packages                                    
Pobieranie:2 http://ftp.pl.debian.org oldstable-updates/main amd64 Packages/DiffIndex [8884 B]        
Stary http://www.deb-multimedia.org jessie/main i386 Packages                                         
Stary http://www.deb-multimedia.org jessie/non-free i386 Packages                                     
Stary http://ftp.pl.debian.org oldstable-updates/contrib amd64 Packages                               
Stary http://www.deb-multimedia.org jessie/main Translation-en                                        
Stary https://repo.skype.com stable/main amd64 Packages                                               
Pobieranie:3 http://ftp.pl.debian.org oldstable-updates/non-free amd64 Packages/DiffIndex [736 B]     
Stary http://www.deb-multimedia.org jessie/non-free Translation-en                                    
Pobieranie:4 https://repo.skype.com stable/main Translation-pl_PL [246 B]                             
Pobieranie:5 http://ftp.pl.debian.org oldstable-updates/main i386 Packages/DiffIndex [8884 B]         
Stary http://ppa.launchpad.net trusty InRelease                                                       
Ign.  http://ftp.de.debian.org jessie InRelease                                                       
Ign.  http://dl.google.com stable InRelease                                                           
Pobieranie:6 https://repo.skype.com stable/main Translation-pl [243 B]                                
Pobieranie:7 http://security.debian.org oldstable/updates InRelease [63,1 kB]                         
Stary http://ftp.de.debian.org jessie Release.gpg                                                     
Stary http://dl.google.com stable Release.gpg                                                         
Pobieranie:8 https://repo.skype.com stable/main Translation-en [243 B]                                
Stary http://ftp.pl.debian.org oldstable-updates/contrib i386 Packages                                
Stary http://ftp.de.debian.org jessie Release                                                         
Stary http://dl.google.com stable Release                                                             
Pobieranie:9 https://repo.skype.com stable/main Translation-pl_PL [246 B]                             
Pobieranie:10 http://ftp.pl.debian.org oldstable-updates/non-free i386 Packages/DiffIndex [736 B]     
Stary http://ftp.de.debian.org jessie/main amd64 Packages                                             
Pobieranie:11 https://repo.skype.com stable/main Translation-pl [243 B]                               
Stary http://ppa.launchpad.net trusty/main Sources                                                    
Stary http://ftp.pl.debian.org oldstable-updates/contrib Translation-en                               
Stary http://ftp.de.debian.org jessie/main i386 Packages                                              
Stary http://dl.google.com stable/main amd64 Packages                                                 
Stary https://deb.opera.com stable InRelease                                                          
Pobieranie:12 http://ftp.pl.debian.org oldstable-updates/main Translation-en/DiffIndex [3688 B]       
Pobieranie:13 http://ftp.pl.debian.org oldstable-updates/non-free Translation-en/DiffIndex [736 B]    
Stary http://ppa.launchpad.net trusty/main amd64 Packages                                             
Stary http://ftp.de.debian.org jessie/main Translation-pl                                             
Stary http://ftp.de.debian.org jessie/main Translation-en                                             
Pobieranie:14 https://repo.skype.com stable/main Translation-en [243 B]                               
Stary http://ftp.pl.debian.org oldstable/main amd64 Packages                                          
Stary http://ftp.pl.debian.org oldstable/contrib amd64 Packages                                       
Stary http://ppa.launchpad.net trusty/main i386 Packages                                              
Stary http://ftp.pl.debian.org oldstable/non-free amd64 Packages                                      
Stary http://ppa.launchpad.net trusty/main Translation-en                                             
Stary http://ftp.pl.debian.org oldstable/main i386 Packages                                           
Stary http://ftp.pl.debian.org oldstable/contrib i386 Packages                                        
Stary http://ftp.pl.debian.org oldstable/non-free i386 Packages                                       
Stary http://security.debian.org oldstable/updates/main amd64 Packages                                
Stary http://security.debian.org oldstable/updates/contrib amd64 Packages                             
Stary http://ftp.pl.debian.org oldstable/contrib Translation-en                                       
Stary http://security.debian.org oldstable/updates/non-free amd64 Packages                            
Stary http://ftp.pl.debian.org oldstable/main Translation-pl                                          
Stary http://security.debian.org oldstable/updates/main i386 Packages                                 
Stary http://ftp.pl.debian.org oldstable/main Translation-en                                          
Stary http://security.debian.org oldstable/updates/contrib i386 Packages                              
Stary http://ftp.pl.debian.org oldstable/non-free Translation-en                                      
Pobieranie:15 https://repo.skype.com stable/main Translation-pl_PL [246 B]                            
Stary http://security.debian.org oldstable/updates/non-free i386 Packages                             
Pobieranie:16 https://repo.skype.com stable/main Translation-pl [243 B]                               
Stary http://security.debian.org oldstable/updates/contrib Translation-en                             
Stary http://security.debian.org oldstable/updates/main Translation-en                                
Stary https://deb.opera.com stable/non-free amd64 Packages                                            
Pobieranie:17 https://repo.skype.com stable/main Translation-en [243 B]                               
Stary http://security.debian.org oldstable/updates/non-free Translation-en                            
Stary https://deb.opera.com stable/non-free i386 Packages                                             
Pobieranie:18 https://repo.skype.com stable/main Translation-pl_PL [246 B]                            
Pobieranie:19 https://deb.opera.com stable/non-free Translation-pl_PL [339 B]                         
Pobieranie:20 https://deb.opera.com stable/non-free Translation-pl [336 B]                            
Pobieranie:21 https://repo.skype.com stable/main Translation-pl [243 B]                               
Ign.  http://dl.google.com stable/main Translation-pl_PL                                              
Pobieranie:22 https://deb.opera.com stable/non-free Translation-en [336 B]                            
Pobieranie:23 https://deb.opera.com stable/non-free Translation-pl_PL [339 B]                         
Pobieranie:24 https://repo.skype.com stable/main Translation-en [243 B]                               
Ign.  http://dl.google.com stable/main Translation-pl                                                 
Pobieranie:25 https://deb.opera.com stable/non-free Translation-pl [336 B]                            
Ign.  http://dl.google.com stable/main Translation-en                                                 
Pobieranie:26 https://repo.skype.com stable/main Translation-pl_PL [246 B]                            
Ign.  https://repo.skype.com stable/main Translation-pl_PL                                            
Pobieranie:27 https://deb.opera.com stable/non-free Translation-en [336 B]                            
Pobieranie:28 https://deb.opera.com stable/non-free Translation-pl_PL [339 B]                         
Pobieranie:29 https://repo.skype.com stable/main Translation-pl [243 B]                               
Ign.  https://repo.skype.com stable/main Translation-pl                                               
Pobieranie:30 https://deb.opera.com stable/non-free Translation-pl [336 B]                            
Pobieranie:31 https://repo.skype.com stable/main Translation-en [243 B]                               
Ign.  https://repo.skype.com stable/main Translation-en                                               
Pobieranie:32 https://deb.opera.com stable/non-free Translation-en [336 B]                            
Pobieranie:33 https://deb.opera.com stable/non-free Translation-pl_PL [339 B]                         
Pobieranie:34 https://deb.opera.com stable/non-free Translation-pl [336 B]                            
Pobieranie:35 https://deb.opera.com stable/non-free Translation-en [336 B]                            
Pobieranie:36 https://deb.opera.com stable/non-free Translation-pl_PL [339 B]                         
Ign.  https://deb.opera.com stable/non-free Translation-pl_PL                                         
Pobieranie:37 https://deb.opera.com stable/non-free Translation-pl [336 B]                            
Ign.  https://deb.opera.com stable/non-free Translation-pl                                            
Pobieranie:38 https://deb.opera.com stable/non-free Translation-en [336 B]                            
Ign.  https://deb.opera.com stable/non-free Translation-en                                            
Pobrano 232 kB w 25s (9173 B/s)                                                                       
Czytanie list pakietów... Gotowe
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
[b]Odczyt informacji o stanie... Gotowe
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5

E: Package 'ia32-libs' has no installation candidate
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 lib32stdc++6 : Wymaga: lib32gcc1 (>= 1:4.1.1) ale nie zostanie zainstalowany
                Wymaga: libc6-i386 (>= 2.18) ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
[/b]
dpkg -x brhl2030lpr-2.0.1-1.i386.deb /
dpkg -x cupswrapperHL2030-2.0.1-2.i386.deb /
dpkg-deb: budowanie pakietu "brhl2030lpr" w "brhl2030lpr-2.0.1-1a.i386.deb".
dpkg -b ./brother_driver_packdir brhl2030lpr-2.0.1-1a.i386.deb
dpkg-deb: budowanie pakietu "cupswrapperhl2030" w "cupswrapperHL2030-2.0.1-2a.i386.deb".
dpkg -b ./brother_driver_packdir cupswrapperHL2030-2.0.1-2a.i386.deb
dpkg -i --force-all brhl2030lpr-2.0.1-1a.i386.deb
Wybieranie wcześniej niewybranego pakietu brhl2030lpr.
(Odczytywanie bazy danych ... 207000 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brhl2030lpr-2.0.1-1a.i386.deb ...
Rozpakowywanie pakietu brhl2030lpr (2.0.1-1) ...
Konfigurowanie pakietu brhl2030lpr (2.0.1-1) ...
dpkg -i --force-all cupswrapperHL2030-2.0.1-2a.i386.deb
Wybieranie wcześniej niewybranego pakietu cupswrapperhl2030.
(Odczytywanie bazy danych ... 207017 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu cupswrapperHL2030-2.0.1-2a.i386.deb ...
Rozpakowywanie pakietu cupswrapperhl2030 (2.0.1-2) ...
Konfigurowanie pakietu cupswrapperhl2030 (2.0.1-2) ...
Restarting cups (via systemctl): cups.service.
#
Will you specify the Device URI? [Y/n] ->n

Test Print? [y/N] ->y 

wait 5s.
lpr -P HL2030 /usr/share/cups/data/testprint
root@debian:/home/abc/Dokumenty#

Widzę tu: https://forum.dug.net.pl/viewtopic.php?id=25381

że:

Pakiet ia32-libs nie jest potrzebny odkąd mamy multiarch. Jeśli nie ma prawdziwej 64-bitowej wersji tego programu, to zainstaluj 32-bitową via multiarch.

"Dependency is not satisfiable: ia32-libs"
Jeżeli pakiet ma wpisaną taką zależność, to trzeba mu podrzucić jakiś lipny pakiet z taką nazwą, żeby myślał, że jest w systemie, albo zajrzeć do tego pakietu i poprawić zależności.

W FAQ/HOWTO ktoś pisał tutek, jak tworzyć fake-pakiety w Debianie.

[EDIT]
Nie ktoś tylko Arni:
http://dug.net.pl/tekst/154/equivs___tworzenie_pustych_pakietow/
[/EDIT]

Czyli "ia32-libs" nie jest potrzebny i mam tylko podrzucić atrapę zgodnie z powyższą instrukcją? Na pewno, bo w tym wątku: https://forum.dug.net.pl/viewtopic.php?id=29911 mimo, że "ia32-libs" nie zainstalowałem (post 17) problem się rozwiązał przez:

Kod:

apt-get install libfontconfig1:i386

czyli jednak potrzebna była jakaś biblioteka?

Ostatnio edytowany przez pltvgz20 (2017-10-15 20:37:11)

Offline

 

#3 2017-10-15 20:55:47

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

Widzę też, że, choć Jessie nie ma w repozytoriach "ia32-libs", to Wheezy jeszcze go posiada. https://packages.debian.org/wheezy/ia32-libs Kolejny pomysł to go zainstalować z repozytorium Wheezy, tylko czy to coś da i przede wszystkim czy się tym "nie uszkodzę"?

Ostatnio edytowany przez pltvgz20 (2017-10-15 20:56:20)

Offline

 

#4 2017-10-16 00:39:43

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

Tu: https://forum.dobreprogramy.pl/t/blad-przy-instalac … z-kadu/479230 ktoś miał też taką zwrotkę jak ja podczas instalacji:

Kod:

Nie udało się zainstalować niektórych pakietów. Może to oznaczać, że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej, w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione z katalogu Incoming ("Przychodzące"). Następujące informacje mogą pomóc rozwiązać sytuację: Następujące pakiety mają niespełnione zależności:

więc za poradą stamtąd:

sudo apt-get update && sudo apt-get dist-upgrade

zrobiłem to, z tą różnicą, że najpierw dałem:

Kod:

apt-get dist-upgrade

a potem:

Kod:

apt-get update

- bo w międzyczasie zerwało mi internet. I znowu:

Kod:

apt-get dist-upgrade

Też to nie pomogło i nadal w instalacji jest fragment:

Kod:

Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5

E: Package 'ia32-libs' has no installation candidate
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 lib32stdc++6 : Wymaga: lib32gcc1 (>= 1:4.1.1) ale nie zostanie zainstalowany
                Wymaga: libc6-i386 (>= 2.18) ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

Tu: https://www.debian.pl/viewtopic.php?t=19042&start=50 pojawia się podobny wątek, który może mieć związek z tą powyższą zwrotką:

"1347" miał taką zwrotkę:

Czytanie list pakietów...
Budowanie drzewa zależności...
Należy uruchomić "apt-get -f install", aby je naprawić:
Następujące pakiety mają niespełnione zależności:
  base-files: PreWymaga: awk
  dpkg: PreWymaga: coreutils (>= 5.93-1) ale nie zostanie zainstalowany
        PreWymaga: lzma ale nie zostanie zainstalowany
  libc6: Wymaga: libgcc1 ale nie zostanie zainstalowany

(specjalnie dałem to w cytat, a nie w code, żeby nie mylić z moimi)

i dostał taką odpowiedź:

Jeszcze jedno pytanie - bo to co pokazujesz (czyli upartość Twojego systemu pakietów jest doprawdy zastanawiająca i - chyba w tym zakresie, jak występuje - niespotykana) - czy przez przypadek, gdzieś w przeszłości nie zrobiłeś jakiejś aktualizacji/instalacji jakichś pakietów z wykorzystaniem nowszych wersji niż te, które znajdują się w Lenny, a potem powróciłeś w ustawieniach do Lenny?
Osobiście z podobnym przypadkiem spotkałem się lata temu, kiedy zachciało mi się na próbę zainstalować coś z ówczesnego testinga, a potem powróciłem do stable. System - słusznie zresztą - dostał podobnego "kręćka" jak u Ciebie.

co się pokrywa z moim postem stąd: https://forum.dug.net.pl/viewtopic.php?id=29805 bo Linuksa dopiero się uczę i mam go od niedawna, a repozytoria miałem ustawione na wersje stabilną a przecież Jessie, już stabilna nie jest i kiedy to się zmieniało pewnie coś poinstalowałem, co pomieszało. Tam w tym wątku o tym pisaliśmy. Tylko którą drogą iść: szukania brakującej biblioteki? (tylko, że tak jak pisałem wyżej przy pomocy "ldd" nie wiem, jak to ustalić) uznania, że instalatorowi trzeba dać fikcyjny pakiet? czy aktualizacji z Jessie do Stretch, wierząc, że te cyrki z zależnościami znikną? (tego trzeciego wyjątkowo nie chciałbym robić bo nie wiem czy odpalę grafikę na Stretchu (mam SISa) - pisałem o tym w tym poście cytowanym przed chwilą w wiadomości numer 5)

Ostatnio edytowany przez pltvgz20 (2017-10-16 01:36:54)

Offline

 

#5 2017-10-16 04:30:59

wikingagressor
Użytkownik
Skąd: Józefów k.Błonia, mazowieckie
Zarejestrowany: 2015-02-03

Re: Drukarka Brother HL-2035 sterownik nie działa

Odinstaluj wszystko do stanu poczatkowego. Potem zwroc uwage na to co sugeruje apt:

Kod:

Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5

Zainstaluj pakiety lib32z1 i lib32ncurses5.
Teraz wykonaj skrypt instalacyjny do drukarki i zobacz czy przejdzie.


Peace, Love and Debian for the World!!!

Offline

 

#6 2017-10-16 10:00:19

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

wikingagressor napisał(-a):

Odinstaluj wszystko do stanu poczatkowego. Potem zwroc uwage na to co sugeruje apt:

Kod:

Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5

Zainstaluj pakiety lib32z1 i lib32ncurses5.
Teraz wykonaj skrypt instalacyjny do drukarki i zobacz czy przejdzie.

A więc po kolei - sprawdzam, czy są zainstalowane pakiety:

Kod:

dpkg -l brhl* cupswrapper*
Wybór:U=nieznany/I=instalacja/R=usunięcie/P=wyczyszczenie/H=zatrzymanie
| Stan:N=brak/I=zainstalowany/C=skonfigurowany/U=rozpakowany/
|/  F=częśc. skonfigurowany/H=częśc. zainstalowany/W=wyzw. czek./T=wyzw. zapl.
|| Błędy?=(brak)/R-do pon. inst. (duże litery w "Stan" i "Błędy"=problemy)
||/ Nazwa          Wersja       Architektura Opis
+++-==============-============-============-=================================
ii  brhl2030lpr    2.0.1-1      i386         Brother HL-2030 LPR driver
ii  cupswrapperhl2 2.0.1-2      i386         Brother HL2030 CUPS wrapper drive

Odinstalowuję je:

Kod:

apt-get remove --purge brhl2030lpr cupswrapperhl2030:i386
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Następujące pakiety zostaną USUNIĘTE:
  brhl2030lpr:i386* cupswrapperhl2030:i386*
0 aktualizowanych, 0 nowo instalowanych, 2 usuwanych i 0 nieaktualizowanych.
Po tej operacji zostanie zwolnione 311 kB miejsca na dysku.
Kontynuować? [T/n] t
(Odczytywanie bazy danych ... 207050 plików i katalogów obecnie zainstalowanych.)
Usuwanie pakietu brhl2030lpr (2.0.1-1) ...
Czyszczenie z plików konfiguracyjnych pakietu brhl2030lpr (2.0.1-1) ...
dpkg: ostrzeżenie: podczas usuwania pakietu brhl2030lpr, katalog "/usr/local/Brother/inf" nie był pusty, więc nie został usunięty
Usuwanie pakietu cupswrapperhl2030 (2.0.1-2) ...
[ ok ] Restarting cups (via systemctl): cups.service.
Czyszczenie z plików konfiguracyjnych pakietu cupswrapperhl2030 (2.0.1-2) ...
dpkg: ostrzeżenie: podczas usuwania pakietu cupswrapperhl2030, katalog "/usr/local/Brother" nie był pusty, więc nie został usunięty

Instaluję pakiety: "lib32z1" i "lib32ncurses5":

Kod:

apt-get install lib32z1 lib32ncurses5
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 lib32ncurses5 : Wymaga: lib32tinfo5 (= 5.9+20140913-1+b1) ale nie zostanie zainstalowany
                 Wymaga: libc6-i386 (>= 2.4) ale nie zostanie zainstalowany
 lib32z1 : Wymaga: libc6-i386 (>= 2.4) ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

I tu jak się spodziewałem pojawił się ten właśnie błąd.

Teraz wykonaj skrypt instalacyjny do drukarki i zobacz czy przejdzie.

Wykonywać ten skrypt, czy raczej już tu jest błąd do naprawy?

Offline

 

#7 2017-10-16 23:31:48

wikingagressor
Użytkownik
Skąd: Józefów k.Błonia, mazowieckie
Zarejestrowany: 2015-02-03

Re: Drukarka Brother HL-2035 sterownik nie działa

Wyglada na to ze potrzebujesz rozne biblioteki 32-bitowe: libc6-i386 lib32tinfo5 lib32ncurses5 lib32z1
Dopoki nie bedziesz mial tam porzadku, to ci nie ruszy skrypt instalacyjny do drukarki.


Peace, Love and Debian for the World!!!

Offline

 

#8 2017-10-17 10:42:52

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

wikingagressor napisał(-a):

Wyglada na to ze potrzebujesz rozne biblioteki 32-bitowe: libc6-i386 lib32tinfo5 lib32ncurses5 lib32z1
Dopoki nie bedziesz mial tam porzadku, to ci nie ruszy skrypt instalacyjny do drukarki.

Kod:

apt-get install libc6-i386
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 libc6-i386 : Wymaga: libc6 (= 2.19-18+deb8u10) ale 2.24-11+deb9u1 ma zostać zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

Kod:

apt-get install lib32tinfo5
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 lib32tinfo5 : Wymaga: libc6-i386 (>= 2.16) ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

Kod:

apt-get install lib32ncurses5
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 lib32ncurses5 : Wymaga: lib32tinfo5 (= 5.9+20140913-1+b1) ale nie zostanie zainstalowany
                 Wymaga: libc6-i386 (>= 2.4) ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

Kod:

apt-get install lib32z1
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 lib32z1 : Wymaga: libc6-i386 (>= 2.4) ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

Tak to niestety wygląda w chwili obecnej. :( W poście nr 4 piszę o tym jakie są spostrzeżenia o "wymieszaniu" wersji Debiana - starszej i nowszej. (Ja tak jak mówię: repozytoria miałem ustawione na "stable", a nie na "Jessie", a niedawno była zmiana wersji stabilnej na oldstable, więc może je "wymieszałem".) Mam też z rzeczy spoza repozytorium: LibreOffice'a pobranego z jego strony w najnowszej wersji jako plik .deb, zaktualizowaną Operę do najnowszej zainstalowanej też z pobranej paczki .deb ze strony Opery, Vibera i Skajpa - oba instalowane z pobranych z ich stron również plików .deb.

Ostatnio edytowany przez pltvgz20 (2017-10-17 10:54:36)

Offline

 

#9 2017-10-18 17:15:18

mati75
Psuj
Skąd: Rzeszów
Zarejestrowany: 2010-03-14
Serwis

Re: Drukarka Brother HL-2035 sterownik nie działa

Cizys czemu zabieracie się do tak prostego problemu od dupy strony do tego starą metodą.

https://morfitronik.pl/konfiguracja-multiarch-na-debianie/


https://l0calh0st.pl/obrazki/userbar.png

Offline

 

#10 2017-10-18 23:40:08

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

mati75 napisał(-a):

Cizys czemu zabieracie się do tak prostego problemu od dupy strony do tego starą metodą.

https://morfitronik.pl/konfiguracja-multiarch-na-debianie/

Multiarch mam włączone:

Kod:

dpkg --print-architecture
amd64

Kod:

dpkg --print-foreign-architectures
i386

Szczerze mówiąc idąc za Twoją sugestią o stronie:
https://morfitronik.pl/konfiguracja-multiarch-na-debianie/

W debianie multiarch mamy możliwość zainstalowania w tym samym czasie bibliotek różnych architektur, przykładowo, możemy mieć obok siebie libssl1.0.2:amd64 i libssl1.0.2:i386

Jedyne co mi przychodzi do głowy (mam nadzieję, że wszystko prawidłowo ponazywam: ;p)
to, że jeżeli proponowany przez instalator pakiet "lib32z1" jest tylko na "amd64" i zawiera bibliotekę: "libz.so.1" ---> https://packages.debian.org/jessie/lib32z1

To szukam pakietu na "i386", który zawiera tę bibliotekę. I tu: https://packages.debian.org/search?mode=path&su … rds=libz.so.1

wyskakuje, że tę bibliotekę zawiera pakiet: "zlib1g" dostępny na "i386". I to ten pakiet mam zainstalować żeby działało?

Tylko, że widzę, że ja już ten pakiet mam:

Kod:

apt-get install zlib1g:i386
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
zlib1g:i386 jest już w najnowszej wersji.
zlib1g:i386 zaznaczony jako zainstalowany ręcznie.
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.

Kod:

dpkg -l zlib1g:i386
Wybór:U=nieznany/I=instalacja/R=usunięcie/P=wyczyszczenie/H=zatrzymanie
| Stan:N=brak/I=zainstalowany/C=skonfigurowany/U=rozpakowany/
|/  F=częśc. skonfigurowany/H=częśc. zainstalowany/W=wyzw. czek./T=wyzw. zapl.
|| Błędy?=(brak)/R-do pon. inst. (duże litery w "Stan" i "Błędy"=problemy)
||/ Nazwa          Wersja       Architektura Opis
+++-==============-============-============-=================================
ii  zlib1g:i386    1:1.2.8.dfsg i386         compression library - runtime

Ostatnio edytowany przez pltvgz20 (2017-10-18 23:48:07)

Offline

 

#11 2017-10-19 07:23:43

wikingagressor
Użytkownik
Skąd: Józefów k.Błonia, mazowieckie
Zarejestrowany: 2015-02-03

Re: Drukarka Brother HL-2035 sterownik nie działa

Byles bardzo blisko, trzeba bylo jeszcze libc6 doinstalowac i by mogla reszta ruszyc.


Peace, Love and Debian for the World!!!

Offline

 

#12 2017-10-19 14:15:53

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

wikingagressor napisał(-a):

Byles bardzo blisko, trzeba bylo jeszcze libc6 doinstalowac i by mogla reszta ruszyc.

Ten pakiet też mam... Drukarka była teraz niezainstalowana, a biblioteki cały czas były zainstalowane. Poniżej wszystko od początku do końca.

Sprawdzam, czy na pewno nie ma pakietów drukarki zainstalowanych:

Kod:

root@debian:/home/abc# dpkg -l brh*
dpkg-query: nie znaleziono pakietu pasującego do wzorca brh*
root@debian:/home/abc# dpkg -l brhl2030lpr
dpkg-query: nie znaleziono pakietu pasującego do wzorca brhl2030lpr
root@debian:/home/abc# dpkg -l cupsw*
dpkg-query: nie znaleziono pakietu pasującego do wzorca cupsw*

(Tego drugiego nie wywoływałem po całej nazwie bo ma dłuższą nazwę, której już nie szukałem w Synapticu)
Dobra, czyli drukarka na pewno odinstalowana... W LibreOffice też jej nie widać.

Potem sprawdzam, czy mam pierwszą bibliotekę:

Kod:

root@debian:/home/abc# dpkg -l zlib1g:i386
Wybór:U=nieznany/I=instalacja/R=usunięcie/P=wyczyszczenie/H=zatrzymanie
| Stan:N=brak/I=zainstalowany/C=skonfigurowany/U=rozpakowany/
|/  F=częśc. skonfigurowany/H=częśc. zainstalowany/W=wyzw. czek./T=wyzw. zapl.
|| Błędy?=(brak)/R-do pon. inst. (duże litery w "Stan" i "Błędy"=problemy)
||/ Nazwa          Wersja       Architektura Opis
+++-==============-============-============-=================================
ii  zlib1g:i386    1:1.2.8.dfsg i386         compression library - runtime

Czyli mam. I tę drugą, o której mówisz:

Kod:

root@debian:/home/abc# dpkg -l libc6:i386
Wybór:U=nieznany/I=instalacja/R=usunięcie/P=wyczyszczenie/H=zatrzymanie
| Stan:N=brak/I=zainstalowany/C=skonfigurowany/U=rozpakowany/
|/  F=częśc. skonfigurowany/H=częśc. zainstalowany/W=wyzw. czek./T=wyzw. zapl.
|| Błędy?=(brak)/R-do pon. inst. (duże litery w "Stan" i "Błędy"=problemy)
||/ Nazwa          Wersja       Architektura Opis
+++-==============-============-============-=================================
ii  libc6:i386     2.24-11+deb9 i386         GNU C Library: Shared libraries

I też ją mam. Ok, to teraz instalacja drukarki:

Kod:

root@debian:/home/abc# cd Dokumenty/
root@debian:/home/abc/Dokumenty# bash linux-brprinter-installer-2.1.1-1 HL-2035
You are going to install following packages.
   brhl2030lpr-2.0.1-1.i386.deb
   cupswrapperHL2030-2.0.1-2.i386.deb
OK? [y/N] ->y

Pobieranie:1 http://security.debian.org oldstable/updates InRelease [63,1 kB] 
Ign.  http://ftp.pl.debian.org oldstable InRelease                            
Ign.  http://dl.google.com stable InRelease                                   
Stary http://ppa.launchpad.net trusty InRelease                               
Ign.  http://ftp.de.debian.org jessie InRelease                               
Pobieranie:2 http://ftp.pl.debian.org oldstable-updates InRelease [145 kB]    
Stary https://repo.skype.com stable InRelease                                 
Stary http://ftp.de.debian.org jessie Release.gpg                             
Pobieranie:3 http://dl.google.com stable Release.gpg [819 B]                  
Stary http://ftp.de.debian.org jessie Release                                 
Pobieranie:4 http://dl.google.com stable Release [1189 B]                     
Pobieranie:5 http://security.debian.org oldstable/updates/main amd64 Packages [434 kB]
Pobieranie:6 https://deb.opera.com stable InRelease [2592 B]                  
Stary https://repo.skype.com stable/main amd64 Packages                       
Stary http://ppa.launchpad.net trusty/main Sources                            
Stary http://ftp.pl.debian.org oldstable Release.gpg                          
Stary http://ftp.de.debian.org jessie/main amd64 Packages                     
Pobieranie:7 https://repo.skype.com stable/main Translation-pl_PL [246 B]     
Stary http://ftp.pl.debian.org oldstable Release                              
Stary http://ppa.launchpad.net trusty/main amd64 Packages                     
Stary http://ftp.de.debian.org jessie/main i386 Packages                      
Stary http://ftp.de.debian.org jessie/main Translation-pl                     
Pobieranie:8 https://repo.skype.com stable/main Translation-pl [243 B]        
Stary http://ppa.launchpad.net trusty/main i386 Packages                      
Stary http://ftp.de.debian.org jessie/main Translation-en                     
Stary http://ppa.launchpad.net trusty/main Translation-en                     
Pobieranie:9 https://repo.skype.com stable/main Translation-en [243 B]        
Pobieranie:10 https://repo.skype.com stable/main Translation-pl_PL [246 B]    
Pobieranie:11 http://dl.google.com stable/main amd64 Packages [1367 B]        
Pobieranie:12 https://deb.opera.com stable/non-free amd64 Packages [1827 B]   
Pobieranie:13 https://repo.skype.com stable/main Translation-pl [243 B]       
Pobieranie:14 http://www.deb-multimedia.org jessie InRelease [35,2 kB]        
Pobieranie:15 http://ftp.pl.debian.org oldstable-updates/main amd64 Packages/DiffIndex [8884 B]
Pobieranie:16 https://repo.skype.com stable/main Translation-en [243 B]       
Pobieranie:17 https://repo.skype.com stable/main Translation-pl_PL [246 B]    
Pobieranie:18 https://deb.opera.com stable/non-free i386 Packages [1820 B]    
Pobieranie:19 https://deb.opera.com stable/non-free Translation-pl_PL [339 B] 
Pobieranie:20 https://deb.opera.com stable/non-free Translation-pl [336 B]    
Pobieranie:21 https://repo.skype.com stable/main Translation-pl [243 B]       
Ign.  http://dl.google.com stable/main Translation-pl_PL                      
Pobieranie:22 https://deb.opera.com stable/non-free Translation-en [336 B]    
Ign.  http://dl.google.com stable/main Translation-pl                         
Stary http://www.deb-multimedia.org jessie/main amd64 Packages                
Ign.  http://dl.google.com stable/main Translation-en                         
Pobieranie:23 https://deb.opera.com stable/non-free Translation-pl_PL [339 B] 
Pobieranie:24 https://repo.skype.com stable/main Translation-en [243 B]       
Pobieranie:25 http://www.deb-multimedia.org jessie/non-free amd64 Packages [2132 B]
Stary http://www.deb-multimedia.org jessie/main i386 Packages                 
Pobieranie:26 http://www.deb-multimedia.org jessie/non-free i386 Packages [5136 B]
Stary http://www.deb-multimedia.org jessie/main Translation-en                
Stary http://www.deb-multimedia.org jessie/non-free Translation-en            
Stary http://ftp.pl.debian.org oldstable-updates/contrib amd64 Packages       
Pobieranie:27 http://ftp.pl.debian.org oldstable-updates/non-free amd64 Packages/DiffIndex [736 B]
Pobieranie:28 http://ftp.pl.debian.org oldstable-updates/main i386 Packages/DiffIndex [8884 B]
Stary http://security.debian.org oldstable/updates/contrib amd64 Packages     
Stary http://ftp.pl.debian.org oldstable-updates/contrib i386 Packages        
Pobieranie:29 http://ftp.pl.debian.org oldstable-updates/non-free i386 Packages/DiffIndex [736 B]
Stary http://security.debian.org oldstable/updates/non-free amd64 Packages    
Pobieranie:30 http://security.debian.org oldstable/updates/main i386 Packages [434 kB]
Stary http://ftp.pl.debian.org oldstable-updates/contrib Translation-en       
Pobieranie:31 http://ftp.pl.debian.org oldstable-updates/main Translation-en/DiffIndex [3688 B]
Pobieranie:32 http://ftp.pl.debian.org oldstable-updates/non-free Translation-en/DiffIndex [736 B]
Stary http://ftp.pl.debian.org oldstable/main amd64 Packages                  
Stary http://ftp.pl.debian.org oldstable/contrib amd64 Packages               
Stary http://ftp.pl.debian.org oldstable/non-free amd64 Packages              
Stary http://ftp.pl.debian.org oldstable/main i386 Packages                   
Stary http://ftp.pl.debian.org oldstable/contrib i386 Packages                
Stary http://ftp.pl.debian.org oldstable/non-free i386 Packages               
Stary http://ftp.pl.debian.org oldstable/contrib Translation-en               
Pobieranie:33 https://deb.opera.com stable/non-free Translation-pl [336 B]    
Stary http://ftp.pl.debian.org oldstable/main Translation-pl                  
Pobieranie:34 https://repo.skype.com stable/main Translation-pl_PL [246 B]    
Stary http://ftp.pl.debian.org oldstable/main Translation-en                  
Stary http://ftp.pl.debian.org oldstable/non-free Translation-en              
Pobieranie:35 https://deb.opera.com stable/non-free Translation-en [336 B]    
Pobieranie:36 https://repo.skype.com stable/main Translation-pl [243 B]       
Pobieranie:37 https://deb.opera.com stable/non-free Translation-pl_PL [339 B] 
Pobieranie:38 https://repo.skype.com stable/main Translation-en [243 B]       
Pobieranie:39 https://deb.opera.com stable/non-free Translation-pl [336 B]    
Pobieranie:40 https://deb.opera.com stable/non-free Translation-en [336 B]    
Pobieranie:41 https://repo.skype.com stable/main Translation-pl_PL [246 B]    
Ign.  https://repo.skype.com stable/main Translation-pl_PL                    
Pobieranie:42 https://deb.opera.com stable/non-free Translation-pl_PL [339 B] 
Pobieranie:43 https://repo.skype.com stable/main Translation-pl [243 B]       
Ign.  https://repo.skype.com stable/main Translation-pl                       
Pobieranie:44 https://deb.opera.com stable/non-free Translation-pl [336 B]    
Pobieranie:45 https://repo.skype.com stable/main Translation-en [243 B]       
Ign.  https://repo.skype.com stable/main Translation-en                       
Pobieranie:46 https://deb.opera.com stable/non-free Translation-en [336 B]    
Pobieranie:47 https://deb.opera.com stable/non-free Translation-pl_PL [339 B] 
Ign.  https://deb.opera.com stable/non-free Translation-pl_PL                 
Pobieranie:48 https://deb.opera.com stable/non-free Translation-pl [336 B]    
Ign.  https://deb.opera.com stable/non-free Translation-pl                    
Pobieranie:49 https://deb.opera.com stable/non-free Translation-en [336 B]    
Ign.  https://deb.opera.com stable/non-free Translation-en                    
Stary http://security.debian.org oldstable/updates/contrib i386 Packages      
Stary http://security.debian.org oldstable/updates/non-free i386 Packages    
Stary http://security.debian.org oldstable/updates/contrib Translation-en     
Stary http://security.debian.org oldstable/updates/main Translation-en        
Stary http://security.debian.org oldstable/updates/non-free Translation-en   
Pobrano 1152 kB w 21s (54,8 kB/s)                                             
Czytanie list pakietów... Gotowe
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5

E: Package 'ia32-libs' has no installation candidate
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 lib32stdc++6 : Wymaga: lib32gcc1 (>= 1:4.1.1) ale nie zostanie zainstalowany
                Wymaga: libc6-i386 (>= 2.18) ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
dpkg -x brhl2030lpr-2.0.1-1.i386.deb /
dpkg -x cupswrapperHL2030-2.0.1-2.i386.deb /
dpkg-deb: budowanie pakietu "brhl2030lpr" w "brhl2030lpr-2.0.1-1a.i386.deb".
dpkg -b ./brother_driver_packdir brhl2030lpr-2.0.1-1a.i386.deb
dpkg-deb: budowanie pakietu "cupswrapperhl2030" w "cupswrapperHL2030-2.0.1-2a.i386.deb".
dpkg -b ./brother_driver_packdir cupswrapperHL2030-2.0.1-2a.i386.deb
dpkg -i --force-all brhl2030lpr-2.0.1-1a.i386.deb
Wybieranie wcześniej niewybranego pakietu brhl2030lpr.
(Odczytywanie bazy danych ... 207080 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brhl2030lpr-2.0.1-1a.i386.deb ...
Rozpakowywanie pakietu brhl2030lpr (2.0.1-1) ...
Konfigurowanie pakietu brhl2030lpr (2.0.1-1) ...
dpkg -i --force-all cupswrapperHL2030-2.0.1-2a.i386.deb
Wybieranie wcześniej niewybranego pakietu cupswrapperhl2030.
(Odczytywanie bazy danych ... 207097 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu cupswrapperHL2030-2.0.1-2a.i386.deb ...
Rozpakowywanie pakietu cupswrapperhl2030 (2.0.1-2) ...
Konfigurowanie pakietu cupswrapperhl2030 (2.0.1-2) ...
Restarting cups (via systemctl): cups.service.
#
Will you specify the Device URI? [Y/n] ->n

Test Print? [y/N] ->y

wait 5s.
lpr -P HL2030 /usr/share/cups/data/testprint
root@debian:/home/abc/Dokumenty#

Oczywiście drukarka nic nie wydrukowała. I nadal w procesie instalacji jest tych kilka linii:

Kod:

Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5

Ostatnio edytowany przez pltvgz20 (2017-10-19 14:17:31)

Offline

 

#13 2017-10-19 16:08:30

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

Pliki ".so" (czyli jak rozumiem biblioteki) z drugiego sugerowanego przez instalator pakietu "lib32ncurses5" dostępnego tylko na "amd64", czyli te pliki:
https://packages.debian.org/jessie/amd64/lib32ncurses5/filelist

pokrywają się z plikami z dostępnymi na "i386" pakietów: "libncurses5": https://packages.debian.org/jessie/i386/libncurses5/filelist

który mam:

Kod:

dpkg -l libncurses5:i386
Wybór:U=nieznany/I=instalacja/R=usunięcie/P=wyczyszczenie/H=zatrzymanie
| Stan:N=brak/I=zainstalowany/C=skonfigurowany/U=rozpakowany/
|/  F=częśc. skonfigurowany/H=częśc. zainstalowany/W=wyzw. czek./T=wyzw. zapl.
|| Błędy?=(brak)/R-do pon. inst. (duże litery w "Stan" i "Błędy"=problemy)
||/ Nazwa          Wersja       Architektura Opis
+++-==============-============-============-=================================
ii  libncurses5:i3 6.0+20161126 i386         shared libraries for terminal han

i z plikami z "libncurses5-dbg": https://packages.debian.org/jessie/i386/libncurses5-dbg/filelist ,

którego chyba nie mam:

Kod:

dpkg -l libncurses5-dbg:i386
dpkg-query: nie znaleziono pakietu pasującego do wzorca libncurses5-dbg:i386

Więc go instaluję:

Kod:

apt-get install libncurses5-dbg:i386
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 libncurses5-dbg:i386 : Wymaga: libtinfo5:i386 (= 5.9+20140913-1+b1) ale 6.0+20161126-1 ma zostać zainstalowany
                        Wymaga: libncurses5-dev:i386 (= 5.9+20140913-1+b1) ale nie zostanie zainstalowany
                        Wymaga: libtinfo5-dbg:i386 (= 5.9+20140913-1+b1) ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

ze skutkiem niestety takim. :(

Ostatnio edytowany przez pltvgz20 (2017-10-19 16:10:45)

Offline

 

#14 2017-10-19 17:03:49

mati75
Psuj
Skąd: Rzeszów
Zarejestrowany: 2010-03-14
Serwis

Re: Drukarka Brother HL-2035 sterownik nie działa

Zrób fake pakiety: https://dug.net.pl/tekst/154


https://l0calh0st.pl/obrazki/userbar.png

Offline

 

#15 2017-10-20 00:51:56

wikingagressor
Użytkownik
Skąd: Józefów k.Błonia, mazowieckie
Zarejestrowany: 2015-02-03

Re: Drukarka Brother HL-2035 sterownik nie działa

Haha, widac ze zeby te pakiety od drukarki ruszyly to musza miec cale srodowisko podstawowe 32 bitowe. Juz masz coraz wiecej bibliotek z nim zwiazanych, teraz blokuje cie brak pakietu lib32gcc1:i386. Tu masz napisane co instalatorowi nie pasuje:

Następujące pakiety mają niespełnione zależności:
lib32stdc++6 : Wymaga: lib32gcc1 (>= 1:4.1.1) ale nie zostanie zainstalowany
                Wymaga: libc6-i386 (>= 2.18) ale nie zostanie zainstalowany

Ostatnio edytowany przez wikingagressor (2017-10-20 00:55:41)


Peace, Love and Debian for the World!!!

Offline

 

#16 2017-10-20 11:58:05

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

mati75 napisał(-a):

Zrób fake pakiety: https://dug.net.pl/tekst/154

W sumie napisałeś, żeby zrobić pakiety a nie pakiet. Ja zrobiłem "ia32-libs". I nie działa drukarka... Jest w instalacji fragment:

Kod:

Następujące pakiety mają niespełnione zależności:
 lib32stdc++6 : Wymaga: lib32gcc1 (>= 1:4.1.1) ale nie zostanie zainstalowany
                Wymaga: libc6-i386 (>= 2.18) ale nie zostanie zainstalowany

Poniżej całość moich ruchów od odinstalowania drukarki przez instalacje udawanego pakietu "ia32-libs" do zakończenia instalacji.

Kod:

root@debian:/home/abc/Dokumenty# dpkg -l brhl2030lpr cupswrapperhl2030:i386
Wybór:U=nieznany/I=instalacja/R=usunięcie/P=wyczyszczenie/H=zatrzymanie
| Stan:N=brak/I=zainstalowany/C=skonfigurowany/U=rozpakowany/
|/  F=częśc. skonfigurowany/H=częśc. zainstalowany/W=wyzw. czek./T=wyzw. zapl.
|| Błędy?=(brak)/R-do pon. inst. (duże litery w "Stan" i "Błędy"=problemy)
||/ Nazwa          Wersja       Architektura Opis
+++-==============-============-============-=================================
ii  brhl2030lpr    2.0.1-1      i386         Brother HL-2030 LPR driver
ii  cupswrapperhl2 2.0.1-2      i386         Brother HL2030 CUPS wrapper drive
root@debian:/home/abc/Dokumenty# apt-get remove --purge brhl2030lpr cupswrapperhl2030:i386
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Następujące pakiety zostaną USUNIĘTE:
  brhl2030lpr:i386* cupswrapperhl2030:i386*
0 aktualizowanych, 0 nowo instalowanych, 2 usuwanych i 6 nieaktualizowanych.
Po tej operacji zostanie zwolnione 311 kB miejsca na dysku.
Kontynuować? [T/n] t
(Odczytywanie bazy danych ... 207124 pliki i katalogi obecnie zainstalowane.)
Usuwanie pakietu brhl2030lpr (2.0.1-1) ...
Czyszczenie z plików konfiguracyjnych pakietu brhl2030lpr (2.0.1-1) ...
dpkg: ostrzeżenie: podczas usuwania pakietu brhl2030lpr, katalog "/usr/local/Brother/inf" nie był pusty, więc nie został usunięty
Usuwanie pakietu cupswrapperhl2030 (2.0.1-2) ...
[ ok ] Restarting cups (via systemctl): cups.service.
Czyszczenie z plików konfiguracyjnych pakietu cupswrapperhl2030 (2.0.1-2) ...
dpkg: ostrzeżenie: podczas usuwania pakietu cupswrapperhl2030, katalog "/usr/local/Brother" nie był pusty, więc nie został usunięty
root@debian:/home/abc/Dokumenty# dpkg -l brhl2030lpr cupswrapperhl2030:i386dpkg-query: nie znaleziono pakietu pasującego do wzorca brhl2030lpr
dpkg-query: nie znaleziono pakietu pasującego do wzorca cupswrapperhl2030:i386
root@debian:/home/abc/Dokumenty# dpkg -i ia32-libs_2+fake_all.deb
Wybieranie wcześniej niewybranego pakietu ia32-libs.
(Odczytywanie bazy danych ... 207105 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu ia32-libs_2+fake_all.deb ...
Rozpakowywanie pakietu ia32-libs (11:2+fake) ...
Konfigurowanie pakietu ia32-libs (11:2+fake) ...
root@debian:/home/abc/Dokumenty# bash linux-brprinter-installer-2.1.1-1 HL-2035
You are going to install following packages.
   brhl2030lpr-2.0.1-1.i386.deb
   cupswrapperHL2030-2.0.1-2.i386.deb
OK? [y/N] ->y

Pobieranie:1 http://security.debian.org oldstable/updates InRelease [63,1 kB] 
Ign.  http://ftp.pl.debian.org oldstable InRelease                            
Ign.  http://dl.google.com stable InRelease                                   
Stary http://ppa.launchpad.net trusty InRelease                               
Pobieranie:2 http://ftp.pl.debian.org oldstable-updates InRelease [145 kB]    
Ign.  http://ftp.de.debian.org jessie InRelease                               
Stary http://www.deb-multimedia.org jessie InRelease                          
Stary http://dl.google.com stable Release.gpg                                 
Stary http://dl.google.com stable Release                                     
Stary http://ppa.launchpad.net trusty/main Sources                            
Stary http://ftp.de.debian.org jessie Release.gpg                             
Pobieranie:3 http://security.debian.org oldstable/updates/main amd64 Packages [434 kB]
Stary http://ftp.pl.debian.org oldstable Release.gpg                          
Stary http://ftp.de.debian.org jessie Release                                 
Stary http://ppa.launchpad.net trusty/main amd64 Packages                     
Stary http://ftp.pl.debian.org oldstable Release                              
Stary http://www.deb-multimedia.org jessie/main amd64 Packages                
Stary http://dl.google.com stable/main amd64 Packages                         
Stary https://repo.skype.com stable InRelease                                 
Pobieranie:4 http://ftp.pl.debian.org oldstable-updates/main amd64 Packages/DiffIndex [8884 B]
Stary http://ftp.de.debian.org jessie/main amd64 Packages                     
Stary http://ftp.de.debian.org jessie/main i386 Packages                      
Stary http://ftp.de.debian.org jessie/main Translation-pl                     
Stary http://ppa.launchpad.net trusty/main i386 Packages                      
Stary http://www.deb-multimedia.org jessie/non-free amd64 Packages            
Stary http://ftp.de.debian.org jessie/main Translation-en                     
Stary http://www.deb-multimedia.org jessie/main i386 Packages                 
Stary http://ppa.launchpad.net trusty/main Translation-en                     
Stary http://www.deb-multimedia.org jessie/non-free i386 Packages             
Stary http://www.deb-multimedia.org jessie/main Translation-en                
Stary https://repo.skype.com stable/main amd64 Packages                       
Pobieranie:5 https://repo.skype.com stable/main Translation-pl_PL [246 B]     
Stary http://www.deb-multimedia.org jessie/non-free Translation-en            
Pobieranie:6 https://repo.skype.com stable/main Translation-pl [243 B]        
Pobieranie:7 https://deb.opera.com stable InRelease [2592 B]                  
Stary http://ftp.pl.debian.org oldstable-updates/contrib amd64 Packages       
Ign.  http://dl.google.com stable/main Translation-pl_PL                      
Pobieranie:8 http://ftp.pl.debian.org oldstable-updates/non-free amd64 Packages/DiffIndex [736 B]
Ign.  http://dl.google.com stable/main Translation-pl                         
Pobieranie:9 http://ftp.pl.debian.org oldstable-updates/main i386 Packages/DiffIndex [8884 B]
Ign.  http://dl.google.com stable/main Translation-en                         
Pobieranie:10 https://repo.skype.com stable/main Translation-en [243 B]       
Pobieranie:11 https://repo.skype.com stable/main Translation-pl_PL [246 B]    
Stary http://ftp.pl.debian.org oldstable-updates/contrib i386 Packages        
Pobieranie:12 https://repo.skype.com stable/main Translation-pl [243 B]       
Pobieranie:13 http://ftp.pl.debian.org oldstable-updates/non-free i386 Packages/DiffIndex [736 B]
Pobieranie:14 https://repo.skype.com stable/main Translation-en [243 B]       
Pobieranie:15 https://deb.opera.com stable/non-free amd64 Packages [1822 B]   
Stary http://ftp.pl.debian.org oldstable-updates/contrib Translation-en       
Pobieranie:16 http://ftp.pl.debian.org oldstable-updates/main Translation-en/DiffIndex [3688 B]
Pobieranie:17 http://ftp.pl.debian.org oldstable-updates/non-free Translation-en/DiffIndex [736 B]
Stary http://ftp.pl.debian.org oldstable/main amd64 Packages                  
Stary http://ftp.pl.debian.org oldstable/contrib amd64 Packages               
Stary http://ftp.pl.debian.org oldstable/non-free amd64 Packages              
Stary http://ftp.pl.debian.org oldstable/main i386 Packages                   
Stary http://ftp.pl.debian.org oldstable/contrib i386 Packages                
Stary http://ftp.pl.debian.org oldstable/non-free i386 Packages               
Pobieranie:18 https://repo.skype.com stable/main Translation-pl_PL [246 B]    
Pobieranie:19 https://repo.skype.com stable/main Translation-pl [243 B]       
Stary http://ftp.pl.debian.org oldstable/contrib Translation-en               
Pobieranie:20 https://deb.opera.com stable/non-free i386 Packages [1820 B]    
Stary http://ftp.pl.debian.org oldstable/main Translation-pl                 
Pobieranie:21 https://repo.skype.com stable/main Translation-en [243 B]      
Stary http://ftp.pl.debian.org oldstable/main Translation-en                  
Stary http://ftp.pl.debian.org oldstable/non-free Translation-en              
Pobieranie:22 https://repo.skype.com stable/main Translation-pl_PL [246 B]    
Pobieranie:23 https://deb.opera.com stable/non-free Translation-pl_PL [339 B] 
Pobieranie:24 https://repo.skype.com stable/main Translation-pl [243 B]       
Pobieranie:25 https://deb.opera.com stable/non-free Translation-pl [336 B]    
Pobieranie:26 https://repo.skype.com stable/main Translation-en [243 B]       
Pobieranie:27 https://deb.opera.com stable/non-free Translation-en [336 B]    
Pobieranie:28 https://deb.opera.com stable/non-free Translation-pl_PL [339 B] 
Pobieranie:29 https://repo.skype.com stable/main Translation-pl_PL [246 B]    
Pobieranie:30 https://deb.opera.com stable/non-free Translation-pl [336 B]    
Ign.  https://repo.skype.com stable/main Translation-pl_PL                    
Pobieranie:31 https://repo.skype.com stable/main Translation-pl [243 B]       
Ign.  https://repo.skype.com stable/main Translation-pl                       
Pobieranie:32 https://deb.opera.com stable/non-free Translation-en [336 B]    
Pobieranie:33 https://repo.skype.com stable/main Translation-en [243 B]       
Stary http://security.debian.org oldstable/updates/contrib amd64 Packages     
Stary http://security.debian.org oldstable/updates/non-free amd64 Packages    
Pobieranie:34 http://security.debian.org oldstable/updates/main i386 Packages [435 kB]
Ign.  https://repo.skype.com stable/main Translation-en                       
Pobieranie:35 https://deb.opera.com stable/non-free Translation-pl_PL [339 B] 
Pobieranie:36 https://deb.opera.com stable/non-free Translation-pl [336 B]    
Pobieranie:37 https://deb.opera.com stable/non-free Translation-en [336 B]    
Pobieranie:38 https://deb.opera.com stable/non-free Translation-pl_PL [339 B] 
Pobieranie:39 https://deb.opera.com stable/non-free Translation-pl [336 B]    
Pobieranie:40 https://deb.opera.com stable/non-free Translation-en [336 B]    
Pobieranie:41 https://deb.opera.com stable/non-free Translation-pl_PL [339 B] 
Ign.  https://deb.opera.com stable/non-free Translation-pl_PL                 
Pobieranie:42 https://deb.opera.com stable/non-free Translation-pl [336 B]    
Ign.  https://deb.opera.com stable/non-free Translation-pl                    
Pobieranie:43 https://deb.opera.com stable/non-free Translation-en [336 B]    
Ign.  https://deb.opera.com stable/non-free Translation-en                    
Stary http://security.debian.org oldstable/updates/contrib i386 Packages      
Stary http://security.debian.org oldstable/updates/non-free i386 Packages  
Stary http://security.debian.org oldstable/updates/contrib Translation-en  
Pobieranie:44 http://security.debian.org oldstable/updates/main Translation-en [232 kB]
Stary http://security.debian.org oldstable/updates/non-free Translation-en    
Pobrano 1339 kB w 22s (58,4 kB/s)                                             
Czytanie list pakietów... Gotowe
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 lib32stdc++6 : Wymaga: lib32gcc1 (>= 1:4.1.1) ale nie zostanie zainstalowany
                Wymaga: libc6-i386 (>= 2.18) ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
dpkg -x brhl2030lpr-2.0.1-1.i386.deb /
dpkg -x cupswrapperHL2030-2.0.1-2.i386.deb /
dpkg-deb: budowanie pakietu "brhl2030lpr" w "brhl2030lpr-2.0.1-1a.i386.deb".
dpkg -b ./brother_driver_packdir brhl2030lpr-2.0.1-1a.i386.deb
dpkg-deb: budowanie pakietu "cupswrapperhl2030" w "cupswrapperHL2030-2.0.1-2a.i386.deb".
dpkg -b ./brother_driver_packdir cupswrapperHL2030-2.0.1-2a.i386.deb
dpkg -i --force-all brhl2030lpr-2.0.1-1a.i386.deb
Wybieranie wcześniej niewybranego pakietu brhl2030lpr.
(Odczytywanie bazy danych ... 207109 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu brhl2030lpr-2.0.1-1a.i386.deb ...
Rozpakowywanie pakietu brhl2030lpr (2.0.1-1) ...
Konfigurowanie pakietu brhl2030lpr (2.0.1-1) ...
dpkg -i --force-all cupswrapperHL2030-2.0.1-2a.i386.deb
Wybieranie wcześniej niewybranego pakietu cupswrapperhl2030.
(Odczytywanie bazy danych ... 207126 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu cupswrapperHL2030-2.0.1-2a.i386.deb ...
Rozpakowywanie pakietu cupswrapperhl2030 (2.0.1-2) ...
Konfigurowanie pakietu cupswrapperhl2030 (2.0.1-2) ...
Restarting cups (via systemctl): cups.service.
#
Will you specify the Device URI? [Y/n] ->n

Test Print? [y/N] ->y

wait 5s.
lpr -P HL2030 /usr/share/cups/data/testprint
root@debian:/home/abc/Dokumenty#

Robić fake pakiety "lib32z1" i "lib32ncurses5" i ewentualnie tego, co wyskakuje w instalacji "lib32stdc++6", skoro po zainstalowaniu fake "ia32-libs" drukarka nie ruszyła?

Haha, widac ze zeby te pakiety od drukarki ruszyly to musza miec cale srodowisko podstawowe 32 bitowe. Juz masz coraz wiecej bibliotek z nim zwiazanych, teraz blokuje cie brak pakietu lib32gcc1:i386. Tu masz napisane co instalatorowi nie pasuje:

Czyli pomysł z fake pakietami jest zły?

Ostatnio edytowany przez pltvgz20 (2017-10-20 12:09:52)

Offline

 

#17 2017-10-20 16:32:43

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Drukarka Brother HL-2035 sterownik nie działa

Zamiast apt-get i dpkg (z przełącznikiem --force-all w tym przypadku to w ogóle szczyt głupoty) użyj aptitude.
Do tego zrób porządek z repozytoriami i wersjami bibliotek.

Ten pakiet ze sterownikiem jest po prostu beznadziejnie zrobiony i stąd te problemy.

Kod:

aptitude search ~i~ri386

Offline

 

#18 2017-10-20 22:37:28

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

yossarian napisał(-a):

Zamiast apt-get i dpkg (z przełącznikiem --force-all w tym przypadku to w ogóle szczyt głupoty) użyj aptitude.
Do tego zrób porządek z repozytoriami i wersjami bibliotek.

Ten pakiet ze sterownikiem jest po prostu beznadziejnie zrobiony i stąd te problemy.

Kod:

aptitude search ~i~ri386

Ale ja tę instalację uruchamiam tylko przez wpisanie:

Kod:

bash linux-brprinter-installer-2.1.1-1 HL-2035

i się potem wszystko dzieje niemalże "samo", więc tu "z mojej strony" nie ma nigdzie "apt-geta" ani "dpkg" oprócz ostatniej próby dodania fikcyjnego pakietu: "ia32-libs" przez "dpkg", więc jak mogę użyć aptitude?
I jak się "robi porządek z repozytoriami i wersjami bibliotek", bo jedyne co mi do głowy przychodziło to, że wszystko się wymieszało jak "Stretch" stawał się "stable" a ja repozytoria miałem ustawione na "stable" a nie na "Jessie" i że trzeba zrobić aktualizację z "Jessie" do "Stretcha", której wolałbym nie robić bo mi SiSa grafika może nie chcieć chodzić potem?

A to poniżej to zwrotka tej komendy, którą podałeś:

Kod:

root@debian:/home# aptitude search ~i~ri386
i   brhl2030lpr:i386                - Brother HL-2030 LPR driver               
i   cupswrapperhl2030:i386          - Brother HL2030 CUPS wrapper driver       
i A gcc-4.9-base:i386               - Pakiet podstawowy Kolekcji Kompilatorów G
i A i965-va-driver:i386             - VAAPI driver for Intel G45 & HD Graphics 
i A libaacplus2:i386                - AAC+ encoding library - runtime files    
i A libasound2:i386                 - Biblioteka współdzielona do aplikacji ALS
i A libasound2-plugins:i386         - ALSA library additional plugins          
i A libasyncns0:i386                - Biblioteka do asynchronicznych zapytań o 
i A libattr1:i386                   - Biblioteka składowa atrybutów rozszerzony
i A libavcodec56:i386               - Library to encode decode multimedia strea
i A libavresample2:i386             - FFmpeg audio conversion library          
i A libavutil54:i386                - FFmpeg avutil library - runtime files    
i A libblkid1:i386                  - block device ID library                  
i A libbsd0:i386                    - Użyteczne funkcje z systemów BSD - biblio
i   libc6:i386                      - Biblioteka GNU C:  biblioteki współdzielo
i A libcap2:i386                    - Funkcje POSIX 1003.1e (biblioteka)       
i A libcrystalhd3:i386              - Crystal HD Video Decoder (shared library)
i A libdb5.3:i386                   - Biblioteki bazy danych Berkeley w wersji 
i A libdbus-1-3:i386                - Prosty system komunikacji międzyprocesowe
i A libdrm-intel1:i386              - Interfejs przestrzeni użytkownika do spec
i A libdrm-nouveau2:i386            - Interfejs przestrzeni użytkownika do spec
i A libdrm-radeon1:i386             - Interfejs przestrzeni użytkownika do spec
i A libdrm2:i386                    - Interfejs przestrzeni użytkownika do usłu
i A libedit2:i386                   - Biblioteka do edytowania wiersza poleceń 
i A libelf1:i386                    - Biblioteka do odczytywania i zapisywania 
i A libexpat1:i386                  - Biblioteka C do parsowania XML-a - biblio
i A libfaac0:i386                   - AAC audio encoder - library files.       
i A libfdk-aac1:i386                - Fraunhofer FDK AAC codec library.        
i A libffi6:i386                    - Pliki biblioteki uruchomieniowej dla inte
i A libflac8:i386                   - Free Lossless Audio Codec - biblioteka ur
i   libfontconfig1:i386             - Ogólna bilioteka konfiuracji czcionek - u
i A libfreetype6:i386               - Silnik czcionek FreeType 2, pliki bibliot
i A libgcc1:i386                    - Biblioteka wspomagająca GCC              
i A libgcrypt20:i386                - LGPL Crypto library - runtime library    
i A libgl1-mesa-dri:i386            - Darmowa implementacja API OpenGL -- moduł
i   libgl1-mesa-glx:i386            - Darmowa implementacja API OpenGL -- pliki
i A libglapi-mesa:i386              - Wolna implementacja API GL - biblioteka w
i   libglib2.0-0:i386               - Glib, biblioteka funkcji języka C        
i   libglu1-mesa:i386               - Mesa OpenGL utility library (GLU)        
i A libgmp10:i386                   - Biblioteka działań arytmetycznych z dużą 
i A libgnutls-deb0-28:i386          - Biblioteka GNU TLS - główna biblioteka ur
i A libgpg-error0:i386              - Biblioteka dla typowych błędów i wiadomoś
i A libgpm2:i386                    - Uniwersalna Mysz - biblioteki współdzielo
i A libgsm1:i386                    - Biblioteki współdzielone do kompresora mo
i A libgstreamer-plugins-base0.10-0 - Biblioteki GStreamer z "bazowego" zestawu
i A libgstreamer0.10-0:i386         - Podstawowe biblioteki i elementy GStreame
i A libhogweed2:i386                - low level cryptographic library (public-k
i A libice6:i386                    - Biblioteka X11 Inter-Client Exchange     
i A libjack-jackd2-0:i386           - JACK Audio Connection Kit (libraries)    
i A libjson-c2:i386                 - Biblioteka do zarządzania JSON - bibliote
i A liblcms2-2:i386                 - LittleCMS 2 - biblioteka zarządzająca kol
i A libldap-2.4-2:i386              - Biblioteki OpenLDAP                      
i A libllvm3.5:i386                 - Modular compiler and toolchain technologi
i A liblz4-1:i386                   - Fast LZ compression algorithm library - r
i A liblzma5:i386                   - Biblioteka do kompresji w formacie XZ    
i A libmount1:i386                  - device mounting library                  
i A libmp3lame0:i386                - Shared libraries for MP3 encoding        
i A libmpg123-0:i386                - MPEG layer 1/2/3 audio decoder (shared li
i   libncurses5:i386                - Biblioteki współdzielone przeznaczone do 
i A libnettle4:i386                 - Niskopoziomowa biblioteka kryptograficzna
i A libogg0:i386                    - Biblioteka strumieniowa Ogg              
i A libopenal1:i386                 - Software implementation of the OpenAL aud
i A libopencore-amrnb0:i386         - Adaptive Multi Rate speech codec - shared
i A libopencore-amrwb0:i386         - Adaptive Multi-Rate - Wideband speech cod
i A libopenjpeg5:i386               - JPEG 2000 image compression/decompression
i A libopus0:i386                   - Opus codec runtime library               
i A liborc-0.4-0:i386               - Biblioteka ORC (Optimized Inner Loops Run
i A libp11-kit0:i386                - library for loading and coordinating acce
i A libpciaccess0:i386              - Standardowa biblioteka zapewniająca dostę
i A libpcre3:i386                   - Kompatybilna z Perl 5 biblioteka wyrażeń 
i A libpng12-0:i386                 - Biblioteka uruchomieniowa PNG            
i A libpulse0:i386                  - Biblioteki klienta PulseAudio            
i A libsamplerate0:i386             - Biblioteka do konwersji częstotliwości pr
i A libsasl2-2:i386                 - Cyrus SASL - biblioteka abstrakcji uwierz
i A libsasl2-modules:i386           - Cyrus SASL - dołączalne moduły uwierzytel
i A libsasl2-modules-db:i386        - Cyrus SASL - moduł uwierzytelniania bazy 
i A libschroedinger-1.0-0:i386      - library for encoding/decoding of Dirac vi
i A libselinux1:i386                - Współdzielone biblioteki uruchomieniowe S
i   libsm6:i386                     - Biblioteka X11 Session Management        
i A libsndfile1:i386                - Library for reading/writing audio files  
i A libspeex1:i386                  - Biblioteka uruchomieniowa kodeka Speex   
i A libspeexdsp1:i386               - The Speex extended runtime library       
i A libssl1.0.0:i386                - Zestaw narzędzi Secure Sockets Layer - bi
i   libstdc++6:i386                 - Standardowa biblioteka GNU C++, wersja 3 
i A libswresample1:i386             - FFmpeg audio rescaling library           
i A libsystemd0:i386                - systemd utility library                  
i A libtasn1-6:i386                 - Zarządza strukturami ASN.1 (wersja urucho
i A libtheora0:i386                 - Kodek Theora do kompresji wideo          
i A libtinfo5:i386                  - Współdzielona, niskopoziomowa biblioteka 
i A libtxc-dxtn-s2tc0:i386          - Texture compression library for Mesa     
i A libudev1:i386                   - Biblioteka współdzielona udev            
i A libutvideo15:i386               - Ut Video Codec Suite library             
i A libuuid1:i386                   - Biblioteka uniwersalnych, unikalnych iden
i A libva1:i386                     - Video Acceleration (VA) API for Linux -- 
i A libvdpau1:i386                  - Video Decode and Presentation API for Uni
i A libvo-aacenc0:i386              - VisualOn AAC encoder library             
i A libvo-amrwbenc0:i386            - VisualOn AMR-WB encoder library          
i A libvorbis0a:i386                - Biblioteka dekodująca do ogólnego kodeka 
i A libvorbisenc2:i386              - encoder library for Vorbis General Audio 
i A libvpx1:i386                    - VP8 and VP9 video codec (shared library) 
i A libwine:i386                    - Implementacja Windows API - biblioteka   
i A libwrap0:i386                   - Biblioteka opakowań TCP Wietse Venemy    
i   libx11-6:i386                   - Biblioteka X11 po stronie klienta        
i A libx11-xcb1:i386                - Biblioteka interfejsu Xlib/XCB           
i A libx264-146:i386                - x264 video coding library                
i A libx265-51:i386                 - x265 video coding library                
i A libxau6:i386                    - Biblioteka autoryzacji X11               
i A libxcb-dri2-0:i386              - X C Binding, dri2 extension              
i A libxcb-dri3-0:i386              - X C Binding, dri3 extension              
i A libxcb-glx0:i386                - X C Binding, glx extension               
i A libxcb-present0:i386            - X C Binding, present extension           
i A libxcb-sync1:i386               - X C Binding, sync extension              
i A libxcb1:i386                    - X C Binding                              
i A libxcursor1:i386                - Biblioteka zarządzająca kursorem X       
i A libxdamage1:i386                - X11 damaged region extension library     
i A libxdmcp6:i386                  - Biblioteka X11 Display Manager Control Pr
i   libxext6:i386                   - Biblioteka różnych rozszerzeń X11        
i A libxfixes3:i386                 - Biblioteka różnych rozszerzeń fixes dla X
i A libxi6:i386                     - Biblioteka z rozszerzeniem Input dla X11 
i A libxml2:i386                    - Biblioteka GNOME XML                     
i   libxrender1:i386                - Biblioteka kliencka Rozszerzenia Renderuj
i A libxshmfence1:i386              - X shared memory fences - shared library  
i A libxtst6:i386                   - X11 Testing -- biblioteka rozszerzeń reko
i A libxvidcore4:i386               - High quality ISO MPEG4 codec library     
i A libxxf86vm1:i386                - Biblioteka rozszerzeń trybu video X11 XFr
i A libzvbi0:i386                   - Vertical Blanking Interval decoder (VBI) 
i A mesa-vdpau-drivers:i386         - Mesa VDPAU video acceleration drivers    
i   ooobasis3.3-base:i386           - Base module for OpenOffice.org 3.3       
i   ooobasis3.3-binfilter:i386      - Legacy filters (e.g. StarOffice 5.2) for 
i   ooobasis3.3-calc:i386           - Calc module for OpenOffice.org 3.3       
i   ooobasis3.3-core01:i386         - Core module for OpenOffice.org 3.3       
i   ooobasis3.3-core02:i386         - Office core module for OpenOffice.org 3.3
i   ooobasis3.3-core03:i386         - Office core module for OpenOffice.org 3.3
i   ooobasis3.3-core04:i386         - Office core module for OpenOffice.org 3.3
i   ooobasis3.3-core05:i386         - Office core module for OpenOffice.org 3.3
i   ooobasis3.3-core06:i386         - Office core module for OpenOffice.org 3.3
i   ooobasis3.3-core07:i386         - Office core module for OpenOffice.org 3.3
i   ooobasis3.3-draw:i386           - Draw module for OpenOffice.org 3.3       
i   ooobasis3.3-gnome-integration:i - Gnome integration module for OpenOffice.o
i   ooobasis3.3-graphicfilter:i386  - Graphic filter module for OpenOffice.org 
i   ooobasis3.3-images:i386         - Images module for OpenOffice.org 3.3     
i   ooobasis3.3-impress:i386        - Impress module for OpenOffice.org 3.3    
i   ooobasis3.3-javafilter:i386     - Java filter module for OpenOffice.org 3.3
i   ooobasis3.3-math:i386           - Math module for OpenOffice.org 3.3       
i   ooobasis3.3-ogltrans:i386       - OpenGL slide transitions module for OpenO
i   ooobasis3.3-ooofonts:i386       - Mailcap module for OpenOffice.org 3.3    
i   ooobasis3.3-ooolinguistic:i386  - Linguistic module for OpenOffice.org 3.3 
i   ooobasis3.3-pl:i386             - Language module for OpenOffice.org 3.3, l
i   ooobasis3.3-pl-base:i386        - Base language module for OpenOffice.org 3
i   ooobasis3.3-pl-binfilter:i386   - Legacy filters (e.g. StarOffice 5.2) for 
i   ooobasis3.3-pl-calc:i386        - Calc language module for OpenOffice.org 3
i   ooobasis3.3-pl-draw:i386        - Draw language module for OpenOffice.org 3
i   ooobasis3.3-pl-help:i386        - Language help module for OpenOffice.org 3
i   ooobasis3.3-pl-impress:i386     - Impress language module for OpenOffice.or
i   ooobasis3.3-pl-math:i386        - Math language module for OpenOffice.org 3
i   ooobasis3.3-pl-res:i386         - Language resource module for OpenOffice.o
i   ooobasis3.3-pl-writer:i386      - Writer language module for OpenOffice.org
i   ooobasis3.3-pyuno:i386          - Pyuno module for OpenOffice.org 3.3      
i   ooobasis3.3-testtool:i386       - Testtool module for OpenOffice.org 3.3   
i   ooobasis3.3-writer:i386         - Writer module for OpenOffice.org 3.3     
i   ooobasis3.3-xsltfilter:i386     - XSLT filter samples module for OpenOffice
i   openoffice.org-ure:i386         - UNO Runtime Environment                  
i A va-driver-all:i386              - API do Video Acceleration (VA) - metapaki
i A vdpau-va-driver:i386            - VDPAU-based backend for VA API           
i   wine32:i386                     - Windows API implementation - 32-bit binar
i   zlib1g:i386                     - Biblioteka kompresyjna - pliki wykonawcze
root@debian:/home#

Ostatnio edytowany przez pltvgz20 (2017-10-20 22:53:59)

Offline

 

#19 2017-10-20 23:00:41

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Drukarka Brother HL-2035 sterownik nie działa

Klika przykładów:

Kod:

libc6-i386 : Wymaga: libc6 (= 2.19-18+deb8u10) ale 2.24-11+deb9u1 ma zostać zainstalowany

Kod:

libncurses5-dbg:i386 : Wymaga: libtinfo5:i386 (= 5.9+20140913-1+b1) ale 6.0+20161126-1 ma zostać zainstalowany

Szczególnie ten pierwszy blokuje jakiekolwiek próby rozwiązania. Warto by wszystko cofnąć do Jessie lub zaktualizować do bieżącego stable.

Dopóki nie uporządkujesz i wyrównasz pakietów do prawidłowych wersji (z aptitude powinno być łatwiej przy poprawnych repozytoriach), dopóty cała ta zabawa to marnowanie czasu twojego i innych.

Jak już to ogarniesz, to zainstaluj te pakiety (w aktualnej dla twojej dystrybucji wersji i architekturze i386), wchodzące kiedyś w skład ia32-libs:
https://packages.debian.org/wheezy/ia32-libs-i386

Numery w nazwach mogą się trochę różnić w kolejnych wydaniach.

Offline

 

#20 2017-10-24 19:43:31

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

yossarian napisał(-a):

Klika przykładów:

Kod:

libc6-i386 : Wymaga: libc6 (= 2.19-18+deb8u10) ale 2.24-11+deb9u1 ma zostać zainstalowany

Kod:

libncurses5-dbg:i386 : Wymaga: libtinfo5:i386 (= 5.9+20140913-1+b1) ale 6.0+20161126-1 ma zostać zainstalowany

Szczególnie ten pierwszy blokuje jakiekolwiek próby rozwiązania. Warto by wszystko cofnąć do Jessie lub zaktualizować do bieżącego stable.

Dopóki nie uporządkujesz i wyrównasz pakietów do prawidłowych wersji (z aptitude powinno być łatwiej przy poprawnych repozytoriach), dopóty cała ta zabawa to marnowanie czasu twojego i innych.

Jak już to ogarniesz, to zainstaluj te pakiety (w aktualnej dla twojej dystrybucji wersji i architekturze i386), wchodzące kiedyś w skład ia32-libs:
https://packages.debian.org/wheezy/ia32-libs-i386

Numery w nazwach mogą się trochę różnić w kolejnych wydaniach.

Przepraszam za zwłokę w odpowiedzi, ale też trochę badałem temat aktualizacji, żeby się na niej nie wyłożyć, skoro jest konieczna tak jak mówisz. W sprawie aktualizacji założę nowy temat lub tematy, bo też jest sprawa wifi (połączenia internetowego podczas aktualizacji). Gdybyście mogli pomóc z góry dziękuję, a o drukarce napiszę jak już będę na Stretchu i będzie można próbować walczyć dalej. :)

Ostatnio edytowany przez pltvgz20 (2017-10-24 19:44:23)

Offline

 

#21 2017-10-24 20:03:49

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Drukarka Brother HL-2035 sterownik nie działa

pltvgz20 napisał(-a):

Przepraszam za zwłokę w odpowiedzi, ale też trochę badałem temat aktualizacji, żeby się na niej nie wyłożyć, skoro jest konieczna tak jak mówisz.

Nie pisałem, że aktualizacja jest niezbędna.
Chodziło o uporządkowanie wersji bibliotek by wszystkie były z Jessie albo Stretcha, a nie wszystko wymieszane - obecny stan.

Offline

 

#22 2017-10-24 21:17:05

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

yossarian napisał(-a):

pltvgz20 napisał(-a):

Przepraszam za zwłokę w odpowiedzi, ale też trochę badałem temat aktualizacji, żeby się na niej nie wyłożyć, skoro jest konieczna tak jak mówisz.

Nie pisałem, że aktualizacja jest niezbędna.
Chodziło o uporządkowanie wersji bibliotek by wszystkie były z Jessie albo Stretcha, a nie wszystko wymieszane - obecny stan.

A przepraszam - źle zrozumiałem, wybacz. :) A podpowiedz mi proszę - z czym jest więcej roboty, jak się nie wie, jak się zabrać do porządkowania wersji bibliotek - zrobić aktualizację systemu (z Jessie do Stretcha) i ewentualnie potem wsteczną (ze Stretcha do Jessie), gdyby mi sterownik ten, co mam do SISa do grafiki nie chciał chodzić, czy porządkować biblioteki?

Offline

 

#23 2017-10-24 21:47:41

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Drukarka Brother HL-2035 sterownik nie działa

Repozytoria chyba umiesz ustawić na wersję oldstable?
Potem coś w tym stylu:

Kod:

Package: *
Pin: release o=Debian,a=oldstable
Pin-Priority: 1001

I aktualizacja systemu (dist-upgrade)

Tylko najpierw zrób symulację i wklej na forum to co wypluje menedżer pakietów.
A i jeszcze wyłącz wszystkie nieoficjalne repozytoria.

Offline

 

#24 2017-10-24 21:56:15

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

yossarian napisał(-a):

Repozytoria chyba umiesz ustawić na wersję oldstable?
Potem coś w tym stylu:

Kod:

Package: *
Pin: release o=Debian,a=oldstable
Pin-Priority: 1001

I aktualizacja systemu (dist-upgrade)

Tylko najpierw zrób symulację i wklej na forum to co wypluje menedżer pakietów.
A i jeszcze wyłącz wszystkie nieoficjalne repozytoria.

To co wkleiłeś, to tak jak piszą tu: https://pl.wikibooks.org/wiki/Debian_-_uniwersalna_ … a-.3E_Testowa mam umieścić w: "/etc/apt/preferences"? W repozytoriach to wystarczy zmieniać jedynie wyraz "stable" na "oldstable", dobrze myślę nie? Zobacz też proszę na ten wątek https://forum.dug.net.pl/viewtopic.php?id=30002, co założyłem z pytaniem "w drugą stronę" (aktualizacja z Jessie do Stretcha), czy jakieś rzeczy mogą mi narobić kłopotu z tych wymienionych przeze mnie. Z góry dzięki. :)

Ostatnio edytowany przez pltvgz20 (2017-10-24 21:58:18)

Offline

 

#25 2017-10-27 20:22:53

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Drukarka Brother HL-2035 sterownik nie działa

Zasada jest generalnie taka sama — ustawienie priorytetu powyżej 1000 oznacza instalację pakietu nawet wtedy, gdy wymaga to jego cofnięcia

Priorytety obecnie ustawia się w plikach konfiguracyjnych znajdujących się w /etc/apt/preferences.d/, ale /etc/apt/preferences też będzie ok (szczególnie, że starsza wersja Debiana).

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Nas ludzie lubią po prostu, a nie klikając w przyciski ;-)