Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2017-08-11 19:38:54

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

apt-get install xfce4 zwraca błąd

Po dłuższej nieobecności przepraszając zarazem za nią, chciałem powiedzieć cześć wszystkim. :)

Zaś co do problemu, to jak w temacie...

Kod:

apt-get install xfce4

zwraca błąd:

Kod:

Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 xfce4 : Wymaga: xfdesktop4 (>= 4.10.0) ale nie zostanie zainstalowany
         Wymaga: thunar (>= 1.6.0) ale nie zostanie zainstalowany
         Poleca: thunar-volman (>= 0.8.0) ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.

Co czuje mój nos... ;p Mam wciąż Debiana Jessie (8). Nie aktualizowałem go, bo boję się, co się stanie. ;p W "sources.list" miałem repozytoria z wpisem "stable" i pewnie w międzyczasie, kiedy Jessie przestawało być "stable", a zaczynało być "oldstable" coś instalowałem, czego chyba robić nie można z takim wpisem, skoro Jessie już wtedy nie było wersją stabilną tylko "oldstable". Potem te wpisy ze słowem "stable" w sources.list zmieniłem podmieniając słowo "stable" na "jessie" i zrobiłem:

Kod:

apt-get update

I nic to nie dało. Doczytałem, że wpisy dla "oldstable" mają inną formę niż sobie wymyśliłem, więc wstawiłem nowe, chyba poprawne i zrobiłem:

Kod:

apt-get update && apt-get upgrade

i dalej to samo... Tak coś mi świta, że ten błąd już mi wyskakiwał wcześniej przy instalacji innych pakietów. Może też podpowiedzią w sprawie jest fakt, że ostatnio Xfce mi się zaczęło sypać, bo poirytowany tym, że z Orage nie umiałem usunąć załadowanego przez siebie pliku kalendarza postanowiłem zrealizować pomysł:

Kod:

apt-get remove orage

co chyba skończyło się "sypaniem się" całego Xfce - nie działał mikser dźwięku między innymi, zmienił się wygląd Xfce. Zrobiłem więc:

Kod:

apt-get remove  --purge xfce4*

zgodnie z poradą z https://forum.dug.net.pl/viewtopic.php?id=26252 - dzięki czemu Xfce usunąłem, ale już zainstalować nie mogłem bo wyskakiwał ten właśnie powyższy błąd. Natomiast mimo tego błędu udało mi się bez żadnego problemu zainstalować LXDE, z którego właśnie piszę w tej chwili. :) Uratujcie proszę, bom biedny i bez pomysłów już. :)

Z góry dzięki. :)

Ostatnio edytowany przez pltvgz20 (2017-08-11 19:41:00)

Offline

 

#2 2017-08-11 21:51:58

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: apt-get install xfce4 zwraca błąd

Nie masz się czego obawiać, Debian Stretch chodzi bardzo grzecznie.
Przy okazji apt-get i aptitude już są zabytkami, używa się w nim samego

Kod:

apt

Poza tym prawdopodobnie już masz pomieszanego Jessie i Stretcha, stąd takie cyrki.

Pokaż może wyniki:

Kod:

cat /etc/apt/sources.list

Kod:

cat /etc/apt/sources.list.d/*

Kod:

cat /etc/apt/apt.conf

Ostatnio edytowany przez Jacekalex (2017-08-11 21:54:03)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#3 2017-08-11 23:02:45

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: apt-get install xfce4 zwraca błąd

Jacekalex napisał(-a):

Nie masz się czego obawiać, Debian Stretch chodzi bardzo grzecznie.
Przy okazji apt-get i aptitude już są zabytkami, używa się w nim samego

Kod:

apt

Ale w jakim sensie zabytki i co to znaczy, że używa się samego "apt", bo ja nie gniewaj się ale dość nieogarnięty jeszcze jestem w temacie Linuxa? ;p

Poza tym prawdopodobnie już masz pomieszanego Jessie i Stretcha, stąd takie cyrki.

Pokaż może wyniki:

Kod:

cat /etc/apt/sources.list

Kod:

cat /etc/apt/sources.list.d/*

Kod:

cat /etc/apt/apt.conf

A oto wyniki:

Kod:

cat /etc/apt/sources.list

zwraca:

Kod:

## podstawowe repozytorium
deb http://ftp.pl.debian.org/debian/ oldstable main contrib non-free

## uaktualnienia bezpieczeństwa
deb http://security.debian.org/ oldstable/updates main contrib non-free

## często uaktualniane pakiety, np. dotyczące
## filtrowania spamu czy skanowania antywirusowego
deb http://ftp.pl.debian.org/debian oldstable-updates main contrib non-free

i to już po tych zmianach, jak wtedy zmieniłem repozytoria ze "stable" na "oldstable", jak się "poedukowałem".

Dalej...

Kod:

root@debian:/home/abc# cat /etc/apt/sources.list.d/*

zwróciło:

Kod:

### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
# This file makes sure that Opera Browser is kept up-to-date
# as part of regular system upgrades

deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
deb [arch=amd64] https://repo.skype.com/deb stable main

I tu przyznam nic "nie czyściłem", bo jedynie mi istnienie tego katalogu się obiło o uszy, ale mój umysł nie dotarł do tego, czym on jest i po co on jest. ;p Teraz widzę, że Chrome, Opera i Skype mają tu jakieś pliki ".list" czyli swoje repozytoria jak rozumiem.

I

Kod:

cat /etc/apt/apt.conf

zwraca:

Kod:

cat: /etc/apt/apt.conf: Nie ma takiego pliku ani katalogu

a w /etc/apt jest tylko katalog "apt.conf.d", z rzeczy zawierających "apt", jeśli o to chodziło. :)

Ostatnio edytowany przez pltvgz20 (2017-08-11 23:07:27)

Offline

 

#4 2017-08-11 23:20:24

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: apt-get install xfce4 zwraca błąd

Kod:

apt

jest nowym programem, bardzo szybkim w działaniu, i łączącym najważniejsze zalety poprzedników.


Kod:

 cat  /etc/apt/apt.conf

Tu masz przykład apt.conf do stable:

Kod:

APT::Default-Release "stable";

APT::Get::Install-Recommends "false";
APT::Get::Install-Suggests "false";

Apt::Get::Purge;

Acquire::PDiffs "true";

Jeśli chcesz koniecznie siedzieć na jessie, to zmień:

Kod:

APT::Default-Release "stable";

na:

Kod:

APT::Default-Release "jessie";

Taki konfig moim zdaniem jest optymalny, pomaga zrobić porządek z priorytetami paczek w przypadku używania repozytoriów z różnych wydań czy pomieszania paczek przy przypadkowej aktualizacji.

I nie masz się czego bać w stabilnym wydaniu, nie gryzie, a ma aktualnie najlepsze wsparcie Developerów.

Zainstaluj sobie też dla pewności pakiet:

Kod:

apt-listbugs

żeby ostrzegał przed potencjalnymi kłopotami podczas instalacji/aktualizacji.

Pozdro

Ostatnio edytowany przez Jacekalex (2017-08-11 23:32:20)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#5 2017-08-12 00:05:06

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: apt-get install xfce4 zwraca błąd

Nie upieram się oczywiście przy byciu na jessie, wręcz wolałbym przejść na stretch, bo w sumie po co być "na starym" jak można być "na nowym", ale miałem meksykańskie problemy ze sterownikiem grafiki, bo mam SISa i jego producent "kocha" Linuksa, na skutek czego nie ma do niego oficjalnych sterowników, co oznaczało lekką delikatnie mówiąc gimnastykę no i jeszcze pozostają problemy jakiś tam zakładek z przeglądarek i innych tego typu plików, które wypadałoby zabezpieczyć przed aktualizacją. No i jeszcze te 50 ostrzeżeń co się może stać podczas aktualizacji z 8 na 9, więc dlatego tak zwlekam i zwlekam.

A co do tego co poradziłeś... Utworzyłem w /etc/apt plik "apt.conf" z treścią, którą podałeś, zamiast "stable" wpisując "jessie" i zainstalowałem apt-listbugs. Niestety znowu jak próbuje instalować Xfce wyskakuje ten sam błąd. :(

Właśnie przed chwilą udało mi się zainstalować Xfce. Prawdopodobnie pomogło wpisanie wcześniej:

Kod:

apt-get autoremove

Będę dalej obserwował, czy przy instalowaniu innych rzeczy nie wyskakują błędy. :)

Instalowałem dzisiaj kilka pakietów i problemów nie było. Repozytoria są ustawione cały czas na "oldstable" i wszystko działa podczas instalacji, więc to pewnie było spowodowane tym nierobieniem "apt-get autoremove". Jeżeli to było przyczyną, to szkoda, że terminal "apt-get autoremove" nie sugeruje wtedy, kiedy wywala ten błąd, który był powodem tego wpisu, tylko trzeba podjąć próbę instalacji czegoś innego i dopiero wtedy to wyskakuje. W szczególności, że w przypadku innych "usterek" terminal często sugeruje, co zrobić...

Ostatnio edytowany przez pltvgz20 (2017-08-12 23:34:52)

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
To nie jest tylko forum, to nasza mała ojczyzna ;-)