Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2013-09-02 21:01:02

compix
Użytkownik
Zarejestrowany: 2012-05-25

XFCE `nie trzymanie` ustawień pulpitu

Witam,

zauważyłem że po włączeniu laptopa/zrestartowaniu systemu ikony na pulpicie są ułożone po kolei, czyli rozmieszczenie ikon jest inne niż sam ustawiłem. Pracuje na pulpicie i jest to bardzo uciążliwe, a nie chce mi się przemieszczać ikon z każdy uruchomieniem komputera.

OS: Debian testing i686
  Kernel: 3.9-1-686-pae

środowisko XFCE

Dzięki z góry za pomoc!


' jeden człowiek przed klawiaturą budzi większy respect niż zawodowa armia`

Offline

 

#2 2013-09-05 14:33:18

remi
amputować akrobatów
Zarejestrowany: 2011-05-27

Re: XFCE `nie trzymanie` ustawień pulpitu

Cześć Compix. Ja również korzystam ze środowiska Xfce. Jedyną rzeczą jaka przychodzi mi do głowy w tym momencie, to opcja Zapisanie sesji przed wylogowaniem, dostępna via menu ==> wyloguj. Sprawdź, czy jest zaznaczona. Dodatkowo możesz sprawdzić pliki konfiguracyjne mieszczące się w ~/.config/xfce4/desktop/icons*. Więcej informacji znajdziesz tu: Desktop icons on Xfce. Użytkownik pyta "I'm wondering if is there any way to have a functionality like in KDE: I can set icons to be "locked", so they will not change of location".

Pozdrawiam serdecznie.


Łam ZAsady! wYjąTkÓw jest wIęcej.

Offline

 

#3 2013-09-05 14:37:38

compix
Użytkownik
Zarejestrowany: 2012-05-25

Re: XFCE `nie trzymanie` ustawień pulpitu

Witaj remi. Dzięki za odpowiedź i pomoc, zerknę i poczytam. Zobaczę co da się z tym zrobić. Szukam również rozwiązania problemu na zagranicznych forach.

Pozdrawiam!


' jeden człowiek przed klawiaturą budzi większy respect niż zawodowa armia`

Offline

 

#4 2013-09-05 18:45:38

remi
amputować akrobatów
Zarejestrowany: 2011-05-27

Re: XFCE `nie trzymanie` ustawień pulpitu

Serwus. W takim razie powodzenia. Słuchaj Compix, może warto poszukać na oficjalnej stronie projektu? Wiesz, sprawdzę jeszcze u siebie, czy Xfce zapamięta położenie ikon na pulpicie, po zmianie ich lokacji i restarcie systemu.

Również pozdrawiam.

EDYCJA: (swoje spostrzeżenia przedstawiam jeszcze w tym poście, ponieważ nie dodano nowej wiadomości). A więc tak; po zmianie domyślnego położenia trzech ikon tj. Katalog użytkownika, System plików oraz Kosz na - powiedzmy - przypadkowe, losowe np. umiejscowienie ikon w centralnym punkcie lub przeniesienie na przeciwną stronę pulpitu, cokolwiek - wprowadzone zmiany zostały zapamiętane, zarówno po ponownym uruchomieniu systemu oraz zwykłym przelogowaniu się użytkownika. Zaznaczam, że opisane działanie odniosło skutek, kiedy opcja 'Zapisanie sesji przed wylogowaniem' (Ustawienia ==> Sesja i uruchamianie ==> zakładka Ogólne) o której wspominałem, była aktywna/zaznaczona.

Ostatnio edytowany przez remi (2013-09-06 18:13:46)


Łam ZAsady! wYjąTkÓw jest wIęcej.

Offline

 

#5 2013-09-07 00:06:05

compix
Użytkownik
Zarejestrowany: 2012-05-25

Re: XFCE `nie trzymanie` ustawień pulpitu

Póki co walczę z tym. `zapisanie sesji przed wylogowaniem` oczywiście jest włączone. Jak problem rozwiążę problem, dam znać jak mi się udało. W wolnej większej chwili zobaczę co tam na stronie projektu.


' jeden człowiek przed klawiaturą budzi większy respect niż zawodowa armia`

Offline

 

#6 2013-09-07 13:41:15

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: XFCE `nie trzymanie` ustawień pulpitu

Sprawdzałeś na koncie nowego użytkownika?

Offline

 

#7 2013-09-07 13:44:26

compix
Użytkownik
Zarejestrowany: 2012-05-25

Re: XFCE `nie trzymanie` ustawień pulpitu

Nie sprawdzałem, aczkolwiek w XFCE zaczynało mnie czasem irytować, i z polecenia zainstalowałem MATE, z które aktualnie jestem bardzo zdowolony. XFCE zostawiam by sprawdzić co go boli, między innymi z konta innego użytkownika. W wolnej chwili przysiądę nad tym i zdam relacje


' jeden człowiek przed klawiaturą budzi większy respect niż zawodowa armia`

Offline

 

#8 2013-09-07 20:46:08

remi
amputować akrobatów
Zarejestrowany: 2011-05-27

Re: XFCE `nie trzymanie` ustawień pulpitu

Witam serdecznie. Compix mała prośba do Ciebie — gdyby kiedyś udało Ci się rozwiązać, tudzież poznać przyczynę ewentualnego braku rozwiązania, dlaczego Xfce nie potrafi zapamiętać położenia ikon etc, napisz o tym. Oczywiście jeżeli nie zapomnisz. I tak przy okazji: być może jeszcze lepszym tropem od przeglądania oficjalnej strony projektu, jest zadanie pytania za pomocą listy mailingowej np. Xfce4-dev lub Xfce-bugs? Subskrybcja jest doprawdy prosta: mail.xfce.org. Yossarian podsunąłeś równie dobry pomysł, aby sprawdzić w/w problem na koncie nowego użytkownika. Ja zupełnie o tym zapomniałem.

Compix w takim razie przyjemnego i przede wszystkim bezproblemowego korzystania ze środowiska MATE.

Pozdrawiam.


Łam ZAsady! wYjąTkÓw jest wIęcej.

Offline

 

#9 2013-09-07 22:37:36

compix
Użytkownik
Zarejestrowany: 2012-05-25

Re: XFCE `nie trzymanie` ustawień pulpitu

Jasne! Na pewno napiszę, i pamiętać będę. Problem będę rozwiązywał od razu jak znajdę chwilkę czasu tylko po to by zaspokoić swoją ciekawość i by na przyszłość mieli inni:)

lista mailigowa też jest dobrym pomysłem, myślę że wszystko spróbuję i zobaczymy.

Pozdrawiam, i życzę miłego weekendu!


' jeden człowiek przed klawiaturą budzi większy respect niż zawodowa armia`

Offline

 

#10 2015-01-17 00:42:25

iromarek
Nowy użytkownik
Skąd: Szczecin
Zarejestrowany: 2009-05-07

Re: XFCE `nie trzymanie` ustawień pulpitu

Podziękowania dla użytkownika "remi"
       Po krótkim przeszukaniu googla trafiłem na ten wątek szukając odpowiedzi na zadana kwestię i otóż problem miałem podobny z tym zapamiętaniem położenia ikon na moim XFCE. Zmyłkę miałem taką, że przy wylogowaniu czy wyłączaniu kompa w oknie "Kończenie sesji użytkownika /nazwa_użytkownika/" checkbox zapamiętanie sesji, był zaznaczony a ikony i tak wracały na domyślne miejsce :( . Po zastosowaniu się do rady w poście #4 użytkownika remi

Zaznaczam, że opisane działanie odniosło skutek, kiedy opcja 'Zapisanie sesji przed wylogowaniem' (Ustawienia ==> Sesja i uruchamianie ==> zakładka Ogólne) o której wspominałem, była aktywna/zaznaczona

checkbox w oknie "Kończenie sesji użytkownika /nazwa_użytkownika/" zniknął a w ślad za tym ikony zaczęły pojawiać się tam gdzie je ustawiłem. Rozwiązanie jak zwykle okazało się proste ale jakoś nie wpadło mi do głowy zajrzeć do Sesja i uruchamianie :D .


Manjaro 0.8.11 "Ascella" Xfce 4.10... 'because it works'.   LRU #462667

Offline

 

#11 2015-01-18 11:00:57

remi
amputować akrobatów
Zarejestrowany: 2011-05-27

Re: XFCE `nie trzymanie` ustawień pulpitu

Serwus iromarek. Super, że udało Ci się rozwiązać problem z przemieszczaniem ikon. Masz również rację pisząc, że: "(...) Rozwiązanie jak zwykle okazało się proste". Tak to już bywa, ale najważniejsze, że wszystko się wyjaśniło, prawda? :- )

Tak przy okazji — mógłbyś pokrótce napisać na jakim sprzęcie, tj. ilość pamięci RAM, karta graficzna, procesor etc., zainstalowałeś Manjaro?

Pozdrawiam serdecznie.


Łam ZAsady! wYjąTkÓw jest wIęcej.

Offline

 

#12 2015-04-21 22:48:43

NieGooglujMnie
Użytkownik
Zarejestrowany: 2015-04-21

Re: XFCE `nie trzymanie` ustawień pulpitu

blokowanie ikon w XFCE:

Kod:

sudo chattr +i ~/.config/xfce4/desktop/icons*

odblokowanie ikon:

Kod:

sudo chattr -i ~/.config/xfce4/desktop/icons*

Robisz tak:
1. odblokowujesz
2. ustawiasz jak chcesz
3. blokujesz z powrotem

najlepiej podpiąć sobie te komendy do klawiszy na klawiaturze.


W domu: 2x Debian Sid (laptopy), jeden zainstalowany w dniu 23.04.2016, a drugi w maju 2016. Raspbian na rpi3. W pracy: RHEL, CentOS.

Offline

 

#13 2017-04-15 10:50:26

Bobislaw
Nowy użytkownik
Zarejestrowany: 2017-04-15

Re: XFCE `nie trzymanie` ustawień pulpitu

NieGooglujMnie napisał(-a):

blokowanie ikon w XFCE:

Kod:

sudo chattr +i ~/.config/xfce4/desktop/icons*

odblokowanie ikon:

Kod:

sudo chattr -i ~/.config/xfce4/desktop/icons*

Robisz tak:
1. odblokowujesz
2. ustawiasz jak chcesz
3. blokujesz z powrotem

najlepiej podpiąć sobie te komendy do klawiszy na klawiaturze.

Dzieki za to rozwiazanie - moze nie jest zbyt piekne ale SKUTECZNE, a to jest najwazniejsze
Minelo juz kilka lat od pierwszego wpisu, a problem szalajacych ikon w xfce pozostal !

thx


LinuxMint 17.3 x64 xfce

Offline

 

#14 2017-04-16 13:25:35

remi
amputować akrobatów
Zarejestrowany: 2011-05-27

Re: XFCE `nie trzymanie` ustawień pulpitu

Witam serdecznie. Rozwiązanie z wykorzystaniem polecenia chattr(1) jest także wspomniane w odnośniku Desktop icons on Xfce, który znajduje się w poście #2. Natomiast, sposób ze skrótami klawiszy etc., opisany został w tym miejscu: Backup/restore XFCE desktop icons. Sposób równie ciekawy, a przy tym niewymagający korzystania z sudo(8) oraz chattr(1).

Pozdrawiam serdecznie.

EDYCJA: stylistyka etc.

Ostatnio edytowany przez remi (2017-04-16 13:27:46)


Łam ZAsady! wYjąTkÓw jest wIęcej.

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Nas ludzie lubią po prostu, a nie klikając w przyciski ;-)