Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2016-01-19 14:30:05

skullman
Użytkownik
Zarejestrowany: 2010-04-08

[solved] Ładowanie modułu it87

Mam problem z tym modułem, poprzednio nie ładował się nawet z palca ale znalazłem, że należy dodać mu takie coś

Kod:

it87 force_id=0x8728

i o ile przy montowaniu z palca działa to już dodanie tego do pliku konfiguracyjnego nie koniecznie. Dodanie wpisu do

Kod:

/etc/modules

albo do

Kod:

/etc/modules-load.d/modules.conf

powoduje wyplucie podczas startu systemu błąd ładowania modułu. Ludzie napisałi w wątku którym się sugerowałem, że u nich zadziałało a u mnie niestety nie chce.

Ostatnio edytowany przez skullman (2016-01-19 17:16:18)

Offline

 

#2 2016-01-19 14:58:58

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: [solved] Ładowanie modułu it87

Zrób plik /etc/modprobe.d/it87.conf:

options it87 force_id=0x8728

Offline

 

#3 2016-01-19 15:22:18

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Re: [solved] Ładowanie modułu it87

Niestety, też nie działa, nie pisałem o tym w pierwszym poście ale już to robiłem wcześniej, później usunąłem ten plik i teraz zrobiłem to jeszcze raz ale znowu ten sam błąd.

Offline

 

#4 2016-01-19 15:25:51

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: [solved] Ładowanie modułu it87

A w tym komunikacie błędu jest jakaś treść?
I gdzie w końcu te parametry dopisujesz?

Offline

 

#5 2016-01-19 16:13:50

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Re: [solved] Ładowanie modułu it87

A w tym komunikacie  to mi wywala takie oto cudo:

Kod:

Starting Load Kernel Modules...
[FAILED] Failed to start Load Kernel Modules.
See 'systemctl status system-modules-load.service' for details.

więc ja tak robię i dostaję coś takiego

Kod:

# systemctl status system-modules-load.service
● system-modules-load.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)

Chyba jasno napisałeś, gdzie to ma być, w necie też to już widziałem dlatego mnie dziwi, że nie działa.

Ostatnio edytowany przez skullman (2016-01-19 16:18:37)

Offline

 

#6 2016-01-19 16:22:19

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: [solved] Ładowanie modułu it87

Tam nie masz literówki?
Powinno być  systemd-modules-load:

Kod:

systemctl status systemd-modules-load
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; vendor preset: enabled)
   Active: active (exited) since Tue 2016-01-19 09:10:01 GMT; 6h ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 194 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=0/SUCCESS)
 Main PID: 194 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 512)
   CGroup: /system.slice/systemd-modules-load.service

Pytałem bo parametry modułów dopisuje się w /etc/modules-load.d/*.conf a nie w /etc/modules.

Spróbuj wykonać ręcznie:

Kod:

/lib/systemd/systemd-modules-load

Offline

 

#7 2016-01-19 16:32:26

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Re: [solved] Ładowanie modułu it87

O, widzisz, pomogło

Kod:

# systemctl status systemd-modules-load.service -l
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; vendor preset: enabled)                                                        
   Active: failed (Result: exit-code) since wto 2016-01-19 16:04:30 CET; 26min ago                                                                          
     Docs: man:systemd-modules-load.service(8)                                                                                                              
           man:modules-load.d(5)                                                                                                                            
  Process: 624 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)                                                                  
 Main PID: 624 (code=exited, status=1/FAILURE)                                                                                                              
                                                                                                                                                            
sty 19 16:04:30 debian-ss systemd[1]: Starting Load Kernel Modules...                                                                                       
sty 19 16:04:30 debian-ss systemd-modules-load[624]: libkmod: ERROR ../libkmod/libkmod-config.c:635 kmod_config_parse: /etc/modprobe.d/it87.conf line 1: ignoring bad line starting with 'it87'                                                                                                                         
sty 19 16:04:30 debian-ss systemd-modules-load[624]: Failed to find module 'it87 force_id=0x8728'
sty 19 16:04:30 debian-ss systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
sty 19 16:04:30 debian-ss systemd[1]: Failed to start Load Kernel Modules.
sty 19 16:04:30 debian-ss systemd[1]: systemd-modules-load.service: Unit entered failed state.
sty 19 16:04:30 debian-ss systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.

Offline

 

#8 2016-01-19 16:34:49

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: [solved] Ładowanie modułu it87

Kod:

cat /etc/modprobe.d/it87.conf

Offline

 

#9 2016-01-19 16:40:29

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Re: [solved] Ładowanie modułu it87

Wiem, ale to na próbę było, już poprawione:

Kod:

# systemctl status systemd-modules-load.service -l
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; vendor preset: enabled)
   Active: failed (Result: exit-code) since wto 2016-01-19 16:37:39 CET; 30s ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 487 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 487 (code=exited, status=1/FAILURE)

sty 19 16:37:39 debian-ss systemd[1]: Starting Load Kernel Modules...
sty 19 16:37:39 debian-ss systemd-modules-load[487]: Failed to find module 'it87 force_id=0x8728'
sty 19 16:37:39 debian-ss systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
sty 19 16:37:39 debian-ss systemd[1]: Failed to start Load Kernel Modules.
sty 19 16:37:39 debian-ss systemd[1]: systemd-modules-load.service: Unit entered failed state.
sty 19 16:37:39 debian-ss systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.

Kod:

# cat /etc/modprobe.d/it87.conf 
 options it87 force_id=0x8728

Offline

 

#10 2016-01-19 16:43:54

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: [solved] Ładowanie modułu it87

Nic zostały żadne śmieci w /etc/modules lub /etc/modules-load.d/modules.conf?

Offline

 

#11 2016-01-19 17:07:12

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Re: [solved] Ładowanie modułu it87

A widzisz, miałeś rację, zostały ale już posprzątałem:

Kod:

# cat /etc/modules
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.


# Generated by sensors-detect on Sun Jan 10 22:35:23 2016
# Chip drivers

Kod:

# cat /etc/modules-load.d/modules.conf 
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.


# Generated by sensors-detect on Sun Jan 10 22:35:23 2016
# Chip drivers

system wstaje bez błędów, wszystko wydaje się być OK:

Kod:

# systemctl status systemd-modules-load.service -l
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; vendor preset: enabled)
   Active: active (exited) since wto 2016-01-19 16:59:32 CET; 44s ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 190 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=0/SUCCESS)
 Main PID: 190 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/systemd-modules-load.service

Jest tylko jeden mały szkopuł, moduł nie działa. Ładuję go ręcznie i zaczyna śmigać. Przynajmniej posprzątałem w systemie.

Offline

 

#12 2016-01-19 17:11:00

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: [solved] Ładowanie modułu it87

No bo go nie ładujesz ze startem, dodaj sobie nazwę tego modułu do /etc/modules , samą nazwę, bez żadnych opcji.

Tak by uprzedzić kolejne pytania. Ten plik /etc/modules i katalog /etc/modules-load.d/ odpowiadają za ładowanie modułów na starcie systemu. Wszelkie opcje dla tych modułów określa się w plikach w katalogu /etc/modprobe.d/ . Ty potrzebujesz załadować moduł na starcie i dodatkowo jeszcze opcje, zatem dwie rzeczy musisz tutaj ustawić.

Ostatnio edytowany przez morfik (2016-01-19 17:16:07)


Morfitronik — blog o linux'ach, głównie Debian, OpenWRT/LEDE i Android

Offline

 

#13 2016-01-19 17:15:45

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Re: [solved] Ładowanie modułu it87

O widzisz, działa jak natura chciała. Dzięki panowie i sorki za zmarnowany wasz czas.

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
To nie jest tylko forum, to nasza mała ojczyzna ;-)