Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2013-07-10 20:13:45

atare
Użytkownik
Skąd: Śląsk, okolice Katowic
Zarejestrowany: 2011-03-08

Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Witam wszystkich. Kiedy instalowalem dzisiaj swiezy system Debian stable mialem polskie znaki podczas instalacji. Teraz znakow polskich nie mam wciskajac alt. Mam klawiature 105 klawiszy bezprzewodowa razem z myszka. Zainstalowalem zarowno LXDE jak tez XFCE.

Ostatnio edytowany przez atare (2013-07-10 20:16:48)

Offline

 

#2 2013-07-10 20:21:09

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Kod:

setxkbmap pl

Pomaga?


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#3 2013-07-10 20:28:02

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

A pod tty masz polskie znaki?

Spróbuj

Kod:

dpkg-reconfigure keyboard-configuration

i pokaż:

Kod:

setxkbmap -print -verbose 10

Morfitronik — blog o linux'ach, głównie Debian, OpenWRT/LEDE i Android

Offline

 

#4 2013-07-10 20:28:15

atare
Użytkownik
Skąd: Śląsk, okolice Katowic
Zarejestrowany: 2011-03-08

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Faktycznie pomogło, a co zrobić aby było na stałe?

Offline

 

#5 2013-07-10 20:31:00

atare
Użytkownik
Skąd: Śląsk, okolice Katowic
Zarejestrowany: 2011-03-08

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     pl
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+pl+inet(evdev)
geometry:   pc(pc105)
xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)"    };
    xkb_types     { include "complete"    };
    xkb_compat    { include "complete"    };
    xkb_symbols   { include "pc+pl+inet(evdev)"    };
    xkb_geometry  { include "pc(pc105)"    };
};

Zaraz się wyloguję i sprawdzę czy będę miał polskie znaki

Offline

 

#6 2013-07-10 20:36:17

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

atare napisał(-a):

Faktycznie pomogło, a co zrobić aby było na stałe?

Kod:

echo "setxkbmap pl" >>~/.xinitrc

Powinno pomóc.

Można też w programach startowych, w Xfce jest coś takiego w ustawieniach.


Albo poczytaj tutaj:

Kod:

Tworzymy katalog /etc/X11/xorg.conf.d a w nim nastepujace pliki konfiguracyjne
keyboard.conf z polska mapa klawiatury:

http://forums.gentoo.org/viewtopic-t-922308.html

Pozdro
;-)

Ostatnio edytowany przez Jacekalex (2013-07-10 20:37:44)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#7 2013-07-10 20:36:21

atare
Użytkownik
Skąd: Śląsk, okolice Katowic
Zarejestrowany: 2011-03-08

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

No i po ponownym uruchomieniu kompa polskich znakow nie ma znowu a zrobilem rekonfiguracje klawiatury. Mam tez pytanie jaki programik teraz zastepuje gdm bo nie chce sie za kazdym razem logowac jako uzytkownik a we wczesniejszym Debianie jak zrobilem automat w gdm to mi starowal LXDE bez logowania.

ta komenda echo "setxkbmap pl" >>~/.xinitrc nie pomogla

Wklejam samo setxkbmap pl i mam polskie znaki

Nie jestem taki zaawansowany aby grzebać w ustawieniach konfiguracyjnych

Ostatnio edytowany przez atare (2013-07-10 20:40:47)

Offline

 

#8 2013-07-10 20:54:24

dhg
Amiga User
Skąd: podlasie / bielsk-podlaski
Zarejestrowany: 2010-09-24

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Otwórz dowolnym edytorem ~/.xinitrc i dopisz ręcznie

Kod:

setxkbmap pl &

Tylko amigowiec potrafi generować fractale w czasie rzeczywistym używając do obliczeń wyłącznie żołądka

http://th06.deviantart.net/fs8/200H/i/2005/353/1/a/Fluxbox_User___User_Bar_by_The_pGo.jpg

Offline

 

#9 2013-07-10 21:02:51

atare
Użytkownik
Skąd: Śląsk, okolice Katowic
Zarejestrowany: 2011-03-08

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Zrobilem tak jak pisales, ale juz bylo raz dopisane tam recznie jednak nadal brak polskich znakow.

Ostatnio edytowany przez atare (2013-07-10 21:03:35)

Offline

 

#10 2013-07-10 21:05:51

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

atare -- to polecenie:

Kod:

setxkbmap -print -verbose 10

wydawałeś jak miałeś polskie znaki?

Spróbuj jeszcze:

Kod:

dpkg-reconfigure locales

i wybierz mu tam język pl.


Morfitronik — blog o linux'ach, głównie Debian, OpenWRT/LEDE i Android

Offline

 

#11 2013-07-10 21:06:43

atare
Użytkownik
Skąd: Śląsk, okolice Katowic
Zarejestrowany: 2011-03-08

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Napiszcie czym mam zastąpić gdm aby nie musieć się jako użytkownik logować. Polecenie wpisane w terminalu: setxkbmap pl działa i jak nie macie jakiegoś pomysłu będę je zawsze musiał wpisywać w terminalu na początku użytkowania kompa. Robiłem upgrade na pendrivie z porzedniej wersji Debiana na obecną stable i się wysypało. Coś ten Debian niby stabilny jednak ostro szwankuje. Co myślicie o Lubuntu?

Teraz mam polskie znaki i taki mam screen
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     pl
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+pl+inet(evdev)
geometry:   pc(pc105)
xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)"    };
    xkb_types     { include "complete"    };
    xkb_compat    { include "complete"    };
    xkb_symbols   { include "pc+pl+inet(evdev)"    };
    xkb_geometry  { include "pc(pc105)"    };
};

Co do locales mam wygenerowane wcześniej:
pl_PL.UTF-8 UTF-8

Ostatnio edytowany przez atare (2013-07-10 21:09:40)

Offline

 

#12 2013-07-10 21:11:01

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Wydaj to polecenie gdy nie masz polskich znaków. xD


Morfitronik — blog o linux'ach, głównie Debian, OpenWRT/LEDE i Android

Offline

 

#13 2013-07-10 21:15:03

atare
Użytkownik
Skąd: Śląsk, okolice Katowic
Zarejestrowany: 2011-03-08

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Nie mam teraz polskich znakow:

Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     pl
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+pl+inet(evdev)
geometry:   pc(pc105)
xkb_keymap {
    xkb_keycodes  { include "evdev+aliases(qwerty)"    };
    xkb_types     { include "complete"    };
    xkb_compat    { include "complete"    };
    xkb_symbols   { include "pc+pl+inet(evdev)"    };
    xkb_geometry  { include "pc(pc105)"    };
};

Offline

 

#14 2013-07-10 21:19:36

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Są takie same -- to dziwne. Według tego powinieneś mieć. :]


Morfitronik — blog o linux'ach, głównie Debian, OpenWRT/LEDE i Android

Offline

 

#15 2013-07-10 21:21:06

atare
Użytkownik
Skąd: Śląsk, okolice Katowic
Zarejestrowany: 2011-03-08

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Niby wszystko ok ale nie jest OK pomozcie i napiszcie o zamienniku GDM.

Offline

 

#16 2013-07-10 21:22:42

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Ja używam lightdm. A jeszcze takie pytanie -- jak wciśniesz ctrl+alt+f1 i tam się zalogujesz to tam masz polskie znaki?


Morfitronik — blog o linux'ach, głównie Debian, OpenWRT/LEDE i Android

Offline

 

#17 2013-07-10 21:27:58

atare
Użytkownik
Skąd: Śląsk, okolice Katowic
Zarejestrowany: 2011-03-08

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Tak wypieprzylo mnie z trybu graficznego ale w terminalu mialem polskie znaki . Mam lightdm ale on nie pozwala na automatyczne logowanie.

Offline

 

#18 2013-07-10 21:30:19

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Tam możesz sobie ustawić, poczytaj opcje.

Daj:

Kod:

cat /etc/default/keyboard

Będzie trzeba napisać plik xorga chyba.

Ostatnio edytowany przez morfik (2013-07-10 21:30:32)


Morfitronik — blog o linux'ach, głównie Debian, OpenWRT/LEDE i Android

Offline

 

#19 2013-07-10 22:10:41

atare
Użytkownik
Skąd: Śląsk, okolice Katowic
Zarejestrowany: 2011-03-08

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Wpisalem i taki mam komunikat:

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="pl"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

Dajcie mi prawdziwego nastepce gdm PROSZE !!!

Ostatnio edytowany przez atare (2013-07-10 22:12:10)

Offline

 

#20 2013-07-10 23:34:24

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

atare napisał(-a):

Mam lightdm ale on nie pozwala na automatyczne logowanie.

Oczywiście, że pozwala.

Offline

 

#21 2013-07-11 00:18:21

marcin'82
Użytkownik
Skąd: Sosnowiec
Zarejestrowany: 2011-10-02

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Może być tak, że to Lightdm miesza i nadpisuje ustawienia systemowe:
http://www.google.pl/search?client=opera&q=debi … annel=suggest .
Zainstaluj slim:

root@debian ~ % apt-cache policy slim
slim:
  Zainstalowana: 1.3.4-2
  Kandydująca:   1.3.4-2
  Tabela wersji:
*** 1.3.4-2 0
        990 http://ftp.pl.debian.org/debian/ testing/main i386 Packages
        800 ftp://ftp.de.debian.org/debian/ sid/main i386 Packages
        100 /var/lib/dpkg/status

Dla porównania:

Kod:

root@debian ~ % locale
LANG=pl_PL.UTF-8
LANGUAGE=
LC_CTYPE="pl_PL.UTF-8"
LC_NUMERIC="pl_PL.UTF-8"
LC_TIME="pl_PL.UTF-8"
LC_COLLATE="pl_PL.UTF-8"
LC_MONETARY="pl_PL.UTF-8"
LC_MESSAGES="pl_PL.UTF-8"
LC_PAPER="pl_PL.UTF-8"
LC_NAME="pl_PL.UTF-8"
LC_ADDRESS="pl_PL.UTF-8"
LC_TELEPHONE="pl_PL.UTF-8"
LC_MEASUREMENT="pl_PL.UTF-8"
LC_IDENTIFICATION="pl_PL.UTF-8"
LC_ALL=

------------------------------------------------

root@debian ~ % cat /etc/default/keyboard
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="pl"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

Odnośnie autlogowania w Slim, ustawiasz dwie opcje w pliku /etc/slim.conf:

Kod:

default_user nazwa
auto_login yes

Ostatnio edytowany przez marcin'82 (2013-07-11 00:19:28)


marcin'82

Offline

 

#22 2013-07-11 07:13:20

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

atare , pokaż jeszcze:

Kod:

cat ~/.dmrc

I zrób sobie plik /etc/X11/xorg.conf.d/10-keyboard.conf :

Kod:

Section "InputClass"
Identifier              "keyboard0"
MatchIsKeyboard         "on"
MatchDevicePath         "/dev/input/event*"
Driver                  "evdev"
Option                  "XkbModel"      "pc105"
Option                  "XkbLayout"     "pl"
EndSection

Morfitronik — blog o linux'ach, głównie Debian, OpenWRT/LEDE i Android

Offline

 

#23 2013-07-11 07:20:48

atare
Użytkownik
Skąd: Śląsk, okolice Katowic
Zarejestrowany: 2011-03-08

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Problem polskich znaków sam się rozwiązał kiedy zainstalowałem gdm3. Doinstalowało mi sporo pakietów ale jest OK. Teraz w gdm3 nadal nie wiem jak graficznie czyli klikalnie ustawić automatyczne logowanie. Z poziomu środowiska LXDE nie mam dostępu do ustawień gdm3. W squeeze to było w gdm bezproblemowe teraz zrobili z tego problem.

Napiszcie też jak zainstalować gnome minime oraz kde minime. Nie chcę sobie śmieci instalować w kompie. Oczywiście proszę o polecenia do wykonania w terminalu.

Używam od lat LXDE a tamte środowiska miałem tylko zainstalowane jako cukierkowe dodatki z których raz jak to mówią na ruski rok korzystałem.

Offline

 

#24 2013-07-11 08:26:16

atare
Użytkownik
Skąd: Śląsk, okolice Katowic
Zarejestrowany: 2011-03-08

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Ten niby stabilny Debian to masakra. Zainstalowałem przed chwilą LibreOffice i pojawia mi się przez chwilę logo a potem programy się nie uruchamiają. Ściągam OpenOffice Apache. Albo system skopałem poleceniami, które w wątku podaliście albo Debian po prostu się skończył i czas przesiąść się na inną dystrybucję.

Offline

 

#25 2013-07-11 08:43:55

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Brak polskich znakow w LXDE, XFCE klawiatura A4tech bezprzewodowa

Może to użyszkodnik się skończył i pora go wymienić na bardziej kompetentnego?

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Nas ludzie lubią po prostu, a nie klikając w przyciski ;-)