Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundacji Dzieciom zdazyć z Pomocą.
Więcej informacji na dug.net.pl/pomagamy/.

#1  2019-01-28 13:06:49

  sebian - Użytkownik

sebian
Użytkownik
Zarejestrowany: 2019-01-28

Po restarcie brak dzwieku debian 9

Witam Was.
Mam problem. Po restarcie nie mam dzwieku, mam Debiana 9 - proszę o pomoc o instrukcje jak moge to naprawić:
dane:

cat /proc/asound/cards
00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21)


dpkg -l | grep alsa
ii  alsa-utils     1.1.3-1    amd64        Utilities for configuring and using ALSA

Offline

 

#2  2019-01-28 13:22:02

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Po restarcie brak dzwieku debian 9


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#3  2019-01-28 15:49:05

  sebian - Użytkownik

sebian
Użytkownik
Zarejestrowany: 2019-01-28

Re: Po restarcie brak dzwieku debian 9

lspci
00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21)

cat /proc/asound/cards
0 [PCH            ]: HDA-Intel - HDA Intel PCH
     HDA Intel PCH at 0xef528000 irq 283

cat /proc/asound/modules
0 snd_hda_intel

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version k4.9.0-8-amd64.

uname -a
Linux debian 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux

dpkg -l | grep alsa
ii  alsa-utils                            1.1.3-1                                     amd64        Utilities for configuring and using ALSA

dpkg -l | grep pulse
ii  gir1.2-cvc-1.0                        3.2.4-4                                     amd64        Introspection data for Cinnamon pulseaudio abstraction
ii  gstreamer1.0-pulseaudio:amd64         1.10.4-1                                    amd64        GStreamer plugin for PulseAudio
ii  libcvc0:amd64                         3.2.4-4                                     amd64        Cinnamon pulseaudio abstraction library
ii  libpulse-mainloop-glib0:amd64         10.0-1+deb9u1                               amd64        PulseAudio client libraries (glib support)
ii  libpulse0:amd64                       10.0-1+deb9u1                               amd64        PulseAudio client libraries
ii  libpulse0:i386                        10.0-1+deb9u1                               i386         PulseAudio client libraries
ii  libpulsedsp:amd64                     10.0-1+deb9u1                               amd64        PulseAudio OSS pre-load library
ii  pulseaudio                            10.0-1+deb9u1                               amd64        PulseAudio sound server
ii  pulseaudio-utils                      10.0-1+deb9u1                               amd64        Command line tools for the PulseAudio sound server

alsamixer sie odpala z terminala.

Offline

 

#4  2019-01-28 16:09:44

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Po restarcie brak dzwieku debian 9

Daj sznurek do wyniku skrypta, który jest opisany we wskazanym wyżej wątku.

Chodzi mi o to dokładnie:

Sposób postępowania.

Ściągamy skrypt.

Kod:

Kod:

wget http://www.alsa-project.org/alsa-info.sh

Odpalamy skrypt

Kod:

Kod:

bash  ~/alsa-info.sh  --with-all

Skrypt wrzuci wszelkie dane na serwer i pokaże nam link pod jakim się znajdują.
Wystarczy link wkleić do postu.

Ostatnio edytowany przez Jacekalex (2019-01-28 16:11:34)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#5  2019-01-28 17:15:22

  sebian - Użytkownik

sebian
Użytkownik
Zarejestrowany: 2019-01-28

Re: Po restarcie brak dzwieku debian 9

Pierwsza komenda cos zrobila a druga

bash  ~/alsa-info.sh  --with-all
bash: /root/alsa-info.sh: Nie ma takiego pliku ani katalogu

utworzylem plik ale nic sie w nim nie zapisało - jak mam to zrobić, bardzo dziekuje za wszelką pomoc.

Offline

 

#6  2019-01-28 17:58:13

  skullman - Użytkownik

skullman
Użytkownik
Zarejestrowany: 2010-04-08

Re: Po restarcie brak dzwieku debian 9

Żeby odpalić ten skrypt to musisz w wierszu poleceń być w folderze, w którym ten skrypt się znajduje. Gdzie go utworzyłeś? Tylda oznacza katalog domowy aktualnego użytkownika więc jeśli wydaleś to polecenie jako root to system szuka w /root.

Offline

 

#7  2019-01-28 20:45:49

  sebian - Użytkownik

sebian
Użytkownik
Zarejestrowany: 2019-01-28

Re: Po restarcie brak dzwieku debian 9

Offline

 

#8  2019-01-28 21:34:10

  sebian - Użytkownik

sebian
Użytkownik
Zarejestrowany: 2019-01-28

Re: Po restarcie brak dzwieku debian 9

po restarcie dzwięk się pojawił, zresetowałem ponownie i znowu nie ma dzwięku - nic nie aktualizowalem i nic nie zmieniałem, dla jasności sytuacji wygenerowałem ponownie plik z alsa-project

http://www.alsa-project.org/db/?f=44d97e89754348e47 … eb702a6ae3df2

Offline

 

#9  2019-01-28 22:00:13

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Po restarcie brak dzwieku debian 9

Sprzęt się w obu wynikach znacząco nie różni.

Przejrzyj ustawienia Pulseaudio w programie pavucontrol.
W obu przypadkach Pulseaudio masz uruchomiony, wiec tam zacznij szukać najpierw.


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#10  2019-01-28 22:07:22

  sebian - Użytkownik

sebian
Użytkownik
Zarejestrowany: 2019-01-28

Re: Po restarcie brak dzwieku debian 9

zauwazylem ze jesli restartuje i loguje sie do windowsa to po restarcie z windowsa dziweku nie ma. Gdy wylacze i wlacze i uruchomie debiana dzwiek jest. Dodam ze podczas uruchamiania - chyba to jest GRUB wyskakuja bledy PCI bus error - nie wiem jak zrobic zrzut ekranu odczas ładowania daemonów w linuxie - moze w tym jest problem??

Offline

 

#11  2019-01-28 22:24:08

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Po restarcie brak dzwieku debian 9

Czyli masz o wiele poważniejszy problem.

Windows w jakiś sposób ustawia kartę, że Debian za pierwszym razem jej nie ogarnia, dopiero za drugim razem.

Może problemem jest w tym, że Windows nie wyłączasz tylko przechodzi w tryb "suspend to disk", czyli hibernację?
Windows 10 się praktycznie nie wyłącza (to jest jego domyślne ustawienie),
jeżeli tego wyraźnie nie skonfigurujesz, to się nie wyłączy.


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#12  2019-01-28 22:28:12

  sebian - Użytkownik

sebian
Użytkownik
Zarejestrowany: 2019-01-28

Re: Po restarcie brak dzwieku debian 9

czyli pozostało mi wyłączanie a nie restart gdy bede korzystal z win10? Moze da sie to obejsc w windows ?? albo na debianie?

Gdy wlaczam cos z dzwiekiem i wydaje komende pavucontrol to widze ze pasek z dzwiekiem sie przesuwa ale nie slysze dzwieku.

Offline

 

#13  2019-01-29 08:20:23

  arecki - Użytkownik

arecki
Użytkownik
Skąd: 44 Bronson Lane Hensonville
Zarejestrowany: 2016-03-03

Re: Po restarcie brak dzwieku debian 9

Ustaw sobie w Windows aby się nie hibernował.
https://answers.microsoft.com/en-us/windows/forum/w … -718446f9d5f8

Please take note that you must be signed in as an Administrator to be able to turn fast startup on or off. Fast startup requires that hibernate be enabled. If you disable hibernate, then it will also disable fast startup.

Steps on how to manually turn off the Fast Startup

Open the Control Panel (icons view), and click on the Power Options icon.
Click/tap on the Choose what the power buttons do link on the left side
Click/tap on the Change settings that are currently unavailable link at the top
If prompted by UAC, click/tap on Yes
If the option for turning off the Fast Startup is not available, then changing the registry key maybe required.

Note: Please note that configuring Registry key requires extra care as it might cause another issue with your system.

Type RegEdit in the search field on your Task bar and open the Registry tool.On the left pane of the Registry window, locate HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Power.
On the right pane of the said location, check if the HiberbootEnabled is available. If not, we need to create it by clicking the right key of the mouse, select New and click on DWORD (32 bit) Value.
Replace it with the word HiberbootEnabled under Name column.Data value must be zero (0) that will represent as the Fast Startup is turned off.
Restart the computer for the changes to take effect.
Steps on how to disable UAC in Windows 10

Type UAC in the search field on your Task bar. (If the search field isn't visible, right-click the Start button and choose Search.)
Click Change User Account Control settings in the search results.
To turn UAC off, drag the slider down to Never notify and click OK.
You may be prompted to confirm your selection or enter an administrator password.
Reboot your computer for the changes to take effect.

Offline

 

#14  2019-01-29 17:47:42

  sebian - Użytkownik

sebian
Użytkownik
Zarejestrowany: 2019-01-28

Re: Po restarcie brak dzwieku debian 9

Nie pomogło - nie przeszkadza mi, że wyłączam win10, jeśli chcecie to możemy zamknąć wątek, chyba, że ktoś z Was ma inny pomysł na mój problem? Dziękuję wszystkim za pomoc:)

Offline

 

#15  2019-02-05 10:43:28

  sebian - Użytkownik

sebian
Użytkownik
Zarejestrowany: 2019-01-28

Re: Po restarcie brak dzwieku debian 9

zmykam wątek

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
To nie jest tylko forum, to nasza mała ojczyzna ;-)