Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2018-12-01 10:04:59

jastrzab2
Nowy użytkownik
Zarejestrowany: 2018-12-01

Strench Stable 9.6 i karta Wi- FI na USB, TL-WN722N nie działa..

Witajcie, mam problem z kartą Wi-Fi, USB Adapter 150 Mbps Tp-Link TL-WN722N sys w ogóle jej nie wykrywa, ba nie wykrywa USB na której zamontowana jest karta, po wydaniu komendy lsusb nic nie pokazuje. Dodam że Mobilny Orange na USB wykrywa bez problemu i internet jest. Komputer jest leciwy, bo juz 11 letni, ale do przegladania internetu sie jeszcze nadaje, ostatnio rodzice zalozyli sobie internet światłowodowy z routerem. I na tym starym kompie trzeba było dokupić odbiornik Wi-Fi, dokupili wspomniany. Z tego starego kompa korzystaja tylko do internetu na debianie. Dodam że mobilny net z Orange działał bez zarzutu. Więc jak zmusić żeby odbiornik Wi-Fi zadziałał??? Może brakuje jakiegoś sterownika? Dodam że instalacja sterownika firmware-atheros co proponują nic nie dała. Wiec pewnie chodzi o coś innego. Na opakowaniu wsparcie podobno dla linuxa jest jak pisze ale z kernelami od 2.6.13 do 3.19.3. A ten kernel jest 4.9. Może tutaj tkwi przyczyna??? Jeśli wiecie co doinstalować, żeby w koncu wykrył tą kartę to proszę o pomoc. Oczywiscie na network manager nic nie wykrywa bo w ogóle jak widzę ten system tej karty nie widzi.. Pozdro i będę wdzięczny za pomoc.

Offline

 

#2 2018-12-01 10:11:16

arecki
Użytkownik
Skąd: 44 Bronson Lane Hensonville
Zarejestrowany: 2016-03-03

Re: Strench Stable 9.6 i karta Wi- FI na USB, TL-WN722N nie działa..

Skoro wynik lsusb nie daje informacji o nowych urządzeniach to najpierw sprawdziłbym czy ta karta w ogóle jest sprawna (np. gdzieś na innym komputerze) i czy port USB jest sprawny (np. podpinając ten orange czy jakiś pendrive).
I prośba: formatuj tekst bo tego czytać się nie da.

Offline

 

#3 2018-12-01 10:44:29

jastrzab2
Nowy użytkownik
Zarejestrowany: 2018-12-01

Re: Strench Stable 9.6 i karta Wi- FI na USB, TL-WN722N nie działa..

Port USB jest sprawny bo orange działa. Podpinam i wykrywa. Nawet teraz korzystam.
lsusb

Kod:

Bus 001 Device 003: ID 12d1:1436 Huawei Technologies Co., Ltd. Broadband stick
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Karta wi-fi jest sprawna bo np na laptopie z win7 (też starym) wykrywa ją.
Postaram się pisać zwinniej. Dzięki za zainteresowanie tematem.
Więc jak działać? Może to wina braku jeszcze jakiegoś sterownika prócz firmware-realtek. I chyba tak jest bo juz po swiezej instalacji gdy wlozylem mobilnego orange to od razu network-manager wykryl i skonfigurowal. A w przypadku karty wifi tutaj milczy i usb i network-manager.

Ostatnio edytowany przez jastrzab2 (2018-12-01 11:40:08)

Offline

 

#4 2018-12-01 14:28:37

wikingagressor
Użytkownik
Skąd: Józefów k.Błonia, mazowieckie
Zarejestrowany: 2015-02-03

Re: Strench Stable 9.6 i karta Wi- FI na USB, TL-WN722N nie działa..

Podlacz to nowe urzadzenie i zaraz z konsoli z uprawnieniami roota wpisz:

Kod:

dmesg | tail

To nam powinno powiedziec co sie dzieje z systemem jak podlaczysz to urzadzenie.


Peace, Love and Debian for the World!!!

Offline

 

#5 2018-12-01 17:34:40

wxn
Użytkownik
Zarejestrowany: 2015-04-29

Re: Strench Stable 9.6 i karta Wi- FI na USB, TL-WN722N nie działa..

Przed podłączeniem tego urządzenia polecenie w konsoli ze swojego konta

Kod:

dmesg -w

gdy przelecą komunikaty parę razy Enter-em, aby oddzielić nowe komunikaty pustym polem, i podłączenie urządzenia (u mnie to z Huawei E3372)

Kod:

[  294.076174] usb 8-3: new high-speed USB device number 3 using ehci-pci
[  294.226245] usb 8-3: New USB device found, idVendor=12d1, idProduct=14fe
[  294.226257] usb 8-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  294.226265] usb 8-3: Product: HUAWEI_MOBILE
[  294.226271] usb 8-3: Manufacturer: HUAWEI_MOBILE
[  294.226277] usb 8-3: SerialNumber: 0123456789ABCDEF
[  294.416049] usb-storage 8-3:1.0: USB Mass Storage device detected
[  294.416420] scsi4 : usb-storage 8-3:1.0
[  294.416537] usbcore: registered new interface driver usb-storage
[  295.162207] usb 8-3: USB disconnect, device number 3
[  295.804211] usb 8-3: new high-speed USB device number 4 using ehci-pci
[  295.938159] usb 8-3: New USB device found, idVendor=12d1, idProduct=1506
[  295.938171] usb 8-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  295.938178] usb 8-3: Product: HUAWEI_MOBILE
[  295.938185] usb 8-3: Manufacturer: HUAWEI_MOBILE
[  295.969880] usb-storage 8-3:1.3: USB Mass Storage device detected
...

zakończenie ctrl+c
Przydatne też jest polecenie (po podłączeniu urządzenia)

Kod:

usb-devices

to komunikaty z tego Huaweia

Kod:

...
T:  Bus=08 Lev=01 Prnt=01 Port=02 Cnt=01 Dev#=  4 Spd=480 MxCh= 0
D:  Ver= 2.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=1506 Rev=01.02
S:  Manufacturer=HUAWEI_MOBILE
S:  Product=HUAWEI_MOBILE
C:  #Ifs= 5 Cfg#= 1 Atr=c0 MxPwr=2mA
I:  If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=02 Prot=12 Driver=option
I:  If#= 1 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=01 Driver=option
I:  If#= 2 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=02 Prot=16 Driver=(none)
I:  If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
I:  If#= 4 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

;poprawka

Polecenie dmesg wywołane ze swojego konta w  Debianie 9.6.0 wywala komunikat:

Kod:

dmesg -w
dmesg: odczyt bufora jądra nie powiódł się: Operacja niedozwolona

tak jest już OK:

Kod:

sudo dmesg -w

W Debianie 8 można stosować to polecenie bez sudo.

Ostatnio edytowany przez wxn (2018-12-02 20:57:39)

Offline

 

#6 2018-12-04 11:41:02

jastrzab2
Nowy użytkownik
Zarejestrowany: 2018-12-01

Re: Strench Stable 9.6 i karta Wi- FI na USB, TL-WN722N nie działa..

Dzieki za porady, obecnie nie mam jak sprawdzić bo jestem u siebie w domu, gdy bede u rodziców ponownie w którys weekend to sprawdzę.
Ale wziąłem tą kartę do siebie i sprawdziłem czy u mnie wykrywa na Debianie (też 9.6 tyle ze już na amd64) i wykrywa bez problemu. Nawet nic nie instalowałem, sterowników, włożyłem do usb i od razu migało a w network-manager pojawiły się sieci do wyboru. Więc karta sprawna. Obstawiam że to jest wina sprzętu już leciwego bo 11 letniego prawie. I czegoś brakuje do usb.. chyba jakiegoś sterownika. Samo usb raczej sprawne bo inne rzeczy wykrywa bez problemu czy to mobilny net z Orange, czy aparat fotograficzny czy telefon komórkowy na tym starym kompie, a WiFi juz nie.

Offline

 

#7 2018-12-13 14:48:34

jastrzab2
Nowy użytkownik
Zarejestrowany: 2018-12-01

Re: Strench Stable 9.6 i karta Wi- FI na USB, TL-WN722N nie działa..

Witam wszystkich to znów ja. A więc wywalają się błędy po podłączeniu tego urządzenia. Jak wyżej mi podpowiedzieliście.. zaraz wkleję te błędy. Macie  jakiś sposób? Może brakuje jeszcze jakiegoś sterownika do usb???
O to komunikaty po podłaczeniu tej karty:

Kod:

dmesg |tail
[ 4108.727311] Chip Version Info: CHIP_8188E_Normal_Chip_TSMC_D_CUT_1T1R_RomVer(0)
[ 4108.846924] r8188eu 1-1:1.0 wlx503eaa5e0ffd: renamed from wlan0
[ 4108.879173] IPv6: ADDRCONF(NETDEV_UP): wlx503eaa5e0ffd: link is not ready
[ 4108.891620] r8188eu 1-1:1.0: firmware: failed to load rtlwifi/rtl8188eufw.bin (-2)
[ 4108.891628] r8188eu 1-1:1.0: Direct firmware load for rtlwifi/rtl8188eufw.bin failed with error -2
[ 4108.891632] r8188eu 1-1:1.0: Firmware rtlwifi/rtl8188eufw.bin not available
[ 4108.891635] MAC Address = 50:3e:aa:5e:0f:fd
[ 4108.912637] usb 1-1: USB disconnect, device number 18
[ 4108.916779] IPv6: ADDRCONF(NETDEV_UP): wlx503eaa5e0ffd: link is not ready
[ 4108.917304] R8188EU: indicate disassoc

Kod:

usb-devices

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480 MxCh=10
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev=04.09
S:  Manufacturer=Linux 4.9.0-8-686-pae ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=0000:00:02.1
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

T:  Bus=01 Lev=01 Prnt=01 Port=03 Cnt=01 Dev#= 17 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=ef(misc ) Sub=02 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=1436 Rev=00.00
S:  Manufacturer=HUAWEI Technology
S:  Product=HUAWEI Mobile
C:  #Ifs= 7 Cfg#= 1 Atr=e0 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I:  If#= 1 Alt= 0 #EPs= 1 Cls=02(commc) Sub=06 Prot=ff Driver=cdc_ether
I:  If#= 2 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_ether
I:  If#= 3 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I:  If#= 4 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
I:  If#= 5 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
I:  If#= 6 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh=10
D:  Ver= 1.10 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0001 Rev=04.09
S:  Manufacturer=Linux 4.9.0-8-686-pae ohci_hcd
S:  Product=OHCI PCI host controller
S:  SerialNumber=0000:00:02.0
C:  #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub

Obok tego urządzenia mam podłączony mobilny net z orange więc jego widać a wi-fi nie. Macie jakiś sposób żeby to naprawić?? Działają inne urządzenia a karta wi-fi nie. Dodam że sprzęt jest leciwy 11 letni więc może to ma jakieś znaczenie? Ale do internetu i nawet z multimediami ten stary komputer daje sobie jeszcze radę i może być śmiało uzywany. Więc chyba problem leży w usb??

Nie wiem jak to przeoczyłem, ale problem został rozwiązany. Wystarczyło doinstalować firmware-realtek, ja miałem wcześniej zainstalowane firmware-atheros wg innego poradnika i to mnie wprowadziło w błąd. Po instalacji tego pakietu, network-manager się odezwał od razu znalazł sieć. Nawet reboot nie musial isc od razu wszystko zadziałało. Internet śmiga aż miło.Więc dzięki za pomoc. Problem rozwiąany. Nie wiem jak mi to umknęło, zainstalowałem po prostu nie ten pakiet co trzeba wcześniej.

Ostatnio edytowany przez jastrzab2 (2018-12-13 16:43:13)

Offline

 

#8 2018-12-13 21:05:41

ilin
Palacz
Skąd: PRLu
Zarejestrowany: 2006-05-03

Re: Strench Stable 9.6 i karta Wi- FI na USB, TL-WN722N nie działa..

Masz zainstalowany pakiet

Kod:

firmware-realtek

?


Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Polski portal Debiana

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
To nie jest tylko forum, to nasza mała ojczyzna ;-)