Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2018-10-17 20:47:05

newbiex
Użytkownik
Zarejestrowany: 2017-07-23

ImportError: No module named QtWebKit

Mam problem. Nie działa Anki. Wersja 2.0.32+dfsg-1. Pobrana z Add / Remove Software.

Kod:

newbiex@raspberrypi:~ $ anki
Traceback (most recent call last):
  File "/usr/bin/anki", line 7, in <module>
    import aqt
  File "/usr/share/anki/aqt/__init__.py", line 12, in <module>
    from aqt.qt import *
  File "/usr/share/anki/aqt/qt.py", line 22, in <module>
    from PyQt4.QtWebKit import QWebPage, QWebView, QWebSettings
ImportError: No module named QtWebKit

Czy mógłby ktoś ożywić Anki?

Offline

 

#2 2018-10-17 20:48:54

arecki
Użytkownik
Skąd: 44 Bronson Lane Hensonville
Zarejestrowany: 2016-03-03

Re: ImportError: No module named QtWebKit

Komunikat mówi sam za siebie: "ImportError: No module named QtWebKit"

Kod:

dpkg -l | grep qtwebkit

Wydruk z mojego systemu:

Kod:

ii  libqtwebkit4:amd64                           2.3.4.dfsg-10                       amd64        Web content engine library for Qt
ii  python-pyside.qtwebkit                       1.2.2+source1-1                     amd64        Qt 4 WebKit module - Python bindings

Ostatnio edytowany przez arecki (2018-10-17 20:58:24)

Offline

 

#3 2018-10-17 22:58:27

newbiex
Użytkownik
Zarejestrowany: 2017-07-23

Re: ImportError: No module named QtWebKit

Kod:

ii  libqtwebkit-qmlwebkitplugin:armhf     2.3.4.dfsg-9.1                    armhf        Qt WebKit QML plugin
ii  libqtwebkit4:armhf                    2.3.4.dfsg-9.1                    armhf        Web content engine library for Qt

Offline

 

#4 2018-10-18 05:49:48

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: ImportError: No module named QtWebKit

Ja tam za bardzo się na tym nie znam, ale ten Anki chyba potrzebuje PyQt5:

* dependency graph for app-misc/anki-2.1.0_beta29
`--  app-misc/anki-2.1.0_beta29  M[package.mask]
   `--  dev-lang/python-3.6.5  (dev-lang/python) ~amd64  [sqlite]
   `--  dev-lang/python-exec-9999  (>=dev-lang/python-exec-2)   
   `--  dev-python/PyQt5-5.10.1-r1  (dev-python/PyQt5) amd64 
   `--  dev-python/httplib2-0.10.3-r1  (>=dev-python/httplib2-0.7.4) amd64 
   `--  dev-python/beautifulsoup-4.5.1  (dev-python/beautifulsoup) amd64 
   `--  dev-python/decorator-4.2.1  (dev-python/decorator) amd64 
   `--  dev-python/markdown-2.6.8  (dev-python/markdown) amd64 
   `--  dev-python/requests-2.18.4-r1  (dev-python/requests) amd64 
   `--  dev-python/send2trash-1.3.0  (dev-python/send2trash) amd64 
   `--  media-sound/lame-3.100-r1  (media-sound/lame) amd64
   `--  dev-python/pyaudio-0.2.11  (>=dev-python/pyaudio-0.2.4) amd64 
   `--  media-video/mpv-0.27.2  (media-video/mpv) amd64
   `--  app-text/texlive-2017  (app-text/texlive) amd64
   `--  app-text/dvipng-1.15  (app-text/dvipng) amd64
   `--  dev-python/nose-1.3.7-r3  (dev-python/nose) amd64 
[ app-misc/anki-2.1.0_beta29 stats: packages (16), max depth (1) ]

Poza tym która to wersja Debiana, bo Qt4 wyleciało niedawno z testinga.

Ostatnio edytowany przez Jacekalex (2018-10-18 05:51:22)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#5 2018-10-18 06:45:40

arecki
Użytkownik
Skąd: 44 Bronson Lane Hensonville
Zarejestrowany: 2016-03-03

Re: ImportError: No module named QtWebKit

Jacekalex napisał(-a):

Ja tam za bardzo się na tym nie znam, ale ten Anki chyba potrzebuje PyQt5:

Jego logi mówią co innego.

File "/usr/share/anki/aqt/qt.py", line 22, in <module>
    from PyQt4.QtWebKit import QWebPage, QWebView, QWebSettings
ImportError: No module named QtWebKit

Jacekalex napisał(-a):

Poza tym która to wersja Debiana, bo Qt4 wyleciało niedawno z testinga.

Raczej jakiś Raspbian czy inne ustrojstwo.

newbiex@raspberrypi:~ $ anki

Offline

 

#6 2018-10-18 07:59:28

newbiex
Użytkownik
Zarejestrowany: 2017-07-23

Re: ImportError: No module named QtWebKit

Tak, to Raspbian. Wersja 2018-06-29.

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Nas ludzie lubią po prostu, a nie klikając w przyciski ;-)