Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2018-04-30 03:42:00

ethanak
Użytkownik
Skąd: Ungwenor
Zarejestrowany: 2010-07-19
Serwis

[wine-3.0]Błąd przy próbie utworzenia obiektu

Witam.
Działało, działało, a teraz przestało :(
Próbuję uruchomić SAPI5.1 pod Wine. Dotychczas działało toto całkiem nieźle - niestety, przy próbie odpalenia pod najnowszym łajnem mam coś takiego:

Kod:

  File "ssapi.py", line 391, in __init__
    self.speaker = win32com.client.Dispatch("SAPI.SpVoice")
  File "Z:\usr\lib\sapi4linux\pydir\lib\site-packages\win32com\client\__init__.py", line 95, in Dispatch
    dispatch, userName = dynamic._GetGoodDispatchAndUserName(dispatch,userName,clsctx)
  File "Z:\usr\lib\sapi4linux\pydir\lib\site-packages\win32com\client\dynamic.py", line 114, in _GetGoodDispatchAndUserName
    return (_GetGoodDispatch(IDispatch, clsctx), userName)
  File "Z:\usr\lib\sapi4linux\pydir\lib\site-packages\win32com\client\dynamic.py", line 91, in _GetGoodDispatch
    IDispatch = pythoncom.CoCreateInstance(IDispatch, None, clsctx, pythoncom.IID_IDispatch)
pywintypes.com_error: (-2147221005, 'COM Error 0x800401f3', None, None)

Ktoś ma jakiś pomysł skąd się to bierze?
W razie czego peny kod jest tu: http://www.polip.com/files/sapi/sapi4linux-netinstall-0.1.9.tar.gz


Nim mechaniczne larum zagrasz mi, kanalio,
głosząc nadejście Javy - śmiertelnego wroga!
Zespół Adwokacki Dyskrecja

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
To nie jest tylko forum, to nasza mała ojczyzna ;-)