Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2018-01-16 12:30:14

klito1920
Użytkownik
Zarejestrowany: 2010-06-06

Problem z gammu i gammu-smsd

Witam,

potrzebny mi jest automat do wysyłki SMS..
Problem polega na tym że po default-owej instalacji gammu bez plików konfiguracyjnych jest OK. W momencie zmiany konfiguracji i instalacji gammu-smsd wyrzuca błędy .. i nie idzie wrócić do poprzedniej konfiguracji.

root@smsdebian:/# gammu-detect
; Plik konfiguracyjny wygenerowany przez gammu-detect.
; Please check The Gammu Manual for more information.

[gammu]
device = /dev/ttyUSB0
name = Port telefonu USB HUAWEI_Technology HUAWEI_Mobile
connection = at

[gammu1]
device = /dev/ttyUSB1
name = Port telefonu USB HUAWEI_Technology HUAWEI_Mobile
connection = at

[gammu2]
device = /dev/ttyS1
name = Telefon na porcie szeregowym 1
connection = at

[gammu3]
device = /dev/ttyS2
name = Telefon na porcie szeregowym 2
connection = at

[gammu4]
device = /dev/ttyS3
name = Telefon na porcie szeregowym 3
connection = at

opening socket: Nie ma takiego urządzenia

gammu --identify

root@smsdebian:/# gammu --identify
Can not open specified file.

/etc/init.d/gammu-smsd status

root@smsdebian:/# /etc/init.d/gammu-smsd status
● gammu-smsd.service - SMS daemon for Gammu
   Loaded: loaded (/lib/systemd/system/gammu-smsd.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2018-01-16 12:20:04 CET; 8min ago
     Docs: man:gammu-smsd(1)
  Process: 1345 ExecStopPost=/bin/rm -f /var/run/gammu-smsd.pid (code=exited, status=0/SUCCESS)
  Process: 1375 ExecStart=/usr/bin/gammu-smsd --pid=/var/run/gammu-smsd.pid --daemon (code=exited, status=0/SUCCESS)
Main PID: 1376 (gammu-smsd)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/gammu-smsd.service
           └─1376 /usr/bin/gammu-smsd --pid=/var/run/gammu-smsd.pid --daemon

sty 16 12:20:04 smsdebian systemd[1]: Starting SMS daemon for Gammu...
sty 16 12:20:04 smsdebian systemd[1]: gammu-smsd.service: PID file /var/run/gammu-smsd.pid not readable (yet?) after start: No such file or directory
sty 16 12:20:04 smsdebian gammu-smsd[1376]: Created POSIX RW shared memory at 0xb7732000
sty 16 12:20:04 smsdebian gammu-smsd[1376]: Starting phone communication...
sty 16 12:20:04 smsdebian systemd[1]: Started SMS daemon for Gammu.

w gammu-config  i wszędzie
podane /dev/ttyUSB0

wcześniej pokazywało /dev/mobile.. teraz już nawet pod tym nie działa ..

Offline

 

#2 2018-01-16 20:06:05

wxn
Użytkownik
Zarejestrowany: 2015-04-29

Re: Problem z gammu i gammu-smsd

Gdy używam gammu to wcześniej wyłączam ModemManager, który blokuje porty modemu

Kod:

$ sudo systemctl stop ModemManager
$ sudo systemctl disable ModemManager
Removed symlink /etc/systemd/system/multi-user.target.wants/ModemManager.service.
Removed symlink /etc/systemd/system/dbus-org.freedesktop.ModemManager1.service.

Dla Huaweia E3372s-153 non-hilink, który ma dwa porty

Kod:

$ ls /dev/ttyUSB*
/dev/ttyUSB0  /dev/ttyUSB1

i USB0 jest dla komend AT a USB1 jest do transmisji danych, mam taki config .gammurc

Kod:

$ sudo cat /root/.gammurc
[gammu]
port = /dev/ttyUSB0
connection = at

Kod:

$ sudo gammu identify
Urządzenie          : /dev/ttyUSB0
Producent            : Huawei
Model                : unknown (E3372)
Firmware             : 21.297.05.00.264
IMEI                 : 
SIM IMSI             :

W większości Huaweiów non-hilink pierwszy port USB0 jest do transmisji danych a ostatni do komend AT i wtedy można go wpisać w pliku konfiguracyjnym .gammurc

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Nas ludzie lubią po prostu, a nie klikając w przyciski ;-)