Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2017-10-17 16:44:28

hubot
Użytkownik
Zarejestrowany: 2017-04-13

gst-plugins-bad-1.11.90 is blocking gst-plugins-base-1.12.3

Otrzymałem następujący błąd w Gentoo:

Kod:

tux ~ # emerge @preserved-rebuild

 * IMPORTANT: 8 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!
[ebuild   R    ] dev-libs/botan-1.10.17 
[ebuild     U  ] media-gfx/imagemagick-7.0.7.6 [6.9.9.0]
[ebuild   R    ] dev-python/pillow-4.2.1-r1 
[ebuild     U  ] media-libs/gst-plugins-base-1.12.3 [1.10.5]
[ebuild     U  ] dev-qt/qtgui-5.9.2 [5.7.1-r1] USE="libinput* -vnc%" 
[ebuild   R    ] media-video/ffmpeg-3.3.4 
[ebuild     U  ] dev-qt/qtwidgets-5.9.2 [5.7.1] USE="gtk%*" 
[ebuild     U  ] media-libs/gst-plugins-ugly-1.12.3 [1.10.5]
[ebuild     U  ] dev-qt/qtdeclarative-5.9.2 [5.7.1]
[ebuild     U  ] dev-qt/qtprintsupport-5.9.2 [5.7.1]
[ebuild     U  ] media-video/vlc-2.2.6-r2 [2.2.6] USE="qt5*" 
[ebuild     U  ] media-plugins/gst-plugins-x264-1.12.3 [1.10.5]
[ebuild     U  ] dev-qt/qtwebchannel-5.9.2 [5.7.1]
[ebuild   R    ] net-analyzer/wireshark-2.4.2 
[ebuild     U  ] xfce-base/xfwm4-4.13.0-r1 [4.12.3-r1] USE="opengl%* -xpresent%" 
[ebuild     U  ] app-editors/vim-8.0.1188 [8.0.0386] USE="terminal%*" PYTHON_SINGLE_TARGET="python3_4%* -python2_7% -python3_5% -python3_6%" 
[ebuild     U  ] dev-qt/qtwebengine-5.9.2 [5.7.1-r2]
[ebuild   R    ] dev-db/postgresql-9.6.5-r1 
[ebuild     U  ] media-video/obs-studio-20.0.1-r1 [20.0.1]
[ebuild     U  ] net-print/cups-filters-1.17.9 [1.16.4] USE="-pclm%" 
[ebuild     U  ] media-gfx/graphviz-2.40.1 [2.38.0-r1]
[ebuild   R    ] www-servers/nginx-1.12.1 
[ebuild   R    ] dev-lang/php-7.0.24 
[ebuild   R    ] dev-db/mariadb-10.2.9 
[blocks B      ] <media-libs/gst-plugins-bad-1.11.90:1.0 ("<media-libs/gst-plugins-bad-1.11.90:1.0" is blocking media-libs/gst-plugins-base-1.12.3)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtgui:5

  (dev-qt/qtgui-5.7.1-r1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.7.1 required by (dev-qt/qtquickcontrols-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                           
    (and 9 more with the same problem)

  (dev-qt/qtgui-5.9.2:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.9.2 required by (dev-qt/qtwebengine-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                        
    (and 3 more with the same problem)

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.7.1 required by (dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                    
    (and 6 more with the same problem)

  (dev-qt/qtwidgets-5.9.2:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.9.2 required by (dev-qt/qtwebengine-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                        
    (and 2 more with the same problem)

dev-qt/qtprintsupport:5

  (dev-qt/qtprintsupport-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtprintsupport-5.7.1 required by (dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, installed)
    ^                      ^^^^^                                                                                                                    

  (dev-qt/qtprintsupport-5.9.2:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtprintsupport-5.9.2 required by (dev-qt/qtwebengine-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^                      ^^^^^                                                                                                                                        

dev-qt/qtdeclarative:5

  (dev-qt/qtdeclarative-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtdeclarative-5.7.1 required by (dev-qt/qtquickcontrols-5.7.1:5/5.7::gentoo, installed)
    ^                     ^^^^^                                                                                                                           

  (dev-qt/qtdeclarative-5.9.2:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdeclarative-5.9.2 required by (dev-qt/qtwebchannel-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                         
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-libs/gst-plugins-base-1.12.3:1.0/1.0::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/gst-plugins-base:1.0 required by (dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, installed)
    >=media-libs/gst-plugins-base-1.10.5:1.0[alsa?,ogg?,theora?,vorbis?,X?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/gst-plugins-base-1.10.5:1.0[alsa,ogg,vorbis,X,abi_x86_32(-),abi_x86_64(-)]) required by (media-plugins/gst-plugins-meta-1.10.5:1.0/1.0::gentoo, installed)
    >=media-libs/gst-plugins-base-1.12.3:1.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/gst-plugins-base-1.12.3:1.0[abi_x86_32(-),abi_x86_64(-)]) required by (media-libs/gst-plugins-ugly-1.12.3:1.0/1.0::gentoo, ebuild scheduled for merge)
    >=media-libs/gst-plugins-base-1.4.5:1.0 required by (media-video/vlc-2.2.6-r2:0/5-8::gentoo, ebuild scheduled for merge)
    >=media-libs/gst-plugins-base-1.10.5:1.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/gst-plugins-base-1.10.5:1.0[abi_x86_32(-),abi_x86_64(-)]) required by (media-plugins/gst-plugins-cdparanoia-1.10.5:1.0/1.0::gentoo, installed)
    >=media-libs/gst-plugins-base-1.10.5:1.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/gst-plugins-base-1.10.5:1.0[abi_x86_32(-),abi_x86_64(-)]) required by (media-libs/gst-plugins-good-1.10.5:1.0/1.0::gentoo, installed)
    >=media-libs/gst-plugins-base-1.10.5:1.0[X,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/gst-plugins-base-1.10.5:1.0[X,abi_x86_32(-),abi_x86_64(-)]) required by (media-plugins/gst-plugins-v4l2-1.10.5:1.0/1.0::gentoo, installed)
    >=media-libs/gst-plugins-base-1.10.5:1.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/gst-plugins-base-1.10.5:1.0[abi_x86_32(-),abi_x86_64
(-)]) required by (media-plugins/gst-plugins-vaapi-1.10.5:1.0/1.0::gentoo, installed)
    media-libs/gst-plugins-base:1.0 required by (dev-qt/qtmultimedia-5.7.1:5/5.7::gentoo, installed)
    >=media-libs/gst-plugins-base-1.10.5:1.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,introspection?] (>=media-libs/gst-plugins-base-1.10.5:1.0[abi_x86_32(-),abi_x86_64(-),introspection]) required by (media-libs/gst-plugins-bad-1.10.5:1.0/1.0::gentoo, installed)

  (media-libs/gst-plugins-bad-1.10.5:1.0/1.0::gentoo, installed) pulled in by
    >=media-libs/gst-plugins-bad-1.10.5:1.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/gst-plugins-bad-1.10.5:1.0[abi_x86_32(-),abi_x86_64(-)]) required by (media-plugins/gst-plugins-dts-1.10.5:1.0/1.0::gentoo, installed)
    media-libs/gst-plugins-bad:1.0 required by (dev-qt/qtmultimedia-5.7.1:5/5.7::gentoo, installed)
    >=media-libs/gst-plugins-bad-1.10.5:1.0[opengl?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/gst-plugins-bad-1.10.5:1.0[opengl,abi_x86_32(-),abi_x86_64(-)]) required by (media-plugins/gst-plugins-vaapi-1.10.5:1.0/1.0::gentoo, installed)
    >=media-libs/gst-plugins-bad-1.10.5:1.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/gst-plugins-bad-1.10.5:1.0[abi_x86_32(-),abi_x86_64(-)]) required by (media-plugins/gst-plugins-resindvd-1.10.5:1.0/1.0::gentoo, installed)
    >=media-libs/gst-plugins-bad-1.10.5:1.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/gst-plugins-bad-1.10.5:1.0[abi_x86_32(-),abi_x86_64(-)]) required by (media-plugins/gst-plugins-faad-1.10.5:1.0/1.0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


!!! The following installed packages are masked:
- app-admin/keepassx-2.0.2-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Lars Wendler <polynomial-c@gentoo.org> (12 Oct 2017)
# Dead upstream. No qt5 release. Use app-admin/keepassxc as drop-in
# replacement which has very active upstream and regular releases.
# Masked for removal in 30 days.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Czy pomoże mi ktoś?

Ostatnio edytowany przez hubot (2017-10-17 17:07:57)

Offline

 

#2 2017-10-17 18:58:15

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: gst-plugins-bad-1.11.90 is blocking gst-plugins-base-1.12.3

Przeca wszystko masz napisane jak krowie na rowie.

Qtwebkit4 wylatuje, nie ma już wsparcia, za to ma kilka nie załatanych błędów, a razem z nim poleci conieco z programów, które nie są zgodne z QT5.


Zapętlanie się QT5? były jakieś błędy w ebuildach z tydzień temu, ale wczoraj u mnie wszystko się grzecznie zaktualizowało.

Co do samego gst-plugins-bad, to możesz go wywalić na chwilę,
i powinien wtedy zainstalować aktualniejszą wersję.
Jeżeli dalej będzie wolał o wersję gst-plugins-bad-1.11.90
to po prostu dorzuć ją do /etc/portage/profile/package.provided
(po wywaleniu), a system sobie pociągnie nowszą wersję, albo tą nowszą zainstalujesz  z palca podając emerge numerek wersji.

Przy okazji, ja mam:

Kod:

media-libs/gst-plugins-bad-1.10.5

i w niczym to  nie przeszkadza, (to aktualnie stabilna wersja).

Poza tym jak upierasz się na testowych paczkach, to  takie cyrki będziesz miał przy każdej aktualizacji, co przy twoim doświadczeniu oznacza zaoranie systemu.

Zwłaszcza,ze włączyłeś tam pierdylion flag USE w make.conf, a to przy testowym systemie prosta droga do katastrofy.


EDIT

W ogóle bzdurę masz w make.conf

Kod:

ACCEPT_KEYWORDS="amd64 ~amd64"

Zdecyduj się, czy chcesz mieć stabilny działający system, wtedy wywal flagę ~amd64, czy chcesz mieć testowy system, i  brać na klatę wszystkie błędy, ale wtedy musisz się nauczyć z nimi radzić, i przede wszystkim zmykać na polskie i angielskie forum Gentoo, bo tutaj już wszystkiego nie załatwisz.
Sznurek: https://forums.gentoo.org/viewforum-f-45.html

Pozdro

Ostatnio edytowany przez Jacekalex (2017-10-17 19:06:34)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Nas ludzie lubią po prostu, a nie klikając w przyciski ;-)