Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#26 2017-09-07 13:45:34

jawojx
Użytkownik
Zarejestrowany: 2012-10-11

Re: failed to start raise network, problem z wifi po instalacji

Wyłącz w network-managerze dla swojego połączenia wifi w domu "abcd" protokół ipv6.
Nie przez root-a, normalny user.

Kod:

nmcli con modify abcd ipv6.method ignore

Można wyłączyć połączenie

Kod:

nmcli con down abcd

i włączyć ponownie.

Kod:

nmcli con up abcd

Jak dalej jest źle to pokaż swoje otoczenie wifi:

Kod:

nmcli dev wifi list

Zainstaluj lekką przeglądarkę tekstową links2. Na połączeniu wifi  wpisz w  konsoli i enter, sprawdź czy otworzy stronę:

Kod:

links2 www.onet.pl

Pokaż jeszcze:

Kod:

traceroute 8.8.8.8

Offline

 

#27 2017-09-12 17:01:55

div
Użytkownik
Zarejestrowany: 2017-09-04

Re: failed to start raise network, problem z wifi po instalacji

na linksie request sent i koniec
formatowalem debiana, wysle wam wszystkie komendy ktore mialem sprawdzic.. dalej nie działa


Kod:

root@debian:/etc/network# nmcli con modify abcd ipv6.method ignore
root@debian:/etc/network# nmcli con down abcd
Connection 'abcd'' successfully deactivated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/5)
root@debian:/etc/network# nmcli con up abcd
Connection successfully activated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/6)
root@debian:/etc/network# nmcli dev wifi list
*  SSID   MODE   CHAN  RATE       SIGNAL  BARS  SECURITY 
*  abcd  Infra  5     54 Mbit/s  83      ▂▄▆█  WPA2     
root@debian:/etc/network# traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
 1  192.168.1.1 (192.168.1.1)  9.853 ms  9.830 ms  11.953 ms
 2  10.161.1.1 (10.161.1.1)  11.949 ms  15.208 ms  15.205 ms
 3  * * *
 4  xxxx-xx-xxx-xxx-x.xxx.pl (xx.xxx.xxx.x)  18.178 ms  15.151 ms  18.155 ms
 5  google.ip4.epix.net.pl (195.191.170.134)  22.832 ms  27.118 ms  27.114 ms
 6  108.170.250.217 (108.170.250.217)  30.335 ms 108.170.250.201 (108.170.250.201)  20.060 ms  20.049 ms
 7  72.14.232.241 (72.14.232.241)  66.490 ms 209.85.246.99 (209.85.246.99)  72.835 ms 216.239.50.217 (216.239.50.217)  69.476 ms
 8  216.239.40.177 (216.239.40.177)  69.434 ms 209.85.247.77 (209.85.247.77)  66.386 ms 216.239.40.177 (216.239.40.177)  72.756 ms
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  google-public-dns-a.google.com (8.8.8.8)  124.230 ms  121.169 ms  121.182 ms
root@debian:/etc/network# iwconfig
wwp0s29f7u6i7  no wireless extensions.

lo        no wireless extensions.

enp0s25   no wireless extensions.

wlp12s0   IEEE 802.11  ESSID:"abcd"  
          Mode:Managed  Frequency:2.432 GHz  Access Point: 00:15:20:20:1D:C4   
          Bit Rate=1 Mb/s   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-40 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:4   Missed beacon:0

root@debian:/etc/network# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback
root@debian:/etc/network# cat /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=true
root@debian:/etc/network# systemctl status network-manager 
● NetworkManager.service - Network Manager
   Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2017-09-12 16:42:48 CEST; 12min ago
     Docs: man:NetworkManager(8)
 Main PID: 1052 (NetworkManager)
    Tasks: 4 (limit: 4915)
   CGroup: /system.slice/NetworkManager.service
           ├─1052 /usr/sbin/NetworkManager --no-daemon
           └─1837 /sbin/dhclient -d -q -sf /usr/lib/NetworkManager/nm-dhcp-helper -pf /var/run/dhclient-wlp12s0.pid -lf /var/l

Sep 12 16:53:34 debian NetworkManager[1052]: <info>  [1505228014.0910] dhcp4 (wlp12s0):   wins '192.168.1.1'
Sep 12 16:53:34 debian NetworkManager[1052]: <info>  [1505228014.0910] dhcp4 (wlp12s0): state changed unknown -> bound
Sep 12 16:53:34 debian NetworkManager[1052]: <info>  [1505228014.0970] device (wlp12s0): state change: ip-config -> ip-check (
Sep 12 16:53:34 debian NetworkManager[1052]: <info>  [1505228014.0977] device (wlp12s0): state change: ip-check -> secondaries
Sep 12 16:53:34 debian NetworkManager[1052]: <info>  [1505228014.0981] device (wlp12s0): state change: secondaries -> activate
Sep 12 16:53:34 debian NetworkManager[1052]: <info>  [1505228014.0982] manager: NetworkManager state is now CONNECTED_LOCAL
Sep 12 16:53:34 debian dhclient[1837]: bound to 192.168.1.11 -- renewal in 128485 seconds.
Sep 12 16:53:34 debian NetworkManager[1052]: <info>  [1505228014.2205] manager: NetworkManager state is now CONNECTED_GLOBAL
Sep 12 16:53:34 debian NetworkManager[1052]: <info>  [1505228014.2206] policy: set 'abcd' (wlp12s0) as default for IPv4 routi
Sep 12 16:53:34 debian NetworkManager[1052]: <info>  [1505228014.2209] device (wlp12s0): Activation: successful, device activa

root@debian:/etc/network# systemctl status networking.service
● networking.service - Raise network interfaces
   Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled)
   Active: active (exited) since Tue 2017-09-12 16:38:30 CEST; 17min ago
     Docs: man:interfaces(5)
  Process: 242 ExecStart=/sbin/ifup -a --read-environment (code=exited, status=0/SUCCESS)
  Process: 234 ExecStartPre=/bin/sh -c [ "$CONFIGURE_INTERFACES" != "no" ] && [ -n "$(ifquery --read-environment --list --excl
 Main PID: 242 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   CGroup: /system.slice/networking.service

Sep 12 16:38:29 debian systemd[1]: Starting Raise network interfaces...
Sep 12 16:38:30 debian systemd[1]: Started Raise network interfaces.

root@debian:/etc/network#

Ostatnio edytowany przez div (2017-09-12 17:04:53)

Offline

 

#28 2017-09-12 21:31:30

jawojx
Użytkownik
Zarejestrowany: 2012-10-11

Re: failed to start raise network, problem z wifi po instalacji

Sygnał mocny, a ty masz bardzo duże opóźnienie komputer-router i słaby Bit Rate=1 Mb/s.

Przeinstalowałeś Debiana i znowu zainstalowałeś firmware-iwlwifi_0.43 tak jak pisałeś w pierwszym wpisie, czy ty masz jessiego. Może to nie to, ale przeinstaluj firmware-iwlwifi, jak masz jednak Debiana 9.

Sprawdź czy w /etc/apt/sources.list masz na końcu linii z adresem głównego repo non-free. Odinstaluj stary.
Jeżeli firmware-linux-nonfree instalowałeś tak samo jak firmware-iwlwifi, to też go odinstaluj i ewentualnie zainstaluj z repo.

Kod:

apt-get update && apt-get purge firmware-iwlwifi firmware-linux-nonfree

Zainstaluj nowy:

Kod:

apt-get install firmware-iwlwifi

Przeładuj:

Kod:

modprobe -r iwlwifi && modprobe iwlwifi

Ostatnio edytowany przez jawojx (2017-09-12 21:42:20)

Offline

 

#29 2017-09-12 22:12:50

div
Użytkownik
Zarejestrowany: 2017-09-04

Re: failed to start raise network, problem z wifi po instalacji

po tej komendzie odlaczylem kabel modprobe -rv iwldvm, po wlaczeniu puscilem linksa i dalej request sent;/

Kod:

root@debian:/home/debian# dpkg -l | grep firmware
ii  firmware-iwlwifi                      20161130-3                        all          Binary firmware for Intel Wireless cards
root@debian:/home/debian# apt-get update && apt-get purge firmware-iwlwifi 
Hit:1 http://security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://ftp.pl.debian.org/debian stretch InRelease
Hit:3 http://ftp.pl.debian.org/debian stretch-updates InRelease
Hit:4 http://ftp.pl.debian.org/debian stretch Release
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  firmware-iwlwifi*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 46.7 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 93999 files and directories currently installed.)
Removing firmware-iwlwifi (20161130-3) ...
root@debian:/home/debian# apt-get install firmware-iwlwifi
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  firmware-iwlwifi
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/5,524 kB of archives.
After this operation, 46.7 MB of additional disk space will be used.
Selecting previously unselected package firmware-iwlwifi.
(Reading database ... 93934 files and directories currently installed.)
Preparing to unpack .../firmware-iwlwifi_20161130-3_all.deb ...
Unpacking firmware-iwlwifi (20161130-3) ...
Setting up firmware-iwlwifi (20161130-3) ...
root@debian:/home/debian# modprobe -r iwlwifi && modprobe iwlwifi
modprobe: FATAL: Module iwlwifi is in use.
root@debian:/home/debian# modprobe -rv iwldvm
rmmod iwldvm
rmmod mac80211
rmmod iwlwifi
rmmod cfg80211
root@debian:/home/debian# modprobe iwlwifi
root@debian:/home/debian# links2 www.onet.pl

Offline

 

#30 2017-09-12 22:25:58

jawojx
Użytkownik
Zarejestrowany: 2012-10-11

Re: failed to start raise network, problem z wifi po instalacji

Odłącz WIFI software/hardware, tak czy tak. W konsoli jako root:

Kod:

dmesg -w

Włącz WIFI ponownie i wklej tu te kilkanaście linii które się pojawi tylko po włączeniu wifi.
Sprawdzałeś ping teraz.

Co do links2 to zobacz tak, nie na root:

Kod:

links2 -g www.onet.pl

Ostatnio edytowany przez jawojx (2017-09-12 22:36:56)

Offline

 

#31 2017-09-12 22:44:36

div
Użytkownik
Zarejestrowany: 2017-09-04

Re: failed to start raise network, problem z wifi po instalacji

działa hah

Kod:

[ 2682.636100] iwlwifi 0000:0c:00.0: L1 Enabled - LTR Disabled
[ 2682.639296] iwlwifi 0000:0c:00.0: L1 Enabled - LTR Disabled
[ 2682.639385] iwlwifi 0000:0c:00.0: Radio type=0x1-0x2-0x0
[ 2682.750282] iwlwifi 0000:0c:00.0: L1 Enabled - LTR Disabled
[ 2682.753379] iwlwifi 0000:0c:00.0: L1 Enabled - LTR Disabled
[ 2682.753480] iwlwifi 0000:0c:00.0: Radio type=0x1-0x2-0x0
[ 2682.786979] IPv6: ADDRCONF(NETDEV_UP): wlp12s0: link is not ready
[ 2686.007053] wlp12s0: authenticate with 00:15:20:20:1d:c4
[ 2686.016117] wlp12s0: send auth to 00:15:20:20:1d:c4 (try 1/3)
[ 2686.026169] wlp12s0: authenticated
[ 2686.028097] wlp12s0: associate with 00:15:20:20:1d:c4 (try 1/3)
[ 2686.035726] wlp12s0: RX AssocResp from 00:15:20:20:1d:c4 (capab=0x411 status=0 aid=3)
[ 2686.044124] wlp12s0: associated
[ 2686.044167] IPv6: ADDRCONF(NETDEV_CHANGE): wlp12s0: link becomes ready
[ 2687.974129] IPv6: wlp12s0: IPv6 duplicate address fe80::224:d6ff:fe74:e92e detected!

jak odpale linksa to laduje, lekko wolno ale zaladowalo
teraz tez jak dodaje ten post to normalnie na wifi bez kabla



dzieki wszystkim za pomoc:))

Ostatnio edytowany przez div (2017-09-12 22:48:19)

Offline

 

#32 2017-09-13 12:21:47

jawojx
Użytkownik
Zarejestrowany: 2012-10-11

Re: failed to start raise network, problem z wifi po instalacji

@div:...jak odpale linksa to laduje, lekko wolno ale zaladowalo...

I co będziesz siedział na tym linksie i wolnym połączeniu, czy coś się zmieniło. Links był do sprawdzenia czy na tym wolnym łączu cokolwiek się załaduje.

Spróbuj w routerze wyłączyć standard b (jak nie ma urządzeń wspierających tylko b), zostaw tylko g lub mieszany g-n. Z informacji podanych od ciebie wynika że twój router nie ma zakłóceń od sąsiadów, to ustaw skrajne kanały na przykład 1. Zapisz ustawienia i po nowym połączeniu z routerem spróbuj na karcie włączyć większą przepustowość. Lista wspieranych nie zawsze się pojawia to zacznij od 54M i jak się nie załaduje, to zmniejszaj przez 48M, 36M do 24M (no można jeszcze 18M jak będą jakieś kłopoty z większymi). Jako root:

# wlp12s0 <- oczywiście twoja karta WIFI

Kod:

iwconfig wlp12s0 rate 54M

Poczekaj chwile (co najmniej 5-15s.) na zmiany, sprawdź i przetestuj internet.

Kod:

iwlist wlp12s0 bitrate

Offline

 

#33 2017-09-16 22:10:34

div
Użytkownik
Zarejestrowany: 2017-09-04

Re: failed to start raise network, problem z wifi po instalacji

nie mam dostępu do routera, musze pogadac z isp.. za jakis czas sie odezwe
wgl dziwnie, wczoraj normalnie wifi dziala na laptopie a dzisiaj z niczym sie polaczyc nie moge hah

Ostatnio edytowany przez div (2017-09-16 22:12:15)

Offline

 

#34 2017-09-17 11:41:55

jawojx
Użytkownik
Zarejestrowany: 2012-10-11

Re: failed to start raise network, problem z wifi po instalacji

@div:...nie mam dostępu do routera, musze pogadac z isp.. za jakis czas sie odezwe
wgl dziwnie, wczoraj normalnie wifi dziala na laptopie a dzisiaj z niczym sie polaczyc nie moge...

Możliwe że przydzielił parę adresów ip i coś ci zabrało przydział (telefon,tablet inny komputer). Ważne jest jak to WIFI działa na innym sprzęcie, czy tak samo ślamazarnie. Jeżeli internet działa dobrze na kablu, a źle tylko na WIFI, to kup sobie lepiej jakiś router podłącz kablem ze sprzętem operatora i będziesz niezależny na WIFI. Router np. TP-Linka z WIFI N 300 Mbps kupisz nowy za około 100zł, używany WIFI N 150 Mb/s można znaleźć za 20-30zł.

A pokaż z połączenia na kablu:

Kod:

traceroute 8.8.8.8

Offline

 

#35 2017-09-17 11:46:29

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: failed to start raise network, problem z wifi po instalacji

@div:...nie mam dostępu do routera, musze pogadac z isp.. za jakis czas sie odezwe

Czyżby Vectra albo inna kablówka?


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#36 2017-09-17 23:26:12

div
Użytkownik
Zarejestrowany: 2017-09-04

Re: failed to start raise network, problem z wifi po instalacji

traceroute na kompie podlaczonym kablem

Kod:

:~$ traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
 1  192.168.1.1 (192.168.1.1)  0.461 ms  0.648 ms  0.845 ms
 2  10.161.1.1 (10.161.1.1)  4.081 ms  4.094 ms  4.136 ms
 3  * * *
 4  xxxx-xx-xxx-xxx-x.xxx.xx (xx.xxx.xxx.x)  8.289 ms  8.290 ms  8.283 ms
 5  xxxx-xx-xxx-xxx-x.xxx.xx (xx.xxx.xxx.x)  8.620 ms  8.620 ms  8.615 ms
 6  google.ip4.epix.net.pl (195.191.170.134)  15.354 ms  12.751 ms  14.315 ms
 7  108.170.250.193 (108.170.250.193)  14.351 ms 108.170.250.209 (108.170.250.209)  13.305 ms 108.170.250.193 (108.170.250.193)  14.447 ms
 8  216.239.48.171 (216.239.48.171)  14.236 ms 72.14.239.137 (72.14.239.137)  12.976 ms 209.85.142.209 (209.85.142.209)  14.228 ms
 9  google-public-dns-a.google.com (8.8.8.8)  14.372 ms  14.367 ms  14.398 ms

"Możliwe że przydzielił parę adresów ip i coś ci zabrało przydział (telefon,tablet inny komputer)." własnie dzisiaj nie mam tylu podlaczonych urzadzen pod wifi i dzisiaj z powrotem na laptopie dziala
we wtorek pojde po nowy router
ps. isp to takie wsiowe, nie jakas taka wieksza sieciowka tylko taka miejscowa, ale nie jest taka zla haha swiatlowody z uni pociagneli i przepustowosc w stosunku do ceny jest bardzo dobra

Offline

 

#37 2017-09-18 00:04:07

div
Użytkownik
Zarejestrowany: 2017-09-04

Re: failed to start raise network, problem z wifi po instalacji

udostepnilem sobie wifi z telefonu i laptop normalnie sie laczy ze stronami, wlaczam wifi na telefonie -> lacze sie na domowe wifi na telefonie i laptopie i linux nic nie laduje.. no dramat to jest

Offline

 

#38 2017-09-18 15:16:28

jawojx
Użytkownik
Zarejestrowany: 2012-10-11

Re: failed to start raise network, problem z wifi po instalacji

Połączenie na kablu wygląda przyzwoicie, w godzinach których sprawdzałeś. Jak nie możesz dłubać w urządzeniu od operatora, zrób tak jak pisałem. Kup router xDSL (brał bym minimum WIFI N 300Mb/s z antenami zewnętrznymi), podłącz kablem z urządzeniem od operatora, ustaw wifi (tam jest na kanale 5 to ustaw na 11, ewentualnie może być pierwszy) będziesz miał kontrole nad tym i nikt nie będzie ci ograniczał podłączonych urządzeń. Oczywiście możesz zgłosić tą usterkę/ustawienia do swojego dostawcy, tylko przeczytaj warunki umowy czy nie ma w nich nic o tym.

Ostatnio edytowany przez jawojx (2017-09-18 15:22:07)

Offline

 

#39 2017-09-18 23:10:42

div
Użytkownik
Zarejestrowany: 2017-09-04

Re: failed to start raise network, problem z wifi po instalacji

bardzo dziekuje za pomoc! mam nadzieje ze juz z tym nie bedzie zadnego problemu pozniej:D

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Możesz wyłączyć AdBlock — tu nie ma reklam ;-)