Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2016-03-22 21:51:19

andrewdre
Użytkownik
Zarejestrowany: 2014-12-19

[SOLVED]OpenBSD: incron nie działa poprawnie

Żeby nie było, że tak ciągle pytam, to wiele spraw rozwiązałem sam, ale tutaj nie mam pojęcia, co powinienem zrobić więc proszę o pomoc:) Zainstalowałem incron. Wykonałem te polecenia (będąc rootem):

Kod:

nano /etc/incron.allow

dodałem tam

Kod:

root

potem:

Kod:

env EDITOR=nano incrontab -e

Dodałem prostą regułkę:

Kod:

/home/ja/testy/file12 IN_MODIFY,IN_ATTRIB /usr/local/bin/xfce4-about

"/usr/local/bin/xfce4-about" by od razu widzieć czy działa. Uruchomiłem:

Kod:

incrontab --reload
/etc/rc.d/incrond start

I niestety nie działa. Działa za to jak uruchomię polecenie

Kod:

incrond

ale też nie wszystkie parametry. Zamieszczam jeszcze plik "/etc/rc.d/incrond":

Kod:

#!/bin/sh
#
# $OpenBSD: incrond.rc,v 1.1.1.1 2016/01/23 16:06:05 landry Exp $

daemon="/usr/local/sbin/incrond"

. /etc/rc.d/rc.subr

rc_stop=NO

# sending SIGTERM is not enough, incrond is stuck on poll()
# waiting for an event - and only exits after it
#rc_stop() {
#    ${daemon} -k
#}

rc_cmd $1

Ostatnio edytowany przez andrewdre (2016-03-24 23:08:43)

Offline

 

#2 2016-03-22 22:18:45

uzytkownikubunt
Zbanowany
Zarejestrowany: 2012-04-25

Re: [SOLVED]OpenBSD: incron nie działa poprawnie

2869

Ostatnio edytowany przez uzytkownikubunt (2016-12-01 01:37:48)

Offline

 

#3 2016-03-22 22:42:13

andrewdre
Użytkownik
Zarejestrowany: 2014-12-19

Re: [SOLVED]OpenBSD: incron nie działa poprawnie

Dzięki za odpowiedź, niestety przy użyciu poleceń, które podałeś incron również nie działa. Wyświetla się

Kod:

incrond(ok)

ale incron nie reaguje na zmiany w pliku. Po uruchomieniu

Kod:

rcctl reload incrond

otrzymuję

Kod:

incrond(failed)

ale jak znowy dam start to ponownie otrzymuję

Kod:

incrond(ok)

Offline

 

#4 2016-03-22 22:53:36

uzytkownikubunt
Zbanowany
Zarejestrowany: 2012-04-25

Re: [SOLVED]OpenBSD: incron nie działa poprawnie

2870

Ostatnio edytowany przez uzytkownikubunt (2016-12-01 01:37:50)

Offline

 

#5 2016-03-23 00:31:50

andrewdre
Użytkownik
Zarejestrowany: 2014-12-19

Re: [SOLVED]OpenBSD: incron nie działa poprawnie

Zacząłem od polecenia

Kod:

incrond

I wtedy xfce4-about się uruchamiał. Gdy zmieniłem na

Kod:

/etc/rc.d/incrond start

wtedy już nie i to mnie zmyliło. Masz rację problem jest pewnie w tym, że aplikacja jest pod X-serwer. Zmieniłem na wysyłanie maila gdy nastąpi zmiana w pliku i maile dochodzą. W logu incrona można znaleźć

Kod:

host incrond[3150]: (root) CMD (/usr/local/bin/xfce4-about)

Będę miał nauczkę, żeby sprawdzać logi :) Mam do Ciebie jeszcze pytanie: czy jest możliwość, by jednak xfce4-about był uruchamiany przez incrona (lub jakiekolwiek okienko)?

A tak w ogóle to jest jakaś alternatywa dla incrona na OpenBSD- aplikacja, która będzie mnie informować o zmianie w pliku?

Ostatnio edytowany przez andrewdre (2016-03-23 00:46:59)

Offline

 

#6 2016-03-23 01:02:33

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: [SOLVED]OpenBSD: incron nie działa poprawnie

Ja sobie kiedyś naskrobałem takie conieco do powiadomień udeva (siedzi sobie jako /usr/local/bin/udevmess):

Kod:

#!/bin/bash

MESSAGE="$*"

 for NUMBER in `ls /tmp/.X11-unix | awk -F"X" '{print $2}'`; do env DISPLAY=":$NUMBER"  notify-send -t 50000  "${MESSAGE}";  done;

Pewnie da się to przerobić na xfce4-about, kdialog, zenity, matedialog,
czy co tam potrzebujesz.

Zauważ tylko, że u mnie udev odpala notify-snd z roota, jak chcesz zrzucanie uprawnień i start z konta pacjenta, to możesz użyć sudo.

Żeby na Xserwer docierały komunikaty z konsoli musiałem dać do skryptów startowych :

Kod:

xhost local:+

Wygląda to tak:

Kod:

 cat  ~/.config/autostart/xhost.desktop 

[Desktop Entry]
Type=Application
Exec=xhost local:+
Hidden=false
X-GNOME-Autostart-enabled=true
Name[pl_PL]=xhost+
Name=xhost+
Comment[pl_PL]=
Comment=
X-MATE-Autostart-enabled=true

Rezultat polecenia:

Kod:

xhost local:+
non-network local connections being added to access control list

EDIT:

A tak w ogóle to jest jakaś alternatywa dla incrona na OpenBSD- aplikacja, która będzie mnie informować o zmianie w pliku?

Możesz oskrypcić inotifywait albo inotifywatch, albo poszukać czegoś gotowego, np:
https://github.com/gregghz/Watcher

Albo np Perlem:
http://blogs.perl.org/users/smash/2010/07/watching- … ew-files.html

Pozdro
;-)

Ostatnio edytowany przez Jacekalex (2016-03-23 01:40:22)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#7 2016-03-23 17:25:00

andrewdre
Użytkownik
Zarejestrowany: 2014-12-19

Re: [SOLVED]OpenBSD: incron nie działa poprawnie

Kod:

export DISPLAY=:0 && /usr/local/bin/xfce4-about

i działa:)
Dzięki za pomoc:)

Offline

 

#8 2016-03-23 17:31:09

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: [SOLVED]OpenBSD: incron nie działa poprawnie

Niekoniecznie i nie zawsze, Xorg czasem dostaje humorów, i potrafi wstać na ekranie :1 albo nawet :2. tak bywało u mnie.

Dlatego numer ekranu jest czesany z /tmp/.x11-unix/*, żeby zawsze się otworzyło, niezależnie od humorów Xorga.

Pozdro
;-)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#9 2016-03-23 20:25:17

andrewdre
Użytkownik
Zarejestrowany: 2014-12-19

Re: [SOLVED]OpenBSD: incron nie działa poprawnie

Załóżmy, że Xorg uruchamia się na ekranie :2. Jaka jest wtedy zawartość folderu "/tmp/.x11-unix/"- "X2" czy "X0, X1, X2"?

Ostatnio edytowany przez andrewdre (2016-03-23 20:25:47)

Offline

 

#10 2016-03-23 23:00:52

uzytkownikubunt
Zbanowany
Zarejestrowany: 2012-04-25

Re: [SOLVED]OpenBSD: incron nie działa poprawnie

2872

Ostatnio edytowany przez uzytkownikubunt (2016-12-01 01:37:52)

Offline

 

#11 2016-03-24 22:11:38

andrewdre
Użytkownik
Zarejestrowany: 2014-12-19

Re: [SOLVED]OpenBSD: incron nie działa poprawnie

Dzięki:) Czyli najlepszy będzie skrypt, który zamieścił Jacekalex i który niepotrzebnie chciałem modyfikować. Chciałbym jeszcze spytać, czy da się ten skrypt w całości wklepać do incrona? Próbuję:

Kod:

for NUMBER in `ls /tmp/.X11-unix | awk -F"X" '{print $2}'`; do env DISPLAY=":$NUMBER" /usr/local/bin/xfce4-about;  done;

log incrona

Kod:

(root) CMD (for NUMBER in `ls /tmp/.X11-unix | awk -F"X" '{print 2}'`; do env DISPLAY=":NUMBER" /usr/local/bin/xfce4-about;  done;)
: cannot exec process: No such file or directory

Polecenie działa w terminalu, a w incronie nie.

Offline

 

#12 2016-03-24 22:26:21

uzytkownikubunt
Zbanowany
Zarejestrowany: 2012-04-25

Re: [SOLVED]OpenBSD: incron nie działa poprawnie

2875

Ostatnio edytowany przez uzytkownikubunt (2016-12-01 01:37:56)

Offline

 

#13 2016-03-24 22:28:20

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: [SOLVED]OpenBSD: incron nie działa poprawnie

Zostaw sobie skrypta w /usr/local/bin - różne programy mogą potem z niego korzystać podając jako argument wiadomość do przekazania do środowiska graficznego.
Ja go napisałem do udeva, ale też znalazł zastosowanie w paru innych rzeczach, np wyświetlaniem info z jednego robocika w perlu, który sobie siedzi w systemie odpalany przez daemontools i odbiera wiadomości przychodzące przez jabbera od "kolegów".

Ostatnio edytowany przez Jacekalex (2016-03-24 22:29:13)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#14 2016-03-24 23:08:18

andrewdre
Użytkownik
Zarejestrowany: 2014-12-19

Re: [SOLVED]OpenBSD: incron nie działa poprawnie

Wrzucam do /usr/local/bin i problem rozwiązany :) Dziękuję bardzo za pomoc Panowie :)

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Możesz wyłączyć AdBlock — tu nie ma reklam ;-)