Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundacji Dzieciom zdazyć z Pomocą.
Więcej informacji na dug.net.pl/pomagamy/.

#1  2019-09-01 01:39:11

  nastymajestic - Nowy użytkownik

nastymajestic
Nowy użytkownik
Skąd: Łódź
Zarejestrowany: 2019-09-01

Update z Debian Squeeze na wyższe wersje

No cześć,

Jestem tu świeżynką i mam pewien problem.

Otóż nadzoruję pewien serwer który jest... super staruszkiem. Wcześniejsi admini zrobili straszny syf, nie do końca dbali o aktualizacje ani archiwizację systemu ani tego co jest na serwerze.

Pytań mam kilka, dużo błędów, dużo zabawy.

1. Czy mogę zrobić update ze Squeeze 6 na Buster 10 czy lepiej robić to po kolei wersjami(czyli z 6 na 7, z 7 na 8 itd.)?
2. Czy na Squeeze da radę mieć szyfrowanie OpenPGP? (Generalnie podczas aktualizacji na np. Jessie, krzyczy błąd gpg: no valid OpenPGP data found)
3. Co ciekawe, próbowałam zrobić na Squeeze PGP ale miałam błąd PGP: Not enough random bytes available. Please do some other work to give the OS a chance to collect more entropy Czy da radę to jakoś obejść?

Uprzedzając komentarze, tak, Googlowałam jak dzika przez dobre 4h i walczyłam z błędami, po update do chociażby WHEEZY totalnie wywalił mi się serwer że nie odpalał lsb_release i użyłam snapshota aby przywrócić serwer do stanu przed eksperymentacją.

Wszelka pomoc baaardzo mile widziana.

Ostatnio edytowany przez nastymajestic (2019-09-01 01:40:31)

Offline

 

#2  2019-09-01 03:18:43

  Pavlo950 - człowiek pasjonat :D

Pavlo950
człowiek pasjonat :D
Zarejestrowany: 2012-02-20
Serwis

Re: Update z Debian Squeeze na wyższe wersje

nastymajestic napisał(-a):

1. Czy mogę zrobić update ze Squeeze 6 na Buster 10 czy lepiej robić to po kolei wersjami(czyli z 6 na 7, z 7 na 8 itd.)?

Zdecydowanie z wersji na wersję. Dłużej, ale być może nieco mniej problemów. Co do reszty, nie mam pojęcia.

Offline

 

#3  2019-09-01 08:59:26

  urbinek - Użytkownik

urbinek
Użytkownik
Skąd: Sosnowiec
Zarejestrowany: 2009-10-01
Serwis

Re: Update z Debian Squeeze na wyższe wersje

nastymajestic napisał(-a):

1. Czy mogę zrobić update ze Squeeze 6 na Buster czy lepiej robić to po kolei wersjami(czyli z 6 na 7, z 7 na 8 itd.)?

https://www.debian.org/releases/stable/i386/release-notes/ch-upgrading.pl.html napisał(-a):

Direct upgrades from Debian releases older than 9 (stretch) are not supported. Please follow the instructions in the Release Notes for Debian 9 to upgrade to Debian 9 first.

Więc trzeba po kolei

nastymajestic napisał(-a):

2. Czy na Squeeze da radę mieć szyfrowanie OpenPGP? (Generalnie podczas aktualizacji na np. Jessie, krzyczy błąd gpg: no valid OpenPGP data found)

Ciężko nie mieć, sporo aplikacji na tym bazuje. Jeśli to jest jsqueeze to obstawiam, że klucze sa turbo stare i zostały usunięte po stronie serwerów, jeśli jeszcze istnieją.

Spróbuj https://askubuntu.com/questions/1054697/gpg-no-vali … und-in-ubuntu

nastymajestic napisał(-a):

3. Co ciekawe, próbowałam zrobić na Squeeze PGP ale miałam błąd PGP: Not enough random bytes available. Please do some other work to give the OS a chance to collect more entropy Czy da radę to jakoś obejść?

Serwer cierpi na brak entropii, z czasem jego działania powinno być jej więcej alr może bug w jakiekst antycznej apce?

Na desktopiee wystarczy przejechać twarzą po klawiaturze parę razy ale na serwerze spróbuj rng-tools
https://wiki.archlinux.org/index.php/Rng-tools

No i reboot by się przydał




Co do całego projektu - co tam jest uruchomione? Moze łatwiej postawić nowy serwer i zmigrowac konfig?


A w wolnym czasie, robię noże :)
http://nginx.urbinek.eu/_photos/signature.png

Online

 

#4  2019-09-01 09:46:31

  andreq - Członek DUG

andreq
Członek DUG
Skąd: Nisko
Zarejestrowany: 2005-01-11

Re: Update z Debian Squeeze na wyższe wersje

Urbinek mnie wyprzedził...

Zamiast rng-tools można zastosować haveged jest w backportach Squeeze.

Przyłączam się do pytania urbinka (odmienia się czy nie ;-) ) Co na tym jest, żeby marnować tyle czasu na aktualizację przez 4 wydania, a i tak pewnie trzeba będzie coś dostosować do Bustera?

Offline

 

#5  2019-09-01 10:26:51

  nastymajestic - Nowy użytkownik

nastymajestic
Nowy użytkownik
Skąd: Łódź
Zarejestrowany: 2019-09-01

Re: Update z Debian Squeeze na wyższe wersje

Właśnie miałam pisać:

Używałam rng-tools oraz haveged. Przy rng tools właśnie jest brak entropii, haveged nie chce się zainstalować.

Zapomniałam napisać czemu nie mogę ot tak zaorać tego serwera i postawić na nowo.
Otóż,
1. serwer jest uczelni, mam dostęp do niego z VMWare przez połączenie VPN z siecią uczelni,
2. na serwerze znajduje się cały GSuite Stowarzyszenia Studentów BEST Łódź gdzie jestem adminem,
3. strona Akademickich Targów Pracy, ma ustawione DNSy więc jest mały z tym problem. Ja jestem adminem a Biuro Karier uczelni jest redaktorem tej strony i jeśli coś spartole, psy na mnie są wieszane ALE nowa strona jest w przygotowaniu więc może i wizja "zaorania i postawienia na nowo" jest bliżej, tyle że strona miała być ukończona przez firmę w marcu, mamy wrzesień :))))))
4. Strona SS BEST PŁ ale o nią się nie martwię bo to jest zwykły html gdzie jest z proxy ustawione i sobie leci

Dodatkowo jeszcze jest baza phpMyAdmin do strony ATP i BEST.

Generalnie na serwerze znajduje się nieuprzątnięty syf sprzed ponad dekady. Strona ATP jest w 3 różnych folderach, nie wiadomo co ruszyć a co nie.

Ostatnio edytowany przez nastymajestic (2019-09-01 10:28:35)

Offline

 

#6  2019-09-01 12:19:46

  urbinek - Użytkownik

urbinek
Użytkownik
Skąd: Sosnowiec
Zarejestrowany: 2009-10-01
Serwis

Re: Update z Debian Squeeze na wyższe wersje

nastymajestic napisał(-a):

Używałam rng-tools oraz haveged. Przy rng tools właśnie jest brak entropii, haveged nie chce się zainstalować.

Alle rngd jest własnie do tworzenia entriopii. Pokaż log z dmesga czy tej aplikacji jestli jest

nastymajestic napisał(-a):

Generalnie na serwerze znajduje się nieuprzątnięty syf sprzed ponad dekady. Strona ATP jest w 3 różnych folderach, nie wiadomo co ruszyć a co nie.

To doskonały moment aby ten syf sprzątnać :D


A w wolnym czasie, robię noże :)
http://nginx.urbinek.eu/_photos/signature.png

Online

 

#7  2019-09-01 22:56:28

  urbinek - Użytkownik

urbinek
Użytkownik
Skąd: Sosnowiec
Zarejestrowany: 2009-10-01
Serwis

Re: Update z Debian Squeeze na wyższe wersje

Co do entriopii zobacz jeszcze to
https://www.certdepot.net/rhel7-get-started-random-number-generator/

Może vmware nie dostarcza odpowiednio rng?


A w wolnym czasie, robię noże :)
http://nginx.urbinek.eu/_photos/signature.png

Online

 

#8  2019-09-01 23:31:28

  nastymajestic - Nowy użytkownik

nastymajestic
Nowy użytkownik
Skąd: Łódź
Zarejestrowany: 2019-09-01

Re: Update z Debian Squeeze na wyższe wersje

Dzięki za porady, jutro po południu posprawdzam wszystko i dam znać :)

Offline

 

#9  2019-09-03 09:33:51

  nastymajestic - Nowy użytkownik

nastymajestic
Nowy użytkownik
Skąd: Łódź
Zarejestrowany: 2019-09-01

Re: Update z Debian Squeeze na wyższe wersje

Update sytuacji.

Po rozmowie z adminami co zarządzają Centrum Komputerowym uczelni, są mi w stanie dać nową maszynę gdzie będę mogła zainstalować od nowa wszystko aka rehosting, czyli najwidoczniej wizja zaorania i reinstalacji jest bliżej niż myślałam :D Dzisiaj myślę że też będę kombinowała z tym PGP co wyżej mi doradziliście w razie czego.

Offline

 

#10  2019-09-03 09:48:18

  loms - Użytkownik

loms
Użytkownik
Skąd: Tarnowskie Góry
Zarejestrowany: 2007-07-20
Serwis

Re: Update z Debian Squeeze na wyższe wersje

nastymajestic napisał(-a):

1. Czy mogę zrobić update ze Squeeze 6 na Buster 10 czy lepiej robić to po kolei wersjami(czyli z 6 na 7, z 7 na 8 itd.)?

Nie możesz zrobić. Musisz zainstalować na nowo Buster i skonfigurować go podobnie jak Squeeze.


Prawo jest jak płot, wąż się prześlizgnie, tygrys przeskoczy a bydło się nie rozbiega.

Offline

 

#11  2019-09-06 19:10:03

  hi - Użytkownik

hi
Użytkownik
Zarejestrowany: 2016-03-24

Re: Update z Debian Squeeze na wyższe wersje

najmajestatyczniej napisał(-a):

Otóż nadzoruję pewien serwer który jest... super staruszkiem. Wcześniejsi admini zrobili straszny syf, nie do końca dbali o aktualizacje ani archiwizację systemu ani tego co jest na serwerze.

'nastymajestic" napisał(-a):

Czy mogę zrobić update ze Squeeze 6 na Buster 10 czy lepiej robić to po kolei wersjami(czyli z 6 na 7, z 7 na 8 itd.)?

z wyszczególnieniem:

najmajestatyczniej napisał(-a):

Wcześniejsi admini zrobili straszny syf

....

najmajestatyczniej napisał(-a):

Czy mogę zrobić update ze Squeeze 6 na Buster 10

ktoś coś spierdolił według Ciebie ale pomimo to ciągniesz to dalej? hm ciekawe ciekawe...

Ostatnio edytowany przez hi (2019-09-06 21:22:30)


"Jeśli wolność słowa w ogóle coś oznacza, to oznacza prawo do mówienia ludziom tego, czego nie chcą słyszeć."
Eric Arthur Blair

Offline

 

#12  2019-09-11 08:16:20

  loms - Użytkownik

loms
Użytkownik
Skąd: Tarnowskie Góry
Zarejestrowany: 2007-07-20
Serwis

Re: Update z Debian Squeeze na wyższe wersje

W Debianie jest root i kto jest nim ma dostęp do całego serwera i nikt nie może mieć takich praw w systemie. Praca administratora to jest instalacja i konfiguracja nowego serwera. Jak wspierany jest Debian wiedzą wszyscy, żyje kilka lat po tym czasie trzeba wszystko zrobić na nowo, trzeba mieć dokumentację do starej wersji i ją poprawić i wdrożyć na nowej wersji.
Z doświadczenia wiem, że w ogromnych firmach jest stara wersja Debiana na serwerach i to jest problem i to powoduje problemy i czasami nawet płoną serwerownie.


Prawo jest jak płot, wąż się prześlizgnie, tygrys przeskoczy a bydło się nie rozbiega.

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
To nie jest tylko forum, to nasza mała ojczyzna ;-)