Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#26 2017-10-28 00:11:29

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

yossarian napisał(-a):

Zasada jest generalnie taka sama — ustawienie priorytetu powyżej 1000 oznacza instalację pakietu nawet wtedy, gdy wymaga to jego cofnięcia

Priorytety obecnie ustawia się w plikach konfiguracyjnych znajdujących się w /etc/apt/preferences.d/, ale /etc/apt/preferences też będzie ok (szczególnie, że starsza wersja Debiana).

Dzięki za wyjaśnienie. Ta opcja z "cofaniem" chyba na razie zdaje się łatwiejsza u mnie do zrobienia, ponieważ mam 3 obrazy iso Jessie, więc mogę łatwo zrobić cofnięcie, a przy moim nędznym łączu obawiam się przerwania połączenia i przeraża mnie czas jaki może trwać pobieranie pakietów do aktualizacji do Stretcha. Zastanawiam się tylko, czy cofając do Jessie lepiej do sources.list dodać 3 obrazy iso jako cdromy, czy lepiej zrobić lokalne repozytorium.

Chociaż teraz tak po namyśle, to nie wiem, czy mimo wszystko nie da się łatwo cofnąć przez repozytoria z internetu. W sumie skoro mam już pakiety w systemie Jessie, to przecież podczas "dist-upgrade" większości cofać nie trzeba będzie, więc się pewnie pobierać też nie będą.

Ostatnio edytowany przez pltvgz20 (2017-10-28 00:16:53)

Offline

 

#27 2017-10-28 10:53:29

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Drukarka Brother HL-2035 sterownik nie działa

Możesz zrobić tak:

Kod:

apt-get dist-upgrade -dV

To tylko wyświetli zmiany wersji pakietów i pobierze je z serwerów do późniejszej aktualizacji.

Pobieranie możesz w każdej chwili przerywać i wznawiać.
Gdy już wszystko zostanie pobrane, możesz normalnie zaktualizować system (w twoim przypadku będzie to cofnięcie pakietów) poprzez usunięcie przełącznika -d (download only).

Offline

 

#28 2017-10-28 17:07:27

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

yossarian napisał(-a):

Możesz zrobić tak:

Kod:

apt-get dist-upgrade -dV

To tylko wyświetli zmiany wersji pakietów i pobierze je z serwerów do późniejszej aktualizacji.

Pobieranie możesz w każdej chwili przerywać i wznawiać.
Gdy już wszystko zostanie pobrane, możesz normalnie zaktualizować system (w twoim przypadku będzie to cofnięcie pakietów) poprzez usunięcie przełącznika -d (download only).

O, czyli mógłbym też zrobić tak, że pobrałbym jedynie pierwszy obraz iso "Stretcha", potem dodał go do "sources.list", wpisał tę komendę bez połączenia z Internetem i jak by sobie z tego iso wszystkie pobrał, to by oznaczało, że mi pozostałe dwie płyty niepotrzebne?

Ostatnio edytowany przez pltvgz20 (2017-10-28 17:08:12)

Offline

 

#29 2017-10-28 17:15:55

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Drukarka Brother HL-2035 sterownik nie działa

A po cholerę ci obraz Stretcha przy cofaniu do Jessie?

W ogóle co to za pomysł by pobierać cały obraz płyty by coś zainstalować? Rzadko kiedy pobierane pakiety zajmują razem powyżej 700MB by to w ogóle miało jakikolwiek sens.

Miałeś tylko sprawdzić ile i jakich pakietów potrzeba pobrać.

Offline

 

#30 2017-10-28 17:27:04

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

yossarian napisał(-a):

A po cholerę ci obraz Stretcha przy cofaniu do Jessie?

W ogóle co to za pomysł by pobierać cały obraz płyty by coś zainstalować? Rzadko kiedy pobierane pakiety zajmują razem powyżej 700MB by to w ogóle miało jakikolwiek sens.

Miałeś tylko sprawdzić ile i jakich pakietów potrzeba pobrać.

Przepraszam, może już mieszam pytania, bo w obu wątkach na forum pytam o dwie w sumie opcje: jedna to cofnąć z Jessie do Jessie, druga to zaktualizować z Jessie do Stretcha. Wszystko w sumie się rozbija o dwa problemy - jeden to grafika SiS (nie wiem czy będzie działać na Stretchu) a drugi to wolny i zrywający Internet. Obraz Jessie mam już od dawna pobrany, bo nie miałem wcześniej Debiana i zdawało mi się to najszybszym sposobem na instalację. Nie wiedziałem też które płyty będą mi potrzebne, więc pobrałem wszystkie trzy, czyli teoretycznie mogę wszystko cofnąć do Jessie bez używania Internetu w ogóle. Natomiast widzę, że aktualizacja jest wspierana (cokolwiek to znaczy?) jedynie z Jessie do Stretcha, czyli zakładam, że jeśli w ogóle mam aktualizować system, to wolę nie wpaść z czasem w taką historię, że ciężko będzie mi zaktualizować z Jessie do wersji kolejnej po Stretchu, bo aktualizacja nie będzie "wspierana". 700 mega na moim łączu to trzy godziny pobierania i zrywanie Internetu, więc dmucham na zimne, żeby problemów nie było, a tak sobie myślę, że skoro tak długo to ma się pobierać, to może wezmę gdzieś u kogoś znajomego pobiorę raz dwa obraz iso, skoro na łączu np. 100 mb będzie to trwało 4 minuty, a takie łącza chyba są już powszechne (ja straciłem dawno rachubę, mam nadzieję, że nie podaję głupoty), a mając iso gdyby mi się wywalił system, mogę go instalować nawet 20 razy w zasadzie w chwilę.

Ostatnio edytowany przez pltvgz20 (2017-10-28 17:28:59)

Offline

 

#31 2017-10-28 17:34:34

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Drukarka Brother HL-2035 sterownik nie działa

700 mega na moim łączu to trzy godziny pobierania i zrywanie Internetu, więc dmucham na zimne

Ale skąd wziąłeś te 700MB?

Ile razy trzeba powtarzać, że miałeś tylko sprawdzić ile pakietów (i ilość danych do pobrania) wymaga aktualizacja (w twoim przypadku rozumiana jako cofnięcie).
A samo pobieranie możesz sobie przerywać pińcet razy — nic to nie szkodzi bo sama realna aktualizacja (już bez pobierania pakietów) będzie później, ręcznie uruchomiona po zakończeniu tej operacji (-d — download only).

Offline

 

#32 2017-10-28 17:52:03

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

yossarian napisał(-a):

700 mega na moim łączu to trzy godziny pobierania i zrywanie Internetu, więc dmucham na zimne

Ale skąd wziąłeś te 700MB?

Ile razy trzeba powtarzać, że miałeś tylko sprawdzić ile pakietów (i ilość danych do pobrania) wymaga aktualizacja (w twoim przypadku rozumiana jako cofnięcie).
A samo pobieranie możesz sobie przerywać pińcet razy — nic to nie szkodzi bo sama realna aktualizacja (już bez pobierania pakietów) będzie później, ręcznie uruchomiona po zakończeniu tej operacji (-d — download only).

Ok, masz rację, w sumie warto sprawdzić, niepotrzebnie zakładam, że aż tak dużo trzeba będzie pobrać. Więc robię po kolei tak:

Kod:

nano /etc/apt/preferences

tam wkleiłem:

Kod:

Package: *
Pin: release o=Debian,a=oldstable
Pin-Priority: 1001

ctrl+o - zapisałem Enterem i ctrl+x, żeby wyjść z nano, wyszedłem.

moje repozytoria w tej chwili to:

Kod:

cat /etc/apt/sources.list
## podstawowe repozytorium
deb http://ftp.pl.debian.org/debian/ oldstable main contrib non-free

## uaktualnienia bezpieczeństwa
deb http://security.debian.org/ oldstable/updates main contrib non-free

## często uaktualniane pakiety, np. dotyczące
## filtrowania spamu czy skanowania antywirusowego
deb http://ftp.pl.debian.org/debian oldstable-updates main contrib non-free

deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main

deb http://ftp.de.debian.org/debian jessie main 

deb http://www.deb-multimedia.org jessie main non-free

Dobrze wszystko jest? Mogę wpisać w celu sprawdzenia ile do pobrania i ewentualnie do pobrania przed aktualizacją?:

Kod:

apt-get dist-upgrade -dV

Ostatnio edytowany przez pltvgz20 (2017-10-28 17:54:24)

Offline

 

#33 2017-10-28 17:58:29

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Drukarka Brother HL-2035 sterownik nie działa

Tę część zakomentuj:

Kod:

deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main

deb http://ftp.de.debian.org/debian jessie main 

deb http://www.deb-multimedia.org jessie main non-free

i zapomniałeś o:

Kod:

apt-get update

Offline

 

#34 2017-10-28 18:05:58

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

yossarian napisał(-a):

Tę część zakomentuj:

Kod:

deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main

deb http://ftp.de.debian.org/debian jessie main 

deb http://www.deb-multimedia.org jessie main non-free

i zapomniałeś o:

Kod:

apt-get update

Czyli, że mam powiedzieć, co to? To z "java" to znalazłem na początku jeszcze sposób, że stamtąd można pobrać javę. To drugie niżej to tam znalazłem libfontconfig dla 32-bitów, którego nie miałem, a był potrzebny do odpalania jednego programu, a ostatnie niżej to chyba dodałem ostatnio jak chciałem jakieś kodeki pobierać, ale chyba niepotrzebnie, bo film mi działał.

Zrobiłem teraz:

Kod:

apt-get update

Wykreślić tamte wpisy z sources.list i zrobić jeszcze raz apt-get update, czy mogę je instalować i robić?:

Kod:

apt-get dist-upgrade -dV

Ostatnio edytowany przez pltvgz20 (2017-10-28 18:07:47)

Offline

 

#35 2017-10-28 18:48:16

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Drukarka Brother HL-2035 sterownik nie działa

Po pierwsze: przy tego typu aktualizacjach, a w w ogóle przy cofaniu pakietów (co jest niewspierane) wszystkie lewe repozytoria się wyłącza. Dla zasady wypadałoby też wywalić lewe pakiety, ale pewnie obejdzie się bez tego. Potem apt-get update

Po drugie: o żadnej instalacji nie było mowy —  apt-get dist-upgrade -dV tylko wyświetla numery wersji i pobiera niezbędne pakiety. I na tym kończy swoje działanie.

Czemu wszystko trzeba ci 10 razy powtarzać?

Offline

 

#36 2017-10-28 19:54:52

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

yossarian napisał(-a):

Po pierwsze: przy tego typu aktualizacjach, a w w ogóle przy cofaniu pakietów (co jest niewspierane) wszystkie lewe repozytoria się wyłącza. Dla zasady wypadałoby też wywalić lewe pakiety, ale pewnie obejdzie się bez tego. Potem apt-get update

Po drugie: o żadnej instalacji nie było mowy —  apt-get dist-upgrade -dV tylko wyświetla numery wersji i pobiera niezbędne pakiety. I na tym kończy swoje działanie.

Czemu wszystko trzeba ci 10 razy powtarzać?

Sorry, to z odruchu, wyżej też napisałem podobnie, ale wyłapałem to i zmieniłem na:

Dobrze wszystko jest? Mogę wpisać w celu sprawdzenia ile do pobrania i ewentualnie do pobrania przed aktualizacją?:

Dla mnie to wszystko całkowicie nowe, ja jestem laikiem komputerowym, jeśli chodzi o Linuksa, to już w ogóle. W sumie, to gdyby XP nie skończyli wspierać i gdyby nie to, że tam antywirusy już ważą po gigabajt i tak zamulają stare komputery, to pewnie nawet samoistnie bym się nie przerzucił na Debiana, choć nie mówię, że nie jest lepiej, tylko jednak to wymaga jakiegoś zaangażowania, a ja też niespecjalnie wskakuję o poziom wyżej, bo póki mi coś działa, to w temacie komputera nie siedzę, dopiero jak przestaje, to zaczynam szukać i pytać, a tak to komputer tylko do codzienności mi służy. Więc wiesz, jedno Twoje zdanie, to dla mnie często pięć nowych informacji, które jak widzę pierwszy, czy trzeci raz nawet, to jeszcze mnóstwo rzeczy mi się miesza. Dla kogoś, kto sporo więcej wie, pewnie jest to irytujące, ale co złego to nie ja - postaram się jak najlepiej ogarniać porady, nie gniewaj się. :)

Wywaliłem te wpisy, co mówiłeś, soruces.list wygląda teraz tak:

Kod:

cat /etc/apt/sources.list
## podstawowe repozytorium
deb http://ftp.pl.debian.org/debian/ oldstable main contrib non-free

## uaktualnienia bezpieczeństwa
deb http://security.debian.org/ oldstable/updates main contrib non-free

## często uaktualniane pakiety, np. dotyczące
## filtrowania spamu czy skanowania antywirusowego
deb http://ftp.pl.debian.org/debian oldstable-updates main contrib non-free

Kod:

apt-get update

zrobiłem już na takim stanie sources.list. Myślę, że już tu nic zepsuć nie mogę teraz, więc daję:

Kod:

apt-get dist-upgrade -dV

Ostatnio edytowany przez pltvgz20 (2017-10-28 19:56:05)

Offline

 

#37 2017-10-28 19:59:50

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

Dostałem taką zwrotkę:

Kod:

Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Obliczanie aktualizacji...Gotowe
Następujące pakiety zostaną zaktualizowane:
   google-chrome-stable (61.0.3163.100-1 => 62.0.3202.75-1)
   libcurl3 (7.38.0-4+deb8u6 => 7.38.0-4+deb8u7)
   libcurl3-gnutls (7.38.0-4+deb8u6 => 7.38.0-4+deb8u7)
   opera-stable (48.0.2685.39 => 48.0.2685.52)
   wget (1.16-1+deb8u2 => 1.16-1+deb8u4)
   xserver-common (1.16.4-1+deb8u1 => 1.16.4-1+deb8u2)
   xserver-xephyr (1.16.4-1+deb8u1+b1 => 1.16.4-1+deb8u2)
   xserver-xorg-core (1.16.4-1+deb8u1+b1 => 1.16.4-1+deb8u2)
   xwayland (1.16.4-1+deb8u1+b1 => 1.16.4-1+deb8u2)
9 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
Konieczne pobranie 110 MB archiwów.
Po tej operacji zostanie zwolnione 88,6 MB miejsca na dysku.
Kontynuować? [T/n]

110 mega to niedużo, więc niech sobie leci z Internetu nawet na tak wolnym łączu, ale czy to, że chce aktualizować "w górę", a nie "w dół", np.

Kod:

google-chrome-stable (61.0.3163.100-1 => 62.0.3202.75-1)

(z wersji 61 na 62) to znaczy, że wszystko jest ok?

Ostatnio edytowany przez pltvgz20 (2017-10-28 20:00:22)

Offline

 

#38 2017-10-28 21:00:07

arecki
Użytkownik
Zarejestrowany: 2016-03-03

Re: Drukarka Brother HL-2035 sterownik nie działa

Pewnie masz dodatkowe listy w /etc/apt/sources.list.d/

Offline

 

#39 2017-10-28 21:36:35

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Drukarka Brother HL-2035 sterownik nie działa

Pokaż wynik:

Kod:

apt-cache policy

Offline

 

#40 2017-10-28 22:22:24

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

arecki napisał(-a):

Pewnie masz dodatkowe listy w /etc/apt/sources.list.d/

Chyba tak - jest tam takie coś:

Kod:

ls /etc/apt/sources.list.d
google-chrome.list  opera-stable.list  skype-stable.list

Wywalić te pliki z tego folderu? (Jak tak, to skopiować je gdzie indziej?)

Ostatnio edytowany przez pltvgz20 (2017-10-28 22:28:29)

Offline

 

#41 2017-10-28 22:23:21

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

yossarian napisał(-a):

Pokaż wynik:

Kod:

apt-cache policy

Kod:

apt-cache policy
Plików pakietów:
 100 /var/lib/dpkg/status
     release a=now
 500 https://repo.skype.com/deb/ stable/main amd64 Packages
     release o=. stable,a=stable,n=stable,l=. stable,c=main
     origin repo.skype.com
 500 https://deb.opera.com/opera-stable/ stable/non-free i386 Packages
     release o=Opera Software ASA,a=stable,n=stable,l=The Opera web browser,c=non-free
     origin deb.opera.com
 500 https://deb.opera.com/opera-stable/ stable/non-free amd64 Packages
     release o=Opera Software ASA,a=stable,n=stable,l=The Opera web browser,c=non-free
     origin deb.opera.com
 500 http://dl.google.com/linux/chrome/deb/ stable/main amd64 Packages
     release v=1.0,o=Google, Inc.,a=stable,n=stable,l=Google,c=main
     origin dl.google.com
 500 http://ftp.pl.debian.org/debian/ oldstable-updates/non-free Translation-en
 500 http://ftp.pl.debian.org/debian/ oldstable-updates/main Translation-en
 500 http://ftp.pl.debian.org/debian/ oldstable-updates/contrib Translation-en
 500 http://ftp.pl.debian.org/debian/ oldstable-updates/non-free i386 Packages
     release o=Debian,a=oldstable-updates,n=jessie-updates,l=Debian,c=non-free
     origin ftp.pl.debian.org
 500 http://ftp.pl.debian.org/debian/ oldstable-updates/contrib i386 Packages
     release o=Debian,a=oldstable-updates,n=jessie-updates,l=Debian,c=contrib
     origin ftp.pl.debian.org
 500 http://ftp.pl.debian.org/debian/ oldstable-updates/main i386 Packages
     release o=Debian,a=oldstable-updates,n=jessie-updates,l=Debian,c=main
     origin ftp.pl.debian.org
 500 http://ftp.pl.debian.org/debian/ oldstable-updates/non-free amd64 Packages
     release o=Debian,a=oldstable-updates,n=jessie-updates,l=Debian,c=non-free
     origin ftp.pl.debian.org
 500 http://ftp.pl.debian.org/debian/ oldstable-updates/contrib amd64 Packages
     release o=Debian,a=oldstable-updates,n=jessie-updates,l=Debian,c=contrib
     origin ftp.pl.debian.org
 500 http://ftp.pl.debian.org/debian/ oldstable-updates/main amd64 Packages
     release o=Debian,a=oldstable-updates,n=jessie-updates,l=Debian,c=main
     origin ftp.pl.debian.org
 500 http://security.debian.org/ oldstable/updates/non-free Translation-en
 500 http://security.debian.org/ oldstable/updates/main Translation-en
 500 http://security.debian.org/ oldstable/updates/contrib Translation-en
 990 http://security.debian.org/ oldstable/updates/non-free i386 Packages
     release v=8,o=Debian,a=oldstable,n=jessie,l=Debian-Security,c=non-free
     origin security.debian.org
 990 http://security.debian.org/ oldstable/updates/contrib i386 Packages
     release v=8,o=Debian,a=oldstable,n=jessie,l=Debian-Security,c=contrib
     origin security.debian.org
 990 http://security.debian.org/ oldstable/updates/main i386 Packages
     release v=8,o=Debian,a=oldstable,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 990 http://security.debian.org/ oldstable/updates/non-free amd64 Packages
     release v=8,o=Debian,a=oldstable,n=jessie,l=Debian-Security,c=non-free
     origin security.debian.org
 990 http://security.debian.org/ oldstable/updates/contrib amd64 Packages
     release v=8,o=Debian,a=oldstable,n=jessie,l=Debian-Security,c=contrib
     origin security.debian.org
 990 http://security.debian.org/ oldstable/updates/main amd64 Packages
     release v=8,o=Debian,a=oldstable,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 500 http://ftp.pl.debian.org/debian/ oldstable/non-free Translation-en
 500 http://ftp.pl.debian.org/debian/ oldstable/main Translation-pl
 500 http://ftp.pl.debian.org/debian/ oldstable/main Translation-en
 500 http://ftp.pl.debian.org/debian/ oldstable/contrib Translation-en
 990 http://ftp.pl.debian.org/debian/ oldstable/non-free i386 Packages
     release v=8.9,o=Debian,a=oldstable,n=jessie,l=Debian,c=non-free
     origin ftp.pl.debian.org
 990 http://ftp.pl.debian.org/debian/ oldstable/contrib i386 Packages
     release v=8.9,o=Debian,a=oldstable,n=jessie,l=Debian,c=contrib
     origin ftp.pl.debian.org
 990 http://ftp.pl.debian.org/debian/ oldstable/main i386 Packages
     release v=8.9,o=Debian,a=oldstable,n=jessie,l=Debian,c=main
     origin ftp.pl.debian.org
 990 http://ftp.pl.debian.org/debian/ oldstable/non-free amd64 Packages
     release v=8.9,o=Debian,a=oldstable,n=jessie,l=Debian,c=non-free
     origin ftp.pl.debian.org
 990 http://ftp.pl.debian.org/debian/ oldstable/contrib amd64 Packages
     release v=8.9,o=Debian,a=oldstable,n=jessie,l=Debian,c=contrib
     origin ftp.pl.debian.org
 990 http://ftp.pl.debian.org/debian/ oldstable/main amd64 Packages
     release v=8.9,o=Debian,a=oldstable,n=jessie,l=Debian,c=main
     origin ftp.pl.debian.org
Przypięte pakiety:

Offline

 

#42 2017-10-28 22:36:20

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Drukarka Brother HL-2035 sterownik nie działa

Nie masz tam priorytetów powyżej 1000.
Prawdopodobnie ustawiłeś kiedyś APT::Default-Release

Pokaz jeszcze wynik:

Kod:

apt-config dump

Offline

 

#43 2017-10-28 22:49:35

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

yossarian napisał(-a):

Nie masz tam priorytetów powyżej 1000.
Prawdopodobnie ustawiłeś kiedyś APT::Default-Release

Pokaz jeszcze wynik:

Kod:

apt-config dump

Ciężko mi powiedzieć coś odnośnie "APT::Default-Release" - nie kojarzę tego. I nie sięgam pamięcią, jak to się ustawia, więc może to się jakoś "automatycznie" ustawiło? A za priorytety tam to jaki plik odpowiada i gdzie zlokalizowany? Też go się tworzy według wzoru, który podałeś?

Kod:

apt-config dump
APT "";
APT::Architecture "amd64";
APT::Build-Essential "";
APT::Build-Essential:: "build-essential";
APT::Install-Recommends "true";
APT::Install-Suggests "0";
APT::Authentication "";
APT::Authentication::TrustCDROM "true";
APT::NeverAutoRemove "";
APT::NeverAutoRemove:: "^firmware-linux.*";
APT::NeverAutoRemove:: "^linux-firmware$";
APT::NeverAutoRemove:: "^linux-image-3\.16\.0-4-amd64$";
APT::NeverAutoRemove:: "^linux-headers-3\.16\.0-4-amd64$";
APT::NeverAutoRemove:: "^linux-image-extra-3\.16\.0-4-amd64$";
APT::NeverAutoRemove:: "^linux-signed-image-3\.16\.0-4-amd64$";
APT::NeverAutoRemove:: "^kfreebsd-image-3\.16\.0-4-amd64$";
APT::NeverAutoRemove:: "^kfreebsd-headers-3\.16\.0-4-amd64$";
APT::NeverAutoRemove:: "^gnumach-image-3\.16\.0-4-amd64$";
APT::NeverAutoRemove:: "^.*-modules-3\.16\.0-4-amd64$";
APT::NeverAutoRemove:: "^.*-kernel-3\.16\.0-4-amd64$";
APT::NeverAutoRemove:: "^linux-backports-modules-.*-3\.16\.0-4-amd64$";
APT::NeverAutoRemove:: "^linux-tools-3\.16\.0-4-amd64$";
APT::VersionedKernelPackages "";
APT::VersionedKernelPackages:: "linux-image";
APT::VersionedKernelPackages:: "linux-headers";
APT::VersionedKernelPackages:: "linux-image-extra";
APT::VersionedKernelPackages:: "linux-signed-image";
APT::VersionedKernelPackages:: "kfreebsd-image";
APT::VersionedKernelPackages:: "kfreebsd-headers";
APT::VersionedKernelPackages:: "gnumach-image";
APT::VersionedKernelPackages:: ".*-modules";
APT::VersionedKernelPackages:: ".*-kernel";
APT::VersionedKernelPackages:: "linux-backports-modules-.*";
APT::VersionedKernelPackages:: "linux-tools";
APT::Never-MarkAuto-Sections "";
APT::Never-MarkAuto-Sections:: "metapackages";
APT::Never-MarkAuto-Sections:: "restricted/metapackages";
APT::Never-MarkAuto-Sections:: "universe/metapackages";
APT::Never-MarkAuto-Sections:: "multiverse/metapackages";
APT::Never-MarkAuto-Sections:: "oldlibs";
APT::Never-MarkAuto-Sections:: "restricted/oldlibs";
APT::Never-MarkAuto-Sections:: "universe/oldlibs";
APT::Never-MarkAuto-Sections:: "multiverse/oldlibs";
APT::Update "";
APT::Update::Post-Invoke-Success "";
APT::Update::Post-Invoke-Success:: "/usr/bin/test -e /usr/share/dbus-1/system-services/org.freedesktop.PackageKit.service && /usr/bin/test -S /var/run/dbus/system_bus_socket && /usr/bin/gdbus call --system --dest org.freedesktop.PackageKit --object-path /org/freedesktop/PackageKit --timeout 4 --method org.freedesktop.PackageKit.StateHasChanged cache-update > /dev/null; /bin/echo > /dev/null";
APT::Default-Release "jessie";
APT::Get "";
APT::Get::Install-Recommends "false";
APT::Get::Install-Suggests "false";
APT::Architectures "";
APT::Architectures:: "amd64";
APT::Architectures:: "i386";
APT::Compressor "";
APT::Compressor::. "";
APT::Compressor::.::Name ".";
APT::Compressor::.::Extension "";
APT::Compressor::.::Binary "";
APT::Compressor::.::Cost "1";
APT::Compressor::gzip "";
APT::Compressor::gzip::Name "gzip";
APT::Compressor::gzip::Extension ".gz";
APT::Compressor::gzip::Binary "gzip";
APT::Compressor::gzip::Cost "2";
APT::Compressor::gzip::CompressArg "";
APT::Compressor::gzip::CompressArg:: "-9n";
APT::Compressor::gzip::UncompressArg "";
APT::Compressor::gzip::UncompressArg:: "-d";
APT::Compressor::bzip2 "";
APT::Compressor::bzip2::Name "bzip2";
APT::Compressor::bzip2::Extension ".bz2";
APT::Compressor::bzip2::Binary "bzip2";
APT::Compressor::bzip2::Cost "3";
APT::Compressor::bzip2::CompressArg "";
APT::Compressor::bzip2::CompressArg:: "-9";
APT::Compressor::bzip2::UncompressArg "";
APT::Compressor::bzip2::UncompressArg:: "-d";
APT::Compressor::xz "";
APT::Compressor::xz::Name "xz";
APT::Compressor::xz::Extension ".xz";
APT::Compressor::xz::Binary "xz";
APT::Compressor::xz::Cost "4";
APT::Compressor::xz::CompressArg "";
APT::Compressor::xz::CompressArg:: "-6";
APT::Compressor::xz::UncompressArg "";
APT::Compressor::xz::UncompressArg:: "-d";
APT::Compressor::lzma "";
APT::Compressor::lzma::Name "lzma";
APT::Compressor::lzma::Extension ".lzma";
APT::Compressor::lzma::Binary "xz";
APT::Compressor::lzma::Cost "5";
APT::Compressor::lzma::CompressArg "";
APT::Compressor::lzma::CompressArg:: "--format=lzma";
APT::Compressor::lzma::CompressArg:: "-9";
APT::Compressor::lzma::UncompressArg "";
APT::Compressor::lzma::UncompressArg:: "--format=lzma";
APT::Compressor::lzma::UncompressArg:: "-d";
Dir "/";
Dir::State "var/lib/apt/";
Dir::State::lists "lists/";
Dir::State::cdroms "cdroms.list";
Dir::State::mirrors "mirrors/";
Dir::State::extended_states "extended_states";
Dir::State::status "/var/lib/dpkg/status";
Dir::Cache "var/cache/apt/";
Dir::Cache::archives "archives/";
Dir::Cache::srcpkgcache "srcpkgcache.bin";
Dir::Cache::pkgcache "pkgcache.bin";
Dir::Etc "etc/apt/";
Dir::Etc::sourcelist "sources.list";
Dir::Etc::sourceparts "sources.list.d";
Dir::Etc::vendorlist "vendors.list";
Dir::Etc::vendorparts "vendors.list.d";
Dir::Etc::main "apt.conf";
Dir::Etc::netrc "auth.conf";
Dir::Etc::parts "apt.conf.d";
Dir::Etc::preferences "preferences";
Dir::Etc::preferencesparts "preferences.d";
Dir::Etc::trusted "trusted.gpg";
Dir::Etc::trustedparts "trusted.gpg.d";
Dir::Bin "";
Dir::Bin::methods "/usr/lib/apt/methods";
Dir::Bin::solvers "";
Dir::Bin::solvers:: "/usr/lib/apt/solvers";
Dir::Bin::dpkg "/usr/bin/dpkg";
Dir::Bin::bzip2 "/bin/bzip2";
Dir::Bin::xz "/usr/bin/xz";
Dir::Bin::lzma "/usr/bin/xz";
Dir::Media "";
Dir::Media::MountPath "/media/cdrom";
Dir::Log "var/log/apt";
Dir::Log::Terminal "term.log";
Dir::Log::History "history.log";
Dir::Ignore-Files-Silently "";
Dir::Ignore-Files-Silently:: "~$";
Dir::Ignore-Files-Silently:: "\.disabled$";
Dir::Ignore-Files-Silently:: "\.bak$";
Dir::Ignore-Files-Silently:: "\.dpkg-[a-z]+$";
Dir::Ignore-Files-Silently:: "\.save$";
Dir::Ignore-Files-Silently:: "\.orig$";
Dir::Ignore-Files-Silently:: "\.distUpgrade$";
Acquire "";
Acquire::cdrom "";
Acquire::cdrom::mount "/media/cdrom";
Acquire::PDiffs "true";
Acquire::Languages "";
Acquire::Languages:: "pl_PL";
Acquire::Languages:: "pl";
Acquire::Languages:: "en";
Acquire::Languages:: "none";
DPkg "";
DPkg::Pre-Install-Pkgs "";
DPkg::Pre-Install-Pkgs:: "/usr/sbin/apt-listbugs apt";
DPkg::Pre-Install-Pkgs:: "/usr/bin/apt-listchanges --apt || test $? -ne 10";
DPkg::Pre-Install-Pkgs:: "/usr/sbin/dpkg-preconfigure --apt || true";
DPkg::Tools "";
DPkg::Tools::Options "";
DPkg::Tools::Options::/usr/sbin/apt-listbugs "";
DPkg::Tools::Options::/usr/sbin/apt-listbugs::Version "3";
DPkg::Tools::Options::/usr/sbin/apt-listbugs::InfoFD "20";
DPkg::Tools::Options::/usr/bin/apt-listchanges "";
DPkg::Tools::Options::/usr/bin/apt-listchanges::Version "2";
DPkg::Post-Invoke "";
DPkg::Post-Invoke:: "/usr/bin/test -e /usr/share/dbus-1/system-services/org.freedesktop.PackageKit.service && /usr/bin/test -S /var/run/dbus/system_bus_socket && /usr/bin/gdbus call --system --dest org.freedesktop.PackageKit --object-path /org/freedesktop/PackageKit --timeout 4 --method org.freedesktop.PackageKit.StateHasChanged cache-update > /dev/null; /bin/echo > /dev/null";
AptListbugs "";
AptListbugs::Severities "critical,grave,serious";
 "Apt::Get::Purge";
CommandLine "";
CommandLine::AsString "apt-config dump";

Ostatnio edytowany przez pltvgz20 (2017-10-28 22:54:36)

Offline

 

#44 2017-10-28 23:11:20

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Drukarka Brother HL-2035 sterownik nie działa

Kod:

APT::Default-Release "jessie";

Masz tak ustawione stąd priorytety pozostały 990 zamiast ustawionych 1001.

Kod:

grep "APT::" /etc/apt/* /etc/apt/*/*

Możesz też jeszcze pokazać wynik:

Kod:

aptitude search ~o

Offline

 

#45 2017-10-28 23:22:03

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

yossarian napisał(-a):

Kod:

APT::Default-Release "jessie";

Masz tak ustawione stąd priorytety pozostały 990 zamiast ustawionych 1001.

Kod:

grep "APT::" /etc/apt/* /etc/apt/*/*

Możesz też jeszcze pokazać wynik:

Kod:

aptitude search ~o

Kod:

grep "APT::" /etc/apt/* /etc/apt/*/*
/etc/apt/apt.conf:APT::Default-Release "jessie";
/etc/apt/apt.conf:APT::Get::Install-Recommends "false";
/etc/apt/apt.conf:APT::Get::Install-Suggests "false";
grep: /etc/apt/apt.conf.d: Jest katalogiem
grep: /etc/apt/listbugs: Jest katalogiem
grep: /etc/apt/preferences.d: Jest katalogiem
grep: /etc/apt/sources.list.d: Jest katalogiem
grep: /etc/apt/trusted.gpg.d: Jest katalogiem
/etc/apt/apt.conf.d/00trustcdrom:APT::Authentication::TrustCDROM "true";
/etc/apt/apt.conf.d/01autoremove-kernels:APT::NeverAutoRemove
/etc/apt/apt.conf.d/20packagekit:APT::Update::Post-Invoke-Success {
/etc/apt/apt.conf.d/99synaptic:APT::Install-Recommends "true";

Kod:

aptitude search ~o
i   brhl2030lpr:i386                - Brother HL-2030 LPR driver               
i   cupswrapperhl2030:i386          - Brother HL2030 CUPS wrapper driver       
i A dbus-user-session               - simple interprocess messaging system (sys
i   deb-multimedia-keyring          - GnuPG archive key of the deb-multimedia r
i   ia32-libs                       - Dummy package to fulfill package dependen
i   jre1.8.0-144                    - Java Platform Standard Edition Runtime En
i A libaacplus2                     - AAC+ encoding library - runtime files    
i A libaacplus2:i386                - AAC+ encoding library - runtime files    
i A libaudcore3                     - Audacious core engine library            
i A libc-l10n                       - GNU C Library: localization files        
i A libfdisk1                       - fdisk partitioning library               
i A libfdk-aac1                     - Fraunhofer FDK AAC codec library.        
i A libfdk-aac1:i386                - Fraunhofer FDK AAC codec library.        
i A libgnutls30                     - GNU TLS library - main runtime library   
i A libgroupsock4                   - multimedia RTSP streaming library (networ
i A libgtop-2.0-10                  - gtop system monitoring library (shared)  
i A libhogweed4                     - low level cryptographic library (public-k
i A libip4tc0                       - netfilter libip4tc library               
i A libjim0.76                      - small-footprint implementation of Tcl - s
i A liblivemedia42                  - multimedia RTSP streaming library        
i A libnettle6                      - low level cryptographic library (symmetri
i A libnm0                          - GObject-based client library for NetworkM
i A libnma0                         - library for wireless and mobile dialogs (
i   libobasis5.4-base               - Base module for LibreOffice 5.4 .1.2     
i   libobasis5.4-calc               - Calc module for LibreOffice 5.4 .1.2     
i   libobasis5.4-core               - Core module for LibreOffice 5.4 .1.2     
i   libobasis5.4-draw               - Draw module for LibreOffice 5.4 .1.2     
i   libobasis5.4-en-us              - Language module for LibreOffice 5.4, lang
i   libobasis5.4-en-us-base         - Base language module for LibreOffice 5.4,
i   libobasis5.4-en-us-calc         - Calc language module for LibreOffice 5.4,
i   libobasis5.4-en-us-math         - Math language module for LibreOffice 5.4,
i   libobasis5.4-en-us-res          - Language resource module for LibreOffice 
i   libobasis5.4-en-us-writer       - Writer language module for LibreOffice 5.
i   libobasis5.4-extension-beanshel - Script provider for BeanShell extension f
i   libobasis5.4-extension-javascri - Script provider for JavaScript extension 
i   libobasis5.4-extension-mediawik - MediaWiki publisher extension for LibreOf
i   libobasis5.4-extension-nlpsolve - NLPSolver extension for LibreOffice 5.4 .
i   libobasis5.4-extension-pdf-impo - PDF import extension for LibreOffice 5.4 
i   libobasis5.4-extension-report-b - Report Builder extension for LibreOffice 
i   libobasis5.4-firebird           - Firebird module for LibreOffice 5.4 .1.2 
i   libobasis5.4-gnome-integration  - Gnome integration module for LibreOffice 
i   libobasis5.4-graphicfilter      - Graphic filter module for LibreOffice 5.4
i   libobasis5.4-images             - Images module for LibreOffice 5.4 .1.2   
i   libobasis5.4-impress            - Impress module for LibreOffice 5.4 .1.2  
i   libobasis5.4-kde-integration    - KDE integration module for LibreOffice 5.
i   libobasis5.4-librelogo          - LibreLogo toolbar for LibreOffice 5.4 Wri
i   libobasis5.4-math               - Math module for LibreOffice 5.4 .1.2     
i   libobasis5.4-ogltrans           - OpenGL slide transitions module for Libre
i   libobasis5.4-onlineupdate       - Online update module for LibreOffice 5.4 
i   libobasis5.4-ooofonts           - 3rd party free fonts for LibreOffice 5.4 
i   libobasis5.4-ooolinguistic      - Linguistic module for LibreOffice 5.4 .1.
i   libobasis5.4-pl                 - Language module for LibreOffice 5.4, lang
i   libobasis5.4-pl-base            - Base language module for LibreOffice 5.4,
i   libobasis5.4-pl-calc            - Calc language module for LibreOffice 5.4,
i   libobasis5.4-pl-math            - Math language module for LibreOffice 5.4,
i   libobasis5.4-pl-res             - Language resource module for LibreOffice 
i   libobasis5.4-pl-writer          - Writer language module for LibreOffice 5.
i   libobasis5.4-postgresql-sdbc    - PostgreSQL Connector driver for LibreOffi
i   libobasis5.4-python-script-prov - Script provider for Python for LibreOffic
i   libobasis5.4-pyuno              - Pyuno module for LibreOffice 5.4 .1.2    
i   libobasis5.4-writer             - Writer module for LibreOffice 5.4 .1.2   
i   libobasis5.4-xsltfilter         - XSLT filter samples module for LibreOffic
i A libpng16-16                     - PNG library - runtime (version 1.6)      
i A libpostproc53                   - postproc shared libraries                
i A libreadline7                    - GNU readline and history libraries, run-t
i   libreoffice5.4                  - Brand module for LibreOffice 5.4 .1.2    
i   libreoffice5.4-base             - Base brand module for LibreOffice 5.4 .1.
i   libreoffice5.4-calc             - Calc brand module for LibreOffice 5.4 .1.
i   libreoffice5.4-debian-menus     - LibreOffice 5.4 desktop integration      
i   libreoffice5.4-dict-en          - En dictionary for LibreOffice 5.4 .1.2   
i   libreoffice5.4-dict-es          - Es dictionary for LibreOffice 5.4 .1.2   
i   libreoffice5.4-dict-fr          - Fr dictionary for LibreOffice 5.4 .1.2   
i   libreoffice5.4-dict-pl          - Pl dictionary for LibreOffice 5.4 .1.2   
i   libreoffice5.4-draw             - Draw brand module for LibreOffice 5.4 .1.
i   libreoffice5.4-en-us            - Brand language module for LibreOffice 5.4
i   libreoffice5.4-impress          - Impress brand module for LibreOffice 5.4 
i   libreoffice5.4-math             - Math brand module for LibreOffice 5.4 .1.
i   libreoffice5.4-pl               - Brand language module for LibreOffice 5.4
i   libreoffice5.4-ure              - UNO Runtime Environment .1.2             
i   libreoffice5.4-writer           - Writer brand module for LibreOffice 5.4 .
i A libswresample1                  - FFmpeg audio rescaling library           
i A libswresample1:i386             - FFmpeg audio rescaling library           
i A libusageenvironment2            - multimedia RTSP streaming library (UsageE
i A libutvideo15                    - Ut Video Codec Suite library             
i A libutvideo15:i386               - Ut Video Codec Suite library             
i A libx264-146                     - x264 video coding library                
i A libx264-146:i386                - x264 video coding library                
i A libx265-51                      - x265 video coding library                
i A libx265-51:i386                 - x265 video coding library                
i   ooobasis3.3-base:i386           - Base module for OpenOffice.org 3.3       
i   ooobasis3.3-binfilter:i386      - Legacy filters (e.g. StarOffice 5.2) for 
i   ooobasis3.3-calc:i386           - Calc module for OpenOffice.org 3.3       
i   ooobasis3.3-core01:i386         - Core module for OpenOffice.org 3.3       
i   ooobasis3.3-core02:i386         - Office core module for OpenOffice.org 3.3
i   ooobasis3.3-core03:i386         - Office core module for OpenOffice.org 3.3
i   ooobasis3.3-core04:i386         - Office core module for OpenOffice.org 3.3
i   ooobasis3.3-core05:i386         - Office core module for OpenOffice.org 3.3
i   ooobasis3.3-core06:i386         - Office core module for OpenOffice.org 3.3
i   ooobasis3.3-core07:i386         - Office core module for OpenOffice.org 3.3
i   ooobasis3.3-draw:i386           - Draw module for OpenOffice.org 3.3       
i   ooobasis3.3-gnome-integration:i - Gnome integration module for OpenOffice.o
i   ooobasis3.3-graphicfilter:i386  - Graphic filter module for OpenOffice.org 
i   ooobasis3.3-images:i386         - Images module for OpenOffice.org 3.3     
i   ooobasis3.3-impress:i386        - Impress module for OpenOffice.org 3.3    
i   ooobasis3.3-javafilter:i386     - Java filter module for OpenOffice.org 3.3
i   ooobasis3.3-math:i386           - Math module for OpenOffice.org 3.3       
i   ooobasis3.3-ogltrans:i386       - OpenGL slide transitions module for OpenO
i   ooobasis3.3-ooofonts:i386       - Mailcap module for OpenOffice.org 3.3    
i   ooobasis3.3-ooolinguistic:i386  - Linguistic module for OpenOffice.org 3.3 
i   ooobasis3.3-pl:i386             - Language module for OpenOffice.org 3.3, l
i   ooobasis3.3-pl-base:i386        - Base language module for OpenOffice.org 3
i   ooobasis3.3-pl-binfilter:i386   - Legacy filters (e.g. StarOffice 5.2) for 
i   ooobasis3.3-pl-calc:i386        - Calc language module for OpenOffice.org 3
i   ooobasis3.3-pl-draw:i386        - Draw language module for OpenOffice.org 3
i   ooobasis3.3-pl-help:i386        - Language help module for OpenOffice.org 3
i   ooobasis3.3-pl-impress:i386     - Impress language module for OpenOffice.or
i   ooobasis3.3-pl-math:i386        - Math language module for OpenOffice.org 3
i   ooobasis3.3-pl-res:i386         - Language resource module for OpenOffice.o
i   ooobasis3.3-pl-writer:i386      - Writer language module for OpenOffice.org
i   ooobasis3.3-pyuno:i386          - Pyuno module for OpenOffice.org 3.3      
i   ooobasis3.3-testtool:i386       - Testtool module for OpenOffice.org 3.3   
i   ooobasis3.3-writer:i386         - Writer module for OpenOffice.org 3.3     
i   ooobasis3.3-xsltfilter:i386     - XSLT filter samples module for OpenOffice
i   openoffice                      - Brand module for OpenOffice 4.1.3        
i   openoffice-base                 - Base module for Apache OpenOffice 4.1.3  
i   openoffice-brand-base           - Base brand module for OpenOffice 4.1.3   
i   openoffice-brand-calc           - Calc brand module for OpenOffice 4.1.3   
i   openoffice-brand-draw           - Draw brand module for OpenOffice 4.1.3   
i   openoffice-brand-impress        - Impress brand module for OpenOffice 4.1.3
i   openoffice-brand-math           - Math brand module for OpenOffice 4.1.3   
i   openoffice-brand-pl             - Brand language module for OpenOffice 4.1.
i   openoffice-brand-writer         - Writer brand module for OpenOffice 4.1.3 
i   openoffice-calc                 - Calc module for Apache OpenOffice 4.1.3  
i   openoffice-core01               - Core module for Apache OpenOffice 4.1.3  
i   openoffice-core02               - Office core module for Apache OpenOffice 
i   openoffice-core03               - Office core module for Apache OpenOffice 
i   openoffice-core04               - Office core module for Apache OpenOffice 
i   openoffice-core05               - Office core module for Apache OpenOffice 
i   openoffice-core06               - Office core module for Apache OpenOffice 
i   openoffice-core07               - Office core module for Apache OpenOffice 
i   openoffice-draw                 - Draw module for Apache OpenOffice 4.1.3  
i   openoffice-gnome-integration    - Gnome integration module for Apache OpenO
i   openoffice-graphicfilter        - Graphic filter module for Apache OpenOffi
i   openoffice-images               - Images module for Apache OpenOffice 4.1.3
i   openoffice-impress              - Impress module for Apache OpenOffice 4.1.
i   openoffice-javafilter           - Java filter module for Apache OpenOffice 
i   openoffice-math                 - Math module for Apache OpenOffice 4.1.3  
i   openoffice-ogltrans             - OpenGL slide transitions module for Apach
i   openoffice-onlineupdate         - Online update modul for Apache OpenOffice
i   openoffice-ooofonts             - Mailcap module for Apache OpenOffice 4.1.
i   openoffice-ooolinguistic        - Linguistic module for Apache OpenOffice 4
i   openoffice-pl                   - Language module for Apache OpenOffice 4.1
i   openoffice-pl-base              - Base language module for Apache OpenOffic
i   openoffice-pl-calc              - Calc language module for Apache OpenOffic
i   openoffice-pl-draw              - Draw language module for Apache OpenOffic
i   openoffice-pl-help              - Language help module for Apache OpenOffic
i   openoffice-pl-impress           - Impress language module for Apache OpenOf
i   openoffice-pl-math              - Math language module for Apache OpenOffic
i   openoffice-pl-res               - Language resource module for Apache OpenO
i   openoffice-pl-writer            - Writer language module for Apache OpenOff
i   openoffice-pyuno                - Pyuno module for Apache OpenOffice 4.1.3 
i   openoffice-ure                  - UNO Runtime Environment for OpenOffice 4.
i   openoffice-writer               - Writer module for Apache OpenOffice 4.1.3
i   openoffice-xsltfilter           - XSLT filter samples module for Apache Ope
i   openoffice.org-ure:i386         - UNO Runtime Environment                  
iB  oracle-java8-installer          - Oracle Java(TM) Development Kit (JDK) 8  
i   viber                           - Free Text & Calls.                       
i   xserver-xorg-video-sisimedia    - X.Org X server -- SiS display driver

"aptitude search ~o" to odpowiednik "dpkg -l"?

Offline

 

#46 2017-10-28 23:38:19

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Drukarka Brother HL-2035 sterownik nie działa

W pliku /etc/apt/apt.conf masz linijkę APT::Default-Release "jessie";
Zakomentuj (lub usuń) ją na czas cofania pakietów.

aptitude search ~o wyświetla pakiety w wersjach nie występujących w obecnie ustawionych repozytoriach.

Offline

 

#47 2017-10-29 00:00:29

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

yossarian napisał(-a):

W pliku /etc/apt/apt.conf masz linijkę APT::Default-Release "jessie";
Zakomentuj (lub usuń) ją na czas cofania pakietów.

aptitude search ~o wyświetla pakiety w wersjach nie występujących w obecnie ustawionych repozytoriach.

Zwracam honor, przepraszam, chyba tam grzebałem... Skojarzyłem dopiero po nazwie "apt.conf", a widzę to po poście nr 4, a w zasadzie to po poście nr 5 z tego tematu: https://forum.dug.net.pl/viewtopic.php?id=29805 Przepraszam jeśli miałeś dużo szukania przez to, w ogóle mi wypadło z głowy.

Zakomentowuje się znakiem "#" tak jak jest w sources.list? Dobrze zrobiłem?

Kod:

cat /etc/apt/apt.conf
#APT::Default-Release "jessie";

APT::Get::Install-Recommends "false";
APT::Get::Install-Suggests "false";

Apt::Get::Purge;

Acquire::PDiffs "true";

A tak mi jeszcze przychodzi do głowy, bo ja w tym cytowanym poście pisałem, że też miałem problem z zależnościami przy instalowani Xfce'a i że pomogło:

Kod:

apt-get autoremove

Wiadomo, dla porządku warto cofnąć system do "czystego (czystej? ;p)" "Jessie", ale może jeszcze spróbować z tym "apt-get autoremove" wcześniej zainstalować sterowniki do drukarki i może pójdą?

Ostatnio edytowany przez pltvgz20 (2017-10-29 00:14:13)

Offline

 

#48 2017-10-29 14:16:46

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

Dostaję taki zwrot:

Kod:

root@debian:/home/abc# apt-get dist-upgrade -dV
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Obliczanie aktualizacji...Następujące pakiety zostały zainstalowane automatycznie i nie są już więcej wymagane:
   keyutils (1.5.9-5+b1)
   libaacplus2 (2.0.2-dmo2)
   libaacplus2:i386 (2.0.2-dmo2)
   libapparmor1 (2.9.0-3)
   libaudcore3 (3.6.1-dmo3)
   libcrystalhd3:i386 (0.0~git20110715.fdd2f19-11)
   libebml4 (1.3.0-2+deb8u1)
   libfaac0 (1.28-6)
   libfaac0:i386 (1.28-6)
   libfdk-aac1 (0.1.4-dmo1)
   libfdk-aac1:i386 (0.1.4-dmo1)
   libhogweed4 (3.3-1+b1)
   libip4tc0 (1.6.0+snapshot20161117-6)
   libjim0.76 (0.76-2+b1)
   liblivemedia23 (2014.01.13-1)
   liblz4-1 (0.0~r122-2)
   liblz4-1:i386 (0.0~r122-2)
   libmatroska6 (1.4.1-2+deb8u1)
   libmowgli-2-0 (2.0.0-3)
   libnettle6 (3.3-1+b1)
   libopencore-amrnb0:i386 (0.1.3-2.1)
   libopencore-amrwb0:i386 (0.1.3-2.1)
   libpng16-16 (1.6.28-1)
   libseccomp2 (2.1.1-1)
   libsoxr0 (0.1.1-1)
   libusageenvironment1 (2014.01.13-1)
   libutvideo15 (15.1.0-dmo2)
   libutvideo15:i386 (15.1.0-dmo2)
   libvo-aacenc0:i386 (0.1.3-1)
   libvo-amrwbenc0:i386 (0.1.3-1)
   libx264-146:i386 (0.146.2538+git121396c-dmo2)
   libx265-51:i386 (1.6-dmo1)
   libzvbi0:i386 (0.2.35-3)
Aby je usunąć należy użyć "apt-get autoremove".
Gotowe
Następujące pakiety zostaną USUNIĘTE:
   dbus-user-session (1.10.18-1)
   libc-l10n (2.24-11+deb9u1)
   libgnutls30 (3.5.8-5+deb9u2)
   libgtop-2.0-10 (2.34.2-1)
   libnm0 (1.6.2-3)
   libnma0 (1.4.4-1)
   libpostproc53 (2.6.9-dmo1)
   libreadline7 (7.0-3)
   libswresample1 (2.6.9-dmo1)
   libswresample1:i386 (2.6.9-dmo1)
   vlc-nox (2.2.6-1~deb8u1)
Zostaną zainstalowane następujące NOWE pakiety:
   libaudcore2 (3.5-2)
   libc6-i686:i386 (2.19-18+deb8u10)
   libelfg0 (0.8.13-5)
   libjim0.75 (0.75-1)
   liblivemedia23 (2014.01.13-1)
   libnl-route-3-200 (3.2.24-2)
   libpostproc52 (0.git20120821-4)
   libproxy-tools (0.4.11-4+b2)
   libusageenvironment1 (2014.01.13-1)
   libx264-142:i386 (0.142.2431+gita5831aa-1+b2)
Następujące pakiety zostaną zaktualizowane:
   google-chrome-stable (61.0.3163.100-1 => 62.0.3202.75-1)
   libcurl3 (7.38.0-4+deb8u6 => 7.38.0-4+deb8u7)
   libcurl3-gnutls (7.38.0-4+deb8u6 => 7.38.0-4+deb8u7)
   opera-stable (48.0.2685.39 => 48.0.2685.52)
   wget (1.16-1+deb8u2 => 1.16-1+deb8u4)
   xserver-common (1.16.4-1+deb8u1 => 1.16.4-1+deb8u2)
   xserver-xephyr (1.16.4-1+deb8u1+b1 => 1.16.4-1+deb8u2)
   xserver-xorg-core (1.16.4-1+deb8u1+b1 => 1.16.4-1+deb8u2)
   xwayland (1.16.4-1+deb8u1+b1 => 1.16.4-1+deb8u2)
Zostaną zainstalowane STARE wersje następujących pakietów:
   alarm-clock-applet (0.3.4-1+b1 => 0.3.3-1)
   audacious (3.6.1-dmo3 => 3.5-2)
   audacious-plugins (3.6.1-dmo1 => 3.5-1+b2)
   audacious-plugins-data (3.6.1-dmo1 => 3.5-1)
   bash-completion (2.1-4.3 => 2.1-4)
   binutils (2.28-5 => 2.25-5+deb8u1)
   console-setup (1.164 => 1.123)
   console-setup-linux (1.164 => 1.123)
   dbus (1.10.18-1 => 1.8.22-0+deb8u1)
   dbus-x11 (1.10.18-1 => 1.8.22-0+deb8u1)
   dmsetup (1.02.137-2 => 1.02.90-2.2+deb8u1)
   exfat-fuse (1.2.5-2 => 1.1.0-2+deb8u1)
   exfat-utils (1.2.5-2 => 1.1.0-2+deb8u1)
   gksu (2.0.2-9+b1 => 2.0.2-9)
   gstreamer1.0-libav (1.4.5-dmo1 => 1.4.4-2)
   ifupdown (0.8.19 => 0.7.53.1)
   init-system-helpers (1.48 => 1.22)
   kbd (2.0.3-2+b1 => 1.15.5-2)
   keyboard-configuration (1.164 => 1.123)
   keyutils (1.5.9-9 => 1.5.9-5+b1)
   libaacs0 (0.8.1-dmo1+deb8u1 => 0.7.1-1+b1)
   libapparmor1 (2.11.0-3 => 2.9.0-3)
   libavcodec56 (2.6.9-dmo1 => 11.9-1~deb8u1)
   libavcodec56:i386 (2.6.9-dmo1 => 11.9-1~deb8u1)
   libavformat56 (2.6.9-dmo1 => 11.9-1~deb8u1)
   libavresample2 (2.6.9-dmo1 => 11.9-1~deb8u1)
   libavresample2:i386 (2.6.9-dmo1 => 11.9-1~deb8u1)
   libavutil54 (2.6.9-dmo1 => 11.9-1~deb8u1)
   libavutil54:i386 (2.6.9-dmo1 => 11.9-1~deb8u1)
   libbasicusageenvironment0 (2015.03.19-dmo1 => 2014.01.13-1)
   libblkid1 (2.29.2-1 => 2.25.2-6)
   libblkid1:i386 (2.29.2-1 => 2.25.2-6)
   libbluray1 (0.7.0-dmo1 => 0.6.2-1)
   libc-bin (2.24-11+deb9u1 => 2.19-18+deb8u10)
   libc-dev-bin (2.24-11+deb9u1 => 2.19-18+deb8u10)
   libc6 (2.24-11+deb9u1 => 2.19-18+deb8u10)
   libc6:i386 (2.24-11+deb9u1 => 2.19-18+deb8u10)
   libc6-dev (2.24-11+deb9u1 => 2.19-18+deb8u10)
   libchromaprint0 (1.2-dmo2 => 1.2-1)
   libdbus-1-3 (1.10.18-1 => 1.8.22-0+deb8u1)
   libdbus-1-3:i386 (1.10.18-1 => 1.8.22-0+deb8u1)
   libdca0 (0.0.5-dmo2+deb8u1 => 0.0.5-7)
   libdevmapper1.02.1 (1.02.137-2 => 1.02.90-2.2+deb8u1)
   libdvbpsi9 (1.2.0-dmo1 => 1.2.0-1)
   libebml4 (1.3.1-dmo2 => 1.3.0-2+deb8u1)
   libfaac0 (1.28-dmo3+deb8u1 => 1.28-6)
   libfaac0:i386 (1.28-dmo3+deb8u1 => 1.28-6)
   libgcrypt20 (1.7.6-2+deb9u1 => 1.6.3-2+deb8u4)
   libgcrypt20:i386 (1.7.6-2+deb9u1 => 1.6.3-2+deb8u4)
   libgegl-0.2-0 (0.2.0-dmo8 => 0.2.0-7+b1)
   libgksu2-0 (2.0.13~pre1-9+b1 => 2.0.13~pre1-8)
   libglib2.0-0 (2.50.3-2 => 2.42.1-1+b1)
   libglib2.0-0:i386 (2.50.3-2 => 2.42.1-1+b1)
   libglib2.0-bin (2.50.3-2 => 2.42.1-1+b1)
   libgssapi-krb5-2 (1.15-1 => 1.12.1+dfsg-19+deb8u2)
   libgtop2-common (2.34.2-1 => 2.28.5-2)
   libguess1 (1.2-dmo2+deb8u1 => 1.2-1)
   libk5crypto3 (1.15-1 => 1.12.1+dfsg-19+deb8u2)
   libkrb5-3 (1.15-1 => 1.12.1+dfsg-19+deb8u2)
   libkrb5support0 (1.15-1 => 1.12.1+dfsg-19+deb8u2)
   liblz4-1 (0.0~r131-2+b1 => 0.0~r122-2)
   liblz4-1:i386 (0.0~r131-2+b1 => 0.0~r122-2)
   libmatroska6 (1.4.2-dmo3 => 1.4.1-2+deb8u1)
   libmjpegutils-2.1-0 (2.1.0-dmo6 => 2.1.0+debian-3)
   libmount1 (2.29.2-1 => 2.25.2-6)
   libmount1:i386 (2.29.2-1 => 2.25.2-6)
   libmowgli-2-0 (2.0.0-dmo1+deb8u1 => 2.0.0-3)
   libmp3lame0 (3.99.5-dmo4 => 3.99.5+repack1-7+deb8u1)
   libmp3lame0:i386 (3.99.5-dmo4 => 3.99.5+repack1-7+deb8u1)
   libmpeg2encpp-2.1-0 (2.1.0-dmo6 => 2.1.0+debian-3)
   libmplex2-2.1-0 (2.1.0-dmo6 => 2.1.0+debian-3)
   libncurses5 (6.0+20161126-1 => 5.9+20140913-1+b1)
   libncurses5:i386 (6.0+20161126-1 => 5.9+20140913-1+b1)
   libncursesw5 (6.0+20161126-1 => 5.9+20140913-1+b1)
   libp11-kit0 (0.23.3-2 => 0.20.7-1)
   libp11-kit0:i386 (0.23.3-2 => 0.20.7-1)
   libpam-systemd (232-25+deb9u1 => 215-17+deb8u7)
   librtmp1 (2.4~20150315.gita107cef9b-dmo1+deb8u2 => 2.4+20150115.gita107cef-1+deb8u1)
   libseccomp2 (2.3.1-2.1 => 2.1.1-1)
   libselinux1 (2.6-3+b1 => 2.3-2)
   libselinux1:i386 (2.6-3+b1 => 2.3-2)
   libsmartcols1 (2.29.2-1 => 2.25.2-6)
   libswscale3 (2.6.9-dmo1 => 11.9-1~deb8u1)
   libsystemd0 (232-25+deb9u1 => 215-17+deb8u7)
   libsystemd0:i386 (232-25+deb9u1 => 215-17+deb8u7)
   libtasn1-6 (4.10-1.1 => 4.2-3+deb8u3)
   libtasn1-6:i386 (4.10-1.1 => 4.2-3+deb8u3)
   libtinfo5 (6.0+20161126-1 => 5.9+20140913-1+b1)
   libtinfo5:i386 (6.0+20161126-1 => 5.9+20140913-1+b1)
   libtirpc1 (0.2.5-1.2 => 0.2.5-1+deb8u1)
   libudev1 (232-25+deb9u1 => 215-17+deb8u7)
   libudev1:i386 (232-25+deb9u1 => 215-17+deb8u7)
   libudisks2-0 (2.1.8-1 => 2.1.3-5)
   libvlc5 (2.2.1-dmo3+deb8u4 => 2.2.6-1~deb8u1)
   libvlccore8 (2.2.1-dmo3+deb8u4 => 2.2.6-1~deb8u1)
   libxvidcore4 (1.3.3-dmo1 => 1.3.3-1)
   libxvidcore4:i386 (1.3.3-dmo1 => 1.3.3-1)
   linux-libc-dev (4.9.30-2+deb9u3 => 3.16.43-2+deb8u5)
   locales (2.24-11+deb9u1 => 2.19-18+deb8u10)
   mount (2.29.2-1 => 2.25.2-6)
   mplayer2 (2.0~git20130903-dmo7 => 2.0-728-g2c378c7-4+b1)
   network-manager (1.6.2-3 => 0.9.10.0-7)
   network-manager-gnome (1.4.4-1 => 0.9.10.0-2)
   nfs-common (1.3.4-2.1 => 1.2.8-9)
   p11-kit-modules (0.23.3-2 => 0.20.7-1)
   ppp (2.4.7-1+4 => 2.4.6-3.1)
   python-glade2 (2.24.0-5.1 => 2.24.0-4)
   python-gtk2 (2.24.0-5.1 => 2.24.0-4)
   python-numpy (1.12.1-3 => 1.8.2-2)
   rpcbind (0.2.3-0.6 => 0.2.1-6+deb8u2)
   sane (1.0.14-12 => 1.0.14-9)
   sudo (1.8.19p1-2.1 => 1.8.10p3-1+deb8u4)
   systemd (232-25+deb9u1 => 215-17+deb8u7)
   systemd-sysv (232-25+deb9u1 => 215-17+deb8u7)
   sysvinit-utils (2.88dsf-59.9 => 2.88dsf-59)
   udev (232-25+deb9u1 => 215-17+deb8u7)
   udisks2 (2.1.8-1 => 2.1.3-5)
   usb-modeswitch (2.5.0+repack0-1 => 2.2.0+repack0-2)
   util-linux (2.29.2-1 => 2.25.2-6)
   vdpau-va-driver (0.7.4-dmo5 => 0.7.4-3)
   vdpau-va-driver:i386 (0.7.4-dmo5 => 0.7.4-3)
   vlc-data (2.2.1-dmo3+deb8u4 => 2.2.6-1~deb8u1)
   xsane (0.999-5 => 0.998-6+b1)
   xsane-common (0.999-5 => 0.998-6)
9 aktualizowanych, 10 nowo instalowanych, 124 cofniętych wersji, 11 usuwanych i 0 nieaktualizowanych.
Konieczne pobranie 183 MB archiwów.
Po tej operacji zostanie zwolnione 130 MB miejsca na dysku.
Kontynuować? [T/n]

Rzeczy, które zwracają uwagę:

Kod:

Następujące pakiety zostały zainstalowane automatycznie i nie są już więcej wymagane:

Kod:

Aby je usunąć należy użyć "apt-get autoremove"

Przed kliknięciem „tak” wpsiać „apt-get autoremove”?

Kod:

Następujące pakiety zostaną USUNIĘTE

To tak ma być, że zostaną usunięte?

Kod:

Zostaną zainstalowane następujące NOWE pakiety:

Tak też powinno być, że będą jakieś nowe?

I nadal widać, że starsze wersje będą się aktualizowały do nowszych:

Kod:

google-chrome-stable (61.0.3163.100-1 => 62.0.3202.75-1)
libcurl3 (7.38.0-4+deb8u6 => 7.38.0-4+deb8u7)
libcurl3-gnutls (7.38.0-4+deb8u6 => 7.38.0-4+deb8u7)
   opera-stable (48.0.2685.39 => 48.0.2685.52)
   wget (1.16-1+deb8u2 => 1.16-1+deb8u4)
   xserver-common (1.16.4-1+deb8u1 => 1.16.4-1+deb8u2)
   xserver-xephyr (1.16.4-1+deb8u1+b1 => 1.16.4-1+deb8u2)
   xserver-xorg-core (1.16.4-1+deb8u1+b1 => 1.16.4-1+deb8u2)
   xwayland (1.16.4-1+deb8u1+b1 => 1.16.4-1+deb8u2)

Ale też widzę, że w sekcji, w której jest informacja, że będą instalowane starsze wersje też są odniesienia chyba do nowszych, między innymi:

Kod:

libavcodec56 (2.6.9-dmo1 => 11.9-1~deb8u1)
libavcodec56:i386 (2.6.9-dmo1 => 11.9-1~deb8u1)
   libavformat56 (2.6.9-dmo1 => 11.9-1~deb8u1)
   libavresample2 (2.6.9-dmo1 => 11.9-1~deb8u1)
   libavresample2:i386 (2.6.9-dmo1 => 11.9-1~deb8u1)
   libavutil54 (2.6.9-dmo1 => 11.9-1~deb8u1)
   libavutil54:i386 (2.6.9-dmo1 => 11.9-1~deb8u1)

Co robić? Bo to tak trochę podejrzanie wszystko wygląda jak na aktualizację wsteczną?

Ostatnio edytowany przez pltvgz20 (2017-10-29 14:18:23)

Offline

 

#49 2017-10-30 18:43:56

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Drukarka Brother HL-2035 sterownik nie działa

Takie cofanie zawsze jest podejrzane bo nie jest to operacja wspierana przez deweloperów i nikt nie da ci żadnej gwarancji, że wszystko będzie działać.

Część pakietów zostanie usunięta (zazwyczaj te z numerkami w nazwie) bo w Jessie były inne wersje (inne numery) lub nie było wcale.
Część pakietów się aktualizuje bo pewnie nie wyłączyłeś wszystkich dodatkowych repozytoriów. Inne to zwykłe aktualizacje w Jessie.
Pakiety z dmo w nazwie pochodzą z repozytorium deb-multimedia — jego opiekun stosuje swoją, jakąś radziecką numerację ;)

Najpierw wykonaj tę operację pobierania. Gdy już wszystko się pobierze — wykonasz właściwą aktualizację/cofnięcie (usuwając opcję -d).
Potem kilka zdrowasiek i po modlitwach sprawdzisz czy wszystko działa po restarcie. ;)

Offline

 

#50 2017-10-30 21:20:29

pltvgz20
Użytkownik
Zarejestrowany: 2017-05-09

Re: Drukarka Brother HL-2035 sterownik nie działa

yossarian napisał(-a):

Część pakietów się aktualizuje bo pewnie nie wyłączyłeś wszystkich dodatkowych repozytoriów. Inne to zwykłe aktualizacje w Jessie.

To wywalić te pliki z "/etc/apt/sources.list.d/", bo chyba to te masz na myśli?

A ja już w wpisuję, żeby nie marnować czasu:

Kod:

apt-get dist-upgrade -dV

najwyżej się jeszcze raz pobierze, gdyby coś było nie tak.

I pytanie "na potem": robiąc aktualizację wsteczną, nie potracę jakiś zakładek z Firefoxa, czy Opery, albo nie pokasują mi się programy, które zainstalowałem potem po instalacji Debiana z płyty, albo coś w tym stylu, czego byłoby szkoda? Mówiąc krótko: robić jakieś kopie zapasowe czegoś, albo spisywać nazwy programów, bo one są często ciężkie do odnalezienia (np. przełącznik języków klawiatury - długo szukałem)? (/home mam na tej samej partycji co system, jeśli to ma jakieś znaczenie.)

Ostatnio edytowany przez pltvgz20 (2017-10-30 22:15:03)

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
To nie jest tylko forum, to nasza mała ojczyzna ;-)