Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundacji Dzieciom zdazyć z Pomocą.
Więcej informacji na dug.net.pl/pomagamy/.

#1  2019-07-28 22:30:45

  torpeda80 - Użytkownik

torpeda80
Użytkownik
Zarejestrowany: 2007-03-28

jak ustawić statyczny IP dla wlan0

Witam
Mam problem z ustawieniem statycznego ip dla sieci wifi.

zmian dokonałem w /etc/network/interfaces następująco:

Kod:

root@torus:/etc/network# cat interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface

# przed zmiana
auto lo
iface lo inet loopback

### dodane - po zmianie
iface wlan0 inet static
        address 192.168.0.229
        netmask 255.255.255.0
        network 192.168.0.1
        broadcast 192.168.0.255
        gateway 192.168.0.1
root@torus:/etc/network#

Gdzie jest błąd? Coś żle robie?

Offline

 

#2  2019-07-28 23:34:12

  yossarian - Szczawiożerca

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: jak ustawić statyczny IP dla wlan0

Sprawdź adresy network i gateway.

Offline

 

#3  2019-07-29 21:08:13

  torpeda80 - Użytkownik

torpeda80
Użytkownik
Zarejestrowany: 2007-03-28

Re: jak ustawić statyczny IP dla wlan0

Kod:

root@torus:/home/torus# route -n 
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG    600    0        0 wlp60s0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlp60s0
192.168.0.0     0.0.0.0         255.255.255.0   U     600    0        0 wlp60s0
root@torus:/home/torus#

Co do network to nie wiem czy nie powinienem tego usnac?

Offline

 

#4  2019-07-29 22:07:36

  torpeda80 - Użytkownik

torpeda80
Użytkownik
Zarejestrowany: 2007-03-28

Re: jak ustawić statyczny IP dla wlan0

czy to powinno wyglądać tak?

Kod:

iface wlan0 inet static
        address 192.168.0.229
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 192.168.0.1

Offline

 

#5  2019-07-29 22:31:07

  lama - Użytkownik

lama
Użytkownik
Zarejestrowany: 2012-08-28

Re: jak ustawić statyczny IP dla wlan0

powinno zadziałać, możesz też spróbować

Kod:

iface wlan0 inet static
        address 192.168.0.229/24
        broadcast 192.168.0.255
        gateway 192.168.0.1

Offline

 

#6  2019-07-29 22:44:24

  torpeda80 - Użytkownik

torpeda80
Użytkownik
Zarejestrowany: 2007-03-28

Re: jak ustawić statyczny IP dla wlan0

nie działa

Kod:

root@torus:/home/torus# ifconfig -a
enp59s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether a4:4c:c8:74:46:2c  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 104  bytes 7916 (7.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 104  bytes 7916 (7.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp60s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.31  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::4c87:9481:6736:f58e  prefixlen 64  scopeid 0x20<link>
        ether d4:25:8b:fa:91:7d  txqueuelen 1000  (Ethernet)
        RX packets 2032  bytes 2751066 (2.6 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 719  bytes 121667 (118.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

root@torus:/home/torus# 
root@torus:/home/torus# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface

# przed zmiana
auto lo
iface lo inet loopback

### dodane - po zmianie, 

#iface wlan0 inet static
#address 192.168.0.229
#netmask 255.255.255.0
#network 192.168.0.0
#broadcast 192.168.0.255
#gateway 192.168.0.1
iface wlan0 inet static
address 192.168.0.229/24
broadcast 192.168.0.255
gateway 192.168.0.1

root@torus:/home/torus#

Offline

 

#7  2019-07-29 23:24:36

  yossarian - Szczawiożerca

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: jak ustawić statyczny IP dla wlan0

Jak już poprawiłeś adresy, to teraz popraw jeszcze nazwy interfejsów sieciowych ;)

Offline

 

#8  2019-07-30 18:51:47

  lama - Użytkownik

lama
Użytkownik
Zarejestrowany: 2012-08-28

Re: jak ustawić statyczny IP dla wlan0

Ha, racja wlp60s0 zamiast wlan0.

Offline

 

#9  2019-08-04 08:43:00

  torpeda80 - Użytkownik

torpeda80
Użytkownik
Zarejestrowany: 2007-03-28

Re: jak ustawić statyczny IP dla wlan0

Niestety ale nie działa. Coś jest jeszcze nie tak.
Po zmianie wygląda to następująco:

Kod:

root@torus:/home/torus# ifconfig -a
enp59s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether a4:4c:c8:74:46:2c  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 408  bytes 32408 (31.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 408  bytes 32408 (31.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp60s0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether d4:25:8b:fa:91:7d  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

root@torus:/home/torus# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface

# przed zmiana
auto lo
iface lo inet loopback

### dodane - po zmianie, jak cos to usun tylko ponizsze

#iface wlan0 inet static
#address 192.168.0.229
#netmask 255.255.255.0
#network 192.168.0.0
#broadcast 192.168.0.255
#gateway 192.168.0.1
iface wlp60s0 inet static
address 192.168.0.229/24
broadcast 192.168.0.255
gateway 192.168.0.1

root@torus:/home/torus#

Offline

 

#10  2019-08-05 23:28:11

  lama - Użytkownik

lama
Użytkownik
Zarejestrowany: 2012-08-28

Re: jak ustawić statyczny IP dla wlan0

wlp60s0 chyba nie jest "UP", bo

(flags=4098<BROADCAST,MULTICAST>)

spróbuj zrobić

Kod:

ifup wlp60s0

Offline

 

#11  2019-08-10 00:25:17

  torpeda80 - Użytkownik

torpeda80
Użytkownik
Zarejestrowany: 2007-03-28

Re: jak ustawić statyczny IP dla wlan0

też nie działa:

Kod:

torus@torus:~$ su
Hasło: 
root@torus:/home/torus# cd /etc/network
root@torus:/etc/network# cat interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface

# przed zmiana
auto lo
iface lo inet loopback

### dodane - po zmianie, 


iface wlp60s0 inet static
address 192.168.0.229/24
broadcast 192.168.0.255
gateway 192.168.0.1

root@torus:/etc/network# ifup wlp60s0
ifup: interface wlp60s0 already configured

po restarcie sieci nie wykrywa.

Nie rozumiem czemu nie mogę wyedytować tego interfaceu przez nmcli:

Kod:

root@torus:/home/torus# nmcli con edit wlan1
Błąd: nieznane połączenie „wlan1”.
root@torus:/home/torus# nmcli con edit wlp60s0
Błąd: nieznane połączenie „wlp60s0”.
root@torus:/home/torus# nmcli con edit wifi
Błąd: nieznane połączenie „wifi”.

Jaki błąd robie?

Offline

 

#12  2019-08-10 07:49:06

  ilin - Palacz

ilin
Palacz
Skąd: PRLu
Zarejestrowany: 2006-05-03

Re: jak ustawić statyczny IP dla wlan0

Nie możesz użyć do skonfigurowania połączenia nmtui ?


Problemy rozwiązujemy na forum nie na PW -> Niech inni na tym skorzystają.
Polski portal Debiana

Offline

 

#13  2019-08-12 21:48:59

  lama - Użytkownik

lama
Użytkownik
Zarejestrowany: 2012-08-28

Re: jak ustawić statyczny IP dla wlan0

jeśli ma Ci się automatycznie włączać, to dodaj na początku

Kod:

auto wlp60s0

Offline

 

#14  2019-08-19 00:20:57

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: jak ustawić statyczny IP dla wlan0

Ja bym wifi zostawił domyślnie na DHCP, a tylko dla pojedynczej lokalizacji ustawiał statyczne parametry.

W /etc/network/interfaces jest możliwość ustawiania sieci per-essid, chociaż ostatnio Debian stawia na różne NM, Connmany i inne badziewia.

Tu masz opis, jak w intefaces ustawiać parametry per-essid:
https://wiki.debian.org/DebianOnFreeRunner/WLAN

Chodzi o ten kawałek:

Kod:

# MySSID comes from an id_str above.
iface MySSID inet dhcp

# default is what's used if there is no id_str setting.
# so the 'SomeNetwork' network will use DHCP.
iface default inet dhcp

iface home inet static
# static interface settings, or whatever...

Oczywiście ten przykład dotyczy użycia czystego wpa_supplicanta, a nie NM, Wicd, Connmana czy czegoś podobnego.

Pozdro

Ostatnio edytowany przez Jacekalex (2019-08-19 00:40:41)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Możesz wyłączyć AdBlock — tu nie ma reklam ;-)