Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundacji Dzieciom zdazyć z Pomocą.
Więcej informacji na dug.net.pl/pomagamy/.

#1  2019-05-12 17:22:44

  Edis0n - Użytkownik

Edis0n
Użytkownik
Zarejestrowany: 2018-07-29

Problem ze static ip na eth1

Hej,
mam problem z automatycznym przypisaniem statycznego adresu dla eth1 na moim routerze\firewallu.

Mam kilka sieci, wymienię główne:
192.168.0.0/24 - eth0 (Public)
192.168.99.0/24 - eth1 (Internal)
10.8.0.0 - tun0 (VPN dla mobilków)
10.9.0.0 - tap1 (VPN dla site'ów)

Interfejsy mam zdefiniowane w /etc/network/interfaces (sama inicjacja) ze wskazaniem do /etc/network/interfaces.d/..eth1 ... 2 etc

Sęk w tym, że mój eth1 za chiny nie przypisuje sobie static ip, np:

iface eth1 inet static
        address 192.168.99.9/24
        dns-search local

działa to dopiero wtedy, kiedy uruchomię sekwencję jako root:

ifconfig eth1 192.168.99.1 netmask 255.255.255.0 up (adresowanie)
systemctl restart isc-dhcp-server (interfejs jest zbindowany jako dhcp dla podsieci 99)
/etc/init.d/samba restart (inaczej samba by nie zaskoczyła)

Pomyśłałem sobie, że skoro sekwencja komend jako root działa to może wrzucę to do rc.local ...
niestety nie pomaga.
W skrypcie próbowałem odnieść się do komend "ifconfig" bezpośrednio, np. poprzez /sbin/ifconfig.

Zapytanie, czy ktoś wie jak sobie z tym poradzić ? Ewentualnie, czy pakiet isc-dhcp może coś tutaj krzaczyć ???

Offline

 

#2  2019-05-12 21:18:38

  arecki - Użytkownik

arecki
Użytkownik
Skąd: 44 Bronson Lane Hensonville
Zarejestrowany: 2016-03-03

Re: Problem ze static ip na eth1

Spójrz w logi to się dowiesz.

Offline

 

#3  2019-05-12 22:08:55

  BiExi - matka przelozona

BiExi
matka przelozona
Skąd: Gorlice
Zarejestrowany: 2004-04-16
Serwis

Re: Problem ze static ip na eth1

Kod:

auto eth1
iface eth1 inet static
       address 192.168.99.9
       netmask 255.255.255.9

Widzę że w pliku masz wpisany adres 192.168.99.9 a z wiersza poleceń 192.168.99.1

Offline

 

#4  2019-05-19 12:08:19

  Yampress - Imperator

Yampress
Imperator
Zarejestrowany: 2007-10-18

Re: Problem ze static ip na eth1

Taa
Tylko teraz przecież interfejsy nazywają się

enp2s0

itp..

Offline

 

#5  2019-05-19 12:57:19

  Bodzio - Ojciec Założyciel

Bodzio
Ojciec Założyciel
Skąd: Gorlice
Zarejestrowany: 2004-04-17
Serwis

Re: Problem ze static ip na eth1

Na starym jajcu mam eth :P


Debian jest lepszy niż wszystkie klony
Linux register users: #359018
http://www.freebsd.org/gifs/powerlogo.gif
Beskid Niski

Offline

 

#6  2019-05-19 15:36:16

  mati75 - Psuj

mati75
Psuj
Skąd: default city
Zarejestrowany: 2010-03-14
Serwis

Re: Problem ze static ip na eth1

Yampress napisał(-a):

Taa
Tylko teraz przecież interfejsy nazywają się

enp2s0

itp..

Zawsze można zmienić:

https://www.itzgeek.com/how-tos/linux/debian/change … debian-9.html


https://l0calh0st.pl/obrazki/userbar.png

Offline

 

#7  2019-05-19 16:04:53

  Yampress - Imperator

Yampress
Imperator
Zarejestrowany: 2007-10-18

Re: Problem ze static ip na eth1

tak ale   bez zmiany.. dziaamy na interfejsach jakie sa

Offline

 

#8  2019-05-19 17:03:51

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Problem ze static ip na eth1

Wystarczy dopisać

Kod:

biosdevname=0 net.ifnames=0

do CMDLINE kernela, i będą stare nazwy eth.


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#9  2019-05-19 18:52:36

  arecki - Użytkownik

arecki
Użytkownik
Skąd: 44 Bronson Lane Hensonville
Zarejestrowany: 2016-03-03

Re: Problem ze static ip na eth1

A ja do dzisiaj mam stare nazewnictwo, a parametrów w kernelu nie zmieniałem, widać udev mi to załatwił w trakcie aktualizacji, ja w każdym nic z tym nie robiłem.

Offline

 

#10  2019-05-20 17:07:41

  hi - Użytkownik

hi
Użytkownik
Zarejestrowany: 2016-03-24

Re: Problem ze static ip na eth1

arecki napisał(-a):

A ja do dzisiaj mam stare nazewnictwo, a parametrów w kernelu nie zmieniałem, widać udev mi to załatwił w trakcie aktualizacji

na pewno nie na debianie (chyba, że nie wiesz co masz wsadzone w regułach udeva)

Kod:

cat /etc/udev/rules.d/80-persistent-net.rules
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:00:00:00:00:00", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

no popatrz coś tam jeszcze siedzi u mnie, no samo się nie zrobiło :)

Kod:

cat /etc/udev/rules.d/60-scheduler.rules 
ACTION=="add|change", KERNEL=="sd*[!0-9]|sr*", ATTR{queue/scheduler}="bfq"

Ostatnio edytowany przez hi (2019-05-20 17:15:50)


"Jeśli wolność słowa w ogóle coś oznacza, to oznacza prawo do mówienia ludziom tego, czego nie chcą słyszeć."
Eric Arthur Blair

Offline

 

#11  2019-05-20 17:51:58

  arecki - Użytkownik

arecki
Użytkownik
Skąd: 44 Bronson Lane Hensonville
Zarejestrowany: 2016-03-03

Re: Problem ze static ip na eth1

hi napisał(-a):

arecki napisał(-a):

A ja do dzisiaj mam stare nazewnictwo, a parametrów w kernelu nie zmieniałem, widać udev mi to załatwił w trakcie aktualizacji

na pewno nie na debianie (chyba, że nie wiesz co masz wsadzone w regułach udeva)

Kod:

cat /etc/udev/rules.d/80-persistent-net.rules
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:00:00:00:00:00", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

no popatrz coś tam jeszcze siedzi u mnie, no samo się nie zrobiło :)

Kod:

cat /etc/udev/rules.d/60-scheduler.rules 
ACTION=="add|change", KERNEL=="sd*[!0-9]|sr*", ATTR{queue/scheduler}="bfq"

A na Debianie testingu od wheezy.

Kod:

cat /etc/udev/rules.d/70-persistent-net.rules 
# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.

# PCI device 0x11ab:/sys/devices/pci0000:00/0000:00:1c.5/0000:02:00.0 (sky2)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:22:15:45:e1:c1", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x11ab:/sys/devices/pci0000:00/0000:00:1e.0/0000:04:02.0 (skge)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:22:15:46:31:f1", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

# USB device 0x:0x (cdc_ether)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:1e:10:1f:0A:01", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth2"

# USB device 0x:0x (rtl8192cu)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:07:c9:18:41:ab", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

# USB device 0x:0x (rt2800usb)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="7c:dd:90:40:e1:da", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan1"

Tak jak widać generowane przez automat.
Choć jak patrzę na to, to przypomina mi się, że jednak chyba generowałem tym programikiem /lib/udev/write_net_rules sobie reguły, także raczej nie było to jednak przy aktualizacji systemu.
Plik reguł jest z 2015 roku więc mogło mi to umknąć :)
W każdym razie musiało to być jeszcze przed przejściem na "persistence names".

Ostatnio edytowany przez arecki (2019-05-20 18:10:53)

Offline

 

#12  2019-05-21 15:57:36

  hi - Użytkownik

hi
Użytkownik
Zarejestrowany: 2016-03-24

Re: Problem ze static ip na eth1

nowe nazwy oparte o id czipa są z dupy za przeproszeniem, na mojej wlance usb miałem krzaki na pół monitora, przecież taka z dupy nazwa utrudnia konfigurację i jakiekolwiek odwołania do interfejsu a dajmy na to przy dziesięciu takich sieciówek można dostać oczopląsów, niezły debil bez wyobraźni to wprowadził (systemd :)

Ostatnio edytowany przez hi (2019-05-21 16:13:21)


"Jeśli wolność słowa w ogóle coś oznacza, to oznacza prawo do mówienia ludziom tego, czego nie chcą słyszeć."
Eric Arthur Blair

Offline

 

#13  Wczoraj 03:16:25

  Jacekalex - Podobno człowiek...;)

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Problem ze static ip na eth1

arecki napisał(-a):

hi napisał(-a):

arecki napisał(-a):

A ja do dzisiaj mam stare nazewnictwo, a parametrów w kernelu nie zmieniałem, widać udev mi to załatwił w trakcie aktualizacji

na pewno nie na debianie (chyba, że nie wiesz co masz wsadzone w regułach udeva)


Kod:

cat /etc/udev/rules.d/60-scheduler.rules 
ACTION=="add|change", KERNEL=="sd*[!0-9]|sr*", ATTR{queue/scheduler}="bfq"

A na Debianie testingu od wheezy.

Kod:

cat /etc/udev/rules.d/70-persistent-net.rules 
# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.

# PCI device 0x11ab:/sys/devices/pci0000:00/0000:00:1c.5/0000:02:00.0 (sky2)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:22:15:45:e1:c1", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x11ab:/sys/devices/pci0000:00/0000:00:1e.0/0000:04:02.0 (skge)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:22:15:46:31:f1", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

# USB device 0x:0x (cdc_ether)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:1e:10:1f:0A:01", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth2"

# USB device 0x:0x (rtl8192cu)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:07:c9:18:41:ab", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

# USB device 0x:0x (rt2800usb)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="7c:dd:90:40:e1:da", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan1"

Tak jak widać generowane przez automat.
...

Lepiej odzwyczajaj się od używania mac-adresów w takich regułach
Jak zaczniesz do wifi używać macchangera, to zrozumiesz, dlaczego. xD

Obecnie w udevie pliczek z regułami powinien się nazywać:

Kod:

/etc/udev/rules.d/80-net-name-slot.rules

natomiast optymalna i odporna na zmiany mac-adresu co 68 sekund regułka tak:

Kod:

# USB device 0x0cf3:0x9271 (usb)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ENV{ID_NET_NAME_PATH}=="wlp0s29f7u2", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

Pozdro

Ostatnio edytowany przez Jacekalex (Wczoraj 03:17:12)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#14  Wczoraj 06:20:42

  arecki - Użytkownik

arecki
Użytkownik
Skąd: 44 Bronson Lane Hensonville
Zarejestrowany: 2016-03-03

Re: Problem ze static ip na eth1

To desktop z łączem kablowym, z WIFI korzystam sporadycznie także nie widzę potrzeby się odzwyczajać.

Obecnie mam jedynie problem z kartą sky2, bo po wybudzeniu systemu ze wstrzymania, sterownik ma jakiś problem z IRQ i wtedy ręcznie jeszcze przeładowuję moduł w kernelu.

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Nas ludzie lubią po prostu, a nie klikając w przyciski ;-)