Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2018-12-05 14:50:58

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Od pewnego czasu doświadczam dziwnego efektu zawieszania się wyświetlanego obrazu na monitorze mojego laptopa. Najlepiej to widać na przykładzie oglądania filmu -- odtwarzanie klatek niby się zatrzymuje ale film jest odtwarzany dalej, bo dźwięk leci normalnie i nie przywiesza się. Kiedy taki freez odpuści, to obraz filmu dostaje nagłego przyśpieszenia tak by nadrobić względem odtwarzanej ścieżki audio i po chwili wszystko wraca do normy. Taka sytuacja nie dotyczy tylko filmów, tylko generalnie zawieszania się całego pulpitu, przynajmniej tego co jest wyświetlane na ekranie. Mysza po ekranie swobodnie się przemieszcza ale kliki już nie działają. Z kolei jeśli chodzi o klawiaturę, to na ekranie się nie wyświetlają znaki podczas tego freeza ale jak odpuści, to już albo są wpisane albo raz dwa w przyśpieszonym tempie te znaki wskakują. Procesor, RAM i dysk nie są obciążone w żaden sposób (przy 0M w SWAP) -- ta sytuacja przytrafia się nawet gdy na laptopie nic nie robię, np. czytam kawałek tekstu. Nie ma żadnych logów systemowych z tego zdarzenia....

Co może być przyczyną i jak ewentualnie zdiagnozować taki problem? Ktoś miał coś podobnego? xD

Offline

 

#2 2018-12-05 17:06:20

młodyLinuxiarz
Użytkownik
Zarejestrowany: 2016-01-25

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Może ma to coś wspólnego ze skalowaniem częstotliwości procesora ? Może jądro sobie z tym nie radzi i zmiana częstotliwości powoduje jakie zmrożenia

Dopisek: W trybie tekstowym też to samo się dzieje ?

Ostatnio edytowany przez młodyLinuxiarz (2018-12-05 17:07:03)


Nic na siłę, wszystko młotkiem :-P

Offline

 

#3 2018-12-05 17:31:35

numer_inaczej
Użytkownik
Zarejestrowany: 2014-08-15

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Tak na marginesie dodam, że kilka ładnych lat temu coś skopali w gkrellm - ten odnotowywał chyba w tmp stan monitorów. Może tym razem coś podobnego - np. w conky?
Ale to oczywiście taka ostateczna z ostatecznych prób jak cię przyciśnie ;)

Offline

 

#4 2018-12-05 17:48:55

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

@młodyLinuxiarz, wiesz ten procesor się przełącza nie wiem ile razy w ciągu minuty na różne częstotliwości ale gdyby to było winną tego przełączania, to bym taki freez miał ciągle. A on się zdarza czasami raz na parę godzin a czasami 2 razy w pół godziny. Nie ma znaczenia obciążenie procesora. A w trybie tekstowym nie używam kompa na co dzień, to nie wiem. xD

Ostatnio edytowany przez morfik (2018-12-05 17:49:13)

Offline

 

#5 2018-12-05 19:40:05

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Sprawdź czy problem występuje przy korzystaniu z innego menedżera okien, koncie innego użytkownika i może na jakimś LiveCD — by wyeliminować problem sprzętowy.

Offline

 

#6 2018-12-05 20:03:01

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

No na windowsie jak siedziałem ostatnio to freezów nie łapał wcale, także raczej to nie jest wina samego sprzętu, być może linux'owych sterów. Może faktycznie też coś tutaj openbox się wiesza. Sprawdzam póki co kilka innych pomysłów i jak nic z tego nie będzie, to zobaczę czy to faktycznie wina openbox'a, bo on wydaje się bardzo podejrzany, zwłaszcza przy takich objawach. xD

Offline

 

#7 2018-12-05 20:11:28

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Ja bym sprawdził na Fluxboksie — jest bardzo łatwy do szybkiego skonfigurowania do takich testów.

Offline

 

#8 2018-12-05 20:19:06

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

No tak, tylko wiesz, te freezy są bardzo nieregularne. xD

Offline

 

#9 2018-12-06 19:34:20

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Udało mi się ustalić, że gdy taki freez się załącza, to on dotyczy tylko i wyłącznie sesji graficznej -- mogę się podczas takiego freeza przełączyć na TTY via ctrl+alt+F1. Czyli klawiatura również działa (obok myszy i dźwięku), choć ten freez powstrzymuje klawisze przed dotarciem do aplikacji (albo docierają w czasie rzeczywistym i dopiero później to widać jakby były wpisywane) xD. Pod TTY podczas tego freez'a mogę swobodnie pisać, ale po powrocie do sesji graficznej, ta dalej wisi przez kilka jeszcze sekund. Wygląda na to, że albo xserver się wiesza albo openbox. Trzeba popatrzeć ale te objawy wskaują jednak, że to openbox. xD

Ostatnio edytowany przez morfik (2018-12-06 19:39:13)

Offline

 

#10 2018-12-06 21:00:13

wikingagressor
Użytkownik
Skąd: Józefów k.Błonia, mazowieckie
Zarejestrowany: 2015-02-03

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

morfik napisał(-a):

Udało mi się ustalić, że gdy taki freez się załącza, to on dotyczy tylko i wyłącznie sesji graficznej — mogę się podczas takiego freeza przełączyć na TTY via ctrl+alt+F1. Czyli klawiatura również działa (obok myszy i dźwięku), choć ten freez powstrzymuje klawisze przed dotarciem do aplikacji (albo docierają w czasie rzeczywistym i dopiero później to widać jakby były wpisywane) xD. Pod TTY podczas tego freez'a mogę swobodnie pisać, ale po powrocie do sesji graficznej, ta dalej wisi przez kilka jeszcze sekund. Wygląda na to, że albo xserver się wiesza albo openbox. Trzeba popatrzeć ale te objawy wskaują jednak, że to openbox. xD

Hmm, ostatnio tez tak mialem, ze podczas np przegladania yt w necie cos sie zacina raz na jakis czas. Poniewaz nie mam openbox tylko korzystam z xfce, to raczej mozliwe jest ze to xorg cos kombinuje. Moze ktos sie probuje z zewnatrz dostac do sesji graficznej.


Peace, Love and Debian for the World!!!

Offline

 

#11 2018-12-06 23:05:17

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

morfik napisał(-a):

Udało mi się ustalić, że gdy taki freez się załącza, to on dotyczy tylko i wyłącznie sesji graficznej — mogę się podczas takiego freeza przełączyć na TTY via ctrl+alt+F1. Czyli klawiatura również działa (obok myszy i dźwięku), choć ten freez powstrzymuje klawisze przed dotarciem do aplikacji (albo docierają w czasie rzeczywistym i dopiero później to widać jakby były wpisywane) xD. Pod TTY podczas tego freez'a mogę swobodnie pisać, ale po powrocie do sesji graficznej, ta dalej wisi przez kilka jeszcze sekund. Wygląda na to, że albo xserver się wiesza albo openbox. Trzeba popatrzeć ale te objawy wskaują jednak, że to openbox. xD

Ewidentnie Xorg, i to nie tylko na OpenBoxie, ale na innych managerach okien bywa podobnie.
Zobacz, o ile sterownik GPU pozwala, czy podobne objawy są na OpenBoxie uruchomionym przez Wayland/Xwayland, i spróbuj też na czystym Waylandzie, ale to już niestety na razie nie na OpenBoxie czy Fluxboxie.


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#12 2018-12-06 23:40:09

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Jeśli ten fluxbox się nie będzie wieszał, to odpowiedź będzie raczej oczywista. Póki co odpaliłem na nim te same appki, które mam w openbox, i zobaczymy co z tego będzie -- popatrzę przez parę dni. Działająca mysza wskazuje raczej, że to nie jest wina z xserverem, bo to on przecie odpowiada za jej działanie, więc skoro xserver działa, to raczej kuleje wyświetlanie okienek. Chyba, że samo wyświetlanie okienek w xserverze ma jakiś problem. xD

Offline

 

#13 2018-12-07 00:38:28

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

U mnie czasem mysz chodzi płynnie a klawiatura ma lagi minutowe.
Zauważyłem to kiedyś na Gnome 3, zdarza się też na Mate i na KDE, zazwyczaj pod sporym obciążeniem systemu.

Na Westonie podobnego efektu nie udało mi się osiągnąć pod żadnym obciążeniem, natomiast na Xorgu od lat miewam takie cyrki,
dlatego portage musiałem obciąć przez cgroup, żeby nie blokowało za bardzo dysku ani procka.

U ciebie procek dostaje w doopę przez szyfrowanie dysku, to na 99.9% jest przyczyna,
dla której Xorg dostaje czasem czkawki.
To z resztą jest dosyć znany błąd Xorga, jeden z tysiąca.

Do tego Xorg ma budowę modułową, pamiętam kiedyś jeszcze w Ubu, myszka reagowała
z lagiem około 3 sekundowym na Xorgu, ale działała płynnie w konsoli, pomogła wtedy aktualizacja kernela. Co ciekawe, myszka łapała lagi ale klawiatura działała normalnie,
co było jeszcze dziwniejsze.
Przekonałem się wtedy, że sterowniki i moduły  Xorga działają niezależnie od siebie, blokada np ekranu czy klawiatury nie oznacza blokady myszki i odwrotnie.

Dlatego radzę spróbować wg schematu: Weston+Xwayland+Openbox.

Pozdro

Ostatnio edytowany przez Jacekalex (2018-12-07 00:39:41)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#14 2018-12-07 00:59:36

ciastek1981
Użytkownik
Zarejestrowany: 2016-06-19

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Eee, albo i915 i kernel albo powrót https://github.com/paradoxxxzero/gnome-shell-system … et/issues/187

PS Nawet dla kogoś rozwiązania tego problemu szukałem "Intel i915 GPU Freeze on Recent Linux Kernels".

Ostatnio edytowany przez ciastek1981 (2018-12-07 01:00:59)


Forum Linux Mint Polska http://forum.linuxmint.pl/

Jak się pisze ;) https://jaksiepisze.pl/

Offline

 

#15 2018-12-07 01:25:46

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Pod obciążeniem, to i u mnie się wszystko przycina dlatego też okroiłem sobie trochę rzeczy przez cgroups i jest nieco lepiej ale to w sumie jest osobną kwestią. U mnie te freezy pojawiają się, gdy ten system jest prawie bezczynny -- po prostu oglądam np. taki film:  xD

Kod:

Bit rate : 1 036 kb/s
Width : 640 pixels
Height : 352 pixels
Frame rate :24.972 FPS
Stream size :304 MiB (91%)

To nie jest jakieś duże obciążenie procka -- mpv ma <10% na jednym rdzeniu, a zużycie procka jest w zakresie 15% na dwóch rdzeniach. Więc ten komp prawie nic nie robi i freez'a łapie? To już lepiej chodzi gdy ma 100% na obu rdzeniach. No fakt lagi są ale nie łapie freez'a na 15s, tylko czasem na 1-2s. xD

Offline

 

#16 2018-12-07 01:45:38

Jacekalex
Podobno człowiek...;)
Skąd: /dev/urandom
Zarejestrowany: 2008-01-07

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

A co dekoduje Video?
GPU czy CPU?

Pytam, bo jak chciałem otworzyć HEVC 8k na Vlc, to skończyło się to na SYSRQ+K (zamiast filmu, nie w trakcie).
Dopiero na MPV z dekodowaniem opartym na opengl jakoś to funkcjonowało.

Ostatnio edytowany przez Jacekalex (2018-12-07 01:46:19)


W demokracji każdy naród ma taką władzę, na jaką zasługuje ;)
Si vis pacem  para bellum  ;)       |       Pozdrawiam :)

Offline

 

#17 2018-12-07 03:30:43

ciastek1981
Użytkownik
Zarejestrowany: 2016-06-19

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Morfik, a ty nie masz tak jakiegoś starego Pentiuma? Może cstate trzeba jak w Bay Trail'ach ustawić? W grubie "intel_idle.max_cstate=1".


Forum Linux Mint Polska http://forum.linuxmint.pl/

Jak się pisze ;) https://jaksiepisze.pl/

Offline

 

#18 2018-12-07 03:40:46

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Już wcześniej patrzyłem z wyłączaniem tego cstate i nie działa nawet przy 0. :]

Offline

 

#19 2018-12-07 11:46:27

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Ja bym szukał problemu w samym Openboksie lub ewentaulanie Xorgu/sterowniku grafiki.

To tylko jakieś zawirowania w rysowaniu/wyświetlaniu okienek. Sam system działa normalnie.

PS Używasz jakiegoś menedżera kompozycji?

Offline

 

#20 2018-12-07 13:37:03

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Ja używam Compton'a jako menadżer kompozycji.

Wygląda na to, że Fluxbox też się wiesza, więc to nie jest wina samego Openbox'a. Czyli pozostaje xserver albo stery do grafy, albo jeszcze compton -- choć jego można wyłączyć i sprawdzić. Jak nic to nie da to może jeszcze spróbuję wywalić cały config xserver'a, bo może tam jakieś opcje są, które powodują tego typu zachowanie.

Ostatnio edytowany przez morfik (2018-12-07 15:00:26)

Offline

 

#21 2018-12-07 15:03:54

ciastek1981
Użytkownik
Zarejestrowany: 2016-06-19

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Jaki sterownik obrabia twoją kartę? Piszesz o tym P6100 z Intel HD - Arrandale?


Forum Linux Mint Polska http://forum.linuxmint.pl/

Jak się pisze ;) https://jaksiepisze.pl/

Offline

 

#22 2018-12-07 15:40:29

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

No ten P6100 ma mój laptop.

Offline

 

#23 2018-12-08 13:23:30

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Wygląda na to, że konfiguracja xorg'a na nic nie wpływa. Co ciekawe domyślny config, czyli bez plików w /etc/X11/xorg.conf.d/ działa bardzo ciekawie. Niby sesja graficzna startuje jak należy ale co druga appka łapię segfault'a, a smplayer nie potrafi odtworzyć filmu w swoim okienku i woła do tego osobne okienko mpv (film działa ale np. vlc łapie crash). xD Jak się określi minimalny config w postaci:

Kod:

Section "Device"
    Identifier "Device0"
    Driver "intel"
EndSection

To wszystko wraca do normy ale freez'y dalej występują.

Jeszcze tak na wszelki wypadek powróciłem sobie do lightdm z sddm. Mam takie dziwne wrażenie, że te problemy zaczęły mi się w momencie zmiany tego menadżera. Może to coś pomoże.

Ostatnio edytowany przez morfik (2018-12-08 13:24:37)

Offline

 

#24 2018-12-08 13:32:39

yossarian
Szczawiożerca
Skąd: Shangri-La
Zarejestrowany: 2011-04-25

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Offline

 

#25 2018-12-08 13:35:52

morfik
Cenzor wirtualnego świata
Skąd: ze WSI
Zarejestrowany: 2011-09-15
Serwis

Re: Obraz zawiesza się nieregularnie co jakiś czas na parę sekund

Domniemywam, że jak usunąłem cały konfig xserwera, to właśnie ten "builtin modesetting" był w użyciu i on nie działał za dobrze. xD Niby ustawiłem mu na sztywno modesetting ale to działa dokładnie tak samo jak bez żadnej konfiguracji, czyli vlc przy odtwarzaniu filmów łapie segfaulta, a smplayer woła dodatkowe okienko mpv. xD Nawet apparmor'a wyłączyłem by sprawdzić czy to może on nie bruździ ale najwyraźniej ten modesetting nie potrafi obsłużyć mojej karty poprawnie, albo trzeba coś gdzieś jeszcze skonfigurować. xD

Ostatnio edytowany przez morfik (2018-12-08 13:44:50)

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Nas ludzie lubią po prostu, a nie klikając w przyciski ;-)