Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2017-04-17 17:38:45

DuchDucha
Użytkownik
Zarejestrowany: 2013-09-24

Usunięcie szumów podczas nagrywania

Ostatnio bawię się w nagrywanie dźwięku na Debianie Stable. Podłączyłem Do laptopa Dell e6430 kartę Creative X-Fi Surround 5.1 pro przez usb i do niego przez wtyczkę Jack mikrofon dynamiczny. Na Audacity nagrywa bardzo cicho, a czasem wariuje. Zainstalowałem OBS Studio 18.0.1 (zajebisty program) i podłączyłem kamerkę. Nadal było cicho. Podgłosiłem w alsamixerze wszystko co było można na maksimum, a w OBSie czułość na 30. Teraz jest dużo szumów, których nie udaje mi się usunąć (wyłączenie niepotrzebnych urządzeń, zamknięcie okna itp). Dbałem w filtrach bramkę szumów, ale ona po prostu odcina dzięki gdy się nie mówi, a gdy się mówi szumy się pojawiają.

Jak jeszcze zrobić nagranie głośniejszym i jednocześnie zredukować szumy?

Offline

 

#2 2017-04-17 20:58:07

jawojx
Użytkownik
Zarejestrowany: 2012-10-11

Re: Usunięcie szumów podczas nagrywania

Ja bym sprawdził czy źródłem szumów nie jest zasilanie, powinna być prawidłowo uziemiona sieć elektryczna lub filtr szumów. Odłącz zasilanie sprawdź na samej baterii. Może mikrofon wewnętrzny w laptopie jest włączony.

Kod:

arecord -vv -fdat test.wav

Offline

 

#3 2017-04-17 21:56:32

seler
Użytkownik
Zarejestrowany: 2012-05-15

Re: Usunięcie szumów podczas nagrywania

Zainteresuj się pakietem sox i jego filtrem noisered. Polega to na tym, że nagrywasz najpierw 1s ciszy - nagrywa się prawie sam specyficzny dla danego mikrofonu szum. Potem sox używa tego nagrania szumów, żeby odszumić właściwe nagranie.


a to feler westchnął seler

Offline

 

#4 2017-04-17 23:21:30

DuchDucha
Użytkownik
Zarejestrowany: 2013-09-24

Re: Usunięcie szumów podczas nagrywania

Środowisko to Mate. Wyłączyłem systemowo mikrofon w lapku. Jutro pogrzebie w ustawieniach alsamixera. Na baterii sprawdziłem raz i wtedy wariowało. Na Audacity był szeroki wykres, ale brak nagrania. 

Nigdy w życiu nie spotkałem się z tym poleceniem. Po dmuchnięciu w mikrofon procent zwiększa się do 2.

Kod:

$ arecord -vv -fdat test.wav
Recording WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Stereo
ALSA <-> PulseAudio PCM I/O Plugin
Its setup is:
  stream       : CAPTURE
  access       : RW_INTERLEAVED
  format       : S16_LE
  subformat    : STD
  channels     : 2
  rate         : 48000
  exact rate   : 48000 (48000/1)
  msbits       : 16
  buffer_size  : 24000
  period_size  : 6000
  period_time  : 125000
  tstamp_mode  : NONE
  period_step  : 1
  avail_min    : 6000
  period_event : 0
  start_threshold  : 1
  stop_threshold   : 24000
  silence_threshold: 0
  silence_size : 0
  boundary     : 6755399441055744000
#+                                                 | 00%

Offline

 

#5 2017-04-18 00:06:12

jawojx
Użytkownik
Zarejestrowany: 2012-10-11

Re: Usunięcie szumów podczas nagrywania

Przełącz zasilacz tam gdzie masz uziemienie. A co do arecord, no to ustaw odpowiednio nagrywanie (głośność, no 2% to za mało powinno być 30% najmniej) pogadaj tam trochę, możesz i dmuchać. I sprawdź co się nagrało i czy są szumy. Wszystko jedno jak. można i tak odsłuchać:

Kod:

apley test.wav

W alsamixer poszukaj swojej karty, wyłącz odsłuch mikrofonu, ja mam swoją pod 0.

Kod:

alsamixer -c0

Offline

 

#6 2017-04-21 09:27:42

DuchDucha
Użytkownik
Zarejestrowany: 2013-09-24

Re: Usunięcie szumów podczas nagrywania

Z braku pomysłów na maksimum ustawiłem PCM i Master, resztę wyciszyłem do minimum, a Auto-Mute Mode i Loopback zrobiłem na Disabled. Myślałem, że nic się nie nagra. Na Audacity jednak nagrywa coś bardzo cicho, po użyciu funkcji "Bas i sopran" dźwięk ma akceptowalną głośność, ale i szumy. W OBS za to dzieją się cuda. Nagrał tak głośno, że musiałem zredukować czułość z 30 do 10, a szumy są akceptowalne. Chyba są jeszcze jakieś ustawienia o których nie wiem, albo tego nie rozumiem.

Offline

 

#7 2017-04-21 13:37:57

jawojx
Użytkownik
Zarejestrowany: 2012-10-11

Re: Usunięcie szumów podczas nagrywania

Nie czytałem teraz całego wątku, ale czy ty próbowałeś wyłączyć pulseaudio. W kdenlive były kiedyś zakłócenia dźwięku z pulseaudio, tylko pulseaudio nie wyłączysz ot tak musisz ustawić wpis w konfiguracji by sie nie restartował.
Wpis:

Kod:

echo autospawn = no > $HOME/.config/pulse/client.conf

Wyłaczenie:

Kod:

pulseaudio --kill

Po sprawdzeniu przywrócenie działania pulseaudio.

Usunięcie wpisu:

Kod:

rm $HOME/.config/pulse/client.conf

Uruchomienie pulseaudio:

Kod:

pulseaudio --start

Ja napisałem skrypt do uruchamiania kdenlive, bo nie dało się nic robić z podsłuchem.

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Nas ludzie lubią po prostu, a nie klikając w przyciski ;-)