Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2016-08-03 10:59:17

nascisz
Użytkownik
Zarejestrowany: 2009-01-10

Openbsd i zwis kompa

Witam.

Od pewnego czasu mam postawiony serwer openbsd v. 5.8 na starym kompie jako serwer plików, poczty itp. Raz na jakiś czas dzieje się coś dziwnego: serwer zawiesza się jednocześnie grzejąc się mocno, wentylator procesora pracuje na pełnych obrotach, reset możliwy tylko po odłączeniu od sieci.
Pomyślałem że może coś sprzętowo jest nie tak. Przeniosłem więc dyski na nowszy komp z mocnym procesorem i dużą pamięcią i jest podobnie. Chodzi wszystko normalnie i nagle w jednej chwili wentylatory na max i totalny zwis.
I teraz zastanawiam się czy to jakiś rodzaj ataku czy jakiś błąd systemu powodujący taką reakcję??
Pozdrawiam...

Offline

 

#2 2016-08-03 11:18:06

uzytkownikubunt
Zbanowany
Zarejestrowany: 2012-04-25

Re: Openbsd i zwis kompa

3099

Ostatnio edytowany przez uzytkownikubunt (2016-12-01 01:42:45)

Offline

 

#3 2016-08-03 11:56:34

nascisz
Użytkownik
Zarejestrowany: 2009-01-10

Re: Openbsd i zwis kompa

System mam w wersji stable. W logach czysto. Arch amd64. Aktualizacje na bieżąco. Przed chwilą uruchomiłem serwer bez dostępu do sieci i po paru minutach znów to samo. Wentylatory na max i totalny zwis.
Mam wrażenie jakby coś z systemem było nie tak. Nie bardzo wiem jak zdebugować jądro, może tam jest jakaś wskazówka....
Co ciekawe dziś gdy w ramach eksperymentu przeniosłem system system na mocniejszy komp (intel dual core 2.40GHz, 4 GB ram) dzieje się to często, dosłownie po kilku minutach.
Może ACPI w biosie ustawione na yes ma jakieś znaczenie? Jest jeszcze ACPI APIC support - Enabled....
Dyski spięte w softraid.

Ostatnio edytowany przez nascisz (2016-08-03 12:23:39)

Offline

 

#4 2016-08-03 13:05:44

uzytkownikubunt
Zbanowany
Zarejestrowany: 2012-04-25

Re: Openbsd i zwis kompa

3100

Ostatnio edytowany przez uzytkownikubunt (2016-12-01 01:42:46)

Offline

 

#5 2016-08-03 14:51:58

nascisz
Użytkownik
Zarejestrowany: 2009-01-10

Re: Openbsd i zwis kompa

Niestety system się wiesza nawet gdy uruchomiłem w trybie single. Podmontowałem tylko partycje, żadna usługa nie pracowała. Może coś z tym softraid coś nie tak?

Offline

 

#6 2016-08-03 15:11:46

uzytkownikubunt
Zbanowany
Zarejestrowany: 2012-04-25

Re: Openbsd i zwis kompa

3101

Ostatnio edytowany przez uzytkownikubunt (2016-12-01 01:42:47)

Offline

 

#7 2016-08-03 15:54:30

nascisz
Użytkownik
Zarejestrowany: 2009-01-10

Re: Openbsd i zwis kompa

System jest już zainstalowany na softraid. Najpierw preparuje się dyski pod soft raid, później właściwa instalacja systemu. Zrobiłem to wg opisu http://www.bsdweb.eu/softraid.html. System plików montowany jest domyślnie wg fstab. Przykładowy wpis: /dev/sd0k /home ffs rw, nodev,nosuid 1 2. Dyski są sprawne (polecenie bioctl softraid0).

Offline

 

#8 2016-08-03 17:48:38

uzytkownikubunt
Zbanowany
Zarejestrowany: 2012-04-25

Re: Openbsd i zwis kompa

3102

Ostatnio edytowany przez uzytkownikubunt (2016-12-01 01:42:48)

Offline

 

#9 2016-08-03 18:19:25

nascisz
Użytkownik
Zarejestrowany: 2009-01-10

Re: Openbsd i zwis kompa

Czy mam to uruchomić w trybie single?

Offline

 

#10 2016-08-03 18:28:59

uzytkownikubunt
Zbanowany
Zarejestrowany: 2012-04-25

Re: Openbsd i zwis kompa

3103

Ostatnio edytowany przez uzytkownikubunt (2016-12-01 01:42:50)

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
To nie jest tylko forum, to nasza mała ojczyzna ;-)