Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2015-03-18 00:39:56

Lopus2
Użytkownik
Zarejestrowany: 2012-01-22

apache22 problem

witajcie mam takie problem z apach'em

Kod:

[Wed Mar 11 12:01:38 2015] [alert] (EAI 8)hostname nor servname provided, or not known: mod_unique_id: unable to find IPv4 address of "mk200"
Configuration Failed

co moge zrobic aby to naprawic ?

Offline

 

#2 2015-03-18 20:00:59

Yampress
Imperator
Zarejestrowany: 2007-10-18

Re: apache22 problem

co jest w /etc/hosts ?

Offline

 

#3 2015-03-19 13:53:47

bryn1u
Użytkownik
Zarejestrowany: 2009-04-17

Re: apache22 problem

Odkomentuj ta linie:

Kod:

LoadModule unique_id_module libexec/apache22/mod_unique_id.so

w

Kod:

/usr/local/etc/apache22/httpd.conf

E-Booki: FreeBSD, OpenBSD, Linux, Hacking, PHP, Catia, Perl_CGI, Mysql ...
http://unix-ebooki.neth.pl/

Offline

 

#4 2015-03-22 21:18:26

Lopus2
Użytkownik
Zarejestrowany: 2012-01-22

Re: apache22 problem

nie było zakomentowana
natomiiast teraz mam taki problem:

Kod:

root@mk200: # apachectl start
Performing sanity check on apache22 configuration:
httpd: apr_sockaddr_info_get() failed for mk200
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
Syntax OK
Starting apache22.
httpd: apr_sockaddr_info_get() failed for mk200
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
/usr/local/etc/rc.d/apache22: WARNING: failed to start apache22

Offline

 

#5 2015-03-23 20:39:47

Yampress
Imperator
Zarejestrowany: 2007-10-18

Re: apache22 problem

pytam 2gi raz

jakie wpisy masz w /etc/hosts?
masz skonfigurowane virtualhosty?

Offline

 

#6 2015-03-24 01:44:15

Lopus2
Użytkownik
Zarejestrowany: 2012-01-22

Re: apache22 problem

Kod:

# $FreeBSD: release/9.2.0/etc/hosts 109997 2003-01-28 21:29:23Z dbaker $
#
# Host Database
#
# This file should contain the addresses and aliases for local hosts that
# share this file.  Replace 'my.domain' below with the domainname of your
# machine.
#
# In the presence of the domain name service or NIS, this file may
# not be consulted at all; see /etc/nsswitch.conf for the resolution order.
#
#
::1            localhost localhost.my.domain
127.0.0.1        localhost localhost.my.domain
#
# Imaginary network.
#10.0.0.2        myname.my.domain myname
#10.0.0.3        myfriend.my.domain myfriend
#
# According to RFC 1918, you can use the following IP networks for
# private nets which will never be connected to the Internet:
#
#    10.0.0.0    -   10.255.255.255
#    172.16.0.0    -   172.31.255.255
#    192.168.0.0    -   192.168.255.255
#
# In case you want to be able to connect to the Internet, you need
# real official assigned numbers.  Do not try to invent your own network
# numbers but instead get one from your network provider (if any) or
# from your regional registry (ARIN, APNIC, LACNIC, RIPE NCC, or AfriNIC.)
#

w httpd.conf ustawiłem ServerName localhost

po ustawieniu na localhost dostaje następujący komuniakt przy próbie włączenia  apache

Kod:

Performing sanity check on apache22 configuration:
Syntax OK
Starting apache22.
/usr/local/etc/rc.d/apache22: WARNING: failed to start apache22

Ostatnio edytowany przez xiva (2015-03-24 01:45:28)

Offline

 

#7 2015-03-24 20:39:07

Yampress
Imperator
Zarejestrowany: 2007-10-18

Re: apache22 problem

Jak działa apache kiedy nie ma zdefiniowanych subdomen? bierze sobie nazwe hosta z /etc/hosts

A gdzie w hosts masz powiazana nazwe swojegop hosta z   adresem ip ?

Pod debianem wygląda to tak u mnie na desktopie...

[yampress@debian ~]$ cat /etc/hosts
127.0.0.1    localhost
10.1.1.254 debian

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
[yampress@debian ~]$

brakuje czegoś w twoim pliku hosts?


Pod localhosta sie apache nie podpina tak jak to chcesz zrobić


I to nie jest to temat BSD tylko temat konfiguracji apache/serwera i nic wspólnego nie ma z BSD tylko to ze jest odpalany na tym systemie.
Wieć najpierw pomyśl gdzie wklejasz takie takie pytania

]:>

Offline

 

#8 2015-03-25 11:34:05

ethanak
Użytkownik
Skąd: Ungwenor
Zarejestrowany: 2010-07-19
Serwis

Re: apache22 problem

e... zawsze myślałem że z ServerName (czyli wpis z localhost jest całkiem prawidłowy)... ale może w ostatnim tygodniu coś się zmieniło?
BTW ja tam bym sprawdził co w errorlogu wylądowało.


Nim mechaniczne larum zagrasz mi, kanalio,
głosząc nadejście Javy - śmiertelnego wroga!
Zespół Adwokacki Dyskrecja

Offline

 

#9 2015-03-25 20:30:26

Yampress
Imperator
Zarejestrowany: 2007-10-18

Re: apache22 problem

stawiamy serwer dla wiekszej liczby ludzi niż dla lokalnego użyszkodnika

Offline

 

#10 2015-03-26 07:05:10

ethanak
Użytkownik
Skąd: Ungwenor
Zarejestrowany: 2010-07-19
Serwis

Re: apache22 problem

A kto Wam w takim razie bzdur naopowiadał, że nazwą kanoniczną serwera nie może być localhost??? Owszem, nie jest to specjalnie mile widziane (potem może być problem z UseCanonicalName On - tylko po co to stosować?) ale całkiem prawidłowe. Niezależnie od tego, czy serwer stoi na 127.0.0.1 dla jednego użytkownika czy ma pięćset adresów IP.
Szukajcie problemu tam gdzie on jest, Apacz sobie doskonale daje radę bez wydumek w /etc/hosts - co zresztą bardzo ładnie zademonstrował:

Kod:

httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName

A kolega wątkotwórca mógłby jakieś dokładniejsze komunikaty błędów pokazać (np. z errorloga), bo z tego co zostało nam okazane nic nie wynika.


Nim mechaniczne larum zagrasz mi, kanalio,
głosząc nadejście Javy - śmiertelnego wroga!
Zespół Adwokacki Dyskrecja

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Nas ludzie lubią po prostu, a nie klikając w przyciski ;-)