Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2010-07-23 20:34:16

azhag
Admin łajza
Skąd: Warszawa
Zarejestrowany: 2005-11-15

Pakiet Mileny

Bez zbędnego wodolejstwa — zgodnie ze wczorajszą obietnicą wstępna wersja pakietu Mileny 0.2.19.1. Na razie dość brzydko (wszystko w jednym pakiecie, nie wszystkie informacje wypełnione jak należy, lintian ma kilka uwag o to czy tamto), ale powinno wszystko działać.

Zamierzam porozdzielać pakiet na mniejsze (milena, milena-common, milena-utils, milena-gtk, milena-dev, ...).

Na razie pakiet przeznaczony jest dla Debiana tylko, okazało się, że w Ubuntu nie ma libao4, tylko libao2... Ktoś będzie musiał przekompilować (sam Ubuntu nie mam), również wersji dla amd64 nie mam gdzie zbudować. Banalna instrukcja jak to zrobić niżej.

Do pobrania wersja dla Debiana:
- http://dug.net.pl/~azhag/milena/milena_0.2.19.1-1_i386.deb

Oraz pakiet źródłowy:
- http://dug.net.pl/~azhag/milena/milena_0.2.19.1-1.debian.tar.gz
- http://dug.net.pl/~azhag/milena/milena_0.2.19.1-1.dsc
- http://dug.net.pl/~azhag/milena/milena_0.2.19.1.orig.tar.gz

Aby przekompilować pakiet źródłowy wystarczy pobrać 3 powyższe pliki i wykonać kolejne 3 polecenia:

Kod:

wget http://dug.net.pl/~azhag/milena/milena_0.2.19.1-1.debian.tar.gz http://dug.net.pl/~azhag/milena/milena_0.2.19.1-1.dsc http://dug.net.pl/~azhag/milena/milena_0.2.19.1.orig.tar.gz
dpkg-source -x milena_0.2.19.1-1.dsc
cd milena-0.2.19.1
dpkg-buildpackage -rfakeroot

Jak widać poradziłaby sobie nawet nieszkolona małpa. ;)


Błogosławieni, którzy czynią FAQ.
opencaching :: debian sources.list :: coś jakby blog :: polski portal debiana :: linux user #403712

Offline

 

#2 2010-07-24 12:32:46

ethanak
Użytkownik
Skąd: Ungwenor
Zarejestrowany: 2010-07-19
Serwis

Re: Pakiet Mileny

To parę pytań:

1) czekam na słowniki od kumpla, zależnie od ich objętości jutro/pojutrze będzie nowa wersja Mileny. Jaki będzie problem z podbiciem wersji do 0.2.20.0?
Milena zmienia się dość często, teraz akurat mamy wakacje i nie bardzo mi się chce, ale czasami dane zmieniają się codziennie...

Dzisiejsze zmiany nie są specjalnie krytyczne, ale poprawiają czytanie kilku konstrukcji gramatycznych, więc warto mieć wszystko nowe...

Aha, wyleci moduł generic do speech-dispatchera.

2) czy mogę umieścić linki na stronie Mileny (w download)?

3) jeśli tak - czy nie lepiej ze źródła mieć w jednym pliku?

4) jeśli chodzi o rozparcelowanie Mileny na poszczególne deby, powinny być co najmniej trzy (zgodnie z tym co jest na stronie):

a) milena (jako taka). Tu można też się bawić w dalszy podział.
b) milena_data (dane). milena powinna wymagać milena_data (w tej samej wersji, czyli milena-0.2.20 powinna wymagać milena_data 0.2.20.x)
c) milena_base. Opcjonalny (ale wymagany np. przez milena_abc, jeśli taki miałby powstać). Tu nie można automatycznie określić zależności, wersja base powinna być najwyższa możliwa nie przekraczająca wersji Mileny (to się akurat rzadko zmienia).

Poza tym jakbyś spaczkował milena_abc (z libepub) to piwo  stawiam (po wypłacie) :)

Tak przy okazji - jako średnio wyszkolona małpa postaram się zrobić deba dla Ubunciaka (10.04 32bit - takie coś mam przed nosem) - ale na razie siedzę w barze, popijam sobie piwko i ostatnia rzecz na którą mam ochotę to kompilacja czegokolwiek :)

Ostatnio edytowany przez ethanak (2010-07-24 12:43:23)


Nim mechaniczne larum zagrasz mi, kanalio,
głosząc nadejście Javy - śmiertelnego wroga!
Zespół Adwokacki Dyskrecja

Offline

 

#3 2010-07-24 13:58:42

azhag
Admin łajza
Skąd: Warszawa
Zarejestrowany: 2005-11-15

Re: Pakiet Mileny

Ad 1. Jeśli nie robisz jakiś większych rewolucji w Makefile'ach, to problemy będą żadne lub pomijalne.

Ad 2. Jasne, gdziekolwiek tylko chcesz. Po to zrobiłem, żeby ludzie korzystali. Jak już porozbijam pakiet na mniejsze mogę przygotować repozytorium.

Ad 3. Cóż, tak już pakiety źródłowe Debiana są skonstruowane, że składają się z kilku plików: (oryginalnych) źródeł, pliku opisowego *.dsc oraz — jeśli pakiet nie jest natywny — archiwum z łatami. Wg mnie tak nawet lepiej, jeśli kogoś interesuje tylko jeden z nich, nie musi pobierać reszty (ależbym klął, jakbym musiał pobierać kilka/kilkadziesiąt/kilkaset MB, żeby podejrzeć w *.dsc pakiety wymagane do kompilacji...).

Ad 4. Osobiście bym spakietował tak:
- milena — metapakiet instalujący wszystkie, kwestia przemyślenia czy milena-abc byłaby w rekomendowanych czy wymaganych
- milena-utils — wszelkie konsolowe programy: milena, milena_say, milena_book, ... (wymaga milena-common)
- milena-common — wszelkie pliki wspólne z /usr/share/milena, /usr/share/doc/milena, /usr/share/milena-words
- milena-dev — pliki nagłówkowe
- milena-abc lub -gtk (pierwsza chyba lepsza) — zawiera milena_abc (wymaga milena-common, jako jedyny pakiet milenowy wymaga GTK)

Pytanie: czy milena_abc wymaga libmilena*.so (jeśli tak, to jeszcze konieczne byłoby libmilena) oraz milena_book, milenizera lub innych?

Chcialbym tak spakietować, aby możliwe było łatwe zainstalowanie wszystkiego, tylko mileny_abc lub tylko konsolowych programów.


Błogosławieni, którzy czynią FAQ.
opencaching :: debian sources.list :: coś jakby blog :: polski portal debiana :: linux user #403712

Offline

 

#4 2010-07-24 14:30:33

ethanak
Użytkownik
Skąd: Ungwenor
Zarejestrowany: 2010-07-19
Serwis

Re: Pakiet Mileny

azhag napisał(-a):

Ad 1. Jeśli nie robisz jakiś większych rewolucji w Makefile'ach, to problemy będą żadne lub pomijalne.

Oprócz poprawienia babola (rm -f w clean) nie przewiduję :)

Ad 2. Jasne, gdziekolwiek tylko chcesz. Po to zrobiłem, żeby ludzie korzystali.

OK. Ja właśnie męczę kumpla o deby na 86_64 - na razie sa jakieś sęki...

Ad 3. Cóż, tak już pakiety źródłowe Debiana są skonstruowane, że składają się z kilku plików[...]

a zobacz - zupełnie jak moje rpm-y i spece :)

Ad 4. Osobiście bym spakietował tak:
- milena — metapakiet instalujący wszystkie, kwestia przemyślenia czy milena-abc byłaby w rekomendowanych czy wymaganych

Nie może być w wymaganych - abc wymaga grafiki, całość mileny (z podstawowego pakietu) działa na konsoli.

- milena-utils — wszelkie konsolowe programy: milena, milena_say, milena_book, ... (wymaga milena-common)

Dodałbym to jeden pakiet (dykcjonarz) ze swoimi wymaganiami. Czyli dykcjonarz wymaga milena_base.

- milena-common — wszelkie pliki wspólne z /usr/share/milena, /usr/share/doc/milena, /usr/share/milena-words

To raczej milena_data (bez tego nic nie pójdzie) i milena_base (plik words, wymagany wyłącznie do dykcjonarza i mileny_abc)

- milena-dev — pliki nagłówkowe

Normalka :)

- milena-abc lub -gtk (pierwsza chyba lepsza) — zawiera milena_abc (wymaga milena-common, jako jedyny pakiet milenowy wymaga GTK)

Pytanie: czy milena_abc wymaga libmilena*.so (jeśli tak, to jeszcze konieczne byłoby libmilena) oraz milena_book, milenizera lub innych?

milena_abc wymaga:

a) libmilena*.so (czyli powiedzmy milena_libs, a milena_libs wymaga milena_data)
b) pliku basewords (czyli milena_base).

Dodatkowo - milena_libs (czyli wyłącznie libmilena*so i data) będą wymagane przez speech-dispatcher-milena i opentts-milena, czyli warto z tego zrobić oddzielny pakiet...

Chcialbym tak spakietować, aby możliwe było łatwe zainstalowanie wszystkiego, tylko mileny_abc lub tylko konsolowych programów.

To wydzieliłbym tu jeszcze jako oddzielny pakiet:
a) milena_ws (90% ludzi tego nie potrzebuje, tylko to z podstawowego pakietu wymaga libao)

b) milena_dykcjonarz - jego funkcję przejęła milena_abc, ale może być przydatny w czysto konsolowych aplikacjach. Wymaga milena_base.

Mam jeszcze problem z milena_convert i tak dalej - ale w takim najbardziej podstawowym pakiecie (czyli biblioteki i mało co więcej) powinny być "milena_convert", "milenizer" i "milena"...


Nim mechaniczne larum zagrasz mi, kanalio,
głosząc nadejście Javy - śmiertelnego wroga!
Zespół Adwokacki Dyskrecja

Offline

 

#5 2010-07-24 17:32:54

mati75
Psuj
Skąd: Rzeszów
Zarejestrowany: 2010-03-14
Serwis

Re: Pakiet Mileny

Zaraz zbuduje paczki dla amd64.

----------edyta-----------------
Nie zrobi paczki sypie mi się na:

Kod:

/usr/bin/make -C src clean
make[1]: Wejście do katalogu `/home/mateusz/Pulpit/milena/milena-0.2.19.1/src'
rm *.o *.so milena milena.h milena.pc milena_cyrillic.h
rm: nie można usunąć `*.o': Nie ma takiego pliku ani katalogu
rm: nie można usunąć `*.so': Nie ma takiego pliku ani katalogu
rm: nie można usunąć `milena': Nie ma takiego pliku ani katalogu
rm: nie można usunąć `milena.h': Nie ma takiego pliku ani katalogu
rm: nie można usunąć `milena.pc': Nie ma takiego pliku ani katalogu
rm: nie można usunąć `milena_cyrillic.h': Nie ma takiego pliku ani katalogu
make[1]: *** [clean] Błąd 1
make[1]: Opuszczenie katalogu `/home/mateusz/Pulpit/milena/milena-0.2.19.1/src'
make: *** [clean] Błąd 2
dpkg-buildpackage: błąd: fakeroot debian/rules clean zwrócił status błędu 2

Ostatnio edytowany przez mati75 (2010-07-24 17:50:05)


https://l0calh0st.pl/obrazki/userbar.png

Offline

 

#6 2010-07-24 18:29:33

ethanak
Użytkownik
Skąd: Ungwenor
Zarejestrowany: 2010-07-19
Serwis

Re: Pakiet Mileny

mati75 napisał(-a):

Zaraz zbuduje paczki dla amd64.

----------edyta-----------------
Nie zrobi paczki sypie mi się na:

Kod:

/usr/bin/make -C src clean

to chyba mój błąd. Poczekaj do jutra, ja swoją część już poprawiłem, kumpel ma poprawić resztę


Nim mechaniczne larum zagrasz mi, kanalio,
głosząc nadejście Javy - śmiertelnego wroga!
Zespół Adwokacki Dyskrecja

Offline

 

#7 2010-07-24 18:57:13

azhag
Admin łajza
Skąd: Warszawa
Zarejestrowany: 2005-11-15

Re: Pakiet Mileny

mati75 napisał(-a):

Nie zrobi paczki sypie mi się na:

Kod:

/usr/bin/make -C src clean
make[1]: Wejście do katalogu `/home/mateusz/Pulpit/milena/milena-0.2.19.1/src'
rm *.o *.so milena milena.h milena.pc milena_cyrillic.h
rm: nie można usunąć `*.o': Nie ma takiego pliku ani katalogu
rm: nie można usunąć `*.so': Nie ma takiego pliku ani katalogu
rm: nie można usunąć `milena': Nie ma takiego pliku ani katalogu
rm: nie można usunąć `milena.h': Nie ma takiego pliku ani katalogu
rm: nie można usunąć `milena.pc': Nie ma takiego pliku ani katalogu
rm: nie można usunąć `milena_cyrillic.h': Nie ma takiego pliku ani katalogu
make[1]: *** [clean] Błąd 1
make[1]: Opuszczenie katalogu `/home/mateusz/Pulpit/milena/milena-0.2.19.1/src'
make: *** [clean] Błąd 2
dpkg-buildpackage: błąd: fakeroot debian/rules clean zwrócił status błędu 2

Tak, zauważyłem właśnie. Daj:

Kod:

find . -name Makefile -exec sed -i "s/rm /rm -f /g" '{}' ';'

Błogosławieni, którzy czynią FAQ.
opencaching :: debian sources.list :: coś jakby blog :: polski portal debiana :: linux user #403712

Offline

 

#8 2010-07-25 11:45:46

ethanak
Użytkownik
Skąd: Ungwenor
Zarejestrowany: 2010-07-19
Serwis

Re: Pakiet Mileny

Właśnie wrzuciłem 0.2.20.0 na serwer - można paczkować :)
Z rzeczy interesujących do pakietowania: poprawione Makefile (wszystkie) w związku z rm.

Drobiazg (azhag, do Ciebie):

zmień:

Kod:

export contrast=$(shell ./have_contrast)

na

Kod:

export contrast=contrast

raczej soxa w wersji 14.0 się już nie spotyka, a przy kompilacji na systemie z pulseaudio wali jakimś durnym błędem, można chyba założyć że mamy soxa >=14.1 albo dać to w requires?

Test "have_contrast" został ze względu na różne centosy które zawierają dość prehistorycznego soxa...


Nim mechaniczne larum zagrasz mi, kanalio,
głosząc nadejście Javy - śmiertelnego wroga!
Zespół Adwokacki Dyskrecja

Offline

 

#9 2010-07-25 18:24:46

azhag
Admin łajza
Skąd: Warszawa
Zarejestrowany: 2005-11-15

Re: Pakiet Mileny

ethanak napisał(-a):

raczej soxa w wersji 14.0 się już nie spotyka, a przy kompilacji na systemie z pulseaudio wali jakimś durnym błędem

Właściwie w Lenny'm jest 0.14... Ale to się ręcznie zrobi rewizję ~lenny1 lub pomyślę, jak to bardziej elegancko zrobić. W tym roku pewnie wyjdzie Squeeze, więc problem zniknie.

Czyli muszę zbudować pakiety z milena-data-0.2.20.0.tar.gz, milena-dist-0.2.20.tar.gz, milena-basewords-0.2.7.tar.gz, milena_abc-0.1.14.tar.gz?

Jeśli chodzi o rozbicie — skłaniam się ku takiej wersji:

- milena (większość konsolowych, z odpowiednimi pakietami w wymaganych, rekomendowanych i polecanych)
- milena-base (basewords)
- milena-data (słowniki)
- milena-doc (z dokumentacją (README))
- libmilena (biblioteki)
- milena-dev (nagłówki)
- milena-abc, milena-ws, milena-dykcjonarz, milena-nokia, milena-kadu, milena-subplayer (zawierające bardziej specyficzne, mniej popularne, a wymagające specyficznych dodatków (libao, kadu, mplayer, GTK, ...) programy; zastanawiam się też czy nie nazwać ich milena-extra-nokia, milena-extra-kadu, etc.; jeszcze jakieś przegapiłem?)

Dopisek:
no i zapomniałem. Przynajmniej jedno z narzędzi (milena_say) to skrypt basha. Szybki rzut oka pokazuje, że nie ma tam jakiś ekwilibrystycznych formuł, nie miałbyś nic przeciwko, jakbym przepisał do czystego sh? Pozwoliłoby to uniknąć dodania basha do wymaganych.

Ostatnio edytowany przez azhag (2010-07-25 18:38:10)


Błogosławieni, którzy czynią FAQ.
opencaching :: debian sources.list :: coś jakby blog :: polski portal debiana :: linux user #403712

Offline

 

#10 2010-07-26 09:56:24

ethanak
Użytkownik
Skąd: Ungwenor
Zarejestrowany: 2010-07-19
Serwis

Re: Pakiet Mileny

Przepraszam  że wczoraj nie odpisałem ale usiadłem na okularach i odeszła mi absolutnie chęć do czegokolwiek :(

azhag napisał(-a):

ethanak napisał(-a):

raczej soxa w wersji 14.0 się już nie spotyka, a przy kompilacji na systemie z pulseaudio wali jakimś durnym błędem

Właściwie w Lenny'm jest 0.14... Ale to się ręcznie zrobi rewizję ~lenny1 lub pomyślę, jak to bardziej elegancko zrobić. W tym roku pewnie wyjdzie Squeeze, więc problem zniknie.

W sumie można sprawdzać wersję soxa (dla >= 14.1 contrast="contrast", dla niższych contrast="")

Czyli muszę zbudować pakiety z milena-data-0.2.20.0.tar.gz, milena-dist-0.2.20.tar.gz, milena-basewords-0.2.7.tar.gz, milena_abc-0.1.14.tar.gz?

Najlepiej tak - przy rozbiciu masz milena_base (z milena_basewords), milena_data (z milena_data) i resta z milena_dist. Dodatkowo - przy zmianach tylko w milena_data czy milena_base nie trzeba nic kombinować ze zmianami w debianowskich dodatkach, basewords to jeden plik który tylko trzeba wrzucić we właściwe miejsce, z data praktycznie jest to samo. Przy milena_dist coś tam się zawsze może zmienić, chociaż po ostatnich poprawkach zmian raczej nie przewiduję .

Jeśli miałby to być jeden wielki deb ze wszystkim to można robić z pojedynczego pliku - mój skrypcik uploadujący dba o to aby tam zawsze były najbardziej aktualne komponenty.

Oczywiście milena_submixer, milena_abc i milena_gtk to oddzielne źródełka.

Jeśli chodzi o rozbicie — skłaniam się ku takiej wersji:
patrz wyżej

Może być.

jeszcze jakieś przegapiłem?

milena_speechd (nazwałbym to milena_speechd_generic). Wymaga speech-dispatchera (wersja dowolna). Tu konieczny jest oddzielny deb, bo plik konfiguracyjny umieszczany jest w katalogu należącym do speech-dispatchera. Nie wiem czy nie byłby potrzebny jakiś mądry programik który dopisałby odpowiednią linijkę AddModule do speechd.conf (o ile takiej już nie ma...). Co prawda mam zamiar się pozbyć tego na rzecz speechd_milena, ale dopóki go nie ma - muszę to niestety zostawić :(

Przynajmniej jedno z narzędzi (milena_say) to skrypt basha. Szybki rzut oka pokazuje, że nie ma tam jakiś ekwilibrystycznych formuł, nie miałbyś nic przeciwko, jakbym przepisał do czystego sh? Pozwoliłoby to uniknąć dodania basha do wymaganych.

Takich tam jest więcej - milena_nokia, milena_book, milena_conf i tak dalej. Oczywiście możesz to przepisać na cokolwiek, ja to po prostu od początku robiłem w PLD a tam bash jest na dzień dobry jako shell dla użytkownika.

Dobra, muszę trochę popracować :)


Nim mechaniczne larum zagrasz mi, kanalio,
głosząc nadejście Javy - śmiertelnego wroga!
Zespół Adwokacki Dyskrecja

Offline

 

#11 2010-07-26 16:13:05

ethanak
Użytkownik
Skąd: Ungwenor
Zarejestrowany: 2010-07-19
Serwis

Re: Pakiet Mileny

Dodatkowo przemyślałem sobie sprawę podziału na pakiety - wyszło mi coś takiego:

milena_doc - wszystkie README (oprócz speechd)

milena_data
Pliki słowników i translacji dla Mileny

milena_libs - oba pliki .so, wymaga milena_data w konkretnej wersji
Biblioteki Mileny

milena_dev - oba pliki .h (req konkretny milena_libs, glibc_dev i co tam)
Pliki devel

milena_common - milena, milena_convert, milenizer (wymaga milena_libs w konkretnej wersji, libenca,  rekomend. antiword, poppler-utils, odt2txt)
Potrzebne dla aplikacji opartych o Milenę

milena_util_say - milena_say, milena_conf (req milena_common, sox, mbrola-pl1)
Proste "gadające echo"

milena_extras_basewords - tylko plik basewords, co zrobić z req?
Pliki potrzebne dla dykcjonarza i mileny_abc (słownik wymawianych wyrazów)

milena_extras_dykcjonarz - (req milena_libs,milena_base)
Umożliwia tworzenie słowników do książek (konsola).

milena_util_book - (req milena_dykcjonarz, milena_say, lame, rekomend. faac)
Umożliwia tworzenie audioksiążek (konsola)
czy dykcjonarz jako required czy recommended?

milena_util_nokia - (req milena_dykcjonarz, milena_say, amrwb, rekomend. ImageMagick)
Umożliwia tworzenie audioksiążek dla Nokia Audiobook (konsola)

milena_extras_kadu - (req milena_say, kadu)
Współpraca z kadu

milena_util_ws - (req milena_say, libao)
Umożliwia współpracę z FireVoxem i ClickSpeak

milena_util_subplayer - (req mplayer, milena_say, rekomend. milena_dykcjonarz lub milena_abc)
Prosty program do czytania mapisów

milena_utilities - metapakiet (wszystkie util)

milena_speechd_generic - (zawiera również README, req speech-dispatcher, milena_say)
Pozwala na współpracę Mileny ze screenreaderami

milena_abc - (req milena_libs, milena_base, gtksourceview, libenca, libepub, lame-libs, libao itd, rekomend.antiword, odt2txt, poppler-tools, ghostscript)
Kombajn w GTK+ do tworzenia audioksiążek

milena_abc_nokia - (req milena_abc, wget, gcc i tak dalej)
Instalator tworzący bibliotekę libamrwb_lib.so na podstawie oryginalnych źródel z 3gpp (licencja nie pozwala na redystrybucję). Konieczny do tworzenia audioksiążek dla Nokia Audiobooks przez milena_abc

milena_submixer - (req milena_say, libsamplerate, rekomend. milena_abc lub milena_dykcjonarz, mplayer)
Program tworzący ścieżkę dźwiękową z lektorem na podstawie
oryginalnej ścieżki dźwiękowej i napisów

milena_gtk - (req milena_say, python-pygtk, python-xlib itd, rekomend. pidgin)
Prosty program pozwalający m.in. na czytanie wiadomości z Pidgina,
czytanie schowka i zaznaczenia oraz współpracę z FireVoxem i ClickSpeak

Może być?

Ostatnio edytowany przez ethanak (2010-07-26 16:15:02)


Nim mechaniczne larum zagrasz mi, kanalio,
głosząc nadejście Javy - śmiertelnego wroga!
Zespół Adwokacki Dyskrecja

Offline

 

#12 2010-07-26 18:17:10

azhag
Admin łajza
Skąd: Warszawa
Zarejestrowany: 2005-11-15

Re: Pakiet Mileny

Tak na szybko, bo nie mam w tej chwili czasu za bardzo się wgryźć. Potem może coś dodam.

ethanak napisał(-a):

milena_doc - wszystkie README (oprócz speechd)

Ja bym dał wszystkie, najwyżej dopisał w README do speechd, że należy zainstalować taki a taki pakiet, żeby z tego korzystać. Tak po prostu będzie łatwiej. :)

milena_common - milena, milena_convert, milenizer (wymaga milena_libs w konkretnej wersji, libenca,  rekomend. antiword, poppler-utils, odt2txt)
Potrzebne dla aplikacji opartych o Milenę

Nie może być milena-common, common jest używane (pewnie nawet w Policy będzie coś na ten temat) dla plików współdzielonych. Proponuję milena-utils-base.

milena_util_book - (req milena_dykcjonarz, milena_say, lame, rekomend. faac)
Umożliwia tworzenie audioksiążek (konsola)
czy dykcjonarz jako required czy recommended?

Ja bym dał jako rekomendowany, koniecznie nie jest chyba wymagany.

oggenc to by się chyba przydał, zdaje się, że widziałem opcję do Ogg Vorbis w pomocy.


milena_util_nokia - (req milena_dykcjonarz, milena_say, amrwb, rekomend. ImageMagick)
Umożliwia tworzenie audioksiążek dla Nokia Audiobook (konsola)

amrwb czyli libopencore-amrwb0?

milena_utilities - metapakiet (wszystkie util)

Myślę, że nazwa milena-utils-all będzie lepsza.

milena_abc_nokia - (req milena_abc, wget, gcc i tak dalej)
Instalator tworzący bibliotekę libamrwb_lib.so na podstawie oryginalnych źródel z 3gpp (licencja nie pozwala na redystrybucję). Konieczny do tworzenia audioksiążek dla Nokia Audiobooks przez milena_abc

a libopencore-amrwb0 (an implementation of the 3GPP TS 26.173 specification for the Adaptive Multi-Rate - Wideband (AMR-WB)) lub libgsm0710-0 (a lightweight implementation of the 3GPP GSM 07.10 multiplexing protocol) się nie nada?

Ponadto drobne uwagi związane z konwencją nazw w Debianie: „-” zamiast „_”, libmilena, zamiast milena_lib.

Jakoś do końca tygodnia postaram się coś wydłubać.


Błogosławieni, którzy czynią FAQ.
opencaching :: debian sources.list :: coś jakby blog :: polski portal debiana :: linux user #403712

Offline

 

#13 2010-07-26 19:00:07

ethanak
Użytkownik
Skąd: Ungwenor
Zarejestrowany: 2010-07-19
Serwis

Re: Pakiet Mileny

azhag napisał(-a):

Tak na szybko, bo nie mam w tej chwili czasu za bardzo się wgryźć. Potem może coś dodam.

ethanak napisał(-a):

milena_doc - wszystkie README (oprócz speechd)

Ja bym dał wszystkie, najwyżej dopisał w README do speechd, że należy zainstalować taki a taki pakiet, żeby z tego korzystać. Tak po prostu będzie łatwiej. :)

Tu jest taki mały problem... speechd się co prawda instaluje, ale uruchomienie go wymaga ręcznej ingerencji. O ile w 0.6.7 możnaby to jeszcze jako zautomatyzować, o tyle w 0.7 (i takoż w OpenTTS) się nie da, stąd konieczność jakiejś instrukcji instalowanej razem z pakietem.

Zresztą - biorąc pod uwagę specyfikę speechda po prostu nie da się zautomatyzować instalacji, nawet jeśli wywalę moduł generic i opublikuję natywny (a chyba tak będzie, koledzy mi zgłaszają prawidłowe działanie, czyli tylko kwestia spakietowania).


Nie może być milena-common, common jest używane (pewnie nawet w Policy będzie coś na ten temat) dla plików współdzielonych. Proponuję milena-utils-base.

Jestem za :)

oggenc to by się chyba przydał, zdaje się, że widziałem opcję do Ogg Vorbis w pomocy.

Ale też jako rekomendowany - bazą jest format mp3.

milena_utilities - metapakiet (wszystkie util)

Myślę, że nazwa milena-utils-all będzie lepsza.

Ja też :)

a libopencore-amrwb0 (an implementation of the 3GPP TS 26.173 specification for the Adaptive Multi-Rate - Wideband (AMR-WB)) lub libgsm0710-0 (a lightweight implementation of the 3GPP GSM 07.10 multiplexing protocol) się nie nada?

Muszę zobaczyć co to za zwierz, te biblioteki nie są chyba dostępne dla wszystkich dystrybucji? Jeśli są - przerobię kod.

Przy okazji amrwb - zerknij na milena_nokia.in, szybciej wyczaisz co jest potrzebne :)

Jakoś do końca tygodnia postaram się coś wydłubać.

Ja też mam teraz niezbyt miły tydzień (kolega poszedł na L4, takie dłuższe, i do końca tygodnia musimy nadrobić to czego koleś nie zrobił w tym miesiącu). Ale bądźmy dobrej myśli :):):)

BTW. załóżmy sytuację taką jak dzisiaj

Mamy wszystkie pakiety, srakiety, rakiety, milenizery i coś tam.
Znajduję błąd w danych (akurat mam,  muszę wprowadzić imię króla "Roger" do prawidłowej odmiany rzymskich liczb, coby mi "Rogera III" czytał jako "roł~'dżera trzeciego"  a nie "roł~'dżera trzy")
Publikuję coś w stylu "milena-data.0.2.20.1234"
Jak (nie mając debiana) zrobić z tego deba? :)

Pliki są wyłącznie tekstowe i niezależne od architektury. Do dyspozycji mam:
a) PLD Th
b) CentOS 5.x
c) Fedora (taka z tych nowszych)
d) Ubuntu 10.04 (na lapku)

Masz jakiś pomysł?

Instalację Debiana na razie pomijam (nie mam wolnych maszyn, chyba że uda mi się ta sztuka pod OpenVZ) :(


Nim mechaniczne larum zagrasz mi, kanalio,
głosząc nadejście Javy - śmiertelnego wroga!
Zespół Adwokacki Dyskrecja

Offline

 

#14 2010-07-27 09:42:50

janosik
Członek DUG
Zarejestrowany: 2009-05-06

Re: Pakiet Mileny

bubuntu przeciez z debow korzysta. wiec nie powinno byc problemow.

Offline

 

#15 2010-07-27 14:41:58

ethanak
Użytkownik
Skąd: Ungwenor
Zarejestrowany: 2010-07-19
Serwis

Re: Pakiet Mileny

janosik napisał(-a):

bubuntu przeciez z debow korzysta. wiec nie powinno byc problemow.

Wiem - tyle że to lapek, który po pierwsze nie jest stale włączony, po drugie i tak z reguły jest za natem (nie wiem, czy na takim najtańszym d-linku da się forwardować port).
A chciałbym po prostu dopisać do swojego skryptu tworzenie debów (noarch) dla _data i _base...
Swoją drogą stworzenie takich debów nie powinno być specjalnie skomplikowane, muszę na spokojnie sprawdzić czy w PLD da się jakiś soft do tego zainstalować...

W ostateczności będę rzeźbił deby na netbooku :)


Nim mechaniczne larum zagrasz mi, kanalio,
głosząc nadejście Javy - śmiertelnego wroga!
Zespół Adwokacki Dyskrecja

Offline

 

#16 2010-07-28 22:11:18

azhag
Admin łajza
Skąd: Warszawa
Zarejestrowany: 2005-11-15

Re: Pakiet Mileny

ethanak napisał(-a):

a libopencore-amrwb0 (an implementation of the 3GPP TS 26.173 specification for the Adaptive Multi-Rate - Wideband (AMR-WB)) lub libgsm0710-0 (a lightweight implementation of the 3GPP GSM 07.10 multiplexing protocol) się nie nada?

Muszę zobaczyć co to za zwierz, te biblioteki nie są chyba dostępne dla wszystkich dystrybucji? Jeśli są - przerobię kod.

Są dostępne dla wszystkich, to — wg opisu pakietu — fragment Androida. Ponieważ są w main, są zgodne z Wytycznymi Debiana odnośnie Wolnego Oprogramowania. Dokładne informacje o licencji są na http://packages.debian.org/changelogs/pool/main/o/o … wb0.copyright (odnośniki „Copyright File” na packages.debian.org).

ethanak napisał(-a):

BTW. załóżmy sytuację taką jak dzisiaj

Mamy wszystkie pakiety, srakiety, rakiety, milenizery i coś tam.
Znajduję błąd w danych (akurat mam,  muszę wprowadzić imię króla "Roger" do prawidłowej odmiany rzymskich liczb, coby mi "Rogera III" czytał jako "roł~'dżera trzeciego"  a nie "roł~'dżera trzy")
Publikuję coś w stylu "milena-data.0.2.20.1234"
Jak (nie mając debiana) zrobić z tego deba? :)

Pliki są wyłącznie tekstowe i niezależne od architektury. Do dyspozycji mam:
a) PLD Th
b) CentOS 5.x
c) Fedora (taka z tych nowszych)
d) Ubuntu 10.04 (na lapku)

Masz jakiś pomysł?

Instalację Debiana na razie pomijam (nie mam wolnych maszyn, chyba że uda mi się ta sztuka pod OpenVZ) :(

Ponieważ to jest pakiet „plikowy”, niczego się nie kompiluje, wyłącznie chodzi o umieszczenie plików w odpowiednich miejscach, nie ma znaczenia na jakim systemie będzie budowany. Warunek — musisz mieć do dyspozycji dpkg z przyległościami, czyli Ubuntu się nada.

Tak długo jak nie będzie rewolucji, jedynie zwykłe podbicie wersji plików, będziesz musiał jedynie dodać wpis w debian/changelog i wykonać

Kod:

dpkg-buildpackage -rfakeroot

.

Zaś jak będzie rewolucja, wystarczy dodatkowo nanieść odpowiednie zmiany w debian/rules, który jest po prostu skryptem make'a.

Ostatnio edytowany przez azhag (2010-07-28 22:14:24)


Błogosławieni, którzy czynią FAQ.
opencaching :: debian sources.list :: coś jakby blog :: polski portal debiana :: linux user #403712

Offline

 

#17 2010-08-02 14:22:31

ethanak
Użytkownik
Skąd: Ungwenor
Zarejestrowany: 2010-07-19
Serwis

Re: Pakiet Mileny

Dwie sprawy:

1) libopencore-amrwb to tylko dekoder, do nagrywania raczej enkoder by się przydał (czyli na razie zostaję przy swoim sposobie na amrwb).

2) dzisiaj wrzuciłem 0.2.21.0, mam nadzieję że już wszystko jest poprawione i dalej tylko ostatnia cyferka się będzie zmieniać...

Próbowałem dojść do tego jak się te nieszczęsne deby robi - kur... zawsze myślałem że PLD jest trudną dystrybucją, bo ni za czort nie rozumiem o co w tym chodzi :)

mam powiedzmy dwa pliki:
a) cośtam.tar.gz
b) cośtam.patch

Jak mi łopatologicznie ktoś wyjaśni jak z tego zrobić cośtam.dsc i cośtam.debian.tar.gz to naprawdę dobre piwo postawię...


Nim mechaniczne larum zagrasz mi, kanalio,
głosząc nadejście Javy - śmiertelnego wroga!
Zespół Adwokacki Dyskrecja

Offline

 

#18 2010-08-02 14:34:29

azhag
Admin łajza
Skąd: Warszawa
Zarejestrowany: 2005-11-15

Re: Pakiet Mileny

1. Rozpakowujesz tar.gz, przechodzisz do utworzonego katalogu.
2. Wykonujesz dh_make -c licencja -f ../cośtam.tar.gz
3. Nakładasz łatę
4. Przechodzisz do katalogu debian/, tam edytujesz/wywalasz odpowiednie pliki. Najważniejsze to: control, changelog, rules.
5. Wracasz do katalogu głównego źródła i wykonujesz dpkg-buildpackage -rfakeroot.

Pakiety dla -data  oraz -basewords już z grubsza (kilka kwestii technicznych jak zależności) przygotowałem, dla mileny oraz abc nie... zapomniałem zapisać sobie tego wątku, żeby wiedzieć co gdzie mam umieścić i co mam pododawać

Zaraz podrzucę te gotowe. milenę i milenę-abc powinienem mieć w środę.

Dopisek:
http://dug.net.pl/~azhag/milena/

Prawdopodobnie wystarczy, że wykonasz dh_make, nałożysz łatę, podmienisz Twój katalog debian/ z moim z wcześinejszej wersji, podbijesz wersję w debian/changelog i możesz budować pakiet.

Jak już uporządkuję, postaram się przygotować pakiet źródłowy tak, aby łatwo się go dało zaktualizować za pomocą uupdate.


Błogosławieni, którzy czynią FAQ.
opencaching :: debian sources.list :: coś jakby blog :: polski portal debiana :: linux user #403712

Offline

 

#19 2010-08-02 14:56:27

ethanak
Użytkownik
Skąd: Ungwenor
Zarejestrowany: 2010-07-19
Serwis

Re: Pakiet Mileny

O, o taką łopatologię chodziło!

Spróbuję później (na razie muszę chałupę posprzątać po miesięcznej nieobecności rodzinki - nie chcę na dzień dobry od żony wałkiem w łeb oberwać) :)

Co do zależności basewords (bo tu jest chyba problem) - właśnie pomyślałem o umieszczeniu gdzieś (np. w głównym archiwum) informacji o aktualnej dla archiwum wersji basewords... zawsze wtedy można to jakoś zautomatyzować?

Coś takiego że basewords 0.2.x wymaga minimum data 0.2.y.z, a data 0.2.m.n wymaga konkretnie basewords 0.2.x?


Nim mechaniczne larum zagrasz mi, kanalio,
głosząc nadejście Javy - śmiertelnego wroga!
Zespół Adwokacki Dyskrecja

Offline

 

#20 2010-08-02 15:01:43

azhag
Admin łajza
Skąd: Warszawa
Zarejestrowany: 2005-11-15

Re: Pakiet Mileny

Wymagania konkretnej wersji można zrobić w zależnościach pakietu, nie ma problemu.

Rzuć też okiem na aktualizację mojego posta.


Błogosławieni, którzy czynią FAQ.
opencaching :: debian sources.list :: coś jakby blog :: polski portal debiana :: linux user #403712

Offline

 

#21 2010-08-02 15:08:35

marg1
Gentoowy Głupek
Skąd: Bytom
Zarejestrowany: 2009-05-15

Re: Pakiet Mileny

Mógłbyś napisać w ogóle jak to się kompiluje? Makefile widzę ale coś nie gra... I nie chodzi mi  o paczki .deb ;)

Kod:

Makefile:11: *** Nie odnaleziono pl1/pl1. Stop.

:)

Ostatnio edytowany przez marg1 (2010-08-02 15:11:50)


marg1@jid.dug.net.pl
Linux User Registration Number: #488674
CISCO CCNA Alumni :)

Offline

 

#22 2010-08-02 15:11:47

ethanak
Użytkownik
Skąd: Ungwenor
Zarejestrowany: 2010-07-19
Serwis

Re: Pakiet Mileny

No właśnie widzę - tyle że teraz już się pakietowaniem zajmować nie będę tylko mopem i ścierą :)

A z tymi wersjami chodziło mi o coś takiego - odpalam skrypt cośtam.sh, ten mi ściaga wszystkie informacje z serwera, i jeśli zmieniły się tylko data (i ewentualnie basewords, zakładam że zmiana basewords pociąga za sobą zmianę data - bo aktualizacja basewords pociąga za sobą zmiany w słownikach czy pliku danych translatora) to po prostu tworzy sobie jeden lub dwa nowe pakiety z konkretnymi zależnościami. Odpalenie czegoś takiego w cronie byłoby chyba dobrym wyjściem?

W sumie chyba jednak (pewnie w weekend) zainstaluję sobie debiana na jakiejś wirtualce...


Nim mechaniczne larum zagrasz mi, kanalio,
głosząc nadejście Javy - śmiertelnego wroga!
Zespół Adwokacki Dyskrecja

Offline

 

#23 2010-08-02 15:16:34

ethanak
Użytkownik
Skąd: Ungwenor
Zarejestrowany: 2010-07-19
Serwis

Re: Pakiet Mileny

marg1 napisał(-a):

Mógłbyś napisać w ogóle jak to się kompiluje? Makefile widzę ale coś nie gra... I nie chodzi mi  o paczki .deb ;)

Kod:

Makefile:11: *** Nie odnaleziono pl1/pl1. Stop.

:)

Debian, zgadza się? Tak prowizorycznie, jak chcesz z palca:

Kod:

make mbrola_voice=/usr/share/mbrola/voices/pl1
make mbrola_voice=/usr/share/mbrola/voices/pl1 install

Przepraszam, ale każda dystrybucja umieszcza głosy mbroli w sobie wiadomym miejscu :(

Poprawię na jutro


Nim mechaniczne larum zagrasz mi, kanalio,
głosząc nadejście Javy - śmiertelnego wroga!
Zespół Adwokacki Dyskrecja

Offline

 

#24 2010-08-02 15:19:23

marg1
Gentoowy Głupek
Skąd: Bytom
Zarejestrowany: 2009-05-15

Re: Pakiet Mileny

Nie no na gentoo, to ja już sobie poszukam czy to tam jest, czy gdzie indziej, ale czemu to jest w tak niestandardowy sposób zbudowane i czemu i o co z grubsza chodzi w tym źródle, jak by Ci się chciało mi wyjaśnić jak i co to są te mbrola_voice w ogóle  :)

Spróbuje najpierw czy pod Debianem to przejdzie :)

Doszedłem do tego, że nie mam mbroli w gentoo :) dobra powoli rozumiem, że muszę ją mieć żeby to skompilować.

Ostatnio edytowany przez marg1 (2010-08-02 15:23:58)


marg1@jid.dug.net.pl
Linux User Registration Number: #488674
CISCO CCNA Alumni :)

Offline

 

#25 2010-08-02 15:29:43

ethanak
Użytkownik
Skąd: Ungwenor
Zarejestrowany: 2010-07-19
Serwis

Re: Pakiet Mileny

marg1 napisał(-a):

Nie no na gentoo, to ja już sobie poszukam czy to tam jest, czy gdzie indziej

Popraw plik find_mbrola_voice i opublikuj poprawkę (nie, nie wiem gdzie gentoo trzyma plik pl1)

ale czemu to jest w tak niestandardowy sposób zbudowane i czemu i o co z grubsza chodzi w tym źródle, jak by Ci się chciało mi wyjaśnić jak i co to są te mbrola_voice w ogóle  :)
[...]
Doszedłem do tego, że nie mam mbroli w gentoo :) dobra powoli rozumiem, że muszę ją mieć żeby to skompilować.

A to już sam wisz :)
Masz mieć mbrolę i głos pl1 tam gdzie find_mbrola_voice potrafi go znaleźć, ew. podać go w parametrach do make.


Nim mechaniczne larum zagrasz mi, kanalio,
głosząc nadejście Javy - śmiertelnego wroga!
Zespół Adwokacki Dyskrecja

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
To nie jest tylko forum, to nasza mała ojczyzna ;-)