Nie jesteś zalogowany.
Jeśli nie posiadasz konta, zarejestruj je już teraz! Pozwoli Ci ono w pełni korzystać z naszego serwisu. Spamerom dziękujemy!

Ogłoszenie

Prosimy o pomoc dla małej Julki — przekaż 1% podatku na Fundację Dzieciom „Zdążyć z Pomocą”.
Więcej informacji na dug.net.pl/pomagamy/.

#1 2009-04-15 10:21:28

tomekgreen1985
Użytkownik
Zarejestrowany: 2008-11-28

[SOLVED]Nie udało się zawłaszczyć urządzenia USB.

Witam mam problem po podpięciu aparatu do kompa pod usb wykrywa go:

Kod:

Bus 001 Device 004: ID 040a:0585 Kodak Co. Digital Camera

ale niestety wywala komunikat:

Kod:

Wystąpił błąd w bibliotece io ('Nie udało się zawłaszczyć urządzenia USB'): Nie udało się zawłaszczyć interfejsu 0 (Operacja niedozwolona). Należy upewnić się, czy żaden inny program lub moduł jądra (taki jak sdc2xx, stv680, spca50x) nie używa tego urządzenia i mamy prawa odczytu/zapisu do urządzenia.

Po wydaniu polecenia w terminalu:

Kod:

gksu gnome-volume-manager-gthumb

mogę bez problemu importować zdjęcia z aparatu.
Robiłem według tego:
http://karmelek.wordpress.com/2008/04/05/klopoty-z-canonami-w-804/
ale niestety nic to nie dało.
Mój: gedit /boot/grub/menu.lst ~/menu.lst

Kod:

# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-legacy-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default        0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout        1

# Pretty colours
color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
## password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
#password --md5 $1$wIahy$tchcJB5o82lB/9f9tKGCt.
#
# examples
#
# title        Windows 95/98/NT/2000
# root        (hd0,0)
# makeactive
# chainloader    +1
#
# title        Linux
# root        (hd0,1)
# kernel    /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##      kopt_2_6_8=root=/dev/hdc1 ro
##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/hda6 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,5)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet vga=773

## should update-grub lock old automagic boot options
## e.g. lockold=false
##      lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(single-user) single
# altoptions=(single-user mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title        Debian GNU/Linux, kernel 2.6.26-2-686
root        (hd0,5)
kernel        /boot/vmlinuz-2.6.26-2-686 root=/dev/hda6 ro quiet vga=773
initrd        /boot/initrd.img-2.6.26-2-686

title        Debian GNU/Linux, kernel 2.6.26-2-686 (single-user mode)
root        (hd0,5)
kernel        /boot/vmlinuz-2.6.26-2-686 root=/dev/hda6 ro single
initrd        /boot/initrd.img-2.6.26-2-686

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title        Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda1
title        Microsoft Windows XP Professional
root        (hd0,0)
savedefault
makeactive
chainloader    +1

Aha z synaptica wywaliłem stary kernel 2.6.26-1-686 i jeszcze z folderu /boot wywaliłem wszystko co się tyczyło 2.6.26-1-686 i po wydaniu polecenia w terminalu update-grub wywala:

Kod:

 update-grub
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.26-2-686
Updating /boot/grub/menu.lst ... done

ale dalej nic to nie dało. Dalej musze montować tym wcześniejszym poleceniem. Ma ktoś jakiś pomysł?

Podpinam inny aparat i wszystko jest ok tylko z tym kodakiem jest coś nie tak ;/

Ostatnio edytowany przez tomekgreen1985 (2009-04-21 18:04:25)

Offline

 

#2 2009-04-16 01:30:32

bercik
Moderator Mamut
Skąd: Warszawa
Zarejestrowany: 2006-09-23
Serwis

Re: [SOLVED]Nie udało się zawłaszczyć urządzenia USB.

problemem sa uprawnienia - zobacz w id (wogole mozesz pokazac wynik tej komendy) czy nalezysz do grupy camera ... mozesz tez pobawic sie udev aby ustawic uprawnienia do urzadzenia ...

Ostatnio edytowany przez bercik (2009-04-16 01:30:57)


"Wszyscy wiedzą, że czegoś zrobić nie można. Ale przypadkowo znajduje się jakiś nieuk, który tego nie wie. I on właśnie robi odkrycie." (A.Einstein)

Offline

 

#3 2009-04-16 09:08:35

tomekgreen1985
Użytkownik
Zarejestrowany: 2008-11-28

Re: [SOLVED]Nie udało się zawłaszczyć urządzenia USB.

Wynik polecenia:

Kod:

id
uid=0(root) gid=0(root) grupy=0(root)

a co do grupy camera nie mam takiej. Utworzyć też jej nie mogę. Gdy robię grupę camera to wpisuje camera w nazwie id wyświetla 1001 ale nazwy niema.

Offline

 

#4 2009-04-16 23:41:19

bercik
Moderator Mamut
Skąd: Warszawa
Zarejestrowany: 2006-09-23
Serwis

Re: [SOLVED]Nie udało się zawłaszczyć urządzenia USB.

ale id nie z root'a tylko z usera na ktorym to nie dziala (bo rozumiem ze z root'a dziala)

jaka wersja systemu?


"Wszyscy wiedzą, że czegoś zrobić nie można. Ale przypadkowo znajduje się jakiś nieuk, który tego nie wie. I on właśnie robi odkrycie." (A.Einstein)

Offline

 

#5 2009-04-17 09:26:54

tomekgreen1985
Użytkownik
Zarejestrowany: 2008-11-28

Re: [SOLVED]Nie udało się zawłaszczyć urządzenia USB.

Aha sorki.

Kod:

id
uid=1000(okok) gid=1000(okok) grupy=20(dialout),24(cdrom),25(floppy),29(audio),44(video),46(plugdev),100(users),113(powerdev),118(scanner),121(fuse),123(vboxusers),1000(okok)

z root'a działa. Debian 5.0 Lenny

Kod:

cat /etc/debian_version
5.0.1
 uname -r
2.6.26-2-686

Ostatnio edytowany przez tomekgreen1985 (2009-04-17 09:30:50)

Offline

 

#6 2009-04-17 18:57:06

bercik
Moderator Mamut
Skąd: Warszawa
Zarejestrowany: 2006-09-23
Serwis

Re: [SOLVED]Nie udało się zawłaszczyć urządzenia USB.

sproboj moze dopisac do /etc/udev/libgphoto2.rules linijke:

Kod:

ATTRS{idVendor}=="040a", ATTRS{idProduct}=="0585", MODE="0664", GROUP="plugdev"

i zrestartowac udev (lub caly system)


"Wszyscy wiedzą, że czegoś zrobić nie można. Ale przypadkowo znajduje się jakiś nieuk, który tego nie wie. I on właśnie robi odkrycie." (A.Einstein)

Offline

 

#7 2009-04-17 20:14:36

tomekgreen1985
Użytkownik
Zarejestrowany: 2008-11-28

Re: [SOLVED]Nie udało się zawłaszczyć urządzenia USB.

Ok dzięki. Już działa. Zgrywanie z aparatu działa ale już wygrywanie czegokolwiek do aparatu nie. Normalnie się juz wkur.... Już mnie nie dziwi czemu ludzie korzystają z Windowsa i tak niechętnie przerzucają się na linuxa, który nie potrafi obsłużyć połowy rzeczy, które stary Windows potrafi obsłużyć bez najmniejszego problemu. MP3 nie działa, cholerny aparat też cud że kamerka działa. Przepraszam za te słowa ale już mnie to normalnie wkur.... Jednym słowem nawet gdyby człowiek chciał się rozstać z Windowsem to niema takiej możliwości.
Zwracam honor xp też nie daje rady.

Ostatnio edytowany przez tomekgreen1985 (2009-04-18 06:49:20)

Offline

 

Stopka forum

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson
Nas ludzie lubią po prostu, a nie klikając w przyciski ;-)